Subject: Re: [6tisch] last changes on Archie

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 8 May 2015 16:00:04 +0000

Hello Kris:

Pascal - I'm not on expert on IESG review, so take my comments with a grain of salt.

High level:
* this feels more like a research proposal or DARPA quarterly status report
than an RFC.  It's filled with lots of good ideas, and evidence that people are
working on solving hard problems, but much of it is *very* preliminary.

It is, Kris, and by design I'd say; Archie is a high level view of things and how they bind together.
It is also the repository of the work as we progress it, and the design decisions as we make them.
* I'm worried that the scope of the document goes way beyond what 6TiSCH
was chartered to do.  Maybe that's a good thing in managing our path forward
with the IESG?

I do not think so. Archie is not about 6top. The charter includes the backbone operation, at least for the architecture level.
But for the components that actuate the architecture, we can only go to the relevant working groups and suggest additions / modifications as appropriate.
* The first section says that we have (using present tense) three different
ways to compute routes, four different ways to manage cell schedules,
and three different forwarding models, or 36 different combinations.
Most of them are still not defined. As an implementer, that really
scared me.  Will the IESG feel differently?

I'm not sure that you'll ever find all of the combinations, some just do not make sense.
But these are the tools that we can play with and it' important that they are explained somewhere before we start using them.
* What little is specified generally relies on IDs, not RFCs, and even the IDs
are often not adopted by their respective working groups yet.

Some specifics:
* move security from 5.1 and put it in 13 with the rest of security
I has that comment from René. Are you looking at Archie 07 - there is a weird thing in the tools that it appears separate?
In 07 security is moved down as you suggest, what's left is just the explanation of  the boxes that are represented above.
We seem to have reached consensus with René, do you wish to reopen?

* all of section 6 "6lowpan (and RPL)" seems to be good stuff, but higher layer
than 6TiSCH, and with no particular impact on, or from, TSCH.  It seems that it
should just be removed to a separate draft in another working group.
We are specifically chartered to describe how things work, Kris.  This includes RPL etc...
The problem that we address is that how things work together is described nowhere and we added that to the 6TiSCH lot.

* I didn't understand section 7 at all.  What are we trying to say here?
It's really defining terms and an intro to section 9, 10, 11.
I could move that down as section 8 and embed  9, 10, and 11, if that makes more sense?

* Section 10 on Forwarding Models seems like an interesting vision, but its so
far beyond anything that anyone has implemented (or even discussed?  Maybe
I missed the threads) that it should be written up in a separate ID.

This was discussed many times at 6TiSCH, Kris. And really, one is plain IP, one is the emulation of industrial protocols, and the last (fragments) may never see the light of day, but it is present in drafts and even books so we need at least to describe it at a high level.

Again, I don't know the process, so maybe this kind of visionary document is
what the IESG is looking for.  I'd be much happier with a bottom-up development,
e.g. this is what we have now, this is what runs, here's a little bit of extrapolation of
where we're headed next.

It is an informational document, so it is not normative. It is reporting the status of our work and providing a high level description of how things work together.
I do think we are OK there...
Thanks for all!
Pascal
ksjp
On 4/29/2015 5:21 PM, Pascal Thubert (pthubert) wrote:
Dear all :

At the interim call we found that Archie is mostly ready to ship but for 2 things;
1) we need to decide on the IEEE reference
2) some editorial changes would be required to improve readability and make the IESG review process smoother.

For 1) the proposal is to use an undated reference since the spec does not reference specific points in IEEE specs.
For 2) Kris, as a coauthor, will propose some changes and come back to us in the coming week.

If you object to these resolutions, please let us know.

Cheers,

Pascal

_______________________________________________

6tisch mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/6tisch

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 8 May 2015 17:06:06 +0000

Dear Kris and all:

I added this commit
https://bitbucket.org/6tisch/draft-ietf-6tisch-architecture/commits/3f43e366a9c532a3a24743f5592c7e70e863f9af
to include the changes made from Kris's comments. You'll find in particular a slight reorg of section whereby section 7 actually introduces ex sections 9, 10 and 11 that are now nested into it.

I also removed the 'e' in most places and added an undated reference to 15.4.

The diffs are more clear in xml https://bitbucket.org/6tisch/draft-ietf-6tisch-architecture/commits/3f43e366a9c532a3a24743f5592c7e70e863f9af#chg-draft-ietf-6tisch-architecture-08.xml

Please let me know if you have issues with this change;

Have a good week end!

Pascal

From: 6tisch [mailto:[email-masked]] On Behalf Of Pascal Thubert (pthubert)
Sent: vendredi 8 mai 2015 18:00
To: Kris Pister; [email-masked]
Subject: Re: [6tisch] last changes on Archie

Hello Kris:

High level:

Some specifics:

Cheers,

Pascal

6tisch mailing list