Subject: Re: [6tisch] last changes on Archie

From: Kris Pister <[email-masked]>
Date: Wed, 06 May 2015 11:39:48 -0700

Pascal - I'm not on expert on IESG review, so take my comments with a 
grain of salt.

High level:
* this feels more like a research proposal or DARPA quarterly status report
than an RFC.  It's filled with lots of good ideas, and evidence that 
people are
working on solving hard problems, but much of it is *very* preliminary.
* I'm worried that the scope of the document goes way beyond what 6TiSCH
was chartered to do.  Maybe that's a good thing in managing our path forward
with the IESG?
* The first section says that we have (using present tense) three different
ways to compute routes, four different ways to manage cell schedules,
and three different forwarding models, or 36 different combinations.
Most of them are still not defined. As an implementer, that really
scared me.  Will the IESG feel differently?
* What little is specified generally relies on IDs, not RFCs, and even 
the IDs
are often not adopted by their respective working groups yet.

Some specifics:
* move security from 5.1 and put it in 13 with the rest of security
* all of section 6 "6lowpan (and RPL)" seems to be good stuff, but 
higher layer
than 6TiSCH, and with no particular impact on, or from, TSCH.  It seems 
that it
should just be removed to a separate draft in another working group.
* I didn't understand section 7 at all.  What are we trying to say here?
* Section 10 on Forwarding Models seems like an interesting vision, but 
its so
far beyond anything that anyone has implemented (or even discussed? Maybe
I missed the threads) that it should be written up in a separate ID.

Again, I don't know the process, so maybe this kind of visionary document is
what the IESG is looking for.  I'd be much happier with a bottom-up 
development,
e.g. this is what we have now, this is what runs, here's a little bit of 
extrapolation of
where we're headed next.

ksjp

On 4/29/2015 5:21 PM, Pascal Thubert (pthubert) wrote:
>
> Dear all :
>
> At the interim call we found that Archie is mostly ready to ship but 
> for 2 things;
>
> 1) we need to decide on the IEEE reference
>
> 2) some editorial changes would be required to improve readability and 
> make the IESG review process smoother.
>
> For 1) the proposal is to use an undated reference since the spec does 
> not reference specific points in IEEE specs.
>
> For 2) Kris, as a coauthor, will propose some changes and come back to 
> us in the coming week.
>
> If you object to these resolutions, please let us know.
>
> Cheers,
>
> Pascal
>
>
>
> _______________________________________________
> 6tisch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 11 May 2015 07:09:54 +0000

Hi Kris:

I processed what I could as https://bitbucket.org/6tisch/draft-ietf-6tisch-architecture/src/3f43e366a9c532a3a24743f5592c7e70e863f9af/draft-ietf-6tisch-architecture-08.txt?at=master

Could you please confirm if that is OK or suggest changes/additions?

Thanks a bunch !

Pascal

From: 6tisch [mailto:[email-masked]] On Behalf Of Kris Pister
Sent: mercredi 6 mai 2015 20:40
To: Pascal Thubert (pthubert); [email-masked]
Subject: Re: [6tisch] last changes on Archie

Pascal - I'm not on expert on IESG review, so take my comments with a grain of salt.

High level:
than an RFC.  It's filled with lots of good ideas, and evidence that people are
* What little is specified generally relies on IDs, not RFCs, and even the IDs

Some specifics:
* move security from 5.1 and put it in 13 with the rest of security
* all of section 6 "6lowpan (and RPL)" seems to be good stuff, but higher layer
than 6TiSCH, and with no particular impact on, or from, TSCH.  It seems that it
should just be removed to a separate draft in another working group.
* I didn't understand section 7 at all.  What are we trying to say here?
* Section 10 on Forwarding Models seems like an interesting vision, but its so
far beyond anything that anyone has implemented (or even discussed?  Maybe
I missed the threads) that it should be written up in a separate ID.

Again, I don't know the process, so maybe this kind of visionary document is
what the IESG is looking for.  I'd be much happier with a bottom-up development,
e.g. this is what we have now, this is what runs, here's a little bit of extrapolation of
where we're headed next.

ksjp

At the interim call we found that Archie is mostly ready to ship but for 2 things;
1) we need to decide on the IEEE reference
2) some editorial changes would be required to improve readability and make the IESG review process smoother.

For 1) the proposal is to use an undated reference since the spec does not reference specific points in IEEE specs.
For 2) Kris, as a coauthor, will propose some changes and come back to us in the coming week.

Cheers,

Pascal

6tisch mailing list

[email-masked]<mailto:[email-masked]>