Subject: [6tisch] DODAG root rank in minimal draft

From: Nicola Accettura <[email-masked]>
Date: Fri, 22 May 2015 10:43:15 -0700

Hi Xavi, Kris, all,

reading RFC 6550, I find:

   1. page 70:

   A DODAG root MUST advertise a Rank of ROOT_RANK.

   2. page 112:

   ROOT_RANK: This is the Rank for a DODAG root.  ROOT_RANK has a value
            of MinHopRankIncrease (as advertised by the DODAG root), such
            that DAGRank(ROOT_RANK) is 1.

So that the example in section 9.1.2 of draft-ietf-6tisch-minimal-06 seems
not compliant with RFC 6550 (unless node 0 is a virtual DODAG root).

Am I missing something?

Sincerely,
Nicola

---

From: Xavier Vilajosana <[email-masked]>
Date: Sun, 24 May 2015 22:08:29 +0200

Dear Nicola,

thanks for your comment! I reviewed both rfc6550 and rfc6552 and you are
right.

I corrected the draft as follows:

  +-------+
    |   0   | R(0) = 0
    |       | DAGRank(R(0)) = 0
    +-------+
        |
        |
    +-------+
    |   1   | R(1)=R(0)+683=683
    |       | DAGRank(R(1)) = 2
    +-------+
...

substituted by this

  +-------+
    |   0   | R(minHopRankIncrease) = 256
    |       | DAGRank(R(0)) = 1
    +-------+
        |
        |
    +-------+
    |   1   | R(1)=R(0)+683 = 939
    |       | DAGRank(R(1)) = 3
    +-------+
...

thanks you very much!
regards,
Xavi

2015-05-22 19:43 GMT+02:00 Nicola Accettura <[email-masked]>:

> _______________________________________________
> 6tisch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch
>
>