Subject: [6tisch] Minimal draft IEs examples

From: Xavier Vilajosana <[email-masked]>
Date: Tue, 12 May 2015 10:57:00 +0200

Hi,

we agreed on replacing the IEs description by several illustrative
examples. I worked a little bit on them and I would like to see what is
your opinion. As said they will be referred in the text and will be placed
at the end in an Examples section.

By now there are 3 examples and I need to work on one or two more security
related examples.

Let's agree if this is a right format. (attached for reference and also at
bitbucket)

https://bitbucket.org/6tisch/draft-ietf-6tisch-minimal/src/88cd3c55a605ae194932bf0c7704570124732fd1/Example_1_EB_content.txt?at=master

regards,
Xavi

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 12 May 2015 09:26:19 +0000

I like your format Xavi, it is perfectly readable.

Cheers,

Pascal

From: 6tisch [mailto:[email-masked]] On Behalf Of Xavier Vilajosana
Sent: mardi 12 mai 2015 10:57
To: [email-masked]
Subject: [6tisch] Minimal draft IEs examples

Hi,

we agreed on replacing the IEs description by several illustrative examples. I worked a little bit on them and I would like to see what is your opinion. As said they will be referred in the text and will be placed at the end in an Examples section.

By now there are 3 examples and I need to work on one or two more security related examples.

Let's agree if this is a right format. (attached for reference and also at bitbucket)

regards,
Xavi

---

From: Qin Wang <[email-masked]>
Date: Tue, 12 May 2015 21:00:10 +0000 (UTC)

Xavi,
The format is very clear. 
I think there is typo on line 54. That should be channel hopping sequence?
ThanksQin 

     On Tuesday, May 12, 2015 9:44 PM, Pascal Thubert (pthubert) <[email-masked]> wrote:

 #yiv9648369827 #yiv9648369827 -- _filtered #yiv9648369827 {font-family:Calibri;panose-1:2 15 5 2 2 2 4 3 2 4;} _filtered #yiv9648369827 {font-family:Tahoma;panose-1:2 11 6 4 3 5 4 4 2 4;}#yiv9648369827 #yiv9648369827 p.yiv9648369827MsoNormal, #yiv9648369827 li.yiv9648369827MsoNormal, #yiv9648369827 div.yiv9648369827MsoNormal {margin:0cm;margin-bottom:.0001pt;font-size:12.0pt;}#yiv9648369827 a:link, #yiv9648369827 span.yiv9648369827MsoHyperlink {color:blue;text-decoration:underline;}#yiv9648369827 a:visited, #yiv9648369827 span.yiv9648369827MsoHyperlinkFollowed {color:purple;text-decoration:underline;}#yiv9648369827 span.yiv9648369827EmailStyle17 {color:#1F497D;}#yiv9648369827 .yiv9648369827MsoChpDefault {} _filtered #yiv9648369827 {margin:70.85pt 70.85pt 70.85pt 70.85pt;}#yiv9648369827 div.yiv9648369827WordSection1 {}#yiv9648369827 I like your format Xavi, it is perfectly readable.    Cheers,    Pascal    From: 6tisch [mailto:[email-masked]]On Behalf Of Xavier Vilajosana
Sent: mardi 12 mai 2015 10:57
To: [email-masked]
Subject: [6tisch] Minimal draft IEs examples    Hi,     we agreed on replacing the IEs description by several illustrative examples. I worked a little bit on them and I would like to see what is your opinion. As said they will be referred in the text and will be placed at the end in an Examples section.    By now there are 3 examples and I need to work on one or two more security related examples.    Let's agree if this is a right format. (attached for reference and also at bitbucket)    https://bitbucket.org/6tisch/draft-ietf-6tisch-minimal/src/88cd3c55a605ae194932bf0c7704570124732fd1/Example_1_EB_content.txt?at=master       regards, Xavi 
_______________________________________________
6tisch mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/6tisch

---

From: Xavier Vilajosana <[email-masked]>
Date: Wed, 13 May 2015 04:54:09 +0200

thanks Qin! I will correct it.

kind regards,
Xavi

2015-05-12 23:00 GMT+02:00 Qin Wang <[email-masked]>:

> Thanks
> Qin
>   *From:* 6tisch [mailto:[email-masked]] *On Behalf Of *Xavier
> Vilajosana
> *Sent:* mardi 12 mai 2015 10:57
> *To:* [email-masked]
> *Subject:* [6tisch] Minimal draft IEs examples
>
>  Hi,
>

---

From: Thomas Watteyne <[email-masked]>
Date: Wed, 13 May 2015 21:06:33 -0700

+1

---

From: Tero Kivinen <[email-masked]>
Date: Mon, 18 May 2015 17:50:30 +0300

Xavier Vilajosana writes:
> examples. I worked a little bit on them and I would like to see what
> is your opinion. As said they will be referred in the text and will
> be placed at the end in an Examples section.

Good.

> Let's agree if this is a right format. (attached for reference and also at

Format looks right. One note you should make there is that all numbers
are in LSB format. This includes length and element IDs, ASNs, join
priorities etc.

As in IETF we use network byte order, it might be better to explictly
mention this, and also provide the final octet sequence for the
frames. 

> https://bitbucket.org/6tisch/draft-ietf-6tisch-minimal/src/
> 88cd3c55a605ae194932bf0c7704570124732fd1/Example_1_EB_content.txt?at=master

SubID name for "MLME-SubIE Timeslot" is missing "TSCH", i.e. the line:

  SubID = 0x1c (MLME-SubIE Timeslot)

should be
  
  SubID = 0x1c (MLME-SubIE TSCH Timeslot)

--

The format of Hopping timing IE (0x1d) is wrong. It is 5 octets, first
3 are the Present Hop Time Offset and last two are Hop Dwell Time.
Also the name is wrong, i.e. the entry should be:

  #MLME-SubIE Hopping Timing
  Len5 = 5 Byte
  SubID = 0x1d (MLME-SubIE Hopping Timing)
  Type = Short (0)
  Present Hop Time Offset = 3 bytes
  Hop Dwell Time = 2 bytes

--

The name of the TSCH Slotframe and link is wrong. I.e. change:

  #MLME-SubIE Frame and Link IE
  Len6 = 10Bytes
  SubID = 0x1b (MLME-SubIE Frame and Link)

with

  #MLME-SubIE TSCH Slotframe and Link IE
  Len6 = 10Bytes
  SubID = 0x1b (MLME-SubIE TSCH Slotframe and Link)

Also the field names do not match the 802.15.4, i.e. replace them with
following:

  Number of slotframes = 0x01
  SlotFrame Handle = 0x00
  SlotFrame Size = 101 slots (0x65)
  Number of Links = 0x01
  Timeslot = 0x0000 (2B)
  Channel Offset = 0x0000 (2B)
  Link Option = 0xE0 (tx,rx,shared)

You also had Channel Offset and Timeslot in wrong order, Timeslot is
first and Channel Offset is after that. Link options is the last one.
Also I think your Link Option value is wrong as the bit 0 is the LSB
of the first octet...

--

Also the Payload IE Header Termination IE format is wrong. It should
have 10 bit length field, and 4 bit GrpID value of 0xf with type of 1
(i.e. long).

--

For the example 2 the correct name for of the IE is "Time Correction
IE".

--

Btw if you swap the order of TSCH Syncroniation IE and TSCH Timeslot
IE then the fields in figure wrap better (i.e the 16-bit numbers do
not warp from each line to next).
-- 
[email-masked]

---

From: Tero Kivinen <[email-masked]>
Date: Mon, 18 May 2015 19:45:17 +0300

>   Present Hop Time Offset = 3 bytes

And as I noted on my other email this IE is wrong. It should be
long MLME Nested Payload Channel Hopping IE:

  #MLME-SubIE Channel hopping IE
  Len5 = 1 Byte
  SubID = 0x9 (MLME-SubIE Channel Hopping)
  Type = Long (1)
  Hopping Sequence ID = 0x00 (default)
-- 
[email-masked]

---

From: Xavier Vilajosana <[email-masked]>
Date: Mon, 18 May 2015 19:18:00 +0200

Dear Tero,

thanks for looking in detail into them. I was actually correcting some of
these mistakes.
As you said  Hopping timing IE (0x1d)  is incorrect as Ch.Hopping IE (0x9)
is a long format .
I will soon push a new version with the examples integrated in the draft.

regards,
Xavi

---

From: Jonathan Simon <[email-masked]>
Date: Mon, 18 May 2015 11:01:38 -0700

Yes, the hopping timing IE is not used in TSCH.  It’s intended to allow for channel hopping in an unslotted network.
-- 
Jonathan Simon, Ph. D
Director of Systems Engineering
Linear Technology, Dust Networks product group
32990 Alvarado-Niles Road, Suite 910
Union City, CA 94587
(510) 400-2936
(510) 489-3799 FAX
[email-masked]

**LINEAR TECHNOLOGY CORPORATION** 
*****Internet Email Confidentiality Notice***** 
 This e-mail transmission, and any documents, files or previous e-mail messages attached to it may contain confidential information that is legally privileged. If you are not the intended recipient, or a person responsible for delivering it to the intended recipient, you are hereby notified that any disclosure, copying, distribution or use of any of the information contained in or attached to this transmission is STRICTLY PROHIBITED. If you have received this transmission in error, please immediately notify me by reply e-mail, or by telephone at (510) 400-2936, and destroy the original transmission and its attachments without reading or saving in any manner. Thank you. 

On May 18, 2015, at 9:45 AM, Tero Kivinen <[email-masked]> wrote:

> http://cp.mcafee.com/d/FZsS81NJ5xB4QsK3DSmjtPqbwVBcSyUepvdEK3zhOyCOqejrzPPPz5XCN6ABqM1hYEvIundDOx-NVsSwCehRZZ_HYYOCYU-NRXBQXEEYyejd7dPhOevVqWdAklrCzB7BgY-F6lK1FJ4SyrLOb2rPUV5xcQsCXCOsVHkiP2Di-rL00s4RtxxYGjB1SKejBiNcSVelb4OV2Hsbvg5i-rL00jr0Vd4SqmT9OFoCqnjh0q83h0dOx9njPh0x7npCy0d6G6y3MY87_gSOedLfZBNT6cyp-E