Subject: Re: [6tisch] Shipping minimal

From: Qin Wang <[email-masked]>
Date: Fri, 1 May 2015 15:05:31 +0000 (UTC)

Hi Pascal,
After the discussion in the thread "Removing the "e" in the charter", do you still ask agreement about solution on the second point? 
Personally, I prefer the text suggested by Pat, because it can decouple 6TiSCH from IEEE802.15.4 MAC. But, if the minimal draft is not final standard, I will agree the current solution for point 2.
ThanksQin 

     On Friday, May 1, 2015 7:21 AM, Thomas Watteyne <[email-masked]> wrote:

 Pascal,+1 on both pointsThomas
On Thu, Apr 30, 2015 at 1:46 AM, Pascal Thubert (pthubert) <[email-masked]> wrote:

Dear all : After the interim call on Friday , we reviewed the discussions on minimal and found that we are ready to ship the draft to the IESG. The only questions left are:1) should we provide a default value for K1 in the security section?2) which IEEE document should the spec reference? For 1) it was suggested that it would help interop if we did. So the proposal on the table is to add a well-known key as a default that can be modified at commissioning time.For 2) the spec makes explicit references deep into 802.15.4e so the proposal on the table is to maintain the reference to 802.15.4e as it stands now. We are now calling for consensus on these 2 points. If you object please let us know and we’ll talk. We’ll conclude this call next Friday. Cheers, Pascal
_______________________________________________
6tisch mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/6tisch

_______________________________________________
6tisch mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/6tisch

---

From: Tom Phinney <[email-masked]>
Date: Fri, 01 May 2015 08:18:29 -0700

Hi all,

For me, resolution of point 2) depends on how long we expect
"minimal" to be of use. In the short term, reference to 802.15.4e
makes sense. However, if "minimal" is expected to be of use for more
than a year or two, then it needs to be written in a way that tracks
the most recently published IEEE 802.15.4 standard, as that is the
one for which chip vendors will invest.

In the short term, many available chips will support 802.15.4-2011
and 802.15.4e-2012, but in the future that support, for low-cost
low-power high-capability SoC IoT devices, will track the
most-recent version of IEEE 802.15.4.

Industrial IoT is not a large enough sub-market to drive variance
from the greater IoT market. Thus it is foolish (in my opinion) to
insist on adherence to what the dominant market will consider an
obsolete spec.

-Tom

=====

On 2015.05.01 08:05, Qin Wang wrote:

Hi Pascal,

After the
discussion in the thread "Removing the "e" in the charter", do
you still ask agreement about solution on the second point?

Personally,
I prefer the text suggested by Pat, because it can decouple
6TiSCH from IEEE802.15.4 MAC. But, if the minimal draft is not
final standard, I will agree the current solution for point 2.

Thanks

Qin

On Friday,
May 1, 2015 7:21 AM, Thomas Watteyne
<[email-masked]> wrote:

Pascal,

+1 on both points

Thomas

On Thu, Apr
30, 2015 at 1:46 AM, Pascal Thubert (pthubert) <[email-masked]>
wrote:

Dear
all :

After
the interim call on Friday , we
reviewed the discussions on minimal
and found that we are ready to ship
the draft to the IESG.

The
only questions left are:

1)
should we provide a default value for
K1 in the security section?

2)
which IEEE document should the spec
reference?

For
1) it was suggested that it would help
interop if we did. So the proposal on
the table is to add a well-known key
as a default that can be modified at
commissioning time.

For
2) the spec makes explicit references
deep into 802.15.4e so the proposal on
the table is to maintain the reference
to 802.15.4e as it stands now.

We
are now calling for consensus on these
2 points. If you object please let us
know and we’ll talk. We’ll conclude
this call next Friday.

Cheers,

Pascal

6tisch mailing list

[email-masked]

6tisch mailing list

[email-masked]

---

From: Kris Pister <[email-masked]>
Date: Fri, 01 May 2015 08:45:57 -0700

Tom - at the risk of appearing dense, I just don't get it.

If minimal is expected to be of use for more than a year or two, then it 
needs to
stay constant, like 802.11b (or USB, or UDP, or ...).  You don't 
integrate new
ideas by changing the underlying spec otherwise there is no interop.  
You integrate
new ideas by adding (802.11g, USB2.0, TCP, ...), but by saying "now when 
we write
'802.11b' on the outside of the box, it means OFDM not DSSS".
How can you call something a standard if it can change and break interop 
at any time?

With regard to silicon vendors, either we are successful with 6tisch and it
becomes widely adopted outside of the existing industrial process 
automation market,
or we fail and it isn't.  If we're successful, silicon vendors will 
include 4e capability in
all chips going forward until the market stops buying it (just like 11b 
capability is still
present in chips that speak much more advanced protocols).  If we fail 
at getting
adoption now, then it doesn't matter what silicon vendors do in the future.

ksjp

On 5/1/2015 8:18 AM, Tom Phinney wrote:
> Hi all,
>
> For me, resolution of point 2) depends on how long we expect "minimal" 
> to be of use. In the short term, reference to 802.15.4e makes sense. 
> However, if "minimal" is expected to be of use for more than a year or 
> two, then it needs to be written in a way that tracks the most 
> recently published IEEE 802.15.4 standard, as that is the one for 
> which chip vendors will invest.
>
> In the short term, many available chips will support 802.15.4-2011 and 
> 802.15.4e-2012, but in the future that support, for low-cost low-power 
> high-capability SoC IoT devices, will track the most-recent version of 
> IEEE 802.15.4.
>
> Industrial IoT is not a large enough sub-market to drive variance from 
> the greater IoT market. Thus it is foolish (in my opinion) to insist 
> on adherence to what the dominant market will consider an obsolete spec.
>
> -Tom
> =====
>> After the discussion in the thread "Removing the "e" in the charter", 
>> do you still ask agreement about solution on the second point?
>>
>> Personally, I prefer the text suggested by Pat, because it can 
>> decouple 6TiSCH from IEEE802.15.4 MAC. But, if the minimal draft is 
>> not final standard, I will agree the current solution for point 2.
>>
>> Thanks
>> Qin
>>
>>
>>
>> On Thu, Apr 30, 2015 at 1:46 AM, Pascal Thubert (pthubert) 
>> <[email-masked] <mailto:[email-masked]>> wrote:
>>
>>     Dear all :
>>     After the interim call on Friday , we reviewed the discussions on
>>     minimal and found that we are ready to ship the draft to the IESG.
>>     The only questions left are:
>>     1) should we provide a default value for K1 in the security section?
>>     2) which IEEE document should the spec reference?
>>     For 1) it was suggested that it would help interop if we did. So
>>     the proposal on the table is to add a well-known key as a default
>>     that can be modified at commissioning time.
>>     For 2) the spec makes explicit references deep into 802.15.4e so
>>     the proposal on the table is to maintain the reference to
>>     802.15.4e as it stands now.
>>     We are now calling for consensus on these 2 points. If you object
>>     please let us know and we’ll talk. We’ll conclude this call next
>>     Friday.
>>     Cheers,
>>     Pascal
>>
>>     [email-masked] <mailto:[email-masked]>
>> [email-masked] <mailto:[email-masked]>

---

From: Tom Phinney <[email-masked]>
Date: Fri, 01 May 2015 09:04:00 -0700

Kris,

Your point is well made. For historical reasons, I tend to focus on
the much more limited industrial market (as is apparent in my
reference to IIoT). 6TiSCH attempts to cover a much broader market
segment, and thus may gain enough traction to be attractive for SoC
development by major semi companies all on its own.

What would be useful in this discussion would be for someone to
enumerate the specific features of 802.15.4-2011 and 802.15.4e-2012
about which people are most concerned. which is to say those
features for which a fear of change has been driving this
discussion. If such a standalone document existed, even if it
references 802.15.4-2011 and 802.15.4e-2012, then it becomes
possible to have a more nuanced discussion of the generic, latest
802.15.4 vs. 802.15.4-2011 and 802.15.4e-2012. It also becomes
feasible to tell chip vendors that "These are the specific features
that we need to remain supported even if the generic 802.15.4
standard evolves away from them." All of that can survive reference
to a spec that will be obsolete and may become unpurchasable when a
later edition is available.

-Tom

====

On 2015.05.01 08:45, Kris Pister wrote:

If minimal is expected to be of use for more than a year or two,
then it needs to

ideas by changing the underlying spec otherwise there is no
interop.  You integrate

new ideas by adding (802.11g, USB2.0, TCP, ...), but by saying
"now when we write

How can you call something a standard if it can change and break
interop at any time?

With regard to silicon vendors, either we are successful with
6tisch and it

or we fail and it isn't.  If we're successful, silicon vendors
will include 4e capability in

all chips going forward until the market stops buying it (just
like 11b capability is still

present in chips that speak much more advanced protocols).  If we
fail at getting

adoption now, then it doesn't matter what silicon vendors do in
the future.

ksjp

On 5/1/2015 8:18 AM, Tom Phinney
wrote:

Hi all,

For me, resolution of point 2) depends on how long we expect
"minimal" to be of use. In the short term, reference to
802.15.4e makes sense. However, if "minimal" is expected to be
of use for more than a year or two, then it needs to be written
in a way that tracks the most recently published IEEE 802.15.4
standard, as that is the one for which chip vendors will invest.

In the short term, many available chips will support
802.15.4-2011 and 802.15.4e-2012, but in the future that
support, for low-cost low-power high-capability SoC IoT devices,
will track the most-recent version of IEEE 802.15.4.

Industrial IoT is not a large enough sub-market to drive
variance from the greater IoT market. Thus it is foolish (in my
opinion) to insist on adherence to what the dominant market will
consider an obsolete spec.

-Tom

=====

On 2015.05.01 08:05, Qin Wang
wrote:

Hi Pascal,

After
the discussion in the thread "Removing the "e" in the
charter", do you still ask agreement about solution on the
second point?

Personally,

I prefer the text suggested by Pat, because it can
decouple 6TiSCH from IEEE802.15.4 MAC. But, if the minimal
draft is not final standard, I will agree the current
solution for point 2.

Thanks

Qin

On
Friday, May 1, 2015 7:21 AM, Thomas Watteyne <[email-masked]>
wrote:

Pascal,

+1 on both points

Thomas

On Thu,
Apr 30, 2015 at 1:46 AM, Pascal Thubert
(pthubert) <[email-masked]>
wrote:

Dear

all :

After

the interim call on Friday , we
reviewed the discussions on
minimal and found that we are
ready to ship the draft to the
IESG.

The

only questions left are:

1)

should we provide a default value
for K1 in the security section?

2)

which IEEE document should the
spec reference?

For

1) it was suggested that it would
help interop if we did. So the
proposal on the table is to add a
well-known key as a default that
can be modified at commissioning
time.

For

2) the spec makes explicit
references deep into 802.15.4e so
the proposal on the table is to
maintain the reference to
802.15.4e as it stands now.

We

are now calling for consensus on
these 2 points. If you object
please let us know and we’ll talk.
We’ll conclude this call next
Friday.

Cheers,

Pascal

6tisch mailing list

[email-masked]

6tisch mailing list

[email-masked]