Subject: Re: [6tisch] proposed text for minimal security

From: Tom Phinney <[email-masked]>
Date: Wed, 06 May 2015 06:40:10 -0700

Let's put this to bed (i.e., reach a conclusion for this aspect).
Saying less is very much in the spirit of "minimal".
+1
===
On 2015.05.05 14:46, Kris Pister wrote:
> This is my proposed text for all of section 8.  This does not force 
> anyone to
> use well-known keys, or 32 bit MICs, or send EBs unencrypted.
> It does make it easy to do interop.
> People who want to use pre-configured secret keys, long MICs, 
> encrypted EBs,
> or no keys at all, are free to do so.
>
> ksjp
> ---------------
> 8.    Security
> Minimal assumes the existence of two keys, K1 and K2.  EBs MAY be
> authenticated with key K1 using security level 1 (32 bit MIC).
> DATA, ACKNOWLEDGEMENT, and MAC COMMAND frame types SHOULD be
> authenticated with key K2 using security level 1.
>
> For early interoperability, K1 MAY be set to "6TiSCH minimal15". K2 
> SHOULD
> be a randomly generated high entropy cryptographic key.
> Key distribution is out of scope.  EBs MAY be filtered based on PANID.
>
>
> _______________________________________________
> 6tisch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch
>

---

From: Qin Wang <[email-masked]>
Date: Wed, 6 May 2015 14:51:27 +0000 (UTC)

+1.
Qin 

     On Wednesday, May 6, 2015 9:40 PM, Tom Phinney <[email-masked]> wrote: