Subject: [6tisch] 6top-interface-04

From: "Turner, Randy" <[email-masked]>
Date: Wed, 30 Sep 2015 14:18:03 +0000

Hi All,

In the 6top 04 draft, section 3.2 "Data Transfer Model",  there is text that says "...if the next active cell is a broadcast cell, it (the MUX module) selects a fragment only from broadcast queues."

We have "TX, RX, Shared, and timekeeping cells"  - we don't have "broadcast" cells labeled as such, or maybe I missed this somewhere.   Is there some cell "type" option that is a subclass of "TX" that I missed ?

Thanks!
Randy

P PLEASE CONSIDER OUR ENVIRONMENT BEFORE PRINTING THIS EMAIL.

This e-mail (including any attachments) is confidential and may be legally privileged. If you are not an intended recipient or an authorized representative of an intended recipient, you are prohibited from using, copying or distributing the information in this e-mail or its attachments. If you have received this e-mail in error, please notify the sender immediately by return e-mail and delete all copies of this message and any attachments. Thank you.

---

From: Qin Wang <[email-masked]>
Date: Wed, 30 Sep 2015 14:43:08 +0000 (UTC)

Hi Randy,
In the IEEE802.15.4e, there are two attributes related with a cell, i.e. LinkOption and LinkType. LinkOption indicates TX, RX, Shared, or Timekeeping; and LinkType indicates Normal or Advertising. According to my understanding, if the attributes of a cell are set as LinkOption = TX and LinkType= ADVERTISING, then the cell can be used as Broadcast cell. Make sense?
ThanksQin 

     On Wednesday, September 30, 2015 10:18 AM, "Turner, Randy" <[email-masked]> wrote:

  <!--#yiv4636351171 _filtered #yiv4636351171 {font-family:Calibri;panose-1:2 15 5 2 2 2 4 3 2 4;}#yiv4636351171 #yiv4636351171 p.yiv4636351171MsoNormal, #yiv4636351171 li.yiv4636351171MsoNormal, #yiv4636351171 div.yiv4636351171MsoNormal {margin:0in;margin-bottom:.0001pt;font-size:11.0pt;font-family:"Calibri", "sans-serif";}#yiv4636351171 a:link, #yiv4636351171 span.yiv4636351171MsoHyperlink {color:blue;text-decoration:underline;}#yiv4636351171 a:visited, #yiv4636351171 span.yiv4636351171MsoHyperlinkFollowed {color:purple;text-decoration:underline;}#yiv4636351171 span.yiv4636351171EmailStyle17 {font-family:"Calibri", "sans-serif";color:windowtext;}#yiv4636351171 .yiv4636351171MsoChpDefault {font-family:"Calibri", "sans-serif";} _filtered #yiv4636351171 {margin:1.0in 1.0in 1.0in 1.0in;}#yiv4636351171 div.yiv4636351171WordSection1 {}-->Hi All,    In the 6top 04 draft, section 3.2 “Data Transfer Model”,  there is text that says “…if the next active cell is a broadcast cell, it (the MUX module) selects a fragment only from broadcast queues.”    We have “TX, RX, Shared, and timekeeping cells”  - we don’t have “broadcast” cells labeled as such, or maybe I missed this somewhere.   Is there some cell “type” option that is a subclass of “TX” that I missed ?     Thanks!
Randy 
P PLEASE CONSIDER OUR ENVIRONMENT BEFORE PRINTING THIS EMAIL.

This e-mail (including any attachments) is confidential and may be legally privileged. If you are not an intended recipient or an authorized representative of an intended recipient, you are prohibited from using, copying or distributing the information in this e-mail or its attachments. If you have received this e-mail in error, please notify the sender immediately by return e-mail and delete all copies of this message and any attachments. Thank you.
_______________________________________________
6tisch mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/6tisch

---

From: "Turner, Randy" <[email-masked]>
Date: Wed, 30 Sep 2015 14:54:59 +0000

Yes, I definitely understand the concept…I guess the language in the -04 draft tends to blend LinkOption and LinkType a bit, but your derivation of the usage makes sense – I would have probably stated that in the draft…”if the next active cell is an 802.15.4 advertisement slot, then the MUX module would only select a frame from a broadcast queue” – I guess I basically understood what you were talking about,  I was just curious about the derivation.  The same paragraph (at the beginning) uses the term “transmit cell” and then we use “broadcast cell” later on like the terms “transmit” and “broadcast” are from the same type enumeration.  Like I said, I do understand what you were trying to say, I’m just a big proponent of being very (almost overly) specific and not presuming (or requiring) too much context in the mind of the reader.

Thanks for the reply!
Randy

From: Qin Wang [mailto:[email-masked]]
Sent: Wednesday, September 30, 2015 10:43 AM
To: Turner, Randy; [email-masked]
Subject: Re: [6tisch] 6top-interface-04

Hi Randy,

Thanks
Qin

On Wednesday, September 30, 2015 10:18 AM, "Turner, Randy" <[email-masked]<mailto:[email-masked]>> wrote:

Hi All,

In the 6top 04 draft, section 3.2 “Data Transfer Model”,  there is text that says “…if the next active cell is a broadcast cell, it (the MUX module) selects a fragment only from broadcast queues.”

We have “TX, RX, Shared, and timekeeping cells”  - we don’t have “broadcast” cells labeled as such, or maybe I missed this somewhere.   Is there some cell “type” option that is a subclass of “TX” that I missed ?

Thanks!
Randy

_______________________________________________
6tisch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch

---

From: Qin Wang <[email-masked]>
Date: Wed, 30 Sep 2015 15:11:53 +0000 (UTC)

Thank you very much for your clarification. We will make it more clear in the next version.
Qin 

     On Wednesday, September 30, 2015 10:55 AM, "Turner, Randy" <[email-masked]> wrote:

 #yiv8893246163 #yiv8893246163 -- _filtered #yiv8893246163 {font-family:Helvetica;panose-1:2 11 6 4 2 2 2 2 2 4;} _filtered #yiv8893246163 {font-family:Helvetica;panose-1:2 11 6 4 2 2 2 2 2 4;} _filtered #yiv8893246163 {font-family:Calibri;panose-1:2 15 5 2 2 2 4 3 2 4;} _filtered #yiv8893246163 {font-family:Tahoma;panose-1:2 11 6 4 3 5 4 4 2 4;} _filtered #yiv8893246163 {font-family:Webdings;panose-1:5 3 1 2 1 5 9 6 7 3;}#yiv8893246163 #yiv8893246163 p.yiv8893246163MsoNormal, #yiv8893246163 li.yiv8893246163MsoNormal, #yiv8893246163 div.yiv8893246163MsoNormal {margin:0in;margin-bottom:.0001pt;font-size:12.0pt;}#yiv8893246163 a:link, #yiv8893246163 span.yiv8893246163MsoHyperlink {color:blue;text-decoration:underline;}#yiv8893246163 a:visited, #yiv8893246163 span.yiv8893246163MsoHyperlinkFollowed {color:purple;text-decoration:underline;}#yiv8893246163 p.yiv8893246163msonormal, #yiv8893246163 li.yiv8893246163msonormal, #yiv8893246163 div.yiv8893246163msonormal {margin-right:0in;margin-left:0in;font-size:12.0pt;}#yiv8893246163 p.yiv8893246163msochpdefault, #yiv8893246163 li.yiv8893246163msochpdefault, #yiv8893246163 div.yiv8893246163msochpdefault {margin-right:0in;margin-left:0in;font-size:12.0pt;}#yiv8893246163 span.yiv8893246163msohyperlink {}#yiv8893246163 span.yiv8893246163msohyperlinkfollowed {}#yiv8893246163 span.yiv8893246163emailstyle17 {}#yiv8893246163 p.yiv8893246163msonormal1, #yiv8893246163 li.yiv8893246163msonormal1, #yiv8893246163 div.yiv8893246163msonormal1 {margin:0in;margin-bottom:.0001pt;font-size:11.0pt;}#yiv8893246163 span.yiv8893246163msohyperlink1 {color:blue;text-decoration:underline;}#yiv8893246163 span.yiv8893246163msohyperlinkfollowed1 {color:purple;text-decoration:underline;}#yiv8893246163 span.yiv8893246163emailstyle171 {color:windowtext;}#yiv8893246163 p.yiv8893246163msochpdefault1, #yiv8893246163 li.yiv8893246163msochpdefault1, #yiv8893246163 div.yiv8893246163msochpdefault1 {margin-right:0in;margin-left:0in;font-size:12.0pt;}#yiv8893246163 span.yiv8893246163EmailStyle27 {color:#1F497D;}#yiv8893246163 .yiv8893246163MsoChpDefault {font-size:10.0pt;} _filtered #yiv8893246163 {margin:1.0in 1.0in 1.0in 1.0in;}#yiv8893246163 div.yiv8893246163WordSection1 {}#yiv8893246163 Yes, I definitely understand the concept…I guess the language in the -04 draft tends to blend LinkOption and LinkType a bit, but your derivation of the usage makes sense – I would have probably stated that in the draft…”if the next active cell is an 802.15.4 advertisement slot, then the MUX module would only select a frame from a broadcast queue” – I guess I basically understood what you were talking about,  I was just curious about the derivation.  The same paragraph (at the beginning) uses the term “transmit cell” and then we use “broadcast cell” later on like the terms “transmit” and “broadcast” are from the same type enumeration.  Like I said, I do understand what you were trying to say, I’m just a big proponent of being very (almost overly) specific and not presuming (or requiring) too much context in the mind of the reader.    Thanks for the reply!
Randy    From: Qin Wang [mailto:[email-masked]]
Sent: Wednesday, September 30, 2015 10:43 AM
To: Turner, Randy; [email-masked]
Subject: Re: [6tisch] 6top-interface-04    Hi Randy,    In the IEEE802.15.4e, there are two attributes related with a cell, i.e. LinkOption and LinkType. LinkOption indicates TX, RX, Shared, or Timekeeping; and LinkType indicates Normal or Advertising. According to my understanding, if the attributes of a cell are set as LinkOption = TX and LinkType= ADVERTISING, then the cell can be used as Broadcast cell. Make sense?    Thanks Qin       On Wednesday, September 30, 2015 10:18 AM, "Turner, Randy" <[email-masked]> wrote:    Hi All,   In the 6top 04 draft, section 3.2 “Data Transfer Model”,  there is text that says “…if the next active cell is a broadcast cell, it (the MUX module) selects a fragment only from broadcast queues.”   We have “TX, RX, Shared, and timekeeping cells”  - we don’t have “broadcast” cells labeled as such, or maybe I missed this somewhere.   Is there some cell “type” option that is a subclass of “TX” that I missed ?     Thanks!
Randy    P PLEASE CONSIDER OUR ENVIRONMENT BEFORE PRINTING THIS EMAIL.

---

From: Tero Kivinen <[email-masked]>
Date: Wed, 30 Sep 2015 21:16:20 +0300

Qin Wang writes:
> In the IEEE802.15.4e, there are two attributes related with a cell, i.e.
> LinkOption and LinkType. LinkOption indicates TX, RX, Shared, or Timekeeping;
> and LinkType indicates Normal or Advertising. According to my understanding,
> if the attributes of a cell are set as LinkOption = TX and LinkType=
> ADVERTISING, then the cell can be used as Broadcast cell. Make sense?

LinkType of ADVERTISING means that this link is used to send enhanced
beacons out. There can be other broadcast traffic going out than
enhanced beacons, so I do not think you can only claim that
ADVERTISING links are broadcast cells. 

	ADVERTISING = 1, and indicates the link may be used to send an
	Enhanced beacon.

and

	ADVERTISE links may be used to send Enhanced beacons as the
	result of the MAC receiving a MLME-BEACON.request.

I would assume that broadcast link is something that is defined so
that all devices are listening that, i.e. where the listeners have RX
bit on, and nodeAddr for the sender is set to 0xffff. I do not think
linkType has anything to do with that, but as 6top-interface-04 does
not define what broadcast link/cell means, it is impossible to say.
-- 
[email-masked]

---

From: Qin Wang <[email-masked]>
Date: Wed, 30 Sep 2015 19:59:54 +0000 (UTC)

Hi Tero,
You raised a good question, i.e. how to define a cell for broadcast in 6top.
(1) I think 6top needs a way to define broadcast cell. A sender can not assume or know if the message transmitted in a TX cell will be received by all other nodes even if its nodeAddr is set to oxffff, because sender cannot know others TSCH schedule. Thus, there must be some bitmap in the sender to tell TSCH scheduler whether the TX cell is a Unicast cell or Broardcast Cell, i.e. neighbors are listening or not sure.
(2) It is indeed that IEEE80.15.4e uses LinkType to indicate if the cell is for Advertisement, but does not say it cannot be used to broadcast other message as you said. Thus, I wonder if 6top, as a sublayer, can take advantage of LinkType to define the broadcast cell, and let the content of broadcast come from broadcast Queue, EB or other broadcast message.
What do you think?
ThanksQin

     On Wednesday, September 30, 2015 2:16 PM, Tero Kivinen <[email-masked]> wrote:

and