Subject: [6tisch] Fwd: Re: [Roll] Call for Adoption for draft-thubert-6lo-routing-dispatch

From: "S.V.R.Anand" <[email-masked]>
Date: Mon, 30 Nov 2015 16:39:23 +0530

Hi Pascal,

I certainly support the adoption even with respect to the upcoming 6tisch WG
activities since bit savings are desirable in LLNs. Thanks a lot for the 
draft!

There could however be one view that, as we are predominantly moving towards
centralized routing and scheduling based architecture, managed through PCE
installed routes and tracks, the role of distributed routing may somewhat be
diminished. This is not imply RPL goes away as there are always going to be
scenarios to carry IP traffic. The counter argument for this line of 
argument
is that if the soft cells left at LLN's disposal are indeed going to be at
premium, why not these be better utilized ? The draft is going to be 
extremely
useful. What do you say ?

Anand

-------- Forwarded Message --------
Subject:     Re: [Roll] Call for Adoption for 
draft-thubert-6lo-routing-dispatch
Date:     Fri, 27 Nov 2015 14:20:44 +0000
From:     Pascal Thubert (pthubert) <[email-masked]>
Reply-To:     Routing Over Low power and Lossy networks <[email-masked]>
To:     Gabriel Montenegro <[email-masked]>, Routing 
Over Low power and Lossy networks <[email-masked]>
CC:     Samita Chakrabarti <[email-masked]>, 
[email-masked] <[email-masked]>

I support the adoption,

This draft makes a difference in the size of data packets in a RPL LLN, 
which translates impact positively the energy consumption, the delivery 
ratio and the available payload size.

Cheers,

Pascal

From: 6lo [mailto:[email-masked]] On Behalf Of Gabriel Montenegro
Sent: mardi 17 novembre 2015 21:07
To: [email-masked]
Cc: Samita Chakrabarti <[email-masked]>
Subject: [6lo] Call for Adoption for draft-thubert-6lo-routing-dispatch

All,

This starts a 6lo Working Group adoption call for the following draft:

A Routing Header Dispatch for 6LoWPAN

https://datatracker.ietf.org/doc/draft-thubert-6lo-routing-dispatch/

This draft solves a problem for ROLL, namely that of compression of RPL 
artifacts. It also appears to be extensible enough that it could be 
useful for other scenarios, especially after discussions at IETF 93 in 
Prague (context switch approach) and confirmation at IETF 94 in Yokohama.

This document is intended as standards-track.

Please send your opinion (Yes or No) to the mailing list on adopting 
this document as a 6lo WG document.

This call will end at 00:00 UTC on December 1, 2015.

Regards,

Chairs

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 30 Nov 2015 12:14:07 +0000

Hello Anand;

At ROLL, we are discussing how the PCE could compute routes and use RPL signaling to install them (https://tools.ietf.org/html/draft-thubert-roll-dao-projection).
This is independent of whether there is a TSCH network or not. If there is none, we do not benefit from the cell reservation and the associated deterministic properties, but we can still optimize the path based on constraints from a centralized perspective, and we still need 6loRH for packets.

Actually, the 6TiSCH architecture suggests (unless we change that in the future) that even for tracks, if the packet inside the track is an IP packet, then there is an RPI HbH option indicates the flow.

Cheers,

Pascal

> -----Original Message-----
> From: S.V.R.Anand [mailto:[email-masked]]
> Sent: lundi 30 novembre 2015 12:09
> To: Pascal Thubert (pthubert) <[email-masked]>
> Cc: [email-masked]
> Subject: Fwd: Re: [Roll] Call for Adoption for draft-thubert-6lo-routing-dispatch
> 
> Hi Pascal,
> 
> activities since bit savings are desirable in LLNs. Thanks a lot for the draft!
> 
> There could however be one view that, as we are predominantly moving
> towards centralized routing and scheduling based architecture, managed
> through PCE installed routes and tracks, the role of distributed routing may
> somewhat be diminished. This is not imply RPL goes away as there are always
> going to be scenarios to carry IP traffic. The counter argument for this line of
> argument is that if the soft cells left at LLN's disposal are indeed going to be at
> premium, why not these be better utilized ? The draft is going to be extremely
> This draft makes a difference in the size of data packets in a RPL LLN, which
> translates impact positively the energy consumption, the delivery ratio and the
> available payload size.
> 
> 
> 
> Cheers,
> 
> 
> 
> Pascal
> 
> 
> 
> artifacts. It also appears to be extensible enough that it could be useful for other
> scenarios, especially after discussions at IETF 93 in Prague (context switch
> approach) and confirmation at IETF 94 in Yokohama.
> 
> 
> 
> Please send your opinion (Yes or No) to the mailing list on adopting this
> document as a 6lo WG document.
> 
> 
>

---

From: "S.V.R.Anand" <[email-masked]>
Date: Mon, 30 Nov 2015 21:20:19 +0530

Hi Pascal,

I agree with your points and thanks for the reference !

Anand