Subject: [6tisch] Recommended configuration for Shared cells Backoff in Minimal

From: Esteban Municio <[email-masked]>
Date: Thu, 9 Feb 2017 10:59:08 +0100

Hi all,

I was wondering if there is any recommendation about how set up the
Backoff mechanism in shared cells when no ACKs are expected. 

According to the standard, macMaxBE and macMinBE are defined and the BE
is increased at every attempt. However, if the node is not expecting any
ACK (i.e sending DIOs or EBs), I guess the BE will be always the same.
Is there any recommendation in Minimal about how to choose this value?

Maybe a value related with the number of nodes or DIO/EB period?

Kind regards,
Esteban

-- 
Esteban Municio
IDLab - Dept. Mathematics and Computer Science 
University of Antwerp - imec
Middelheimlaan 1 , 2020 Antwerp, Belgium 
Office M.G.325

---

From: Thomas Watteyne <[email-masked]>
Date: Fri, 10 Feb 2017 00:46:31 +0100

Esteban,

I believe this is fully specified in the 802.15.4 standard. In a nutshell,
the back-off mechanism is triggered only when the cell is marked as
"shared". When a mote sends a packet and doesn't get an ACK, the BE is
changed. If you send a frame to link-layer destination 0xffff, you're not
expecting an ACK, so BE will not change.

I may be missing your point?

Thomas

On Thu, Feb 9, 2017 at 10:59 AM, Esteban Municio <
[email-masked]> wrote:

> _______________________________________________
> 6tisch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch
>
>

-- 
_______________________________________

Thomas Watteyne, PhD
Research Scientist & Innovator, Inria
Sr Networking Design Eng, Linear Tech
Founder & co-lead, UC Berkeley OpenWSN
Co-chair, IETF 6TiSCH

www.thomaswatteyne.com
_______________________________________

---

From: Esteban Municio <[email-masked]>
Date: Fri, 10 Feb 2017 12:21:17 +0100

Hi Thomas,

No, that's exactly what I ment.

I was just thinking about how the network would behave when for example
20 o 30 nodes are switched on simultaneously in Minimal. If the initial
value of BE is low (1 or 2), collisions are expected to be very frequent
in the shared cell. And since the first messages for joining the network
(EBs and DIOs) are broadcasted without expecting an ACK, the BE could
remain unmodified and the joining process could last forever.

Could this scenario happen? Or am I missing something important?

But indeed maybe this is out of the scope of Minimal since is just
matter of sizing the number of shared cells in the schedule and the
topic is rather related with the 802.15.4 standard than with 6tisch.

Kind regards,
Esteban

On Thu, 2017-02-09 at 23:46 +0000, Thomas Watteyne wrote:
> Esteban, 
> 
> 
> I believe this is fully specified in the 802.15.4 standard. In a
> nutshell, the back-off mechanism is triggered only when the cell is
> marked as "shared". When a mote sends a packet and doesn't get an ACK,
> the BE is changed. If you send a frame to link-layer destination
> 0xffff, you're not expecting an ACK, so BE will not change.
> 
> 
> On Thu, Feb 9, 2017 at 10:59 AM, Esteban Municio
> <[email-masked]> wrote:
>         Hi all,
>

---

From: Thomas Watteyne <[email-masked]>
Date: Tue, 14 Feb 2017 08:24:31 +0100

Esteban,

You are right, if a mote doesn't send anything else than EBs and DIOs
(which are all sent to link-layer address 0xffff), it will not increase the
BE value. It is only when the starts particpating in a join procedure, or
exchanges application-level data that is will realize it doesn't receive an
ACK and increase BE. I do believe that the duration after being switched on
that a mote only sends EBs and DIOs is short.

Thomas

Thomas Watteyne, PhD

www.thomaswatteyne.com

---

From: Esteban Municio <[email-masked]>
Date: Wed, 15 Feb 2017 11:38:16 +0100

Hi, 

Ok, I understand.

Thanks and kind regards,
Esteban

On Tue, 2017-02-14 at 07:24 +0000, Thomas Watteyne wrote:
> (which are all sent to link-layer address 0xffff), it will not
> increase the BE value. It is only when the starts particpating in a
> join procedure, or exchanges application-level data that is will
> realize it doesn't receive an ACK and increase BE. I do believe that
> the duration after being switched on that a mote only sends EBs and
> DIOs is short.
> 
> 
> Thomas
> 
> On Fri, Feb 10, 2017 at 12:21 PM, Esteban Municio
>         >         I was wondering if there is any recommendation about
>         how set
>         >         up the
>         >         According to the standard, macMaxBE and macMinBE are
>         defined
>         >         and the BE
>         >         is increased at every attempt. However, if the node
>         is not
>         >         expecting any
>         >         ACK (i.e sending DIOs or EBs), I guess the BE will
>         be always
>         >         the same.
>         >         Is there any recommendation in Minimal about how to
>         choose
>         >         this value?
>         >
>         >         Maybe a value related with the number of nodes or
>         DIO/EB
>         >         period?
>         >
>         >         Kind regards,
>         >         Esteban
>         >
>         >         --
>         >         Esteban Municio