Subject: [6tisch] nits on draft-ietf-6tisch-6top-sf0-02

From: Randy Turner <[email-masked]>
Date: Sat, 4 Mar 2017 21:20:52 -0500

Hi All,

After reading the current SF0 document, I had a few nits that I thought I would pass along - hope they’re helpful.

Section 2: Introduction

(The Scheduling Algorithm)

“…under effective use…”   the choice of wording seems unorthodox.

Suggest the following  “A portion of these allocated cells will be effectively utilized by neighbors, while the remaining cells can be over-provisioned to handle unanticipated increases in cell requirements”

(The Relocation Algorithm)

“Allocated cells may experiment packet loss” should be “Allocated cells may experience packet loss…”

Section 4: SF0 Triggering Events

1. “…change in the current number of used cells”  - could this be paraphrased to say “…a change in the number of required cells”  ?

Section 5: SF0 Estimation Algorithm

The Cell Estimation Algorithm steps, # 2 - What is an “effectively” used cell?  Could this just say “Collect the current number of used cells” ?

There is actually quite a bit of emphasis in this document on the idea of an “effectively used cell” - perhaps we should explain the concept of an effectively used cell (or a reference if it’s already defined) - I was curious why the term “effective” is used so often?  In the “Cell Estimation Algorithm” Step #2, the text reads:
“Collect the current number of effectively used cells” — which would seem to imply that ineffectively used cells wouldn’t be included in this step.  This may seem a too literal interpretation, I’m just looking for clarity as to whether or not the term “effective” or “effectively” is really needed in the doc.

Section 11: Relocating Cells

Just for completeness, I would emphasize how PDR is calculated, or include a reference to some other document if defined elsewhere

Thanks for this work!
Randy

---

From: Yasuyuki Tanaka <[email-masked]>
Date: Sun, 5 Mar 2017 22:13:05 +0900

Nice comments!

I also want to see the definition of "effectively used cell" and
how to calculate PDR.

In addition, I don't think that we would count the number of
cells used for 6P in terms of SF0. Is it correct? In any case,
some text on how SF0 should handle traffic or cell usage by 6P
would be helpful.

Best,
Yatch

On 2017/03/05 11:20, Randy Turner wrote:
> _______________________________________________
> 6tisch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch
>

---

From: Yasuyuki Tanaka <[email-masked]>
Date: Fri, 17 Mar 2017 15:55:59 +0900

Hi,

I'm reading the new draft of SF0 and noticed the authors have resolved comments
on a phrase of "effectively used cells" in it!

    https://tools.ietf.org/html/draft-ietf-6tisch-6top-sf0-03

However, there is still one "effectively used cells" remaining in section 2:

draft> ... In order to reduce consumption, this algorithm is triggered only when
draft> there is a change on the number of effectively used cells or if there is
draft> a change on the number of requested cells from a particular node.

Should this "effectively used cells" be replaced with "required cells" or should
"the number of effectively used cells" be replaced with "the current number of
required cells" according to section 4...?

Thank you!
Yatch

---

From: Thomas Watteyne <[email-masked]>
Date: Tue, 28 Mar 2017 14:31:52 +0200

@Diego, @Authors,
Any comments?
Thomas

On Sun, Mar 5, 2017 at 2:13 PM, Yasuyuki Tanaka <
[email-masked]> wrote:

>> Suggest the following  “A portion of these allocated cells will be
>> effectively utilized by neighbors, while the remaining cells can be
>> over-provisioned to handle unanticipated increases in cell requirements”
>>
>> 1. “…change in the current number of used cells”  - could this be
>> paraphrased to say “…a change in the number of required cells”  ?
>>
>>
>>
>> The Cell Estimation Algorithm steps, # 2 - What is an “effectively” used
>> cell?  Could this just say “Collect the current number of used cells” ?
>>
>> There is actually quite a bit of emphasis in this document on the idea of
>> an “effectively used cell” - perhaps we should explain the concept of an
>> effectively used cell (or a reference if it’s already defined) - I was
>> curious why the term “effective” is used so often?  In the “Cell Estimation
>> Algorithm” Step #2, the text reads:
>> “Collect the current number of effectively used cells” — which would seem
>> to imply that ineffectively used cells wouldn’t be included in this step.
>> This may seem a too literal interpretation, I’m just looking for clarity as
>> to whether or not the term “effective” or “effectively” is really needed in
>> the doc.
>>
>>
>> Just for completeness, I would emphasize how PDR is calculated, or
>> include a reference to some other document if defined elsewhere
>>
>>
>>
>>
>> Thanks for this work!
>> Randy

-- 
_______________________________________

Thomas Watteyne, PhD
Research Scientist & Innovator, Inria
Sr Networking Design Eng, Linear Tech
Founder & co-lead, UC Berkeley OpenWSN
Co-chair, IETF 6TiSCH

www.thomaswatteyne.com
_______________________________________

---

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Tue, 28 Mar 2017 09:54:47 -0300

Thomas,
             During the last Webex I commented that
I used these comments to modify and correct
the draft. I eliminated (almost) every instance of
"effectively used cell" and fixed the problems
raised by Randy.
Regards,

                          Diego

2017-03-28 9:31 GMT-03:00 Thomas Watteyne <[email-masked]>:

>>> After reading the current SF0 document, I had a few nits that I thought
>>> I would pass along - hope they’re helpful.
>>>
>>>
>>> Section 2: Introduction
>>>
>>> There is actually quite a bit of emphasis in this document on the idea
>>> of an “effectively used cell” - perhaps we should explain the concept of an
>>> “Collect the current number of effectively used cells” — which would
>>> seem to imply that ineffectively used cells wouldn’t be included in this
>>> step.  This may seem a too literal interpretation, I’m just looking for
>>> clarity as to whether or not the term “effective” or “effectively” is
>>> really needed in the doc.
>>>
>>>

-- 
DIEGO DUJOVNE
Profesor Asociado
Escuela de Informática y Telecomunicaciones
Facultad de Ingeniería - Universidad Diego Portales - Chile
www.ingenieria.udp.cl
(56 2) 676 8125

---

From: Thomas Watteyne <[email-masked]>
Date: Tue, 28 Mar 2017 15:41:45 +0200

Great. So we can close this e-mail thread then.
Thanks

On Tue, Mar 28, 2017 at 2:54 PM, Prof. Diego Dujovne <
[email-masked]> wrote:

>>>> The Cell Estimation Algorithm steps, # 2 - What is an “effectively”
>>>> used cell?  Could this just say “Collect the current number of used cells” ?
>>>>

Thomas Watteyne, PhD

www.thomaswatteyne.com