Subject: [6tisch] I-D Action: draft-richardson-6tisch-roll-enrollment-priority-01.txt

From: [email-masked]
Date: Mon, 06 Aug 2018 11:56:44 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the IPv6 over the TSCH mode of IEEE 802.15.4e WG of the IETF.

        Title           : Enabling secure network enrollment in RPL networks
        Author          : Michael Richardson
	Filename        : draft-richardson-6tisch-roll-enrollment-priority-01.txt
	Pages           : 6
	Date            : 2018-08-06

Abstract:
   [I-D.richardson-6tisch-enrollment-enhanced-beacon] defines a method
   by which a potential [I-D.ietf-6tisch-minimal-security] can announce
   itself as a available for new Pledges to Join a network.  The
   announcement includes a priority for join.  This document provides a
   mechanism by which a RPL DODAG root can disable join announcements,
   or adjust the base priority for join operation.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-richardson-6tisch-roll-enrollment-priority/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-richardson-6tisch-roll-enrollment-priority-01
https://datatracker.ietf.org/doc/html/draft-richardson-6tisch-roll-enrollment-priority-01

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-richardson-6tisch-roll-enrollment-priority-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Michael Richardson <[email-masked]>
Date: Mon, 06 Aug 2018 18:43:14 -0400

> https://www.ietf.org/rfcdiff?url2=draft-richardson-6tisch-roll-enrollment-priority-01

There is little change.
I resubmitted simply because it expired.

It is still intended to be considered for WG adoption in ROLL.

There may be other methods to calculate the proxy priority provided for in
draft-ietf-6tisch-enrollment-enhanced-beacon.
(and certainly in non-RPL networks there would be need to be another mechanism)

The intention again, in this draft, is just to provide a DIO-level mesh-wide
announcement of management intention for a minimum.

In a multi-LLN/multi-PANID situation where there are multiple acceptable
DODAGs that a new pledge could join (under the same management),  it would be
possible to shift preference among the different PANIDs using this mechanism.

AFAIK, the WG has not yet started a WG adoption call.
(Alternatively, 6tisch could instead adopt this, consulting on with ROLL for
IETF Review, as the allocation rules for Control Message Options specify in
6550 section 20.4)

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-