Subject: Re: [6tisch] I-D Action: draft-ietf-6tisch-enrollment-enhanced-beacon-00.txt

From: "Georgios Z. Papadopoulos" <[email-masked]>
Date: Sun, 23 Sep 2018 16:38:58 +0200

Hello Michael,

Many thanks for this work.
Going through the draft, I have a comment/question :

Considering that “The containing Enhanced Beacon is not encrypted.” (Section 3), is it necessary to include “rank priority” at L2 and, thus, revealing this information?

Thanks,
Georgios

> On Jul 21, 2018, at 02:00, [email-masked] wrote:
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the IPv6 over the TSCH mode of IEEE 802.15.4e WG of the IETF.
> 
>        Title           : IEEE802.15.4 Informational Element encapsulation of 6tisch Join and Enrollment Information
>        Authors         : Diego Dujovne (editor)
>                          Michael Richardson
> 	Filename        : draft-ietf-6tisch-enrollment-enhanced-beacon-00.txt
> 	Pages           : 8
> 	Date            : 2018-07-16
> 
> Abstract:
>   In TSCH mode of IEEE802.15.4, as described by [RFC8180],
>   opportunities for broadcasts are limited to specific times and
>   specific channels.  Nodes in a TSCH network typically frequently send
>   Enhanced Beacon (EB) frames to announce the presence of the network.
>   This document provides a mechanism by which small details critical
>   for new nodes (pledges) and long sleeping nodes may be carried within
>   the Enhanced Beacon.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-6tisch-enrollment-enhanced-beacon/
> 
> There are also htmlized versions available at:
> https://tools.ietf.org/html/draft-ietf-6tisch-enrollment-enhanced-beacon-00
> https://datatracker.ietf.org/doc/html/draft-ietf-6tisch-enrollment-enhanced-beacon-00
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> 6tisch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch

---

From: Michael Richardson <[email-masked]>
Date: Sun, 23 Sep 2018 16:38:32 -0400

Georgios Z. Papadopoulos <[email-masked]> wrote:
    > Many thanks for this work.  Going through the draft, I have a
    > comment/question :

    > Considering that “The containing Enhanced Beacon is not encrypted.”
    > (Section 3), is it necessary to include “rank priority” at L2 and,
    > thus, revealing this information?

I consider it a concern as well.

When returning from a deep sleep,  where there may be multiple
LLNs on different PANIDs (and in 6tisch, with different schedules, even using
different sets of channels),  there is a desire to know which network will
"closer".

I think that we need to understand the tradeoffs, so let's discuss
(also in the ROLL WG!).  Perhaps a compromise is that the rank priority can
be forced to maximum value on networks that want to keep the information
private.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Sun, 23 Sep 2018 17:49:53 -0300

Michael,
             I agree on putting the rank to the maximum value
to code that the network is not interested in accepting more members,
thus, keeping their internal data private.
Regards,

                             Diego

Le dim. 23 sept. 2018 à 17:38, Michael Richardson <[email-masked]> a

-- 
DIEGO DUJOVNE
Profesor Asociado
Escuela de Informática y Telecomunicaciones
Facultad de Ingeniería - Universidad Diego Portales - Chile
www.ingenieria.udp.cl
(56 2) 676 8125

---

From: "Georgios Z. Papadopoulos" <[email-masked]>
Date: Thu, 27 Sep 2018 14:10:40 +0200

Hello Michael,

> On Sep 23, 2018, at 22:38, Michael Richardson <[email-masked]> wrote:
> 
> 

+1

Georgios