Subject: Re: [6tisch] draft-ietf-6tisch-minimal-security: Error code and server state

From: Christian Amsüss <[email-masked]>
Date: Fri, 5 Apr 2019 16:32:37 +0200

Hello Mališa,

> Let me know what do you think.

thanks for the update, this addresses my concerns.

Only a small question remains: When a pledge sends [0 /* unsupported */,
42 /* some fancy extension */, X] as an Unsupported Configuration, why
should it send the full value that was sent with the join response and
not just a syntactic placeholder (null)?

Best regards
Christian

-- 
To use raw power is to make yourself infinitely vulnerable to greater powers.
  -- Bene Gesserit axiom

---

From: Mališa Vučinić <[email-masked]>
Date: Fri, 5 Apr 2019 18:54:55 +0200

The original intent was to allow the pledge to signal “I can act on this parameter but not on that value that you gave me”, cherry-picking specific keys from the key set or just copying the whole thing if nothing works. The previous text optimized for that by mandating the value or its CBOR-encoded subset to be included all the time. 

I rewrote the paragraph now in order to allow the pledge to send a null for the case where the JRC should not bother to retry configuring that specific parameter again.

The commit is at:

https://bitbucket.org/6tisch/draft-ietf-6tisch-minimal-security/commits/60e2a8a2acbae5cca624932e88c1f650a95d9ca6?at=minimal-security-10 <https://bitbucket.org/6tisch/draft-ietf-6tisch-minimal-security/commits/60e2a8a2acbae5cca624932e88c1f650a95d9ca6?at=minimal-security-10>

Let me know if it reads better.

Mališa

> On 5 Apr 2019, at 16:32, Christian Amsüss <[email-masked]> wrote:
>

---

From: Christian Amsüss <[email-masked]>
Date: Sun, 7 Apr 2019 11:57:24 +0200

> Let me know if it reads better.

Looks good to me now, and also makes the distinction between "malformed"
and "unsupported" clearer to me.

Thanks
Christian