Subject: [6tisch] MSF and RPL

From: Koojana Kuladinithi <[email-masked]>
Date: Wed, 22 May 2019 06:48:46 +0200

Hi

I tried to understand the MSF draft and read in the impression that this was written to work with any kind of routing protocol. 
But, my thinking is that this is written more specifically to work with RPL. 

    A
   /  \
  C   B 
 /
D

For example, in section 3, for the above figure you will end up with having only 2 autonomous cells, which are correspond to the MAC addresses of A and C. In a flat routing, nodes cannot identify the parent/upstream nodes, the same four nodes example, autonomous cells might be decided based on neighbours, and will result in having 2 more cells corresponding to B and D mac addresses. 

Can somebody make MSF implementation working with any other routing protocol other than RPL?

Kind regards
Koojana

---

From: Tengfei Chang <[email-masked]>
Date: Wed, 22 May 2019 09:42:03 +0200

Hi Koojana,

It's true that MSF works with RPL closely. And it's mainly designed for
upstream traffic.

As you mentioned, MSF could be extended by having autonomous cell to any
potential neighbors that the node intend to have packet exchanged with.
The concept of parent/upstream node could be replaced by the nexthop of the
routing protocols, I think.

Tengfei

On Wed, May 22, 2019 at 6:49 AM Koojana Kuladinithi <
[email-masked]> wrote:

> Hi
>
> I tried to understand the MSF draft and read in the impression that this
> was written to work with any kind of routing protocol.
> For example, in section 3, for the above figure you will end up with
> having only 2 autonomous cells, which are correspond to the MAC addresses
> of A and C. In a flat routing, nodes cannot identify the parent/upstream
> nodes, the same four nodes example, autonomous cells might be decided based
> on neighbours, and will result in having 2 more cells corresponding to B
> and D mac addresses.
>
> _______________________________________________
> 6tisch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch
>

-- 
Chang Tengfei,
Postdoctoral Research Engineer, Inria