Subject: [6tisch] downstream traffic adaptation

From: Tengfei Chang <[email-masked]>
Date: Fri, 23 Aug 2019 14:27:41 +0200

Hi All,

As discussed in IETF 105, we are going to support adapting downstream
traffic.
And now this feature is added in draft-ietf-6tisch-msf-06 published one
weeks ago.

Some main changes related to this feature are:

   1. After joined the network and got Rank, the node will only add one Tx
   Cell to its parent (NOT add Rx Cell)
   2. When adapting downstream traffic, the mote will check the cell usage
   on the Rx Cells.
   3. At each Rx cell to parent, the NUMCELLELAPSE increments
   4. If there is any frames received on the Rx cell, the NUMCELLUSED
   increments
   5. If NUMCELLELAPSE reaches MAX_NUMCELLS, check the percentage of cell
   usage, if higher than the high threshold, add one Rx cell to parent, if
   lower than the low threshold, remove one Rx cell to parent.
   6. The AutoRx cell is used for downstream as well and will never be
   removed.

Those changes are integrated into version 06 content. You can read it to
check exactly how we did the changes.
Please let me know if you have comments on them. Thanks!

Tengfei

-- 
Chang Tengfei,
Postdoctoral Research Engineer, Inria

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 23 Aug 2019 14:23:13 +0000

Looks good Tengfei. Did you already implement and test?

Pascal

From: 6tisch <[email-masked]> On Behalf Of Tengfei Chang
Sent: vendredi 23 août 2019 14:28
To: 6tisch <[email-masked]>
Subject: [6tisch] downstream traffic adaptation

Hi All,

As discussed in IETF 105, we are going to support adapting downstream traffic.
And now this feature is added in draft-ietf-6tisch-msf-06 published one weeks ago.

  1.  After joined the network and got Rank, the node will only add one Tx Cell to its parent (NOT add Rx Cell)
  2.  When adapting downstream traffic, the mote will check the cell usage on the Rx Cells.
  3.  At each Rx cell to parent, the NUMCELLELAPSE increments
  4.  If there is any frames received on the Rx cell, the NUMCELLUSED increments
  5.  If NUMCELLELAPSE reaches MAX_NUMCELLS, check the percentage of cell usage, if higher than the high threshold, add one Rx cell to parent, if lower than the low threshold, remove one Rx cell to parent.
  6.  The AutoRx cell is used for downstream as well and will never be removed.
Those changes are integrated into version 06 content. You can read it to check exactly how we did the changes.
Please let me know if you have comments on them. Thanks!

Tengfei