Subject: Re: [6tisch] downstream traffic adaptation

From: Tengfei Chang <[email-masked]>
Date: Fri, 4 Oct 2019 16:25:19 +0200

Hi Pascal,

Yes, it is implemented and tested, the result is shown in the (long) email
"[6tisch] validating the downstream traffic adaptation in
draft-ietf-6tisch-msf-06".
I attached the figure here as well.

Though that email is long, all the information is the explaination of the
result figure, trying to make it clear.
You can check the figure directly, I think is understandable for people
following the msf well.

Tengfei

On Fri, Aug 23, 2019 at 4:23 PM Pascal Thubert (pthubert) <
[email-masked]> wrote:

> Looks good Tengfei. Did you already implement and test?
>
>
>
> Pascal
>
>
>
> *From:* 6tisch <[email-masked]> *On Behalf Of *Tengfei Chang
> *Sent:* vendredi 23 août 2019 14:28
> *To:* 6tisch <[email-masked]>
> *Subject:* [6tisch] downstream traffic adaptation
>
>
>
> Hi All,
>
>
>
> As discussed in IETF 105, we are going to support adapting downstream
> traffic.
>
> And now this feature is added in draft-ietf-6tisch-msf-06 published one
> weeks ago.
>
>
>
> Some main changes related to this feature are:
>
>    1. After joined the network and got Rank, the node will only add one
>    Tx Cell to its parent (NOT add Rx Cell)
>    2. When adapting downstream traffic, the mote will check the cell
>    usage on the Rx Cells.
>    3. At each Rx cell to parent, the NUMCELLELAPSE increments
>    4. If there is any frames received on the Rx cell, the NUMCELLUSED
>    increments
>    5. If NUMCELLELAPSE reaches MAX_NUMCELLS, check the percentage of cell
>    usage, if higher than the high threshold, add one Rx cell to parent, if
>    lower than the low threshold, remove one Rx cell to parent.
>    6. The AutoRx cell is used for downstream as well and will never be
>    removed.
>
> Those changes are integrated into version 06 content. You can read it to
> check exactly how we did the changes.
>
> Please let me know if you have comments on them. Thanks!
>
>
>
> Tengfei
>
>
>
> --
>
> Chang Tengfei,
>
> Postdoctoral Research Engineer, Inria
>

-- 
——————————————————————————————————————

Dr. Tengfei, Chang
Postdoctoral Research Engineer, Inria

www.tcahng.org
——————————————————————————————————————

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 7 Oct 2019 13:03:02 +0000

Hello Tengfei and all

I see that the 2 issues of IETF 105

  *   Rules for CellList
  *   Downward traffic adaptation
Were discussed and there was no objection. Do you fell ready for WGLC now?

All the best

Pascal

From: 6tisch <[email-masked]> On Behalf Of Tengfei Chang
Sent: vendredi 4 octobre 2019 07:25
To: Pascal Thubert (pthubert) <[email-masked]>
Cc: 6tisch <[email-masked]>
Subject: Re: [6tisch] downstream traffic adaptation

Hi Pascal,

Yes, it is implemented and tested, the result is shown in the (long) email "[6tisch] validating the downstream traffic adaptation in draft-ietf-6tisch-msf-06".
I attached the figure here as well.

Though that email is long, all the information is the explaination of the result figure, trying to make it clear.
You can check the figure directly, I think is understandable for people following the msf well.

Tengfei

On Fri, Aug 23, 2019 at 4:23 PM Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>> wrote:
Looks good Tengfei. Did you already implement and test?

Pascal

From: 6tisch <[email-masked]<mailto:[email-masked]>> On Behalf Of Tengfei Chang
Sent: vendredi 23 août 2019 14:28
To: 6tisch <[email-masked]<mailto:[email-masked]>>
Subject: [6tisch] downstream traffic adaptation

Hi All,

As discussed in IETF 105, we are going to support adapting downstream traffic.
And now this feature is added in draft-ietf-6tisch-msf-06 published one weeks ago.

  1.  After joined the network and got Rank, the node will only add one Tx Cell to its parent (NOT add Rx Cell)
  2.  When adapting downstream traffic, the mote will check the cell usage on the Rx Cells.
  3.  At each Rx cell to parent, the NUMCELLELAPSE increments
  4.  If there is any frames received on the Rx cell, the NUMCELLUSED increments
  5.  If NUMCELLELAPSE reaches MAX_NUMCELLS, check the percentage of cell usage, if higher than the high threshold, add one Rx cell to parent, if lower than the low threshold, remove one Rx cell to parent.
  6.  The AutoRx cell is used for downstream as well and will never be removed.
Those changes are integrated into version 06 content.. You can read it to check exactly how we did the changes.
Please let me know if you have comments on them.. Thanks!

Tengfei

Dr. Tengfei, Chang

www.tcahng.org<http://www.tcahng.org>
——————————————————————————————————————

---

From: Tengfei Chang <[email-masked]>
Date: Tue, 8 Oct 2019 13:35:26 +0200

Yes, I have talked with all the authors and we agreed that the current
version is ready for WGLC!

Tengfei

On Mon, Oct 7, 2019 at 3:03 PM Pascal Thubert (pthubert) <[email-masked]>
wrote:

>    - Rules for CellList
>    - Downward traffic adaptation
>
> *Sent:* vendredi 4 octobre 2019 07:25
> *To:* Pascal Thubert (pthubert) <[email-masked]>
> *Cc:* 6tisch <[email-masked]>
> *Subject:* Re: [6tisch] downstream traffic adaptation
>
>
>
> Hi Pascal,
>
>
>

Dr. Tengfei, Chang

www.tcahng.org