Subject: [6tsch] Mobility in 6TSCH

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 26 Jul 2013 16:20:40 +0000

Dear all;

As you know, determinism and fast mobility are quite antagonistic in nature. 

Even with distributed routing, there are a number of issues like timeslot allocation and security context transfer or (re)establishment that will delay the mobility.
In 6TSCH, we have use cases that we want to serve like the crane and the mobile handset, which require a certain degree of mobility but probably not make before break or sub-second reconnection. So we want to express that we aim at supporting this limited mobility but we do not want to raise the expectation higher than we can actually serve.

The mobility term is so overloaded that it might be misleading. Would you have a suggestion for term that would be more appropriate?

(I heard the terms soft, limited, and constrained so far)

Cheers,

Pascal

---

From: Qin Wang <[email-masked]>
Date: Sat, 27 Jul 2013 01:50:15 +0800

Hi Pascal and All,

How about "dynamic adjustment". Because,

In steady network (fixed location and predictable traffic load),  the
features of deterministic and low energy consumption have definitely been
provided. What we want to do is, with distributed reservation and RPL, the
deterministic and low energy consumption features can be extended to the
dynamic network (some degree of location change and/or some degree of
traffic load change).

Thought?

Qin

On Sat, Jul 27, 2013 at 12:20 AM, Pascal Thubert (pthubert) <
[email-masked]> wrote:

> Even with distributed routing, there are a number of issues like timeslot
> allocation and security context transfer or (re)establishment that will
> delay the mobility.
> In 6TSCH, we have use cases that we want to serve like the crane and the
> mobile handset, which require a certain degree of mobility but probably not
> make before break or sub-second reconnection. So we want to express that we
> aim at supporting this limited mobility but we do not want to raise the
> expectation higher than we can actually serve.
>
> The mobility term is so overloaded that it might be misleading. Would you
> have a suggestion for term that would be more appropriate?
>
> _______________________________________________
> 6tsch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tsch
>

---

From: Thomas Watteyne <[email-masked]>
Date: Sat, 27 Jul 2013 09:40:12 +0200

Pascal,

I understand you are looking for the right term.

Terms I can think of:
- roaming
- node relocation
- occasional mobility
- intermittent relocation

Thomas

---

From: Alfredo Grieco <[email-masked]>
Date: Sat, 27 Jul 2013 10:04:14 +0200

Almost static topologies ?

Alfredo

On Saturday, July 27, 2013, Thomas Watteyne wrote:

> On Fri, Jul 26, 2013 at 7:50 PM, Qin Wang <[email-masked]<javascript:_e({}, 'cvml', [email-masked]');>
> > wrote:
>
>> Hi Pascal and All,
>>
>> [email-masked] <javascript:_e({}, 'cvml', [email-masked]');>>wrote:
>>
>>> Dear all;
>>>
>>> Even with distributed routing, there are a number of issues like
>>> timeslot allocation and security context transfer or (re)establishment that
>>> will delay the mobility.
>>> The mobility term is so overloaded that it might be misleading. Would
>>> you have a suggestion for term that would be more appropriate?
>>>
>>> [email-masked] <javascript:_e({}, 'cvml', [email-masked]');>
>> [email-masked] <javascript:_e({}, 'cvml', [email-masked]');>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Sat, 27 Jul 2013 09:41:41 +0000

Dear all;

I love the term "relocation".
We probably want a relocation that is transparent to the upper layers.
The topology can also be qualified as relatively stable.

What do others think?

Cheers,

Pascal

From: [email-masked] [mailto:[email-masked]] On Behalf Of Alfredo Grieco
Sent: samedi 27 juillet 2013 10:04
To: Thomas Watteyne
Cc: [email-masked]
Subject: Re: [6tsch] Mobility in 6TSCH

Alfredo

Terms I can think of:
- roaming
- node relocation
- occasional mobility

Thomas

On Fri, Jul 26, 2013 at 7:50 PM, Qin Wang <[email-masked]<javascript:_e(%7b%7d,%20'cvml',[email-masked]');>> wrote:
Hi Pascal and All,

In steady network (fixed location and predictable traffic load),  the features of deterministic and low energy consumption have definitely been provided. What we want to do is, with distributed reservation and RPL, the deterministic and low energy consumption features can be extended to the dynamic network (some degree of location change and/or some degree of traffic load change).

Thought?

Qin

On Sat, Jul 27, 2013 at 12:20 AM, Pascal Thubert (pthubert) <[email-masked]<javascript:_e(%7b%7d,%20'cvml',[email-masked]');>> wrote:
Dear all;

Cheers,

Pascal

_______________________________________________
6tsch mailing list
[email-masked]<javascript:_e(%7b%7d,%20'cvml',[email-masked]');>
https://www.ietf.org/mailman/listinfo/6tsch

_______________________________________________
6tsch mailing list
[email-masked]<javascript:_e(%7b%7d,%20'cvml',[email-masked]');>
https://www.ietf.org/mailman/listinfo/6tsch

---

From: Xavier Vilajosana Guillen <[email-masked]>
Date: Sat, 27 Jul 2013 13:42:23 +0200

+1 for relocation,

"node relocation"

IMHO is the most suitable candidate.

:-)
X

On Sat, Jul 27, 2013 at 11:41 AM, Pascal Thubert (pthubert) <
[email-masked]> wrote:

>  Dear all;****
>
> ** **
>
> I love the term “relocation”. ****
>
> We probably want a relocation that is transparent to the upper layers.****
>
> The topology can also be qualified as relatively stable.****
>
> ** **
>
> What do others think?****
>
> ** **
>
> Cheers,****
>
> ** **
>
> Pascal****
>
> ** **
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf
> Of *Alfredo Grieco
> *Sent:* samedi 27 juillet 2013 10:04
> *To:* Thomas Watteyne
> *Cc:* [email-masked]
> *Subject:* Re: [6tsch] Mobility in 6TSCH****
>
> ** **
>
> Almost static topologies ?****
>
> ** **
>
> Alfredo
>
> On Saturday, July 27, 2013, Thomas Watteyne wrote:****
>
> Pascal,****
>
> ** **
>
> I understand you are looking for the right term.****
>
> ** **
>
> Terms I can think of:****
>
> - roaming****
>
> - node relocation****
>
> - occasional mobility****
>
> - intermittent relocation****
>
> ** **
>
> Thomas****
>
> ** **
>
> On Fri, Jul 26, 2013 at 7:50 PM, Qin Wang <[email-masked]> wrote:***
> *
>
> Hi Pascal and All,****
>
> ** **
>
> How about "dynamic adjustment". Because,****
>
> ** **
>
> traffic load change).****
>
> ** **
>
> Thought?****
>
> ** **
>
> Qin****
>
> ** **
>
> ** **
>
> ** **
>
> [email-masked]> wrote:****
>
> Dear all;
>
> https://www.ietf.org/mailman/listinfo/6tsch****
>
> ** **
>
>
> https://www.ietf.org/mailman/listinfo/6tsch****
>
> ** **
>

---

From: Qin Wang <[email-masked]>
Date: Sat, 27 Jul 2013 22:52:04 +0800

+1 on "relocation"

Qin

On Sat, Jul 27, 2013 at 7:42 PM, Xavier Vilajosana Guillen <
[email-masked]> wrote:

>> *From:* [email-masked] [mailto:[email-masked]] *On
>> Behalf Of *Alfredo Grieco
>> On Fri, Jul 26, 2013 at 7:50 PM, Qin Wang <[email-masked]> wrote:**
>> **
>>
>> Hi Pascal and All,****
>>
>> ** **
>>