Subject: [6tsch] BoF Agenda & presenters

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 5 Jul 2013 17:37:44 +0000

Dear ML members:
Now is the time when we need every good will and skill on board for a successful BoF. Our objective: convince the audience that there is important work to be done that does not belong to an existing group and that we'll have in this new group the people to handle the work in a reasonable time frame.
We need to demonstrate:
- our skill. We as a group understand and have experience on all aspects of the technology.
- our control of the problem. No boiling the ocean, reinventing the wheel, blah etc...
The role of the speakers at the BoF will be critical. During the call today we have isolated 9 items that we need to cover in Berlin. Now we are calling for presenters for each of these items.
The presenter will own a thread on his topic(s) to discuss the argument he will make at the BoF. No worries, we will have the next 2 calls for rehearsals.
Please respond to this mail with a short summary of what you are willing to take like, e.g.
Thomas Watteyne: 1.d, 2.d
or
Pascal Thubert: 2.e
Based on the following list of topics:

1.      problem statement [30min]

     *   what is IEEE802.15.4e TSCH? (a key to deterministism and scalability)    10mn
     *   what is missing? (mostly the cement as opposed to the building blocks)  15mn
     *   Why is this a problem? (multiple proprietary solutions, costly, limited scope) 3mn
     *   Status of 6TSCH group  (drafts, ML audience, calls, tracking with BB ...)  2mn

  1.  discussion of the charter [30min]

     *   background and introduction (existing work demonstrates feasibility) 5mn
     *   description of WG (we have participants skilled in the art)                   5mn
     *   work items (we reuse as much as we can from existing IETF work)    10mn
     *   non-milestone work items (we demonstrate our will to coexist within regulations) 2mn
     *   external work to other WG (6MAN, PCE, ROLL?)  3mn
 Thanks a bunch!!!
Pascal

---

From: Xavier Vilajosana Guillen <[email-masked]>
Date: Fri, 5 Jul 2013 12:02:14 -0700

Hi all
I can do 1.b:  what is missing? (mostly the cement as opposed to the
building blocks)  15mn

and if nobody does 2.a I can do it as well but I prefer that if there is
someone else interested just goes ahead.

let me know if this is ok!
X

On Fri, Jul 5, 2013 at 10:37 AM, Pascal Thubert (pthubert) <
[email-masked]> wrote:

>  Dear ML members: ****
>
> Now is the time when we need every good will and skill on board for a
> successful BoF. Our objective: convince the audience that there is
> important work to be done that does not belong to an existing group and
> that we’ll have in this new group the people to handle the work in a
> reasonable time frame.****
>
> We need to demonstrate:****
>
> - our skill. We as a group understand and have experience on all aspects
> of the technology.****
>
> - our control of the problem. No boiling the ocean, reinventing the wheel,
> blah etc…****
>
> The role of the speakers at the BoF will be critical. During the call
> today we have isolated 9 items that we need to cover in Berlin. Now we are
> calling for presenters for each of these items.****
>
> The presenter will own a thread on his topic(s) to discuss the argument he
> will make at the BoF. No worries, we will have the next 2 calls for
> rehearsals. ****
>
> Please respond to this mail with a short summary of what you are willing
> to take like, e.g.****
>
> Thomas Watteyne: 1.d, 2.d****
>
> or****
>
> Pascal Thubert: 2.e****
>
> Based on the following list of topics:****
>
> **1.      **problem statement [30min] ****
>
>     1. what is IEEE802.15.4e TSCH? (a key to deterministism and
>       scalability)    10mn****
>       2. what is missing? (mostly the cement as opposed to the building
>       blocks)  15mn****
>       3. Why is this a problem? (multiple proprietary solutions, costly,
>       limited scope) 3mn****
>       4. Status of 6TSCH group  (drafts, ML audience, calls, tracking
>       with BB …)  2mn ****
>
>  ** **
>
>    1. discussion of the charter [30min] ****
>
>
>     1. background and introduction (existing work demonstrates
>       feasibility) 5mn****
>       2. description of WG (we have participants skilled in the
>       art)                   5mn****
>       3. work items (we reuse as much as we can from existing IETF
>       work)    10mn****
>       4. non-milestone work items (we demonstrate our will to coexist
>       within regulations) 2mn****
>       5. external work to other WG (6MAN, PCE, ROLL?)  3mn ****
>
>  Thanks a bunch!!!****
>
> Pascal****
>
> _______________________________________________
> 6tsch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tsch
>
>

---

From: Thomas Watteyne <[email-masked]>
Date: Fri, 5 Jul 2013 12:19:47 -0700

Pascal,

Clarifying question:

   1. background and introduction (existing work demonstrates feasibility)
   5m

What do you mean by "existing work"? Is it synonymous to "companies are
selling networks that use IEEE802.15.4e, so it really does work"?

Thanks,
Thomas

On Fri, Jul 5, 2013 at 12:02 PM, Xavier Vilajosana Guillen <
[email-masked]> wrote:

>> - our control of the problem. No boiling the ocean, reinventing the
>> wheel, blah etc…****
>>
>> The presenter will own a thread on his topic(s) to discuss the argument
>> he will make at the BoF. No worries, we will have the next 2 calls for
>> rehearsals. ****
>>

---

From: Pascal Thubert <[email-masked]>
Date: Fri, 5 Jul 2013 21:56:16 +0200

Yes and more:

Wihart and isa100 demonstrate that we can do deterministic wireless. Proprietary RPL variations scale to the multiple 1000s.
 And there are at least 3 instances of RPL over TSCH that were developped in parallel.
Putting it all together is technically feasible. If all parties agree on mutual benefits 6tsch will roll 😊

Pascal

Le 5 juil. 2013 à 21:19, Thomas Watteyne <[email-masked]> a écrit :

> Pascal,
> 
> Clarifying question:
> background and introduction (existing work demonstrates feasibility) 5m
> What do you mean by "existing work"? Is it synonymous to "companies are selling networks that use IEEE802.15.4e, so it really does work"?
> 
> Thanks,
> Thomas
> 
> 
> On Fri, Jul 5, 2013 at 12:02 PM, Xavier Vilajosana Guillen <[email-masked]> wrote:
>> Hi all
>> I can do 1.b:  what is missing? (mostly the cement as opposed to the building blocks)  15mn
>> 
>> and if nobody does 2.a I can do it as well but I prefer that if there is someone else interested just goes ahead.
>> 
>> On Fri, Jul 5, 2013 at 10:37 AM, Pascal Thubert (pthubert) <[email-masked]> wrote:
>>> Dear ML members:
>>> 
>>> Now is the time when we need every good will and skill on board for a successful BoF. Our objective: convince the audience that there is important work to be done that does not belong to an existing group and that we’ll have in this new group the people to handle the work in a reasonable time frame.
>>> 
>>> We need to demonstrate:
>>> 
>>> - our control of the problem. No boiling the ocean, reinventing the wheel, blah etc…
>>> 
>>> what is IEEE802.15.4e TSCH? (a key to deterministism and scalability)    10mn
>>> what is missing? (mostly the cement as opposed to the building blocks)  15mn
>>> Why is this a problem? (multiple proprietary solutions, costly, limited scope) 3mn
>>> Status of 6TSCH group  (drafts, ML audience, calls, tracking with BB …)  2mn
>>>  
>>> 
>>> discussion of the charter [30min] 
>>> background and introduction (existing work demonstrates feasibility) 5mn
>>> description of WG (we have participants skilled in the art)                   5mn
>>> work items (we reuse as much as we can from existing IETF work)    10mn
>>> non-milestone work items (we demonstrate our will to coexist within regulations) 2mn
>>> external work to other WG (6MAN, PCE, ROLL?)  3mn
>>>  Thanks a bunch!!!
>>> 
>>> Pascal
>>> 
>>>

---

From: Thomas Watteyne <[email-masked]>
Date: Fri, 5 Jul 2013 15:18:38 -0700

Pascal,
Makes absolute sense, thanks for the clarification.
Thomas

On Fri, Jul 5, 2013 at 12:56 PM, Pascal Thubert <[email-masked]>wrote:

> Yes and more:
>
> Wihart and isa100 demonstrate that we can do deterministic wireless.
> Proprietary RPL variations scale to the multiple 1000s.
>    feasibility) 5m
>>>       3. Why is this a problem? (multiple proprietary solutions,
>>>       costly, limited scope) 3mn****