Subject: [6tsch] 15.4e TSCH slides - looking for feedbacks

From: Maria Rita PALATTELLA <[email-masked]>
Date: Wed, 17 Jul 2013 19:08:18 +0000

Dear all,
I have put together a first set of slides for presenting the IEEE802.15.4e TSCH and its potentialities.

I have followed most of the raw ideas we collected during last call.

One point is not so clear to me: "Time sync'ed mesh protocols".
@Xavi: can you please explain me better what you meant with this key word? Thank you!

I am also wondering if some concepts that I introduced will overlap with Thomas'  first overview, or with the following talk given by Xavi. In details:
1) Shall we keep the slide 4 on the TSCH history? Or Xavi will cover this part later?
2) Shall we keep slide 8 on the scheduling approaches? Or Thomas will cover this point in his first talk?
3) Shall we add a slide on the applications? Or Thomas will do it before me?

Please, don't hesitate to provide any sort of comment, feedback for improving the slides, describing better the raw ideas, and fixing any kind of mistake I can have done.

Thank you!
Maria Rita

---

From: <[email-masked]>
Date: Wed, 17 Jul 2013 20:02:34 +0000

Hi Maria,
Actually I mentioned "Time sync'ed mesh protocols" during the last call. Maybe we have to change it a little bit to express my point.
In IEEE 802.15.4 2006 standard, beaconing is used to achieve synchronization. Beacon Scheduling is a challenging issue in tree topology and is not permitted in mesh networks. As far as I know, for example ZigBee mesh networks does not allow beaconing and does not support timeslots.
In IEEE 802.15.4 2006 standard, it is not possible for each neighboring devices to communicate with each other in a timeslot, if they don't have the same parent.
However, in TSCH that Beaconing is not used for synchronization, each node can communicate with each of its neighbors in any timeslot that it wish. That's make it possible for upper layer (e.g. network layer) to construct the mesh topology as well as tree topology.
Best Wishes,
Pouria

From: [email-masked] [mailto:[email-masked]] On Behalf Of Maria Rita PALATTELLA
Sent: Wednesday, July 17, 2013 9:08 PM
To: Alfredo Grieco; Pascal Thubert (pthubert); Thomas Watteyne
Cc: [email-masked]
Subject: [6tsch] 15.4e TSCH slides - looking for feedbacks

Dear all,

Thank you!
Maria Rita

---

From: Maria Rita PALATTELLA <[email-masked]>
Date: Wed, 17 Jul 2013 20:57:36 +0000

Pouria, sorry if I remember wrong and I confused Xavi with you.
Thank you for the prompt reply and the explanations you have provided. Now it is clearer. I will try to summarizy the concepts in bullets points for a slide.
Maria Rita

________________________________
From: [email-masked] [[email-masked]]
Sent: Wednesday, July 17, 2013 10:02 PM
To: Maria Rita PALATTELLA; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [6tsch] 15.4e TSCH slides - looking for feedbacks

Hi Maria,
Actually I mentioned “Time sync'ed mesh protocols” during the last call. Maybe we have to change it a little bit to express my point.
In IEEE 802.15.4 2006 standard, beaconing is used to achieve synchronization. Beacon Scheduling is a challenging issue in tree topology and is not permitted in mesh networks. As far as I know, for example ZigBee mesh networks does not allow beaconing and does not support timeslots.
In IEEE 802.15.4 2006 standard, it is not possible for each neighboring devices to communicate with each other in a timeslot, if they don’t have the same parent.
However, in TSCH that Beaconing is not used for synchronization, each node can communicate with each of its neighbors in any timeslot that it wish. That’s make it possible for upper layer (e.g. network layer) to construct the mesh topology as well as tree topology.
Best Wishes,
Pouria

Dear all,

Thank you!
Maria Rita

---

From: Thomas Watteyne <[email-masked]>
Date: Wed, 17 Jul 2013 23:05:32 +0200

Maria Rita,

This is the kind of fine-tuning we need to do in the next 2 calls. What I
have done is uploaded your slides into the repo to keep track of them. I'll
go over my slides and see who covers what, and what does (not) work. More
by e-mail tomorrow, and by phone on Friday.

Thomas

On Wed, Jul 17, 2013 at 10:02 PM, <[email-masked]> wrote:

>  Hi Maria,****
>
> Actually I mentioned “Time sync'ed mesh protocols” during the last call.
> Maybe we have to change it a little bit to express my point.****
>
> In IEEE 802.15.4 2006 standard, beaconing is used to achieve
> synchronization. Beacon Scheduling is a challenging issue in tree topology
> and is not permitted in mesh networks. As far as I know, for example ZigBee
> mesh networks does not allow beaconing and does not support timeslots.****
>
> In IEEE 802.15.4 2006 standard, it is not possible for each neighboring
> devices to communicate with each other in a timeslot, if they don’t have
> the same parent.  ****
>
> However, in TSCH that Beaconing is not used for synchronization, each node
> can communicate with each of its neighbors in any timeslot that it wish.
> That’s make it possible for upper layer (e.g. network layer) to construct
> the mesh topology as well as tree topology. ****
>
> Best Wishes,****
>
> Pouria****
>
> ** **
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf
> Of *Maria Rita PALATTELLA
> *Sent:* Wednesday, July 17, 2013 9:08 PM
> *To:* Alfredo Grieco; Pascal Thubert (pthubert); Thomas Watteyne
> *Cc:* [email-masked]
> *Subject:* [6tsch] 15.4e TSCH slides - looking for feedbacks****
>
> ** **
>
> Dear all,
> I am also wondering if some concepts that I introduced will overlap with
> Thomas'  first overview, or with the following talk given by Xavi. In
> details:
> Please, don't hesitate to provide any sort of comment, feedback for
> improving the slides, describing better the raw ideas, and fixing any kind
> of mistake I can have done.
>
> Thank you!
> Maria Rita****
>

---

From: Maria Rita PALATTELLA <[email-masked]>
Date: Wed, 17 Jul 2013 21:07:20 +0000

That's sound like a good plan!
Thank you. Maria Rita
________________________________
From: [email-masked] [[email-masked]] on behalf of Thomas Watteyne [[email-masked]]
Sent: Wednesday, July 17, 2013 11:05 PM
To: Pouria Zand
Cc: Maria Rita PALATTELLA; Alfredo Grieco; Pascal Thubert; 6TSCH
Subject: Re: [6tsch] 15.4e TSCH slides - looking for feedbacks

Maria Rita,

This is the kind of fine-tuning we need to do in the next 2 calls. What I have done is uploaded your slides into the repo to keep track of them. I'll go over my slides and see who covers what, and what does (not) work. More by e-mail tomorrow, and by phone on Friday.

Thomas

On Wed, Jul 17, 2013 at 10:02 PM, <[email-masked]<mailto:[email-masked]>> wrote:
Hi Maria,

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Maria Rita PALATTELLA
Sent: Wednesday, July 17, 2013 9:08 PM
To: Alfredo Grieco; Pascal Thubert (pthubert); Thomas Watteyne
Cc: [email-masked]<mailto:[email-masked]>
Subject: [6tsch] 15.4e TSCH slides - looking for feedbacks

Dear all,

Thank you!
Maria Rita

---

From: Kris Pister <[email-masked]>
Date: Wed, 17 Jul 2013 17:49:49 -0700

I'm not sure if you want/need slide 4, but if you keep it you should put 
Wireless HART in 2007, not 2009.
HART 7.0, the first to include Wireless HART, was released in September 
2007.  The latest rev is 7.3, and those documents bear later dates, but 
those were relatively minor changes.

ksjp

On 7/17/2013 12:08 PM, Maria Rita PALATTELLA wrote:
> Dear all,
> I have put together a first set of slides for presenting the 
> IEEE802.15.4e TSCH and its potentialities.
>
> I am also wondering if some concepts that I introduced will overlap 
> with Thomas'  first overview, or with the following talk given by 
> Xavi. In details:
> improving the slides, describing better the raw ideas, and fixing any 
> kind of mistake I can have done.
>
> Thank you!
> Maria Rita
>
>
>
> _______________________________________________
> 6tsch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tsch

---

From: Maria Rita PALATTELLA <[email-masked]>
Date: Thu, 18 Jul 2013 07:55:18 +0000

Thanks Kris for having fixed this!
Anyway, I do agree that maybe we will not keep/need this slide. We will decide all together.
Thank you.
Maria Rita

From: [email-masked] [mailto:[email-masked]] On Behalf Of Kris Pister
Sent: Thursday, July 18, 2013 2:50 AM
To: [email-masked]
Subject: Re: [6tsch] 15.4e TSCH slides - looking for feedbacks

I'm not sure if you want/need slide 4, but if you keep it you should put Wireless HART in 2007, not 2009.
HART 7.0, the first to include Wireless HART, was released in September 2007.  The latest rev is 7.3, and those documents bear later dates, but those were relatively minor changes.

ksjp

Thank you!
Maria Rita

6tsch mailing list

[email-masked]<mailto:[email-masked]>