Subject: [6tsch] slides for work items

From: "Raghuram Sudhaakar (rsudhaak)" <[email-masked]>
Date: Mon, 22 Jul 2013 05:25:18 +0000

All,
Attached are the slides for the work items. Please provide your comments.

Specifically, please provide feedback on whether we must have the security framework as a work item.

-raghuram

---

From: Thomas Watteyne <[email-masked]>
Date: Mon, 22 Jul 2013 16:50:21 +0200

Raghuram,

Thanks! I uploaded the slides into the repo and updated the links in the
wiki.

I believe we want to stick as closely as possible to the charter.

We have elected to treat security not as a explicit work item in the
charter, since it can end up being a requirements document followed by a
security draft, or something which is scattered in different drafts.

The charter text now is:
"A document on the security architecture and requirements for 6TSCH will be
developed, and depending on the security requirements identified in the
document, the group may work on a security solution and ask for security
area
review."

Unless we decide to change the charter text, I would keep the same "logic"
in the presentation, and therefore not give the security work a work item
number.

A couple of remarks:
- please change from 6TOP to 6top throughout.
- [2] I would put the work items in the order they appear in the charter.
- please note that work item 2 might change in the next couple of days, so
you might have to adapt the slides.

Thomas

On Mon, Jul 22, 2013 at 7:25 AM, Raghuram Sudhaakar (rsudhaak) <
[email-masked]> wrote:

> _______________________________________________
> 6tsch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tsch
>
>

---

From: "Raghuram Sudhaakar (rsudhaak)" <[email-masked]>
Date: Mon, 22 Jul 2013 14:54:48 +0000

Thomas,
Thanks for the comments. I will incorporate them.

As for, comment [2], I put in the order of the charter. Can you please point out if something specific is amiss.

No problem with adapting the slides.

-raghuram

From: Thomas Watteyne <[email-masked]<mailto:[email-masked]>>
Date: Monday, July 22, 2013 7:50 AM
To: raghuram sudhaakar <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [6tsch] slides for work items

Raghuram,

Thanks! I uploaded the slides into the repo and updated the links in the wiki.

We have elected to treat security not as a explicit work item in the charter, since it can end up being a requirements document followed by a security draft, or something which is scattered in different drafts.

The charter text now is:
"A document on the security architecture and requirements for 6TSCH will be
developed, and depending on the security requirements identified in the
document, the group may work on a security solution and ask for security area
review."

Unless we decide to change the charter text, I would keep the same "logic" in the presentation, and therefore not give the security work a work item number.

A couple of remarks:
- please change from 6TOP to 6top throughout.
- [2] I would put the work items in the order they appear in the charter.
- please note that work item 2 might change in the next couple of days, so you might have to adapt the slides.

Thomas

On Mon, Jul 22, 2013 at 7:25 AM, Raghuram Sudhaakar (rsudhaak) <[email-masked]<mailto:[email-masked]>> wrote:
All,
Attached are the slides for the work items. Please provide your comments.

-raghuram

_______________________________________________
6tsch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tsch

---

From: Thomas Watteyne <[email-masked]>
Date: Mon, 22 Jul 2013 16:59:38 +0200

I'm referring to the order in charter-ietf-6tsch-00.txt at
https://bitbucket.org/6tsch/charter-ietf-6tsch/src which is

1. "6TSCH Operation Sublayer (6top)"
2. "6TSCH centralized management"
3. "6TSCH distributed management"
4. "Minimal 6TSCH Configuration"
5. "6TSCH architecture"
6. "TSCH overview"
(no number) security architecture and requirements

Thomas

On Mon, Jul 22, 2013 at 4:54 PM, Raghuram Sudhaakar (rsudhaak) <
[email-masked]> wrote:

>  As for, comment [2], I put in the order of the charter. Can you please
> point out if something specific is amiss.
>
>   From: Thomas Watteyne <[email-masked]>
> To: raghuram sudhaakar <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>
>  Unless we decide to change the charter text, I would keep the same
> "logic" in the presentation, and therefore not give the security work a
> work item number.
>
>  A couple of remarks:

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 22 Jul 2013 15:12:34 +0000

Hi Raghu and Thomas:

I made a slight update 6TOP -> 6top since apparently we are using lowercase here.

For security, I'd be OK to revisit the charter and promote the work considering that we have a very serious draft and some identified issues (e.g. securing the beacons or not, scalability). Can we take that to the list separately?

The other item that we need to conclude on is the PCE interaction. The charter (and the slides) miss the fact that we need to define what topological / metric information gets passed to the PCE, how we locate the PCE, how we make available and scale the PCE, and which protocol we use for all this. The chartered piece, working on PCEP, is only the visible part of that iceberg.

We need to conclude on the thread, which is stalled. Should I propose text?

Pascal

From: [email-masked] [mailto:[email-masked]] On Behalf Of Thomas Watteyne
Sent: lundi 22 juillet 2013 16:50
To: Raghuram Sudhaakar (rsudhaak)
Cc: [email-masked]
Subject: Re: [6tsch] slides for work items

Raghuram,

The charter text now is:

A couple of remarks:

Thomas

-raghuram

---

From: "Raghuram Sudhaakar (rsudhaak)" <[email-masked]>
Date: Mon, 22 Jul 2013 15:26:18 +0000

Done. It is in the below order.

I have removed security arch and reqs.

Other updates are also incorporated and can go into the repo.

Thanks
raghuram

Date: Monday, July 22, 2013 7:59 AM

I'm referring to the order in charter-ietf-6tsch-00.txt at https://bitbucket.org/6tsch/charter-ietf-6tsch/src which is

Thomas

On Mon, Jul 22, 2013 at 4:54 PM, Raghuram Sudhaakar (rsudhaak) <[email-masked]<mailto:[email-masked]>> wrote:
Thomas,
Thanks for the comments. I will incorporate them.

-raghuram

Raghuram,

The charter text now is:

A couple of remarks:

Thomas

-raghuram