Subject: Re: [6tsch] 6TUS vs. 6TSCH

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 2 Jul 2013 08:59:22 +0000

Dear all:

The funniest thing I got this far is 6TSCHNTSSL, pronounced as "60 schnitzel" (for 6TSCH TimeSlotted Sub-Layer).
But seriously we need to fix this. I was thinking that the key words I'd like to see there are:
-Cell (allocation and dispatching)
-Track (switching sublayer)

So maybe 6CATS?

Pascal

From: [email-masked] [mailto:[email-masked]] On Behalf Of Pascal Thubert (pthubert)
Sent: mardi 25 juin 2013 17:35
To: [email-masked]
Subject: [6tsch] 6TUS vs. 6TSCH

Hello Maria-Rita:

I think we can easily beat a world record of the most ugly name. For instance try pronouncing this: 6TSCHTSSL  (for TimeSlotted Sub-Layer).

We need advice from the list:

1) what do you think of the definition below for 6TSCH (I'm perfectly happy with ità)
2) Should we rename 6TUS to avoid confusion with 6TSCH that pronounces sixtus already? If so, proposal?

Cheers,

Pascal

From: Maria Rita PALATTELLA [mailto:[email-masked]]
Sent: mardi 25 juin 2013 11:08
To: Pascal Thubert (pthubert); [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: [6tsch] draft-ohba-6tsch-security-00

Hello Pascal,
I do agree that 6TSCH is not well defined in the terminology draft. Sorry for that.  For sure, we need to spell out the acronym. According to what you are suggesting, and what we had before, we may update it as follows:

6TSCH: IPv6 over Time Slotted Channel Hopping. It defines a set of IETF sublayers and protocols (for setting up a schedule with a centralized or distributed approach, managing the resource allocation, etc.), as well as the architecture to bind them together, for use in IPv6  TSCH based networks.

I also agree on the confusion that comes from having 6TSCH = SIXTUS and 6TUS adaptation layer. But I am worried it is a bit late for changing...somehow people got already familiar with this terms...unless, we agree to have only 6TSCH, and call 6TUS 6TSCH adaptation layer. What do you think? Maybe it is even worst :)

Maria Rita

---

From: Xavier Vilajosana Guillen <[email-masked]>
Date: Tue, 2 Jul 2013 06:36:04 -0700

what about

6TMAN (Sixtus TSCH Management layer)
6TOP   (Sixtus Track Operation Layer or Sixtus TSCH Operation Layer)
MTSCH (Management TSCH sub layer)
6SUB    (Sixtus SubLayer)

just ideas!
X

On Tue, Jul 2, 2013 at 1:59 AM, Pascal Thubert (pthubert) <
[email-masked]> wrote:

>  Dear all:****
>
> ** **
>
> The funniest thing I got this far is 6TSCHNTSSL, pronounced as “60
> schnitzel” (for 6TSCH TimeSlotted Sub-Layer).****
>
> But seriously we need to fix this. I was thinking that the key words I’d
> like to see there are:****
>
> -Cell (allocation and dispatching)****
>
> -Track (switching sublayer)****
>
> ** **
>
> So maybe 6CATS? ****
>
> ** **
>
> Pascal****
>
> ** **
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf
> Of *Pascal Thubert (pthubert)
> *Sent:* mardi 25 juin 2013 17:35
> *To:* [email-masked]
> *Subject:* [6tsch] 6TUS vs. 6TSCH****
>
> ** **
>
> Hello Maria-Rita:****
>
> ** **
>
> I think we can easily beat a world record of the most ugly name. For
> instance try pronouncing this: 6TSCHTSSL  (for TimeSlotted Sub-Layer).****
>
> ** **
>
> We need advice from the list:****
>
> ** **
>
> 1) what do you think of the definition below for 6TSCH (I’m perfectly
> happy with ità)****
>
> 2) Should we rename 6TUS to avoid confusion with 6TSCH that pronounces
> sixtus already? If so, proposal?****
>
> ** **
>
> Cheers,****
>
> ** **
>
> Pascal****
>
> ** **
>
> *From:* Maria Rita PALATTELLA [mailto:[email-masked]<[email-masked]>]
>
> *Sent:* mardi 25 juin 2013 11:08
> *To:* Pascal Thubert (pthubert); [email-masked];
> [email-masked]
> *Cc:* [email-masked]
> *Subject:* RE: [6tsch] draft-ohba-6tsch-security-00****
>
> ** **
>
> Hello Pascal,****
>
> I do agree that 6TSCH is not well defined in the terminology draft. Sorry
> for that.  For sure, we need to spell out the acronym. According to what
> you are suggesting, and what we had before, we may update it as follows:**
> **
>
> ** **
>
> *6TSCH: IPv6 over Time Slotted Channel Hopping. It defines a set of IETF
> sublayers and protocols (for setting up a schedule with a centralized or
> distributed approach, managing the resource allocation, etc.), as well as
> the architecture to bind them together, for use in IPv6  TSCH based
> networks.*
>
> ** **
>
> I also agree on the confusion that comes from having 6TSCH = SIXTUS and
> 6TUS adaptation layer. But I am worried it is a bit late for
> changing…somehow people got already familiar with this terms…unless, we
> agree to have only 6TSCH, and call 6TUS 6TSCH adaptation layer. What do you
> think? Maybe it is even worst J ****
>
> ** **
>
> Maria Rita****
>
> ** **
>
> _______________________________________________
> 6tsch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tsch
>
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 2 Jul 2013 14:35:36 +0000

Hello Xavi:

I love the TOp.

Management, OTOH, is both a bit misleading (people expect management console, CNM type of stuff)  and a bit incomplete (missing the forwarding layer).

Cheers,

Pascal

From: Xavier Vilajosana Guillen [mailto:[email-masked]]
Sent: mardi 2 juillet 2013 15:36
To: Pascal Thubert (pthubert)
Cc: [email-masked]
Subject: Re: [6tsch] 6TUS vs. 6TSCH

what about

just ideas!
X
On Tue, Jul 2, 2013 at 1:59 AM, Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>> wrote:
Dear all:

So maybe 6CATS?

Pascal

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Pascal Thubert (pthubert)
Sent: mardi 25 juin 2013 17:35
To: [email-masked]<mailto:[email-masked]>
Subject: [6tsch] 6TUS vs. 6TSCH

Hello Maria-Rita:

Cheers,

Pascal

Hello Pascal,

Maria Rita

_______________________________________________
6tsch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tsch

---

From: Qin Wang <[email-masked]>
Date: Tue, 2 Jul 2013 23:03:42 +0800

6TOP is good, but I prefer that it stands for  Sixtus TSCH Operation Layer,
because "Sixtus Track Operation Layer" is a little bit narrower than the
function of this sub-layer.

Qin

On Tue, Jul 2, 2013 at 10:35 PM, Pascal Thubert (pthubert) <
[email-masked]> wrote:

>  Hello Xavi:****
>
> ** **
>
> I love the TOp. ****
>
> ** **
>
> Management, OTOH, is both a bit misleading (people expect management
> console, CNM type of stuff)  and a bit incomplete (missing the forwarding
> layer). ****
>
> ** **
>
> Cheers,****
>
> ** **
>
> Pascal****
>
> ** **
>
> *From:* Xavier Vilajosana Guillen [mailto:[email-masked]]
> *Sent:* mardi 2 juillet 2013 15:36
> *To:* Pascal Thubert (pthubert)
> *Cc:* [email-masked]
> *Subject:* Re: [6tsch] 6TUS vs. 6TSCH****
>
> ** **
>
> what about
>
> X****
> [email-masked]> wrote:****
>
> Dear all:****
>
>  ****
>
>  ****
>  ****
>  ****
>  ****
>  ****
>  ****
>  ****
>  ****
>  ****
>  ****
>  ****
>  ****
> networks.*****
>  ****
>  ****
>  ****
> https://www.ietf.org/mailman/listinfo/6tsch****
>
> ** **
>

---

From: Maria Rita PALATTELLA <[email-masked]>
Date: Wed, 3 Jul 2013 05:22:33 +0000

I do agree with Qin that 6tus does more than track operation... therefore, I would go for
--Sixtus TSCH Operation Layer --

but I have a minor concern. Shouldn't we remove TSCH? because Sixtus ( = 6TSCH) already includes it. What do you think about?

Maria Rita
________________________________
From: [email-masked] [[email-masked]] on behalf of Qin Wang [[email-masked]]
Sent: Tuesday, July 02, 2013 5:03 PM
To: Pascal Thubert (pthubert)
Cc: [email-masked]; [email-masked]
Subject: Re: [6tsch] 6TUS vs. 6TSCH

6TOP is good, but I prefer that it stands for  Sixtus TSCH Operation Layer, because "Sixtus Track Operation Layer" is a little bit narrower than the function of this sub-layer.

Qin

On Tue, Jul 2, 2013 at 10:35 PM, Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>> wrote:
Hello Xavi:

I love the TOp.

Cheers,

Pascal

From: Xavier Vilajosana Guillen [mailto:[email-masked]<mailto:[email-masked]>]
Sent: mardi 2 juillet 2013 15:36
To: Pascal Thubert (pthubert)
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [6tsch] 6TUS vs. 6TSCH

what about

just ideas!
X

The funniest thing I got this far is 6TSCHNTSSL, pronounced as “60 schnitzel” (for 6TSCH TimeSlotted Sub-Layer).
But seriously we need to fix this. I was thinking that the key words I’d like to see there are:
-Cell (allocation and dispatching)
-Track (switching sublayer)

So maybe 6CATS?

Pascal

Hello Maria-Rita:

1) what do you think of the definition below for 6TSCH (I’m perfectly happy with ità)
2) Should we rename 6TUS to avoid confusion with 6TSCH that pronounces sixtus already? If so, proposal?

Cheers,

Pascal

Hello Pascal,

I also agree on the confusion that comes from having 6TSCH = SIXTUS and 6TUS adaptation layer. But I am worried it is a bit late for changing…somehow people got already familiar with this terms…unless, we agree to have only 6TSCH, and call 6TUS 6TSCH adaptation layer. What do you think? Maybe it is even worst :)

Maria Rita

---

From: "Raghuram Sudhaakar (rsudhaak)" <[email-masked]>
Date: Wed, 3 Jul 2013 14:09:26 +0000

I was wondering the same as Maria Rita.

I suggest retaining 6TSCH (pronounced as Sixtus).

Or

6TS – 6 TSCH Scheduling. IMO layer is obvious and 3 syllables make remembering and saying it a lot easier. It avoids the ambiguity about management.

-raghuram

From: Maria Rita PALATTELLA <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, July 2, 2013 10:22 PM
To: Qin Wang <[email-masked]<mailto:[email-masked]>>, "Pascal Thubert (pthubert)" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [6tsch] 6TUS vs. 6TSCH

Maria Rita
________________________________
From: [email-masked]<mailto:[email-masked]> [[email-masked]<mailto:[email-masked]>] on behalf of Qin Wang [[email-masked]<mailto:[email-masked]>]
Sent: Tuesday, July 02, 2013 5:03 PM
To: Pascal Thubert (pthubert)
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [6tsch] 6TUS vs. 6TSCH

Qin

I love the TOp.

Cheers,

Pascal

what about

just ideas!
X

So maybe 6CATS?

Pascal

From:[email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Pascal Thubert (pthubert)
Sent: mardi 25 juin 2013 17:35
To: [email-masked]<mailto:[email-masked]>
Subject: [6tsch] 6TUS vs. 6TSCH

Hello Maria-Rita:

Cheers,

Pascal

Hello Pascal,

Maria Rita

---

From: Thomas Watteyne <[email-masked]>
Date: Wed, 3 Jul 2013 07:47:52 -0700

If we decide to change the name of 6tus, I would argue that there is no
need to keep the word "sixtus" in the acronym, since we are replacing it.

Thomas

On Wed, Jul 3, 2013 at 7:09 AM, Raghuram Sudhaakar (rsudhaak) <
[email-masked]> wrote:

>  6TS – 6 TSCH Scheduling. IMO layer is obvious and 3 syllables make
> remembering and saying it a lot easier. It avoids the ambiguity about
> management.
>
>  -raghuram
>
>   From: Maria Rita PALATTELLA <[email-masked]>
> To: Qin Wang <[email-masked]>, "Pascal Thubert (pthubert)" <
> [email-masked]>
> Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <
> [email-masked]>
>
> but I have a minor concern. Shouldn't we remove TSCH? because Sixtus ( =
> 6TSCH) already includes it. What do you think about?
>
> Maria Rita
> ------------------------------
> *From:* [email-masked] [[email-masked]] on behalf of Qin
> Wang [[email-masked]]
> *Sent:* Tuesday, July 02, 2013 5:03 PM
> *Cc:* [email-masked]; [email-masked]
> *Subject:* Re: [6tsch] 6TUS vs. 6TSCH
>
>   6TOP is good, but I prefer that it stands for  Sixtus TSCH Operation
> Layer, because "Sixtus Track Operation Layer" is a little bit narrower
> than the function of this sub-layer.
>
>  Qin
>
>
>> *From:[email-masked] [mailto:[email-masked]] *On Behalf
>> you are suggesting, and what we had before, we may update it as follows:*
>> ***
>>
>>  ****
>>
>> think? Maybe it is even worst J****
>>
>>  ****
>>
>> Maria Rita****
>>
>>  ****
>>
>>