Subject: Re: [6tsch] draft-ohba-6tsch-security-00

From: Jonathan Simon <[email-masked]>
Date: Tue, 2 Jul 2013 15:46:33 -0700

Pascal - I don't think we're disagreeing that very large networks of sensors have tremendous value, or that the totality sensor inputs is more valuable than the sum of the individual inputs.  I was simply trying to point out that the language in the draft implies that there is n^2 value in the mote interconnectivity - the utility is not in having 10000 nodes all talking to every other node, it's in connecting each node to a few nearby nodes and through clever routing protocols like RPL getting access to all the data at a central coordinator. 
-- 
Jonathan Simon, Ph. D
Director of Systems Engineering
Linear Technology, Dust Networks product group
30695 Huntwood Ave
Hayward, CA 94544-7021
(510) 400-2936
(510) 489-3799 FAX
[email-masked]

**LINEAR TECHNOLOGY CORPORATION** 
*****Internet Email Confidentiality Notice***** 
 This e-mail transmission, and any documents, files or previous e-mail messages attached to it may contain confidential information that is legally privileged. If you are not the intended recipient, or a person responsible for delivering it to the intended recipient, you are hereby notified that any disclosure, copying, distribution or use of any of the information contained in or attached to this transmission is STRICTLY PROHIBITED. If you have received this transmission in error, please immediately notify me by reply e-mail, or by telephone at (510) 400-2936, and destroy the original transmission and its attachments without reading or saving in any manner. Thank you. 

On Jun 28, 2013, at 8:00 AM, Pascal Thubert (pthubert) wrote:

> 
> "Following Metcalf's law..."
> Not only is it not clear what point is being made, Metcalf’s law measures “utility” in connections.  For a networked sensor device, there are likely a finite number of consumers of its data, and the total number of nodes is an irrelevant utility metric. Additionally, in terms of mesh connectivity, in general there is little additional utility to having 1000 neighbors (which may be more than the node can store) over 100, and perhaps 100 over 10 provided there is sufficient connectivity for the network to function.
> [] And here I respectfully disagree; 6TSCH brings 2 things: 1) better guarantees (deterministic) for a network of limited size under the control of a PCE and for that piece I’m entirely with you but also 2) better scalability for applications such as monitoring using distributed routing (RPL). For the latter, size definitely matters. Take rust monitoring, intrusion detection, etc, one may want to deploy a large number of devices with very low reporting rate. The number of connected devices and the fact that we can correlate inputs from multiple parties, all this augments the value of the network, though maybe not by the square since the idea came from any to any communication. This does not mean that the network is very dense and/or that nodes will need to neighbor with tons of one hop devices. But sometimes brute force has value. I’m curious what Kris had in mind with the idea of sensor dust…
> 
> -- 
> Jonathan Simon, Ph. D
> Director of Systems Engineering
> Linear Technology, Dust Networks product group

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 3 Jul 2013 07:29:04 +0000

Yes, I can buy that, Jonathan.

We'll discuss this at the next call when Yoshi presents and I think we'll remove my misleading reference to Metcalf on the next revision.

Cheers,

Pascal

From: Jonathan Simon [mailto:[email-masked]]
Sent: mercredi 3 juillet 2013 00:47
To: Pascal Thubert (pthubert)
Cc: <[email-masked]>; [email-masked]
Subject: Re: [6tsch] draft-ohba-6tsch-security-00

Pascal - I don't think we're disagreeing that very large networks of sensors have tremendous value, or that the totality sensor inputs is more valuable than the sum of the individual inputs.  I was simply trying to point out that the language in the draft implies that there is n^2 value in the mote interconnectivity - the utility is not in having 10000 nodes all talking to every other node, it's in connecting each node to a few nearby nodes and through clever routing protocols like RPL getting access to all the data at a central coordinator.
--
Jonathan Simon, Ph. D
Director of Systems Engineering
Linear Technology, Dust Networks product group
30695 Huntwood Ave
Hayward, CA 94544-7021
(510) 400-2936
(510) 489-3799 FAX
[email-masked]<mailto:[email-masked]>

"Following Metcalf's law..."
Not only is it not clear what point is being made, Metcalf's law measures "utility" in connections.  For a networked sensor device, there are likely a finite number of consumers of its data, and the total number of nodes is an irrelevant utility metric. Additionally, in terms of mesh connectivity, in general there is little additional utility to having 1000 neighbors (which may be more than the node can store) over 100, and perhaps 100 over 10 provided there is sufficient connectivity for the network to function.
[] And here I respectfully disagree; 6TSCH brings 2 things: 1) better guarantees (deterministic) for a network of limited size under the control of a PCE and for that piece I'm entirely with you but also 2) better scalability for applications such as monitoring using distributed routing (RPL). For the latter, size definitely matters. Take rust monitoring, intrusion detection, etc, one may want to deploy a large number of devices with very low reporting rate. The number of connected devices and the fact that we can correlate inputs from multiple parties, all this augments the value of the network, though maybe not by the square since the idea came from any to any communication. This does not mean that the network is very dense and/or that nodes will need to neighbor with tons of one hop devices. But sometimes brute force has value. I'm curious what Kris had in mind with the idea of sensor dust...