Subject: [6tsch] work item 2 in the charter

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 19 Jul 2013 16:06:05 +0000

Dear all:

Please review the latest draft of the charter at https://bitbucket.org/6tsch/charter-ietf-6tsch/src
Now is a good time to find the bugs!
Work Item 2 in the charter (https://bitbucket.org/6tsch/charter-ietf-6tsch/) is still like this:

"
2. Produce "6TSCH centralized management" to define the mechanism by which an
external Path Computation Entity can communicate with the 6top protocol layer
of the different nodes in the network (1) to modify their TSCH schedule and
(2) to gather link quality statistics and data flow requirements.  The WG will
initially look at PCEP and CoAP.
Depending on the applicability of PCEP, this document will be targeted to
Proposed standard.
"

Since the time we wrote this, we realized that there is a lot more to do than a simple increment to PCE/P.

At the call we agreed that we should keep it to the level of requirements for this round. Do we all agree on this?

If so we'll need to revisit that text... Let us work on this early next week, this is probably the most urgent thing we have to do before the BoF.

Cheers,

Pascal

---

From: Thomas Watteyne <[email-masked]>
Date: Fri, 19 Jul 2013 18:08:16 +0200

Pascal,
I agree that we should keep this at the level of requirements at this
point, since there is more work than we anticipated.
Thomas

On Fri, Jul 19, 2013 at 6:06 PM, Pascal Thubert (pthubert) <
[email-masked]> wrote:

>  Dear all:****
>
> ** **
>
> Please review the latest draft of the charter at
> https://bitbucket.org/6tsch/charter-ietf-6tsch/src ****
>
> Now is a good time to find the bugs! ****
>
> Work Item 2 in the charter (
> https://bitbucket.org/6tsch/charter-ietf-6tsch/) is still like this:****
>
> ** **
>
> “****
>
> 2. Produce "6TSCH centralized management" to define the mechanism by which
> an****
>
> external Path Computation Entity can communicate with the 6top protocol
> layer****
>
> ****
> (2) to gather link quality statistics and data flow requirements.  The WG
> will****
>
> initially look at PCEP and CoAP.****
>
> Depending on the applicability of PCEP, this document will be targeted to*
> ***
>
> Proposed standard.****
>
> “****
>
> ** **
>
> Since the time we wrote this, we realized that there is a lot more to do
> than a simple increment to PCE/P.****
>
> ** **
>
> At the call we agreed that we should keep it to the level of requirements
> for this round. Do we all agree on this?****
>
> ** **
>
> If so we’ll need to revisit that text… Let us work on this early next
> week, this is probably the most urgent thing we have to do before the BoF.
> ****
>
> ** **
>
> Cheers,****
>
> ** **
>
> Pascal****
>
> ** **
>
> ** **
>
> _______________________________________________
> 6tsch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tsch
>
>

---

From: Qin Wang <[email-masked]>
Date: Sat, 20 Jul 2013 03:12:10 +0800

Hi Pascal,

The slides are pretty good. Just a comment on slide-8. Should we add
"mobility" as one of criteria?

Thanks
Qin

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Sat, 20 Jul 2013 06:55:02 +0000

Dear Qin:

I'm a bit out of sync.

1) I agree we shoud have mobility somewhrere
2) slide 8 in the charter slides on the repo is this " Description of Working Group [2/5]"

Is that where you'd like to see mobility mentioned?

Cheers,

Pascal

From: Qin Wang [mailto:[email-masked]]
Sent: vendredi 19 juillet 2013 21:12
To: Pascal Thubert (pthubert)
Cc: [email-masked]
Subject: Re: [6tsch] work item 2 in the charter

Hi Pascal,

The slides are pretty good. Just a comment on slide-8. Should we add "mobility" as one of criteria?

Thanks
Qin

On Sat, Jul 20, 2013 at 12:06 AM, Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>> wrote:
Dear all:

"

Cheers,

Pascal

_______________________________________________
6tsch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tsch

---

From: Qin Wang <[email-masked]>
Date: Sun, 21 Jul 2013 21:45:56 +0800

Pascal,

Yes, I think we can add "mobility" in the first paragraph of "Description
of Working Group [2/5]".

Thanks
Qin

On Sat, Jul 20, 2013 at 2:55 PM, Pascal Thubert (pthubert) <
[email-masked]> wrote:

>  Dear Qin:****
>
> ** **
>
> I’m a bit out of sync.****
>
> ** **
>
> 1) I agree we shoud have mobility somewhrere****
>
> 2) slide 8 in the charter slides on the repo is this “ Description of
> Working Group [2/5]”****
>
> ** **
>
> Is that where you’d like to see mobility mentioned?****
>
> ** **
>
> Cheers,****
>
> ** **
>
> Pascal****
>
> ** **
>
> *From:* Qin Wang [mailto:[email-masked]]
> *Sent:* vendredi 19 juillet 2013 21:12
> *To:* Pascal Thubert (pthubert)
> *Cc:* [email-masked]
> *Subject:* Re: [6tsch] work item 2 in the charter****
>
> ** **
>
> Hi Pascal,****
>
> ** **
>
> "mobility" as one of criteria?****
>
> ** **
>
> Thanks****
>
> Qin****
>
> ** **
>
> ** **
>
> ** **
>
> ** **
>
> ** **
>
> ** **
>
> [email-masked]> wrote:****
>
> Dear all:****
>
>  ****
>
> https://www.ietf.org/mailman/listinfo/6tsch****
>
> ** **
>

---

From: Thomas Watteyne <[email-masked]>
Date: Sun, 21 Jul 2013 23:28:00 +0200

Qin, all,

We've had a lot of discussion around mobility during the webex calls a
couple of months ago. I'm looking at the call from 3/22 in particular, the
minutes of which are at [1] and the recording at [2].

We ended up identifying 2 cases where some nodes are mobile:
- nodes mounted on a crane. Either the crane is pivoting, or two cranes
cooperate to pick containers up.
- a mobile worker

We agreed that there were a number of tricks we could play to accommodate
some mobility:
- for the crane case, Alfredo suggested that we could "have [the] same
cells scheduled at several potential neighbors of the node mounted on the
crane"
- for the mobile worker case, Tom suggested that "mobile worker does not
require deterministic schedules".

In light of that, I would like to suggest to not over-promise on mobility.
That is, we think we have a good solution for building static network, and
that there are some tricks we can play for making space for some mobility.
Yet, the solution we come up with involve some communication to resolve
topological changes, either with a PCE, or locally using some reservation
protocol. Since there is some delay/overhead associated with that, they are
not designed for e.g. swarms of mobile robots. I'm not saying TSCH is not a
good idea for swarms of robot, rather that we first focus on (almost)
static networks.

Maybe I'm missing your point. If I am, could you write down the exact
rewording of the charter you are suggesting, and maybe point out the exact
use cases?

Thanks,
Thomas

[1] https://bitbucket.org/6tsch/meetings/wiki/130322_webex
[2]
https://cisco.webex.com/ciscosales/lsr.php?AT=pb&SP=MC&rID=66940742&rKey=711b58d40cd574d9

On Sunday, July 21, 2013, Qin Wang wrote:

> 2. Produce "6TSCH centrali
>
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 22 Jul 2013 09:21:49 +0000

Hello Thomas and all:

We can achieve some mobility for best effort RPL routes, it is mostly a matter of tuning of the protocol and OF. The exact details on what is needed could be worked out at ROLL.
For us that would mean beef up the dynamic slot allocation that has to be there anyway.

OTOH, my memory is that we agreed that deterministic and mobile do not play well, not well at all for centralized routing. So I agree with Thomas that we should not over commit.
Maybe for the time being we could place that in the interaction with other WGs, ROLL in this case?

Cheers,

Pascal

From: [email-masked] [mailto:[email-masked]] On Behalf Of Thomas Watteyne
Sent: dimanche 21 juillet 2013 23:28
To: 6TSCH
Subject: Re: [6tsch] work item 2 in the charter

Qin, all,

We've had a lot of discussion around mobility during the webex calls a couple of months ago. I'm looking at the call from 3/22 in particular, the minutes of which are at [1] and the recording at [2].

We ended up identifying 2 cases where some nodes are mobile:
- nodes mounted on a crane. Either the crane is pivoting, or two cranes cooperate to pick containers up.
- a mobile worker

We agreed that there were a number of tricks we could play to accommodate some mobility:
- for the crane case, Alfredo suggested that we could "have [the] same cells scheduled at several potential neighbors of the node mounted on the crane"
- for the mobile worker case, Tom suggested that "mobile worker does not require deterministic schedules".

In light of that, I would like to suggest to not over-promise on mobility. That is, we think we have a good solution for building static network, and that there are some tricks we can play for making space for some mobility. Yet, the solution we come up with involve some communication to resolve topological changes, either with a PCE, or locally using some reservation protocol. Since there is some delay/overhead associated with that, they are not designed for e.g. swarms of mobile robots. I'm not saying TSCH is not a good idea for swarms of robot, rather that we first focus on (almost) static networks.

Maybe I'm missing your point. If I am, could you write down the exact rewording of the charter you are suggesting, and maybe point out the exact use cases?

Thanks,
Thomas

[1] https://bitbucket.org/6tsch/meetings/wiki/130322_webex
[2] https://cisco.webex.com/ciscosales/lsr.php?AT=pb&SP=MC&rID=66940742&rKey=711b58d40cd574d9

Yes, I think we can add "mobility" in the first paragraph of "Description of Working Group [2/5]".

Thanks
Qin

On Sat, Jul 20, 2013 at 2:55 PM, Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>> wrote:

Dear Qin:

I'm a bit out of sync.

Cheers,

Pascal

Cc: [email-masked]<mailto:[email-masked]>

Hi Pascal,

Thanks

Qin

Dear all:

"

---

From: Thomas Watteyne <[email-masked]>
Date: Mon, 22 Jul 2013 15:35:52 +0200

Pascal,
This sounds like a great middle ground. Qin, would you agree with this?
Thomas

On Mon, Jul 22, 2013 at 11:21 AM, Pascal Thubert (pthubert) <
[email-masked]> wrote:

>  Hello Thomas and all:****
>
> ** **
>
> We can achieve some mobility for best effort RPL routes, it is mostly a
> matter of tuning of the protocol and OF. The exact details on what is
> needed could be worked out at ROLL.****
>
> For us that would mean beef up the dynamic slot allocation that has to be
> there anyway. ****
>
> ** **
>
> OTOH, my memory is that we agreed that deterministic and mobile do not
> play well, not well at all for centralized routing. So I agree with Thomas
> that we should not over commit.****
>
> Maybe for the time being we could place that in the interaction with other
> WGs, ROLL in this case? ****
>
> ** **
>
> Cheers,****
>
> ** **
>
> Pascal****
>
> ** **
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf
> Of *Thomas Watteyne
> *Sent:* dimanche 21 juillet 2013 23:28
> *To:* 6TSCH
>
> Qin, all,****
> minutes of which are at [1] and the recording at [2].****
>
> ** **
>
> We ended up identifying 2 cases where some nodes are mobile:****
>
> cooperate to pick containers up.****
>
> - a mobile worker****
>
> ** **
>
> some mobility:****
> crane"****
> require deterministic schedules".****
>
> ** **
>
> static networks.****
> use cases?****
> Thanks,****
> Thomas****
> [1] https://bitbucket.org/6tsch/meetings/wiki/130322_webex****
>
> [2]
> On Sunday, July 21, 2013, Qin Wang wrote:****
>
> Pascal,****
>
> ** **
>
> of Working Group [2/5]".****
>
> ** **
>
> Thanks****
>
> Qin****
>
> ** **
>
> *From:* Qin Wang [mailto:[email-masked] <[email-masked]>]
> 2. Produce "6TSCH centrali****
>

---

From: Qin Wang <[email-masked]>
Date: Mon, 22 Jul 2013 23:25:08 +0800

Hi Thomas and Pascal,

I totally agree to the "middle ground".

Thanks
Qin

On Mon, Jul 22, 2013 at 9:35 PM, Thomas Watteyne <[email-masked]
> wrote:

>> Maybe for the time being we could place that in the interaction with
>> other WGs, ROLL in this case? ****
>>
>> ** **
>>
>> Cheers,****
>>
>> ** **
>>
>> Pascal****
>>
>> ** **
>>
>> *From:* [email-masked] [mailto:[email-masked]] *On
>> Behalf Of *Thomas Watteyne
>> In light of that, I would like to suggest to not over-promise on
>> mobility. That is, we think we have a good solution for building static
>> network, and that there are some tricks we can play for making space for
>> some mobility. Yet, the solution we come up with involve some communication
>> to resolve topological changes, either with a PCE, or locally using some
>> reservation protocol. Since there is some delay/overhead associated with
>> that, they are not designed for e.g. swarms of mobile robots. I'm not
>> saying TSCH is not a good idea for swarms of robot, rather that we first
>> focus on (almost) static networks.****
>>
>> ** **
>>

---

From: Thomas Watteyne <[email-masked]>
Date: Tue, 23 Jul 2013 16:26:25 +0200

Great.
Pascal, maybe you can touch on this quickly in your 2e presentation? I went
over the charter, and I believe it does not need to be updated.
Thomas

On Mon, Jul 22, 2013 at 5:25 PM, Qin Wang <[email-masked]> wrote:

> On Mon, Jul 22, 2013 at 9:35 PM, Thomas Watteyne <
> [email-masked]> wrote:
>
>>  Pascal,
>>> For us that would mean beef up the dynamic slot allocation that has to
>>> be there anyway. ****
>>>
>>> ** **
>>>
>>> We agreed that there were a number of tricks we could play to
>>> accommodate some mobility:****
>>>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 23 Jul 2013 14:29:18 +0000

I'm fine with that Thomas;

Pascal

From: [email-masked] [mailto:[email-masked]] On Behalf Of Thomas Watteyne
Sent: mardi 23 juillet 2013 16:26
To: Qin Wang
Cc: 6TSCH
Subject: Re: [6tsch] work item 2 in the charter

Great.
Pascal, maybe you can touch on this quickly in your 2e presentation? I went over the charter, and I believe it does not need to be updated.
Thomas

On Mon, Jul 22, 2013 at 5:25 PM, Qin Wang <[email-masked]<mailto:[email-masked]>> wrote:
Hi Thomas and Pascal,

Thanks
Qin

On Mon, Jul 22, 2013 at 9:35 PM, Thomas Watteyne <[email-masked]<mailto:[email-masked]>> wrote:
Pascal,
This sounds like a great middle ground. Qin, would you agree with this?
Thomas

On Mon, Jul 22, 2013 at 11:21 AM, Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>> wrote:
Hello Thomas and all:

Cheers,

Pascal

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Thomas Watteyne
Sent: dimanche 21 juillet 2013 23:28
To: 6TSCH

Qin, all,

Thanks,
Thomas

Thanks
Qin

Dear Qin:

I'm a bit out of sync.

Cheers,

Pascal

Hi Pascal,

Thanks

Qin

Dear all:

"