Subject: [6tsch] 1c "Why is this a problem? " BoF slides

From: Thomas Watteyne <[email-masked]>
Date: Fri, 19 Jul 2013 18:10:42 +0200

All,

FYI, I pushed the 1c "Why is this a problem? " BoF slides we modified live
during the webex onto the repo. You'll find the latest version at
https://bitbucket.org/6tsch/meetings/src/master/130730_ietf-87_berlin

Thomas

---

From: Qin Wang <[email-masked]>
Date: Sat, 20 Jul 2013 03:29:46 +0800

Hi Thomas and All,

The first item of problems in the slide is:

      Customer dissatisfaction with competing stds

      -> no device interop, double opex

      -> lack of common network management

What does "competing stds" refer to? Referring to existing standards like
WirelessHart, ISA100.11a, or something else? From the statement, it may be
derived that 6TSCH WG wants to create a common standard to replace the
competing standards. It is not our objective, right?

Maybe I misunderstand something. Please point out.

Thanks

Qin

On Sat, Jul 20, 2013 at 12:10 AM, Thomas Watteyne <
[email-masked]> wrote:

> _______________________________________________
> 6tsch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tsch
>
>

---

From: Alfredo Grieco <[email-masked]>
Date: Fri, 19 Jul 2013 21:33:54 +0200

Dear Qin,

As far as I remember, it could be also possible to embrace other
technologies by adding on top of them 6top. No need to replace but include
other technologies.

Cheers

Alfredo

On Friday, July 19, 2013, Qin Wang wrote:

> [email-masked] <javascript:_e({}, 'cvml',
> [email-masked]');>> wrote:
>
>> All,
>>
>> FYI, I pushed the 1c "Why is this a problem? " BoF slides we modified
>> live during the webex onto the repo. You'll find the latest version at
>> [email-masked] <javascript:_e({}, 'cvml', [email-masked]');>

---

From: Qin Wang <[email-masked]>
Date: Sat, 20 Jul 2013 03:52:50 +0800

Hi Alfredo,

I don't think  WirelessHart and ISA100.11a can be added on top of 6top. The
reasons are:

(1) They have their own and different protocol stacks.
(2) They use Timeslotted channel hopping technology, but not IEEE802.15.4e
TSCH.

So, according to my understanding, the problem is how IPv6 protocol stack
can take advantage of TSCH, which has been proven good and standardized by
IEEE.

Thought?
Qin

---

From: Alfredo Grieco <[email-masked]>
Date: Fri, 19 Jul 2013 22:21:39 +0200

Qin,

I was saying the opposite: 6top goes on top.

There was a nice picture shown by Pascal in one of our weekly call several
weeks ago.

Of course, the point you raise about ipv6 taking advantage from tsch is ok.

Cheers

Alfredo

On Friday, July 19, 2013, Qin Wang wrote:

> Hi Alfredo,
>
> I don't think  WirelessHart and ISA100.11a can be added on top of 6top.
> The reasons are:
>
> On Sat, Jul 20, 2013 at 3:33 AM, Alfredo Grieco <[email-masked]<javascript:_e({}, 'cvml', [email-masked]');>
> > wrote:
>
>> Dear Qin,
>>
>>> What does "competing stds" refer to? Referring to existing standards
>>> like WirelessHart, ISA100.11a, or something else? From the statement, it
>>> may be derived that 6TSCH WG wants to create a common standard to replace
>>> the competing standards. It is not our objective, right?
>>>

---

From: Qin Wang <[email-masked]>
Date: Sat, 20 Jul 2013 04:34:40 +0800

Alfredo,

Thank you for clarifying. But, I'm still confused. Maybe I missed
something. Can you tell me what you mean by "competing stds"?

Thanks!
Qin

On Sat, Jul 20, 2013 at 4:21 AM, Alfredo Grieco <[email-masked]>wrote:

>> (2) They use Timeslotted channel hopping technology, but not
>> IEEE802.15.4e TSCH.
>>
>> On Sat, Jul 20, 2013 at 3:33 AM, Alfredo Grieco <[email-masked]
>> > wrote:
>>
>>> Dear Qin,
>>>

---

From: Alfredo Grieco <[email-masked]>
Date: Fri, 19 Jul 2013 22:44:47 +0200

Qin,

I have to dig into the repo to find the exact slide Pascal shown during a
past call in order to exactly clarify how we could reuse what we are doing
for the 4e tsch also in different contextes.

Competing means different, not interoperable, and that require different
management systems.

Cheers and thanks for your valuable questions

Al

On Friday, July 19, 2013, Qin Wang wrote:

> On Sat, Jul 20, 2013 at 4:21 AM, Alfredo Grieco <[email-masked]<javascript:_e({}, 'cvml', [email-masked]');>
> > wrote:
>
>> Qin,
>>
>> There was a nice picture shown by Pascal in one of our weekly call
>> several weeks ago.
>>
>>> So, according to my understanding, the problem is how IPv6 protocol
>>> stack can take advantage of TSCH, which has been proven good and
>>> standardized by IEEE.
>>>
>>> Thought?
>>> Qin
>>>
>>>
>>>
>>> On Sat, Jul 20, 2013 at 3:33 AM, Alfredo Grieco <
>>> [email-masked]> wrote:
>>>
>>>> Dear Qin,
>>>>

---

From: "Alfredo Grieco" <[email-masked]>
Date: Mon, 22 Jul 2013 14:50:23 +0200

Hi Qin,

Sorry for the late reply.

If you go to Sec. 6 of the architecture draft
(http://tools.ietf.org/html/draft-thubert-6tsch-architecture-02) we
explicitly say that ISA100.11a and WiHart could interoperate with a 6tsch
lln.

In this sense, we move from competing to interoperating standards.

Does it sound for you ?

Thanks

Alfredo

Da: Qin Wang [mailto:[email-masked]] 
Inviato: Friday, July 19, 2013 10:35 PM
A: Alfredo Grieco
Cc: Thomas Watteyne; 6TSCH; Pascal Thubert (pthubert)
Oggetto: Re: [6tsch] 1c "Why is this a problem? " BoF slides

Alfredo,

Thank you for clarifying. But, I'm still confused. Maybe I missed something.
Can you tell me what you mean by "competing stds"? 

Thanks!
Qin

On Sat, Jul 20, 2013 at 4:21 AM, Alfredo Grieco <[email-masked]>
wrote:
Qin,

Cheers

Alfredo

Thought?
Qin

On Sat, Jul 20, 2013 at 3:33 AM, Alfredo Grieco <[email-masked]>
wrote:
Dear Qin,

Cheers

Alfredo

On Sat, Jul 20, 2013 at 12:10 AM, Thomas Watteyne
<[email-masked]> wrote:
All,

Thomas

---

From: Qin Wang <[email-masked]>
Date: Mon, 22 Jul 2013 23:20:02 +0800

Hi Alfredo,

Thank you very much for finding it out, i.e. in section 6,

"As a result, as long as the TSCH MAC (and Layer 2 security) accepts a
frame, that frame can be switched regardless of the protocol, whether this
is an IPv6 packet, a 6LoWPAN fragment, or a frame from an alternate
protocol such as WirelessHART of ISA100.11a."

But, from implementation point of view, it seems to me that the NW layer of
WirelessHART or ISA100.11a has to call the commands of 6top, instead of the
primitives of DL layer defined in WirelessHart and ISA100.11a. I'm not sure
if it works for WirelessHart and ISA100.11a.

Thought?
Qin

On Mon, Jul 22, 2013 at 8:50 PM, Alfredo Grieco <[email-masked]>wrote:

> something.

---

From: "Alfredo Grieco" <[email-masked]>
Date: Mon, 22 Jul 2013 17:29:39 +0200

Hi Qin,

There is also this further clarification in 6.1.2

“In that mode, the PCE may coordinate with a WirelessHART Network Manager or
an ISA100.11a System Manager in order to specify the flows that are to be
transported transparently over the Track.”

I was referring to this last one.

What do you think ?

Cheers and thanks

Al

Da: Qin Wang [mailto:[email-masked]] 
Inviato: Monday, July 22, 2013 5:20 PM
A: Alfredo Grieco
Cc: 6TSCH
Oggetto: Re: [6tsch] 1c "Why is this a problem? " BoF slides

Hi Alfredo,

"As a result, as long as the TSCH MAC (and Layer 2 security) accepts a
frame, that frame can be switched regardless of the protocol, whether this
is an IPv6 packet, a 6LoWPAN fragment, or a frame from an alternate protocol
such as WirelessHART of ISA100.11a."

Thought?
Qin

On Mon, Jul 22, 2013 at 8:50 PM, Alfredo Grieco <[email-masked]>
wrote:
Hi Qin,

Does it sound for you ?

Thanks

Alfredo

Alfredo,

Thanks!
Qin

Cheers

Alfredo

Thought?
Qin

Cheers

Alfredo

Thomas

---

From: Qin Wang <[email-masked]>
Date: Mon, 22 Jul 2013 23:34:30 +0800

Alfredo,

It may be too heavy to coordinate with WirelessHart and ISA100.11a. Should
we commit it? I think we need to discuss the problem in ML. How do you
think?

Qin

---

From: "Alfredo Grieco" <[email-masked]>
Date: Mon, 22 Jul 2013 18:00:18 +0200

Qin,
 
Of course, this point merits some discussion in the mailing list.
 
Do you want to open a new tread ?
 
Cheers and thanks
 
Alfredo
 
Da: Qin Wang [mailto:[email-masked]] 
Inviato: Monday, July 22, 2013 5:35 PM
A: Alfredo Grieco
Cc: 6TSCH
Oggetto: Re: [6tsch] 1c "Why is this a problem? " BoF slides
 
Alfredo,

Qin
 
On Mon, Jul 22, 2013 at 11:29 PM, Alfredo Grieco <[email-masked]>
wrote:
Hi Qin,

"In that mode, the PCE may coordinate with a WirelessHART Network Manager or
an ISA100.11a System Manager in order to specify the flows that are to be
transported transparently over the Track."

What do you think ?

Cheers and thanks

Al

Hi Alfredo,

Thought?
Qin

Does it sound for you ?

Thanks

Alfredo

Alfredo,

Thanks!
Qin

Cheers

Alfredo

Thought?
Qin

Cheers

Alfredo

Thomas

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 22 Jul 2013 16:05:21 +0000

Dear Qin:

In this case we need to align time slots that are computed by 2 protocols to make a single track. Computing those tracks would be PCE work, and agreeing to collate path segments is the sort of things PCEs do.

I think it's OK. It's not really impacting the mote. What's impacting the mote is the capability to talk both protocols to forward packets and how it will do that (ona same interface?) is TBD.

Cheers,

Pascal

From: [email-masked] [mailto:[email-masked]] On Behalf Of Qin Wang
Sent: lundi 22 juillet 2013 17:35
To: Alfredo Grieco
Cc: 6TSCH
Subject: Re: [6tsch] 1c "Why is this a problem? " BoF slides

Alfredo,

It may be too heavy to coordinate with WirelessHart and ISA100.11a. Should we commit it? I think we need to discuss the problem in ML. How do you think?

Qin

On Mon, Jul 22, 2013 at 11:29 PM, Alfredo Grieco <[email-masked]<mailto:[email-masked]>> wrote:
Hi Qin,

What do you think ?

Cheers and thanks

Al

Da: Qin Wang [mailto:[email-masked]<mailto:[email-masked]>]
Inviato: Monday, July 22, 2013 5:20 PM
A: Alfredo Grieco
Cc: 6TSCH
Oggetto: Re: [6tsch] 1c "Why is this a problem? " BoF slides

Hi Alfredo,

Thought?
Qin

On Mon, Jul 22, 2013 at 8:50 PM, Alfredo Grieco <[email-masked]<mailto:[email-masked]>>
wrote:
Hi Qin,

Does it sound for you ?

Thanks

Alfredo

Da: Qin Wang [mailto:[email-masked]<mailto:[email-masked]>]
Inviato: Friday, July 19, 2013 10:35 PM
A: Alfredo Grieco
Cc: Thomas Watteyne; 6TSCH; Pascal Thubert (pthubert)
Oggetto: Re: [6tsch] 1c "Why is this a problem? " BoF slides

Alfredo,

Thanks!
Qin

On Sat, Jul 20, 2013 at 4:21 AM, Alfredo Grieco <[email-masked]<mailto:[email-masked]>>
wrote:
Qin,

Cheers

Alfredo

Thought?
Qin

On Sat, Jul 20, 2013 at 3:33 AM, Alfredo Grieco <[email-masked]<mailto:[email-masked]>>
wrote:
Dear Qin,

Cheers

Alfredo

On Sat, Jul 20, 2013 at 12:10 AM, Thomas Watteyne
<[email-masked]<mailto:[email-masked]>> wrote:
All,

Thomas

_______________________________________________
6tsch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tsch

---

From: Qin Wang <[email-masked]>
Date: Tue, 23 Jul 2013 01:30:06 +0800

Hi Pascal,

According to my understanding, wirelessHart or ISA100.11a devices have to
implement their entire stack, including their own Application layer,
network layer, DL, and 802.15.4 MAC and PHY. So,  if we want to use 6top to
forward the packets from WirelessHart and ISA100.11a, we have to
investigate the method to merge 6top with the two standards, and to replace
lower layers of the two standards. Do we really want to do it?

Thus, instead of saying that 6top targets building a common base for
different standards (including wirelessHart and ISA100.11a), I would like
to focus on IPv6 context, and use the two standards as facts to show the
advantage of TSCH.

How do you think?

Qin

On Tue, Jul 23, 2013 at 12:05 AM, Pascal Thubert (pthubert) <
[email-masked]> wrote:

>  Dear Qin:****
>
> ** **
>
> In this case we need to align time slots that are computed by 2 protocols
> to make a single track. Computing those tracks would be PCE work, and
> agreeing to collate path segments is the sort of things PCEs do.****
>
> ** **
>
> I think it’s OK. It’s not really impacting the mote. What’s impacting the
> mote is the capability to talk both protocols to forward packets and how it
> will do that (ona same interface?) is TBD.****
>
> ** **
>
> Cheers,****
>
> ** **
>
> Pascal****
>
> ** **
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf
> Of *Qin Wang
> *Sent:* lundi 22 juillet 2013 17:35
> *To:* Alfredo Grieco
> *Cc:* 6TSCH
> *Subject:* Re: [6tsch] 1c "Why is this a problem? " BoF slides****
>
> ** **
>
> Alfredo,****
>
> ** **
>
> think?****
> ** **
> Qin****
> ** **
> wrote:****
> Al****
> Da: Qin Wang [mailto:[email-masked]]****
>
> Cc: 6TSCH****
> ****
> ** **

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 22 Jul 2013 18:09:18 +0000

Hi Qin:

We do not intend to enable interop between foreign protocols but just to tunnel, meaning that we expect the same protocol on both ends.
6top would just be a G MPLS pipe for that protocol; that's the whole point in the MP of G MPLS, right?

Cheers,

Pascal

From: Qin Wang [mailto:[email-masked]]
Sent: lundi 22 juillet 2013 19:30
To: Pascal Thubert (pthubert)
Cc: Alfredo Grieco; 6TSCH
Subject: Re: [6tsch] 1c "Why is this a problem? " BoF slides

Hi Pascal,

According to my understanding, wirelessHart or ISA100.11a devices have to implement their entire stack, including their own Application layer, network layer, DL, and 802.15.4 MAC and PHY. So,  if we want to use 6top to forward the packets from WirelessHart and ISA100.11a, we have to investigate the method to merge 6top with the two standards, and to replace lower layers of the two standards. Do we really want to do it?

Thus, instead of saying that 6top targets building a common base for different standards (including wirelessHart and ISA100.11a), I would like to focus on IPv6 context, and use the two standards as facts to show the advantage of TSCH.

How do you think?

Qin

On Tue, Jul 23, 2013 at 12:05 AM, Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>> wrote:
Dear Qin:

Cheers,

Pascal

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Qin Wang
Sent: lundi 22 juillet 2013 17:35
To: Alfredo Grieco
Cc: 6TSCH
Subject: Re: [6tsch] 1c "Why is this a problem? " BoF slides

Alfredo,

Qin

What do you think ?

Cheers and thanks

Al

Hi Alfredo,

Thought?
Qin

Does it sound for you ?

Thanks

Alfredo

Alfredo,

Thanks!
Qin

Cheers

Alfredo

Thought?
Qin

Cheers

Alfredo

Thomas

---

From: Qin Wang <[email-masked]>
Date: Tue, 23 Jul 2013 02:19:00 +0800

Agree! Thanks!

Qin

On Tue, Jul 23, 2013 at 2:09 AM, Pascal Thubert (pthubert) <
[email-masked]> wrote:

>  Hi Qin:****
>
> ** **
>
> We do not intend to enable interop between foreign protocols but just to
> tunnel, meaning that we expect the same protocol on both ends.****
>
> 6top would just be a G MPLS pipe for that protocol; that’s the whole point
> in the MP of G MPLS, right?****
>
> ** **
>
> Cheers,****
>
> ** **
>
> Pascal****
>
> ** **
>
> *From:* Qin Wang [mailto:[email-masked]]
> *Sent:* lundi 22 juillet 2013 19:30
> *To:* Pascal Thubert (pthubert)
> *Cc:* Alfredo Grieco; 6TSCH
>
> Hi Pascal,****
> lower layers of the two standards. Do we really want to do it?****
>
> ** **
>
> advantage of TSCH.****
> How do you think?****
> [email-masked]> wrote:****
>
> Dear Qin:****
>
>  ****
>

---

From: Kris Pister <[email-masked]>
Date: Mon, 22 Jul 2013 12:14:09 -0700

Pascal et al. -
   I have no doubt that with a lot of effort we could overcome the 
technical challenges of making this work.
Unfortunately, I don't think that you will find a single company that 
would implement it.
If our goal is to impact the state of wireless for industrial process 
automation, we are doomed.
Fortunately, that's not our goal.  Our goal is to take what has been 
learned there, and give it to the
rest of the world.  Why complicate the process by insisting on bringing 
in WirelessHART and ISA100 again?  Don't we have enough hard problems to 
work on already?

ksjp

On 7/22/2013 11:09 AM, Pascal Thubert (pthubert) wrote:
>
> Hi Qin:
>
> We do not intend to enable interop between foreign protocols but just 
> to tunnel, meaning that we expect the same protocol on both ends.
>
> *From:*Qin Wang [mailto:[email-masked]]
> *Subject:* Re: [6tsch] 1c "Why is this a problem? " BoF slides
>
> Hi Pascal,
>
> According to my understanding, wirelessHart or ISA100.11a devices have 
> to implement their entire stack, including their own Application 
> layer, network layer, DL, and 802.15.4 MAC and PHY. So,  if we want to 
> use 6top to forward the packets from WirelessHart and ISA100.11a, we 
> have to investigate the method to merge 6top with the two standards, 
> and to replace lower layers of the two standards. Do we really want to 
> do it?
>
> different standards (including wirelessHart and ISA100.11a), I would 
> like to focus on IPv6 context, and use the two standards as facts to 
> show the advantage of TSCH.
>
> How do you think?
>
> Qin
>
> On Tue, Jul 23, 2013 at 12:05 AM, Pascal Thubert (pthubert) 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
> Dear Qin:
>
> In this case we need to align time slots that are computed by 2 
> protocols to make a single track. Computing those tracks would be PCE 
> work, and agreeing to collate path segments is the sort of things PCEs do.
>
> I think it's OK. It's not really impacting the mote. What's impacting 
> the mote is the capability to talk both protocols to forward packets 
> and how it will do that (ona same interface?) is TBD.
>
> Cheers,
>
> Pascal
>
> *From:[email-masked] <mailto:[email-masked]> 
> [mailto:[email-masked] <mailto:[email-masked]>] *On 
> Behalf Of *Qin Wang
> *Subject:* Re: [6tsch] 1c "Why is this a problem? " BoF slides
>
> Alfredo,
>
> It may be too heavy to coordinate with WirelessHart and ISA100.11a. 
> Should we commit it? I think we need to discuss the problem in ML. How 
> do you think?
>
> Qin
>
> <[email-masked] <mailto:[email-masked]>> wrote:
>
> Hi Qin,
>
> Da: Qin Wang [mailto:[email-masked] <mailto:[email-masked]>]
>
> On Mon, Jul 22, 2013 at 8:50 PM, Alfredo Grieco 
> <[email-masked] <mailto:[email-masked]>>
> wrote:
> Hi Qin,
>
> Da: Qin Wang [mailto:[email-masked] <mailto:[email-masked]>]
> On Sat, Jul 20, 2013 at 4:21 AM, Alfredo Grieco 
> <[email-masked] <mailto:[email-masked]>>
> wrote:
> Qin,
>
> On Sat, Jul 20, 2013 at 3:33 AM, Alfredo Grieco 
> <[email-masked] <mailto:[email-masked]>>
> wrote:
> Dear Qin,
>
> <[email-masked] <mailto:[email-masked]>> wrote:
> All,
>
> [email-masked] <mailto:[email-masked]>