Subject: [6tsch] work item 3 renaming

From: Maria Rita PALATTELLA <[email-masked]>
Date: Tue, 23 Jul 2013 13:34:03 +0000

Pascal, all,

I was wondering if we should re-name work item 3, according to the  new title we gave to work item 2 (i.e., "6TSCH Centralized routing and track Management").

Right now, we have: "6TSCH Distributed Management"

Should we re-name it: "6TSCH Distributed  routing and track Management"?

Thank you,
Maria Rita

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 23 Jul 2013 13:39:47 +0000

I agree Maria Rita.

If no one disagrees in the next hours I'll make that change to the draft charter.

Cheers,

Pascal

From: Maria Rita PALATTELLA [mailto:[email-masked]]
Sent: mardi 23 juillet 2013 15:34
To: [email-masked]; Pascal Thubert (pthubert); Thomas Watteyne ([email-masked])
Subject: work item 3 renaming

Pascal, all,

Thank you,
Maria Rita

---

From: Qin Wang <[email-masked]>
Date: Tue, 23 Jul 2013 21:58:18 +0800

Hi Pascal and Maria Rita,

Maybe I missed something. I'm just wondering why it is "routing and track
management", instead of "cell and track management"?

Thanks!
Qin

On Tue, Jul 23, 2013 at 9:39 PM, Pascal Thubert (pthubert) <
[email-masked]> wrote:

>  I agree Maria Rita.****
>
> ** **
>
> If no one disagrees in the next hours I’ll make that change to the draft
> charter.****
>
> ** **
>
> Cheers,****
>
> ** **
>
> Pascal****
>
> ** **
>
> *From:* Maria Rita PALATTELLA [mailto:[email-masked]]
> *Sent:* mardi 23 juillet 2013 15:34
> *To:* [email-masked]; Pascal Thubert (pthubert); Thomas Watteyne (
> [email-masked])
> *Subject:* work item 3 renaming****
>
> ** **
>
> Pascal, all,****
>
> ** **
>
> I was wondering if we should re-name work item 3, according to the  new
> title we gave to work item 2 (i.e., “6TSCH Centralized routing and track
> Management”).****
>
> ** **
>
> Right now, we have: “6TSCH Distributed Management”****
>
> ** **
>
> Should we re-name it: “6TSCH Distributed  routing and track Management”?**
> **
>
> ** **
>
> Thank you,****
>
> Maria Rita****
>
> ** **
>
> _______________________________________________
> 6tsch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tsch
>
>

---

From: "Raghuram Sudhaakar (rsudhaak)" <[email-masked]>
Date: Tue, 23 Jul 2013 14:12:40 +0000

I agree. Consistent language makes it a better read.

-raghuram

From: "Pascal Thubert (pthubert)" <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, July 23, 2013 6:39 AM
To: Maria Rita PALATTELLA <[email-masked]<mailto:[email-masked]>>, "Thomas Watteyne ([email-masked]<mailto:[email-masked]>)" <[email-masked]<mailto:[email-masked]>>, raghuram sudhaakar <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: work item 3 renaming

I agree Maria Rita.

If no one disagrees in the next hours I’ll make that change to the draft charter.

Cheers,

Pascal

From: Maria Rita PALATTELLA [mailto:[email-masked]]
Sent: mardi 23 juillet 2013 15:34
To: [email-masked]<mailto:[email-masked]>; Pascal Thubert (pthubert); Thomas Watteyne ([email-masked]<mailto:[email-masked]>)
Subject: work item 3 renaming

Pascal, all,

I was wondering if we should re-name work item 3, according to the  new title we gave to work item 2 (i.e., “6TSCH Centralized routing and track Management”).

Right now, we have: “6TSCH Distributed Management”

Should we re-name it: “6TSCH Distributed  routing and track Management”?

Thank you,
Maria Rita

---

From: Thomas Watteyne <[email-masked]>
Date: Tue, 23 Jul 2013 16:55:30 +0200

Agreed. And I see that the few hours to complain already passed :)

Qin,
The issue is that we have been discussing the possibility for the PCE to
influence not only the TSCH schedule, but also the routing table. This was
highlighted in the calls from 2 and 3 weeks ago, where we discussed the
different forwarding possibilities. The old title of the work items
suggested that the PCE only builds tracks (i.e. modifying the TSCH
schedle); this rename is to give the PCE the possibility to modify the
routing tables, too. This was discussed in the context of the PCE (i.e.
centralized); Maria Rita proposed to generalize this also to the
distributed case.

On Tue, Jul 23, 2013 at 4:12 PM, Raghuram Sudhaakar (rsudhaak) <
[email-masked]> wrote:

>   From: "Pascal Thubert (pthubert)" <[email-masked]>
> To: Maria Rita PALATTELLA <[email-masked]>, "Thomas
> Watteyne ([email-masked])" <[email-masked]>,
> raghuram sudhaakar <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>
> *From:* Maria Rita PALATTELLA [mailto:[email-masked]<[email-masked]>]
>

---

From: Qin Wang <[email-masked]>
Date: Tue, 23 Jul 2013 23:27:27 +0800

Thomas,

Thank you very much for explaining it. It is clear. Now I Agree to
"Centralized routing and track management", because PCE can manage not only
tracks but also routing tables, actually, there is some sort of cross-layer
optimization in PCE.

But, regarding to generalizing it to distributed case, my understanding is
that  the routing management is likely irrelevant with 6top, because it is
conducted by routing layer independently.  Sorry,  I haven't figured out
what the new name will imply.

Qin

On Tue, Jul 23, 2013 at 10:55 PM, Thomas Watteyne <
[email-masked]> wrote:

>> Should we re-name it: “6TSCH Distributed  routing and track Management”?*
>> ***
>>
>> ** **
>>
>> Thank you,****
>>
>> Maria Rita****
>>
>> ** **
>>
>
>

---

From: Xavier Vilajosana Guillen <[email-masked]>
Date: Tue, 23 Jul 2013 19:17:54 +0200

Hi Qin,

"But, regarding to generalizing it to distributed case, my understanding is
that  the routing management is likely irrelevant with 6top, because it is
conducted by routing layer independently.  Sorry,  I haven't figured out
what the new name will imply."

unless you can carry some routing IE on 6top requests or you can use 6top
monitoring and managing capabilities to change links (i.e remove a link in
a route, and add another one to another neighbour to force a routing change)
.

X

On Tue, Jul 23, 2013 at 5:27 PM, Qin Wang <[email-masked]> wrote:

>>> ****

---

From: Qin Wang <[email-masked]>
Date: Wed, 24 Jul 2013 01:29:05 +0800

Xavi,

Obviously, the current version of 6top does not deal with routes, only deal
with cells and tracks. In addition, in charter, it is said about the
distributed case as follows.

"to define the mechanism by which a source node reserves MAC-layer
resources along a pre-established RPL multi-hop
path to a destination node. The WG will initially look at RSVP and NSIS.
Depending on the applicability of RSVP and NSIS, this document will be
targeted to proposed standard"

It should mean that the routing table is managed be RPL, and thus, not
necessary to be included in the proposed standard.

Then, I can not see the necessity to add "routing management" in the
distributed case.

What do you think?

Qin

On Wed, Jul 24, 2013 at 1:17 AM, Xavier Vilajosana Guillen <
[email-masked]> wrote:

> Hi Qin,
>
>
> "But, regarding to generalizing it to distributed case, my understanding
> is that  the routing management is likely irrelevant with 6top, because it
> is conducted by routing layer independently.  Sorry,  I haven't figured out
>> But, regarding to generalizing it to distributed case, my understanding
>> is that  the routing management is likely irrelevant with 6top, because it
>> is conducted by routing layer independently.  Sorry,  I haven't figured out
>>>> If no one disagrees in the next hours I’ll make that change to the
>>>> draft charter.****
>>>>
>>>> ** **
>>>>
>>>> Cheers,****
>>>>
>>>> ** **
>>>>
>>>> Pascal****
>>>>
>>>> ** **
>>>>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 23 Jul 2013 18:17:06 +0000

Hi again Qin,

I agree with all you said below; 6top is a layer below routing thus does not do any routing.

Otoh the 6TSCH architecture has to describe how RPL operates over TSCH and in particular its relation the cell allocation and time sync so distributed routing is still an item for us.

Makes sense?

Pascal

Le 23 juil. 2013 à 19:29, "Qin Wang" <[email-masked]<mailto:[email-masked]>> a écrit :

Xavi,

Obviously, the current version of 6top does not deal with routes, only deal with cells and tracks. In addition, in charter, it is said about the distributed case as follows.

"to define the mechanism by which a source node reserves MAC-layer resources along a pre-established RPL multi-hop
path to a destination node. The WG will initially look at RSVP and NSIS. Depending on the applicability of RSVP and NSIS, this document will be targeted to proposed standard"

It should mean that the routing table is managed be RPL, and thus, not necessary to be included in the proposed standard.

Then, I can not see the necessity to add "routing management" in the distributed case.

What do you think?

Qin

On Wed, Jul 24, 2013 at 1:17 AM, Xavier Vilajosana Guillen <[email-masked]<mailto:[email-masked]>> wrote:
Hi Qin,

"But, regarding to generalizing it to distributed case, my understanding is that  the routing management is likely irrelevant with 6top, because it is conducted by routing layer independently.  Sorry,  I haven't figured out what the new name will imply."

unless you can carry some routing IE on 6top requests or you can use 6top monitoring and managing capabilities to change links (i.e remove a link in a route, and add another one to another neighbour to force a routing change).

X

On Tue, Jul 23, 2013 at 5:27 PM, Qin Wang <[email-masked]<mailto:[email-masked]>> wrote:
Thomas,

Thank you very much for explaining it. It is clear. Now I Agree to "Centralized routing and track management", because PCE can manage not only tracks but also routing tables, actually, there is some sort of cross-layer optimization in PCE.

But, regarding to generalizing it to distributed case, my understanding is that  the routing management is likely irrelevant with 6top, because it is conducted by routing layer independently.  Sorry,  I haven't figured out what the new name will imply.

Qin

On Tue, Jul 23, 2013 at 10:55 PM, Thomas Watteyne <[email-masked]<mailto:[email-masked]>> wrote:
Agreed. And I see that the few hours to complain already passed :)

Qin,
The issue is that we have been discussing the possibility for the PCE to influence not only the TSCH schedule, but also the routing table. This was highlighted in the calls from 2 and 3 weeks ago, where we discussed the different forwarding possibilities. The old title of the work items suggested that the PCE only builds tracks (i.e. modifying the TSCH schedle); this rename is to give the PCE the possibility to modify the routing tables, too. This was discussed in the context of the PCE (i.e. centralized); Maria Rita proposed to generalize this also to the distributed case.

On Tue, Jul 23, 2013 at 4:12 PM, Raghuram Sudhaakar (rsudhaak) <[email-masked]<mailto:[email-masked]>> wrote:
I agree. Consistent language makes it a better read.

-raghuram

I agree Maria Rita.

Cheers,

Pascal

Pascal, all,

Thank you,
Maria Rita

_______________________________________________
6tsch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tsch

_______________________________________________
6tsch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tsch

_______________________________________________
6tsch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tsch

---

From: Qin Wang <[email-masked]>
Date: Wed, 24 Jul 2013 02:28:39 +0800

Pascal,

Thanks. It makes perfect sense.

Qin

On Wed, Jul 24, 2013 at 2:17 AM, Pascal Thubert (pthubert) <
[email-masked]> wrote:

>  Otoh the 6TSCH architecture has to describe how RPL operates over TSCH
> and in particular its relation the cell allocation and time sync so
> distributed routing is still an item for us.
>
>  Makes sense?
>
> Pascal
>
> Le 23 juil. 2013 à 19:29, "Qin Wang" <[email-masked]> a écrit :
>
>   Xavi,
>
>  Obviously, the current version of 6top does not deal with routes, only
> deal with cells and tracks. In addition, in charter, it is said about the
>>  unless you can carry some routing IE on 6top requests or you can use
>> 6top monitoring and managing capabilities to change links (i.e remove a
>> link in a route, and add another one to another neighbour to force a
>> routing change).
>>
>>  X
>>
>>
>>
>>
>>>  But, regarding to generalizing it to distributed case, my
>>> understanding is that  the routing management is likely irrelevant with
>>> 6top, because it is conducted by routing layer independently.  Sorry,  I
>>> haven't figured out what the new name will imply.
>>>
>>>  Qin
>>>
>>>
>>>
>>>
>>>> The issue is that we have been discussing the possibility for the PCE
>>>> to influence not only the TSCH schedule, but also the routing table. This
>>>> was highlighted in the calls from 2 and 3 weeks ago, where we discussed the
>>>>> I was wondering if we should re-name work item 3, according to the
>>>>> new title we gave to work item 2 (i.e., “6TSCH Centralized routing and
>>>>> track Management”).****
>>>>>
>>>>> ** **
>>>>>
>>>>> Should we re-name it: “6TSCH Distributed  routing and track
>>>>> Management”?****
>>>>>
>>>>> ** **
>>>>>
>>>>> Thank you,****
>>>>>
>>>>> Maria Rita****
>>>>>
>>>>> ** **
>>>>>
>>>>
>>>>