Subject: [6tsch] terminology draft: quick questions

From: Thomas Watteyne <[email-masked]>
Date: Fri, 12 Jul 2013 15:40:15 +0200

Maria Rita,

I'm going over the (draft) terminology draft at
https://bitbucket.org/6tsch/draft-palattella-6tsch-terminology/<https://bitbucket.org/6tsch/draft-palattella-6tsch-terminology/wiki/Home>
,
and see that the term "link" is defined as

"Single-hop connection between two or more devices. It can be dedicated
(point-to-point), multi-point, broadcast."

Quick questions:
- do we want to use the term link at all. This raised some conflicts with
IETF and IEEE802.15.4e terminology, and we went for "bundle" and "cell".
Maybe this "link" refers to a different element?
- in the current definition, what do p-to-p and multi-point mean?

Thanks,
Thomas

---

From: Maria Rita PALATTELLA <[email-masked]>
Date: Fri, 12 Jul 2013 14:54:42 +0000

Thomas,
Thanks for having pointed this out.
Yes, you are right. Maybe it is better we do not use link at all, for avoiding any kind of conflict.
Anyway, in the current definition, with p-to-p and multi-point I meant  respectively, a connection between node A and node B, and a connection between node A and several 1-hop neighbor (nodes B, C, D).
Maria Rita

From: [email-masked] [mailto:[email-masked]] On Behalf Of Thomas Watteyne
Sent: Friday, July 12, 2013 3:40 PM
To: 6TSCH
Subject: [6tsch] terminology draft: quick questions

Maria Rita,

I'm going over the (draft) terminology draft at https://bitbucket.org/6tsch/draft-palattella-6tsch-terminology/<https://bitbucket.org/6tsch/draft-palattella-6tsch-terminology/wiki/Home> , and see that the term "link" is defined as

"Single-hop connection between two or more devices. It can be dedicated (point-to-point), multi-point, broadcast."

Quick questions:
- do we want to use the term link at all. This raised some conflicts with IETF and IEEE802.15.4e terminology, and we went for "bundle" and "cell". Maybe this "link" refers to a different element?
- in the current definition, what do p-to-p and multi-point mean?

Thanks,
Thomas

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 12 Jul 2013 15:04:15 +0000

Hi Thomas:

As an IETF document we can expect that the reader will understand the link as an IP link as opposed to a 802.15.4e one.
Maybe our terminology should refer to existing RFCs and say that we have the same concept. We need to insist that these are one hop things for L3 operations...

RFC 4862

   link -  a communication facility or medium over which nodes can
     communicate at the link layer, i.e., the layer immediately below
      IP.  Examples are Ethernets (simple or bridged); PPP links; X.25,
      Frame Relay, or ATM networks; and Internet (or higher) layer
      "tunnels", such as tunnels over IPv4 or IPv6 itself.  The protocol
      described in this document will be used on all types of links
      unless specified otherwise in the link-type-specific document
      describing how to operate IP on the link in line with [RFC4861].
   interface -  a node's attachment to a link.

http://tools.ietf.org/html/draft-ietf-autoconf-manetarch-07

   Link

      a communication facility or medium over which nodes can

      communicate at the link layer, i.e., the layer immediately below

      IP.  Examples are Ethernets (simple or bridged), PPP links, X.25,

      Frame Relay, or ATM networks as well as internet (or higher) layer

      "tunnels", such as tunnels over IPv4 or IPv6 itself.

Cheers,

Pascal

From: [email-masked] [mailto:[email-masked]] On Behalf Of Thomas Watteyne
Sent: vendredi 12 juillet 2013 15:40
To: 6TSCH
Subject: [6tsch] terminology draft: quick questions

Maria Rita,

Quick questions:

Thanks,
Thomas

---

From: Qin Wang <[email-masked]>
Date: Sat, 13 Jul 2013 00:42:11 +0800

Hi Pascal,

Do you mean we use same definition of Link as IP link? If yes, maybe we can
remove the term of "Link" from this draft. How do you think?

Thanks
Qin

On Fri, Jul 12, 2013 at 11:04 PM, Pascal Thubert (pthubert) <
[email-masked]> wrote:

>  Hi Thomas:****
>
> ** **
>
> As an IETF document we can expect that the reader will understand the link
> as an IP link as opposed to a 802.15.4e one.****
>
> Maybe our terminology should refer to existing RFCs and say that we have
> the same concept. We need to insist that these are one hop things for L3
> operations…****
>
> ** **
>
> RFC 4862****
>
>
>
> ****
>
>    link -  a communication facility or medium over which nodes can****
>
>      communicate at the link layer, i.e., the layer immediately below****
>
>       IP.  Examples are Ethernets (simple or bridged); PPP links; X.25,***
> *
>
>       Frame Relay, or ATM networks; and Internet (or higher) layer****
>
>       "tunnels", such as tunnels over IPv4 or IPv6 itself.  The protocol**
> **
>
>       described in this document will be used on all types of links****
>
>       unless specified otherwise in the link-type-specific document****
>
>       describing how to operate IP on the link in line with [RFC4861]. ***
> *
>
>    interface -  a node's attachment to a link.****
>
> ** **
>
> http://tools.ietf.org/html/draft-ietf-autoconf-manetarch-07****
>
>  ** **
>
>    Link****
>
>       a communication facility or medium over which nodes can****
>
>       communicate at the link layer, i.e., the layer immediately below****
>
>       IP.  Examples are Ethernets (simple or bridged), PPP links, X.25,****
>
>       Frame Relay, or ATM networks as well as internet (or higher) layer****
>
>       "tunnels", such as tunnels over IPv4 or IPv6 itself.****
>
> ** **
>
> Cheers,****
>
> ** **
>
> Pascal****
>
> ** **
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf
> Of *Thomas Watteyne
> *Sent:* vendredi 12 juillet 2013 15:40
>
> *To:* 6TSCH
> *Subject:* [6tsch] terminology draft: quick questions****
>
> ** **
>
> Maria Rita,****
>
> ** **
>
> https://bitbucket.org/6tsch/draft-palattella-6tsch-terminology/<https://bitbucket.org/6tsch/draft-palattella-6tsch-terminology/wiki/Home> ,
> and see that the term "link" is defined as****
>
> ** **
>
> (point-to-point), multi-point, broadcast."****
>
> ** **
>
> Quick questions:****
>
> Maybe this "link" refers to a different element?****
>
> - in the current definition, what do p-to-p and multi-point mean?****
>
> ** **
>
> Thanks,****
>
> Thomas****
>
> ** **
>
> _______________________________________________
> 6tsch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tsch
>
>

---

From: Pascal Thubert <[email-masked]>
Date: Fri, 12 Jul 2013 18:47:18 +0200

Well we still need to indicate that the link scope is one radio hop, that much is non obvious. And I think it is better to have the entry if only to avoid any confusion and insist that we use the IETF term, what do you think?

Pascal

Le 12 juil. 2013 à 18:42, Qin Wang <[email-masked]> a écrit :

> Hi Pascal,
> 
> Do you mean we use same definition of Link as IP link? If yes, maybe we can remove the term of "Link" from this draft. How do you think?
> 
> Thanks
> Qin
> 
> 
> 
> On Fri, Jul 12, 2013 at 11:04 PM, Pascal Thubert (pthubert) <[email-masked]> wrote:
>> Hi Thomas:
>> 
>>  
>> 
>> Maybe our terminology should refer to existing RFCs and say that we have the same concept. We need to insist that these are one hop things for L3 operations…
>> 
>>  
>> 
>> RFC 4862
>> 
>> 
>> 
>> 
>> I'm going over the (draft) terminology draft at https://bitbucket.org/6tsch/draft-palattella-6tsch-terminology/ , and see that the term "link" is defined as
>> 
>>  
>>

---

From: Qin Wang <[email-masked]>
Date: Sat, 13 Jul 2013 00:49:28 +0800

Agree!

Qin

On Sat, Jul 13, 2013 at 12:47 AM, Pascal Thubert
<[email-masked]>wrote:

> Well we still need to indicate that the link scope is one radio hop, that
> much is non obvious. And I think it is better to have the entry if only to
> avoid any confusion and insist that we use the IETF term, what do you think?
>
> Pascal
>
> Do you mean we use same definition of Link as IP link? If yes, maybe we
> can remove the term of "Link" from this draft. How do you think?
>
> Thanks
> Qin
>
>
>
>> As an IETF document we can expect that the reader will understand the
>> link as an IP link as opposed to a 802.15.4e one.****
>>
>>       IP.  Examples are Ethernets (simple or bridged); PPP links; X.25,**
>> **
>>
>>       "tunnels", such as tunnels over IPv4 or IPv6 itself.  The protocol*
>> ***
>>
>>       describing how to operate IP on the link in line with [RFC4861]. **
>> **
>>
>> *From:* [email-masked] [mailto:[email-masked]] *On
>> Behalf Of *Thomas Watteyne