Subject: Re: [6tsch] the first 30min

From: Thomas Watteyne <[email-masked]>
Date: Thu, 18 Jul 2013 14:50:07 +0200

Pascal,

Absolutely, I saw your attached e-mail, and I agree we're very close. I was
going through it when preparing this e-mail, after realizing we will
probably be moving thing around between Maria Rita's, Xavi's and my own
slides.

I agree with your modification to the conclusion and the story you're
describing.

Thomas

On Thu, Jul 18, 2013 at 2:26 PM, Pascal Thubert (pthubert) <
[email-masked]> wrote:

>  Hello Thomas****
>
> ** **
>
> I’d discuss the nutshells rather than the content (which is close to
> perfect; ) And I’d argue that the nutshells are also the conclusions.****
>
> Did you see the thread attached? We’re mostly in line but it seems you
> went through it all again. I understand your logic, this is a nice story.*
> ***
>
> My 2 centimes:****
>
> ** **
>
>    - [5min] draft-watteyne-6tsch-tsch-lln-context-02 [Thomas]****
>       - *In a nutshell: IEEE802.15.4e TSCH is Deterministic Wirelessstandard
>       *****
>
> I expect that at this point the crowd understands that deterministic is a
> new and immensely powerful complex, enabling control loops and this key to
> OT/automation networks, and that we can actually achieve it on wireless.**
> **
>
>    - [10min] what is IEEE802.15.4e TSCH? [Maria Rita]****
>       - *In a nutshell: IEEE802.15.4e TSCH is a proven technology which
>       opens up IT/OT/automation convergence if coupled with IPv6*****
>
> I expect that at this point the crowd has a sense of a huge value for the
> real world, even for everyday life. If ùy nutshell is Maria Rita’s
> conclusion then we have a great transition for Xavi (see my attached mail)
> ****
>
>    - [15min] what is missing? [Xavi]****
>       - *In a nutshell: Some Blocks but mostly Glue are missing so 6TSCH
>       is doable*****
>
> By then people must also be convinced that there is work to be done,
> understand what the scope of that work is, and that it is achievable within
> IETF classical operations.****
>
> ** **
>
> Works for you? ****
>
> ** **
>
> Also, do you mind copyting the list or at least the other speakers and Ted
> and Marc?****
>
> ** **
>
> Pascal****
>
> ** **
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf Of *Thomas
> Watteyne
> *Sent:* jeudi 18 juillet 2013 14:08
> *To:* Maria Rita Palattella; Xavi Vilajosana; Pascal Thubert (pthubert)
> *Subject:* BoF: the first 30min****
>
> ** **
>
> Xavi, Maria Rita,****
>
> ** **
>
> [CC'ing Pascal]****
>
> ** **
>
> The first 30min at the BoF will be ours to convey the following messages:*
> ***
>
>    - IEEE802.15.4e TSCH is a powerful new standard****
>    - it's a proven technology****
>    - we want to fit an IETF IPv6 upper stack onto it****
>    - but pieces are missing****
>
>  We need to coordinate closely to avoid (1) that we repeat things and (2)
> that we follow the same stream of thought. From the slides that are now in
> the repo, I can see that we all are hesitant a bit about who says what.***
> *
>
> ** **
>
> This e-mail is the start of the discussion we will have later today in our
> "private" webex.****
>
> ** **
>
> I believe that, high-level, we could separate our speaking time as follows:
> ****
>
>    - [5min] draft-watteyne-6tsch-tsch-lln-context-02 [Thomas]****
>
>
>     - *In a nutshell: IEEE802.15.4e TSCH is new L2 standard*****
>       - what we are presenting is the first draft generated by the group,
>       and which highlights what IEEE802.15.4e TSCH is and what is missing. It's
>       the document we used early on in the definition of the problem statement
>       within the 6TSCH group, and we therefore present early on in the BoF.
>       ****
>       - IEEE802.15.4 is a double standard (PHY and MAC) for low-power
>       wireless radio. It's a very well-known standard, used at the base of the
>       6LoWPAN, CORE and ROLL WGs.****
>       - IEEE802.15.4e is an amendment to its MAC protocol****
>       - one of the modes is Timeslotted Channel Hopping (TSCH)****
>       - TSCH allows low-power through synchronization, high reliability
>       through channel hopping****
>       - nodes in the network follow the TSCH communication schedule****
>       - published IEEE standard, April 2012****
>
>
>    - [10min] what is IEEE802.15.4e TSCH? [Maria Rita]****
>
>
>     - *In a nutshell: IEEE802.15.4e TSCH is a proven technology which
>       opens up new applications*****
>       - playing with the schedule allows for a clean trade-off between
>       throughout, latency, redundancy and power consumption****
>       - allows for a high level of determinism and traffic engineering****
>       - opens up to new range of applications which require high
>       reliability and low-power:****
>
>
>     - ** **
>          - Control loops in a wireless process control network, in which
>          high reliability and a fully deterministic behavior are required.
>          ****
>          - Umbrella networks transporting data from different independent
>          clients, and for which an operator needs flow isolation and traffic shaping.
>          ****
>          - Energy harvesting networks, which require an extremely low and
>          predictable average power consumption.****
>
>
>     - an analogy of our work can be found in WirelessHART and ISA100.11a,
>       although these standards don't use IETF building blocks. Those standards
>       use a variant of Timeslotted Channel Hopping, but not IEEE802.15.4e.
>       ****
>       - we want to define how to run IPv6 on top of IEEE802.15.4e TSCH****
>       - the IEEE802.15.4e standard only defines what nodes do once they
>       have a schedule, NOT how to build and maintain that schedule****
>
>
>    - [15min] what is missing? [Xavi]****
>
>
>     - *In a nutshell: blocks are missing*****
>       - some building blocks are missing to fit an IPv6 stack onto
>       IEEE802.15.4e TSCH. Most of them already exist. We want to provide
>       guidelines on how to glue them together.****
>       - the main blocks are:****
>
>
>     - (per draft-watteyne-6tsch-tsch-lln-context-02) guidelines to fully
>          define the behavior of the network:****
>
>
>      - ** **
>             - network formation****
>             - election of timing parents needed for synchronization****
>             - network maintenance****
>             - security (mostly key management)****
>
>
>     - building and maintaining the communication schedule:****
>
>
>      - "the orchestra director"****
>             - Both centralized and distributed approaches are
>             contemplating****
>             - protocols to coordinate nodes and distribute information****
>
>
>     - multi-hop dataflow****
>
>
>      - integration with RPL (including feeding back metrics)****
>             - packet switching and tunneling****
>
>
>     - QoS and TE (includes different flow/packet priorities, traffic
>          classes, and mapping to layer 2 resources)****
>          - ND and backbone architecture****
>
>  Thoughts? I ca go over this during the webex later today.****
>
> ** **
>
> Thomas****
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 18 Jul 2013 13:21:29 +0000

Great, thanks Thomas : )

BTW I typo'ed down there; I meant concept not complex. I'm unsure how much of that is me mixing fingers and/or neurons and how much outlook's benevolent error correction!

Cheers,

Pascal

From: [email-masked] [mailto:[email-masked]] On Behalf Of Thomas Watteyne
Sent: jeudi 18 juillet 2013 14:50
To: Pascal Thubert (pthubert)
Cc: 6TSCH; Ted Lemon ([email-masked]); Marc Blanchet
Subject: Re: the first 30min

Pascal,

Absolutely, I saw your attached e-mail, and I agree we're very close. I was going through it when preparing this e-mail, after realizing we will probably be moving thing around between Maria Rita's, Xavi's and my own slides.

I agree with your modification to the conclusion and the story you're describing.

Thomas

On Thu, Jul 18, 2013 at 2:26 PM, Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>> wrote:
Hello Thomas

I'd discuss the nutshells rather than the content (which is close to perfect; ) And I'd argue that the nutshells are also the conclusions.
Did you see the thread attached? We're mostly in line but it seems you went through it all again. I understand your logic, this is a nice story.
My 2 centimes:

  *   [5min] draft-watteyne-6tsch-tsch-lln-context-02 [Thomas]

     *   In a nutshell: IEEE802.15.4e TSCH is Deterministic Wireless standard
I expect that at this point the crowd understands that deterministic is a new and immensely powerful complex, enabling control loops and this key to OT/automation networks, and that we can actually achieve it on wireless.

  *   [10min] what is IEEE802.15.4e TSCH? [Maria Rita]

     *   In a nutshell: IEEE802.15.4e TSCH is a proven technology which opens up IT/OT/automation convergence if coupled with IPv6
I expect that at this point the crowd has a sense of a huge value for the real world, even for everyday life. If ùy nutshell is Maria Rita's conclusion then we have a great transition for Xavi (see my attached mail)

  *   [15min] what is missing? [Xavi]

     *   In a nutshell: Some Blocks but mostly Glue are missing so 6TSCH is doable
By then people must also be convinced that there is work to be done, understand what the scope of that work is, and that it is achievable within IETF classical operations.

Works for you?

Also, do you mind copyting the list or at least the other speakers and Ted and Marc?

Pascal

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Thomas Watteyne
Sent: jeudi 18 juillet 2013 14:08
To: Maria Rita Palattella; Xavi Vilajosana; Pascal Thubert (pthubert)
Subject: BoF: the first 30min

Xavi, Maria Rita,

[CC'ing Pascal]

The first 30min at the BoF will be ours to convey the following messages:

  *   IEEE802.15.4e TSCH is a powerful new standard
  *   it's a proven technology
  *   we want to fit an IETF IPv6 upper stack onto it
  *   but pieces are missing
We need to coordinate closely to avoid (1) that we repeat things and (2) that we follow the same stream of thought. From the slides that are now in the repo, I can see that we all are hesitant a bit about who says what.

This e-mail is the start of the discussion we will have later today in our "private" webex.

  *   [5min] draft-watteyne-6tsch-tsch-lln-context-02 [Thomas]

     *   In a nutshell: IEEE802.15.4e TSCH is new L2 standard
     *   what we are presenting is the first draft generated by the group, and which highlights what IEEE802.15.4e TSCH is and what is missing. It's the document we used early on in the definition of the problem statement within the 6TSCH group, and we therefore present early on in the BoF.
     *   IEEE802.15.4 is a double standard (PHY and MAC) for low-power wireless radio. It's a very well-known standard, used at the base of the 6LoWPAN, CORE and ROLL WGs.
     *   IEEE802.15.4e is an amendment to its MAC protocol
     *   one of the modes is Timeslotted Channel Hopping (TSCH)
     *   TSCH allows low-power through synchronization, high reliability through channel hopping
     *   nodes in the network follow the TSCH communication schedule
     *   published IEEE standard, April 2012

  *   [10min] what is IEEE802.15.4e TSCH? [Maria Rita]

     *   In a nutshell: IEEE802.15.4e TSCH is a proven technology which opens up new applications
     *   playing with the schedule allows for a clean trade-off between throughout, latency, redundancy and power consumption
     *   allows for a high level of determinism and traffic engineering
     *   opens up to new range of applications which require high reliability and low-power:

        *
        *   Control loops in a wireless process control network, in which high reliability and a fully deterministic behavior are required.
        *   Umbrella networks transporting data from different independent clients, and for which an operator needs flow isolation and traffic shaping.
        *   Energy harvesting networks, which require an extremely low and predictable average power consumption.

     *   an analogy of our work can be found in WirelessHART and ISA100.11a, although these standards don't use IETF building blocks. Those standards use a variant of Timeslotted Channel Hopping, but not IEEE802.15.4e.
     *   we want to define how to run IPv6 on top of IEEE802.15.4e TSCH
     *   the IEEE802.15.4e standard only defines what nodes do once they have a schedule, NOT how to build and maintain that schedule

  *   [15min] what is missing? [Xavi]

     *   In a nutshell: blocks are missing
     *   some building blocks are missing to fit an IPv6 stack onto IEEE802.15.4e TSCH. Most of them already exist. We want to provide guidelines on how to glue them together.
     *   the main blocks are:

        *   (per draft-watteyne-6tsch-tsch-lln-context-02) guidelines to fully define the behavior of the network:

           *
           *   network formation
           *   election of timing parents needed for synchronization
           *   network maintenance
           *   security (mostly key management)

        *   building and maintaining the communication schedule:

           *   "the orchestra director"
           *   Both centralized and distributed approaches are contemplating
           *   protocols to coordinate nodes and distribute information

        *   multi-hop dataflow

           *   integration with RPL (including feeding back metrics)
           *   packet switching and tunneling

        *   QoS and TE (includes different flow/packet priorities, traffic classes, and mapping to layer 2 resources)
        *   ND and backbone architecture
Thoughts? I ca go over this during the webex later today.

Thomas

---

From: Qin Wang <[email-masked]>
Date: Thu, 18 Jul 2013 22:28:52 +0800

Hi Pascal,

The three stages are very clear in logic. Just a comment on the sub-title
of the second part.

If the conclusion from Maria Rita talk is expected as "the crowd has a
sense of a huge value for the real world, even for everyday life", the
sub-title may need to be changed, e.g. "How it works?" or something else.

Thought?
Qin

On Thu, Jul 18, 2013 at 8:50 PM, Thomas Watteyne <[email-masked]
> wrote:

> Pascal,
>
> Absolutely, I saw your attached e-mail, and I agree we're very close. I
> was going through it when preparing this e-mail, after realizing we will
>> went through it all again. I understand your logic, this is a nice story.
>> ****
>>
>> My 2 centimes:****
>>
>> ** **
>>
>> OT/automation networks, and that we can actually achieve it on wireless.*
>> ***
>>
>> Also, do you mind copyting the list or at least the other speakers and
>> Ted and Marc?****
>>
>> ** **
>>
>> Pascal****
>>
>> ** **
>>
>>  We need to coordinate closely to avoid (1) that we repeat things and
>> (2) that we follow the same stream of thought. From the slides that are now
>> in the repo, I can see that we all are hesitant a bit about who says what.
>> ****
>>
>> ** **
>>
>> This e-mail is the start of the discussion we will have later today in
>> our "private" webex.****
>>
>> ** **
>>
>> I believe that, high-level, we could separate our speaking time as
>> follows:****
>>
>>       - what we are presenting is the first draft generated by the
>>       group, and which highlights what IEEE802.15.4e TSCH is and what is missing.
>>       It's the document we used early on in the definition of the problem
>>       statement within the 6TSCH group, and we therefore present early on in the
>>       BoF.****
>>          - Umbrella networks transporting data from different
>>          independent clients, and for which an operator needs flow isolation and
>>          traffic shaping.****
>>          - Energy harvesting networks, which require an extremely low
>>          and predictable average power consumption.****
>>
>>
>>     - an analogy of our work can be found in WirelessHART and
>>       ISA100.11a, although these standards don't use IETF building blocks. Those
>>       standards use a variant of Timeslotted Channel Hopping, but not
>>       IEEE802.15.4e.****
> _______________________________________________
> 6tsch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tsch
>
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 18 Jul 2013 14:58:36 +0000

Hello Qin;

Just to make sure, the quote is not what I expect Maria Rita to say as her conclusion but the conclusion that people should have drawn from her presentation, do we agree?
I agree the title is not too specific... I'd think that "what is TSCH used for in the real world?", or "what is TSCH proven to be great for?" is even closer than "how does it work?".
The cool thing with the broad title is that we have some freedom to play a little but with the message and the content, which we are still determining at this time : )

Cheers,

Pascal

From: Qin Wang [mailto:[email-masked]]
Sent: jeudi 18 juillet 2013 16:29
To: Thomas Watteyne
Cc: Pascal Thubert (pthubert); Marc Blanchet; 6TSCH; Ted Lemon ([email-masked])
Subject: Re: [6tsch] the first 30min

Hi Pascal,

The three stages are very clear in logic. Just a comment on the sub-title of the second part.

If the conclusion from Maria Rita talk is expected as "the crowd has a sense of a huge value for the real world, even for everyday life", the sub-title may need to be changed, e.g. "How it works?" or something else.

Thought?
Qin

On Thu, Jul 18, 2013 at 8:50 PM, Thomas Watteyne <[email-masked]<mailto:[email-masked]>> wrote:
Pascal,

Thomas

Works for you?

Pascal

Xavi, Maria Rita,

[CC'ing Pascal]

        *

           *
           *   network formation

        *   multi-hop dataflow

Thomas

_______________________________________________
6tsch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tsch

---

From: Qin Wang <[email-masked]>
Date: Thu, 18 Jul 2013 23:21:16 +0800

Pascal,

I understand the conclusion should be drawn by people from Maria Rita's
talk and fully agree with you. Then, I prefer "what is TSCH proven to be
great for?"

Thanks
Qin

On Thu, Jul 18, 2013 at 10:58 PM, Pascal Thubert (pthubert) <
[email-masked]> wrote:

>  Hello Qin;****
>
> ** **
>
> Just to make sure, the quote is not what I expect Maria Rita to say as her
> conclusion but the conclusion that people should have drawn from her
> presentation, do we agree?****
>
> I agree the title is not too specific… I’d think that “what is TSCH used
> for in the real world?”, or “what is TSCH proven to be great for?” is even
> closer than “how does it work?”.****
>
> The cool thing with the broad title is that we have some freedom to play a
> little but with the message and the content, which we are still determining
> at this time : ) ****
>
> ** **
>
> Cheers, ****
>
> ** **
>
> Pascal****
>
> ** **
>
> *From:* Qin Wang [mailto:[email-masked]]
> *Sent:* jeudi 18 juillet 2013 16:29
> *To:* Thomas Watteyne
> *Cc:* Pascal Thubert (pthubert); Marc Blanchet; 6TSCH; Ted Lemon (
> [email-masked])
> *Subject:* Re: [6tsch] the first 30min****
>
> ** **
>
> Hi Pascal, ****
>
> ** **
>
> of the second part.****
> sub-title may need to be changed, e.g. "How it works?" or something else.*
> ***
>
> ** **
>
> Thought?****
>
> Qin****
>
>  ****
>
> ** **
>
>  ****
>
> ** **
>
> On Thu, Jul 18, 2013 at 8:50 PM, Thomas Watteyne <
> [email-masked]> wrote:****
>
> Pascal,****
>
> ** **
>
> slides.****
> describing.****
> [email-masked]> wrote:****
>
> Hello Thomas****
>
>  ****
>
>    - [5min] draft-watteyne-6tsch-tsch-lln-context-02 [Thomas] ****
>
>
>    - [10min] what is IEEE802.15.4e TSCH? [Maria Rita] ****
>
>
>    - [15min] what is missing? [Xavi] ****
>
>
>     - *In a nutshell: Some Blocks but mostly Glue are missing so 6TSCH is
>       doable*****
>
>     -  ****
>      -  ****
> https://www.ietf.org/mailman/listinfo/6tsch****
>
> ** **
>

---

From: Maria Rita PALATTELLA <[email-masked]>
Date: Thu, 18 Jul 2013 16:58:18 +0000

Pascal, all,
>From the overall discuss, I can conclude that I will have to focus on the applications . Right?
Maria Rita

From: [email-masked] [mailto:[email-masked]] On Behalf Of Qin Wang
Sent: Thursday, July 18, 2013 5:21 PM
To: Pascal Thubert (pthubert)
Cc: Thomas Watteyne; Marc Blanchet; 6TSCH; Ted Lemon ([email-masked])
Subject: Re: [6tsch] the first 30min

Pascal,

I understand the conclusion should be drawn by people from Maria Rita's talk and fully agree with you. Then, I prefer "what is TSCH proven to be great for?"

Thanks
Qin

On Thu, Jul 18, 2013 at 10:58 PM, Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>> wrote:
Hello Qin;

Cheers,

Pascal

From: Qin Wang [mailto:[email-masked]<mailto:[email-masked]>]
Sent: jeudi 18 juillet 2013 16:29
To: Thomas Watteyne
Cc: Pascal Thubert (pthubert); Marc Blanchet; 6TSCH; Ted Lemon ([email-masked]<mailto:[email-masked]>)
Subject: Re: [6tsch] the first 30min

Hi Pascal,

Thought?
Qin

Thomas

Works for you?

Pascal

Xavi, Maria Rita,

[CC'ing Pascal]

        *

           *
           *   network formation

        *   multi-hop dataflow

Thomas

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 18 Jul 2013 17:43:34 +0000

Yes, Maria Rita

you need to show that there are already great applications for deterministic wireless, but also give a sense of the value of generalizing to all other sorts of automation thus realizing the IT/OT convergence that is the entry point to Xavi's discussion.

Cheers,

Pascal

From: Maria Rita PALATTELLA [mailto:[email-masked]]
Sent: jeudi 18 juillet 2013 18:58
To: Qin Wang; Pascal Thubert (pthubert)
Cc: Thomas Watteyne; Marc Blanchet; 6TSCH; Ted Lemon ([email-masked])
Subject: RE: [6tsch] the first 30min

Pascal, all,
Maria Rita

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Qin Wang
Sent: Thursday, July 18, 2013 5:21 PM
To: Pascal Thubert (pthubert)
Cc: Thomas Watteyne; Marc Blanchet; 6TSCH; Ted Lemon ([email-masked]<mailto:[email-masked]>)
Subject: Re: [6tsch] the first 30min

Pascal,

Thanks
Qin

Cheers,

Pascal

Hi Pascal,

Thought?
Qin

Thomas

Works for you?

Pascal

Xavi, Maria Rita,

[CC'ing Pascal]

        *

           *
           *   network formation

        *   multi-hop dataflow

Thomas