Subject: Re: [71attendees] [Geopriv] GEOPRIV Experiment at IETF 71

From: "Winterbottom, James" <[email-masked]>
Date: Fri, 11 Apr 2008 06:35:05 -0500

Hi Alberto,

In answer to the first question.
The LIS uses things called location determination functions (LDFs), which are configured through the config.inc file.
There are instructions in that file describing how to change the LDF, the basic LIS from source forge comes with 3 options.
The first two options are SNMP variants, as you will have seen. The third option is a static mapping option, that allows you statically map an IP address to a location.
I think you can do what you are trying to do using this last option, and that will reduce the amount of code you need to write to isolate the HELD component from the LDF.

Secondly the HELD client.
The HELD client is actually more versatile than you give it credit for.
It does have DHCP discovery capability, but you can also set it to always point to a well known LIS by changing the HELDClient.properties file. This is what we did at the IETF meeting.
Next, the HELD client does provide a "raw" API function, which will take a raw XML request and simply pump it over to the LIS. In this way you can use the HELD client to make On-Behalf-Of (OBO) requests by including the IP address of the Target you want to learn the location of. This works very well and we have tested and used it extensively. I think that this is the function you wanted in your third question below.

Note that LIS 2.0 is a little less forgiving that LIS 1.0 in this mode, there is now a OBO whitelist permissions list. Any device that wants to make an OBO location request MUST have its IP address added to the list. Access to this page is available from the ..<LIS PATH>/entry web page.

As for more information on the Client we have produced quite an extensive design document that I may be able to provide to you, but not until next week, and not until I have had a few discussions with a couple of people.

If this didn't answer some of your questions I could be available for a call sometime next week.

Cheers
James

-----Original Message-----
From: Alberto Ballauri [mailto:[email-masked]]
Sent: Fri 4/11/2008 3:58 AM
To: Winterbottom, James
Cc: Richard Barnes; GEOPRIV; [email-masked]
Subject: Re: [Geopriv] GEOPRIV Experiment at IETF 71
 
Hi James,
We have some philosophical questions about the LIS and the HELD client,
First, we would like to know if we could use the LIS 2.0 without the SNMP
part, the part that we are really interested in is the HELD interface and
the DB. In fact we would like to populate database manually and don't be
binded to a specific localization approach such as SNMP.
Could it be achieved isolating some part of the code? So that the LIS
continue to work properly on HELD interface but independently from physical
interface.
Second, we noticed that the HELD client work as a Windows service, it suits
well when it work on the target, and could be considered as a service
enabler, but if we would like to use it on a different logical entity could
we wrap it in a jar file and use it as an isolated program? Is there
available some more doc about the building of the Java Client?
Last but not least, we are interested in using the client also on the LDP
interface, so is it able to take a uri and resolve it to gain the location
of a different target? This is the role in wich we would like to use it now,
and possibly as a program and not a service.

Thanks a lot

Alberto&Tommaso

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]

_______________________________________________
71attendees mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/71attendees

---

From: "Alberto Ballauri" <[email-masked]>
Date: Fri, 11 Apr 2008 10:58:30 +0200

Hi James,

Thanks a lot

Alberto&Tommaso

---

From: "Winterbottom, James" <[email-masked]>
Date: Mon, 14 Apr 2008 16:46:12 -0500

Alberto,

As I have now said 3 times, please take these questions to the source forge HELD forum.
I will not be answering emails sent to this list regarding this topic.

Cheers
James

-----Original Message-----
From: [email-masked] on behalf of Alberto Ballauri
Sent: Fri 4/11/2008 3:58 AM
To: Winterbottom, James
Cc: GEOPRIV; Richard Barnes; [email-masked]
Subject: Re: [71attendees] [Geopriv] GEOPRIV Experiment at IETF 71
 
Hi James,

Thanks a lot

Alberto&Tommaso