Subject: [78attendees] Lessons we can take from the Internet connectivity fiasco in Maastricht...

From: Ted Lemon <[email-masked]>
Date: Wed, 28 Jul 2010 13:17:35 -0700

A while back we were talking about getting a 3G service kiosk set up at future IETF meetings, and I thought it seemed like a slightly unreasonable, yet desirable, request.   I'd like to up that to "pretty important."

Why?   I have wasted a surprising amount of time at this IETF trying to get working Internet in my hotel room.   Since I'm not at the NH, getting the folks in the NOC to do it wasn't an option, although I nevertheless applaud their valiant and apparently successful efforts.

Because this IETF was not near a city center with shops that sell 3G cards, it was at least an hour excursion to go to such a shop, sometimes two, depending on how the buses were running.   I wound up doing this four times during this visit.   It had to be during prime time - 8am to 6pm - because shops don't keep late hours here (nor do I blame them).   And at the end of it, because I do not live in the netherlands, and do not have the ability to receive SMS messages at a Netherlands number, the free offers didn't work, I spent hours on the phone with T-mobile, and after buying two SIM cards, one from Vodaphone and one from T-mobile, wound up with one disabled SIM card (Vodaphone) and one SIM card with a starting balance of 2.50 Euro.   I can't add credit to the T-mobile card because my credit card isn't accepted because I can't put a U.S. address on my T-mobile account.   Total cost so far: 25 Euro.

I don't know how many other people went down this path.   I don't know how many were successful, and how many failed, like I did.   But it was a huge waste of time.   Having a cell phone provider that's on board to provide a bunch of SIMs to needy IETFers would have worked.   The do-it-yourself solution really didn't.

It's easy to say "well, Internet service in the hotel ought to work," but we have a lot of experience with that.   It never does, unless we run it.   IETFers kill hotel networks dead.   It's something we should just accept.

So while I realize that it's yet another annoying request from yet another whiny IETF attendee, I think it would actually save a lot of IETF meeting-person-hours if this could become a checklist item for future IETFS: not "are 3G cards available locally," but "can we get a 3G provider to commit to providing 3G cards to IETFers that don't require local credentials to work, and that can be had at the venue?"   I think it would be fine to set up a prepay, pre order system, as long as the deal is understood up front.   And of course in countries like India where prepaid cards can't be sold to foreigners, or in countries where the 3G provider wants $1/kilobyte, it's not going to be practical.   But it would have worked a treat here.

---

From: Chris Morrow <[email-masked]>
Date: Wed, 28 Jul 2010 16:24:39 -0400

On Wed, Jul 28, 2010 at 4:17 PM, Ted Lemon <[email-masked]> wrote:
<snip good stuff about saving time by having a kiosk>
> Because this IETF was not near a city center with shops that sell 3G cards, it was at least an hour excursion to go to such a shop, sometimes two, depending on how the buses were running.   I wound…

So, a note for the vodafone purchasers (who apparently failed as I
did)... our intrepid googler steve padgett noted that vodafone has a
sim for 7.50 that gets '30 days free internet'. I suspect this is what
Ted bought, it is what I bought.

The store folks didn't pass along to me, but did to spadgett, the
flyer which says:
o put the sim in your phone
o SMS 'Zorgeloos internet aan' to 4000
o rejoice
(paraphrased)

So, my sim was promptly 'deactivated' (minus about 1400 sms messages
from their automated system...suckers!) after ~1day. After getting a
tad miffed I called:
   1200
  option 1 'top up'
  option 9 'register to top up with credit card'
  talk to nice customer service person explain the above "yes, I only
ever want internet, no phone calls, pls check the records i used up
all my credit with internet. Could you see your way through to
re-setting my account and enabling the 'Zorgeloos internet aan' for
me? "

The nice support person did this (to my workmate wkumari as well).
rejoice internetz again!

-chris

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Wed, 28 Jul 2010 23:55:26 +0200

On 28 jul 2010, at 22:17, Ted Lemon wrote:

> IETFers kill hotel networks dead.   It's something we should just accept.

While I sympathize with your ordeal (I sort of had one myself, with the data service on my Dutch SIM that I've had for years not working when I arrived back into the country and getting a new one at the store proved impossible) and I especially recognize the frustration and time suck that is the promise of connectivity working if I just do this, that or the other thing, I have to disagree with you.

There is a very good network at the venue. Nobody has to be without connectivity many non-sleeping, non-eating hours.

Why do IETFers kill hotel networks? I've had some experience where the congestion was unbelievable, at levels that couldn't have been caused by anything remotely resembling normal use. I very strongly suspect that some IETFers are doing things that no normal hotel network can handle. Since I don't do these things, I believe others can live without them, too. And then the hotel networks don't break and we can all be happy and the NOC can get some well deserved sleep.

So as the NH traffic is currently flowing through the IETF network: bring on the tcpdump, nmap and sflow and figure this thing out.

And: count your blessings. I was at a conference two months ago, where the venue network was so bad you couldn't even load the portal page during normal hours, only during breaks it was barely possible to download a few emails. In the hotel, the network only worked every other night. As in: at all. If the tech guy had left for the day without resetting the gateway there was no connectvity until the next day.

---

From: Malcolm Scott <[email-masked]>
Date: Thu, 29 Jul 2010 02:02:42 +0100 (BST)

At 13:17 yesterday, Ted Lemon wrote:

> A while back we were talking about getting a 3G service kiosk set up at 
> future IETF meetings, and I thought it seemed like a slightly 
> unreasonable, yet desirable, request.  I'd like to up that to "pretty 
> important."
>
> Why?  I have wasted a surprising amount of time at this IETF trying to get 
> working Internet in my hotel room.  Since I'm not at the NH, getting the 
> folks in the NOC to do it wasn't an option, although I nevertheless 
> applaud their valiant and apparently successful efforts.

Is it not likely that if presented with free/cheap 3G data, we'd start 
killing the 3G network too?  I believe it's common for older cell towers (in 
the UK, anyway) to have little more than a few megabits of backhaul 
capacity.  (Having the NOC take over in that case would add a whole new 
dimension of fun... :-) )

Malcolm

-- 
Malcolm Scott
University of Cambridge Computer Laboratory

---

From: Ted Lemon <[email-masked]>
Date: Wed, 28 Jul 2010 23:51:32 -0700

> There is a very good network at the venue. Nobody has to be without connectivity many non-sleeping, non-eating hours.

I think you concentrate better than I do.   It's generally difficult to find a place in the venue where you can sit and work in silence.   This is really by design--the whole point of IETF meetings is to meet.   But sometimes once you've met, you need to do a little bit of quiet work, and it can be difficult to get it done in the venue.   If I'd known on Tuesday what I know now, I would have just dealt with it, but it's funny how one can get sucked into solving a problem when it seems like just a little more effort will do it.

---

From: Javier Ubillos <[email-masked]>
Date: Thu, 29 Jul 2010 08:54:11 +0200

The terminal room has been like a half-empty library during the whole
stay.
It's been great!

// Javier

On Wed, 2010-07-28 at 23:51 -0700, Ted Lemon wrote:
> _______________________________________________
> 78attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/78attendees

---

From: <[email-masked]>
Date: Thu, 29 Jul 2010 09:59:43 +0200

Dear all,

>A while back we were talking about getting a 3G service kiosk 
>set up at future IETF meetings...

This is of course up to the organisers and the operators to consider since there is demand for it.

But for my own part, rather than holding my breath to wait for someone to optimise the cost of my connectivity for me, I use the usual excellent service provided at the meeting venue or the free internet service good enough for VoIP provided by my hotel. Outside WLAN coverage I just use my HPLMN SIM like I always do and of course it works fine, like it always does. 

Oh yes, it does cost money. I was never able to figure out the logic of spending thousands on flight tickets and hotels and then using hours of precious time to find a local USIM to save 25 €. I saved more than my phone bill for this whole month by spending just a few minutes to find among the meeting hotels the one that offers free WLAN. I must admit that was not my main criteria, but the location at the city centre.

Maybe I am missing something?

BR,
Hannu Hietalahti
The 3GPP man
+358 40 5021724

---

From: Ben Campbell <[email-masked]>
Date: Thu, 29 Jul 2010 10:09:02 +0200

> Maybe I am missing something?

The US carriers tend towards very high data roaming charges. You can easily rack up charges in the multiple hundreds of euros range.

---

From: Scott Brim <[email-masked]>
Date: Thu, 29 Jul 2010 10:24:20 +0200

On 07/29/2010 10:09 GMT+02:00, Ben Campbell wrote:
> The US carriers tend towards very high data roaming charges. You can
> easily rack up charges in the multiple hundreds of euros range.

Not just USA.  A German visiting California for a week received a bill 
of €2500 when he got home.

---

From: <[email-masked]>
Date: Thu, 29 Jul 2010 11:01:45 +0200

>The US carriers tend towards very high data roaming charges. 
>You can easily rack up charges in the multiple hundreds of euros range.
>
OK, the EU regulation might work to my favour here as it puts a cap on roaming charges. But compared to pre-VoIP times I have decimated my company phone bills from hundreds of euros to tens of euros each month just by using VoIP for calls where free WLAN is easily available. (please don't quote me on that in 3GPP meeting ;-)

Outside of meeting venue and my hotel I just use cellular connectivity whenever I need it.

This usage pattern means that for me 10 € / day for hotel WLAN is expensive compared to my phone usage.

BR,
Hannu Hietalahti
3GPP TSG CT Chairman
tel: +358 40 5021724

---

From: Ted Lemon <[email-masked]>
Date: Thu, 29 Jul 2010 02:21:59 -0700

On Jul 29, 2010, at 9:59 AM, "[email-masked]" <[email-masked]> wrote:
> Oh yes, it does cost money. I was never able to figure out the logic of spending thousands on flight tickets and hotels and then using hours of precious time to find a local USIM to save 25 €.

If I were to use the international roaming on my iPad, it would cost on the order of my train tickets.   There is no chance that that expense would be approved, so it would be entirely out of pocket.

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Thu, 29 Jul 2010 13:44:43 +0200

> I think you concentrate better than I do.   It's generally difficult to find a place in the venue where you can sit and work in silence.

Hm, actually I was thinking earlier about what the talking etiquette should be in the terminal room. We currently also have the room where we eat lunch which has a decent number of power outlets so it seems that a library-like policy on talking in the terminal room wouldn't be unreasonable.

---

From: Randall Gellens <[email-masked]>
Date: Thu, 29 Jul 2010 06:38:44 -0700

At 10:09 AM +0200 7/29/10, Ben Campbell wrote:

>  The US carriers tend towards very high data roaming charges. You 
> can easily rack up charges in the multiple hundreds of euros range.

Well, the 10 Euro/day "business class" Internet access from Swisscom 
includes free phone calls anywhere in the world.  While their 
Internet access failed, their voice service was fine.  Maybe this is 
an option instead of expensive roaming charges?

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly selected tag: ---------------
Most of our so-called reasoning consists in finding arguments for going
on believing as we already do.                  --James Harvey Robinson

---

From: Eric Burger <[email-masked]>
Date: Thu, 29 Jul 2010 17:00:04 +0200

What is the rationale for the IETF to organize 3G service? OTOH, if you know a 3G provider that wants to sponsor the meeting, we would gladly let them hand out free or reduced price 3G cards. Kind of like prior IETFs where some equipment manufactures were giving away or subsidizing 802.11b cards.

---

From: Geert Jan de Groot <[email-masked]>
Date: Thu, 29 Jul 2010 18:42:51 +0200

> > I think you concentrate better than I do.   It's generally difficult to fin
d a place in the venue where you can sit and work in silence.

Try the MECCCafe which is behind the white door at the terminal room.
temp is not ideal but with few folk it might work for you.

Geert Jan

---

From: Ted Lemon <[email-masked]>
Date: Thu, 29 Jul 2010 10:13:22 -0700

> temp is not ideal but with few folk it might work for you.

I would like to thank everyone for their advice on where to sit in the venue. I am afraid I gave a plausible reason for wanting to sit elsewhere than the venue, and I shouldn't have.  The goal for me is to have a reliable network connection (one that supports ssh, smtp, imap, and every other protocol in use, not just www, and not barely limping along under a crushing load) in my hotel room, not to find a place in the venue that has good internet and shares some qualities in common with my hotel room.  Based on the complaints about the hotel network before its heroic rescue, I do not think I am alone in this.  It is by no means the IETF's obligation to solve this problem for me.   However, this is the specific problem for which I am proposing prearranged sim cards as a solution.

---

From: <[email-masked]>
Date: Fri, 30 Jul 2010 12:17:22 +0200

Dear Randall,

>an option instead of expensive roaming charges?

Pity that the main meeting hotel's internet access failed this time. But when it works, the cost issue indeed diminshes. This is how it worked for me this week:
- MECC, any capacity and media I want - FREE
- Hotel room, any capacity I _need_ for my work, (incl. VoIP) - FREE
- Navigation to and at Maastricht - affordable ( <5 kb for GPS assistance data)
- Multimedia messages & SMS - affordable (a few euros to send home some SMSs and pictures)
- Voice calls outside of MECC or Hotel - Expensive

- Working over cellular connectivity outside of hotel and MECC - VERY EXPENSIVE 

Yes, it would be nice to work outdoors in the shadow of an apple tree. And now we all know even better places with tables in the old town pedestrian area ;-)

But that's where the meter starts ticking too fast for me. Being const conscious forces us to usage patterns we might not choose otherwise, but I don't think the price of connectivity stops or even slows down our work.

Parking at MECC was expensive at 9.50 a day, but driving was my own choice, so I have got myself to blame for that.

BR,
Hannu Hietalahti
3GPP TSG CT Chairman
tel: +358 40 5021724