Subject: [78attendees] Pictures from the social event

From: Vinayak Hegde <[email-masked]>
Date: Wed, 28 Jul 2010 13:36:59 +0530

The pictures from the social event (which was fantastic) are up on the
site http://www.ietf78.nl/social-event/photos.html

Is there an option to download them all at once rather than use the
kludged interface to browse them.

Also is this okay to use on a blog ? What license are the pictures
under ? if that is not decided I would suggest one of the CC licenses
(http://creativecommons.org/about/licenses) - more specifically the CC
by-sa

-- Vin

---

From: Marco Davids <[email-masked]>
Date: Wed, 28 Jul 2010 10:51:49 +0200

> kludged interface to browse them.

We are looking in the possibilities for that - stay tuned.

> Also is this okay to use on a blog ? 

Yes, it has been confirmed that there is no copyright on the pictures.
Use them as you please.

Regards,

--
Marco

> What license are the pictures

---

From: Loiseau lucien <[email-masked]>
Date: Wed, 28 Jul 2010 11:11:20 +0200

i'm not sure if we are allowed to do that (but that's reduced size
anyway) but you can get them all here :

http://www.foto-preview.com/albums/6037_3bgs37fguiu4ijn706z64/

and download on your computer with the following shell command :

wget -r -l1 http://www.foto-preview.com/albums/6037_3bgs37fguiu4ijn706z64/

(sorry for duplicated message if so)

On Wed, Jul 28, 2010 at 10:06 AM, Vinayak Hegde <[email-masked]> wrote:
> _______________________________________________
> 78attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/78attendees
>

-- 
-- Lucien Loiseau --
Public key :
http://pgp.mit.edu:11371/pks/lookup?op=get&search=0x49647148

---

From: Yaakov Stein <[email-masked]>
Date: Wed, 28 Jul 2010 12:15:25 +0300

At the social event last night I spoke with some people 
who had complained about the train connections needed to get to Maastricht, 
and with some who found that it worked well. 
Before these discussions I had thought that the problem was related to carrying luggage, 
but discovered that the concerns were more about the differences 
between connection-oriented and connectionless networking.

Plane flights are similar to MPLS or ATM. 
You set up the entire end-to-end route before taking it.
You pay for the desired quality of service (business class / economy) 
and the appropriate resources are reserved for you.
Your connections should be seamless (e.g., they transfer your luggage for you)
but, if a connection fails you have to invoke the management system and wait a long time for a reroute.

Train rides are like IP. 
You pay a flat rate to get to Maastricht. 
There are many valid ways to get there (via Utrecht, via Amsterdam Centraal, or via Rotterdam), 
and which you take is nondeterministic, depending on when you start the journey
and whether some lines are not running (due to weekends, work on the lines, etc).
The processing required at each hop may seem complex 
(arrive at platform 13, take elevator up, and then down to platform 5a),
but your best strategy is just to take the first train in the right direction that comes along 
(after all Dijkstra was Dutch). 
You can pay for a first-class DiffServ priority, 
but the difference is not very big and they don't reserve an assigned seat for you. 
Even if you accidentally get on the wrong cabin and end up in Heerlan, you just take the next train back.

It seems surprising to me that so many IETF78 participants were worried 
that the IP way of doing things may not work.

Y(J)S

---

From: Basil Dolmatov <[email-masked]>
Date: Wed, 28 Jul 2010 13:29:10 +0400

28.07.2010 13:15, Yaakov Stein пишет:

ROTFL!!!!

Thank you, very much! It is a nice projection! ;)))))

dol@

---

From: "Sprecher, Nurit (NSN - IL/Hod HaSharon)" <[email-masked]>
Date: Wed, 28 Jul 2010 11:30:41 +0200

All these will be solved when everything migrate to MPLS-TP.............

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
On Behalf Of ext Yaakov Stein
Sent: Wednesday, July 28, 2010 12:15 PM
To: [email-masked]
Subject: [78attendees] Plane flights vs. train rides = MPLS vs. IP

At the social event last night I spoke with some people 
who had complained about the train connections needed to get to
Maastricht, 
and with some who found that it worked well. 
Before these discussions I had thought that the problem was related to
carrying luggage, 
but discovered that the concerns were more about the differences 
between connection-oriented and connectionless networking.

Plane flights are similar to MPLS or ATM. 
You set up the entire end-to-end route before taking it.
You pay for the desired quality of service (business class / economy) 
and the appropriate resources are reserved for you.
Your connections should be seamless (e.g., they transfer your luggage
for you)
but, if a connection fails you have to invoke the management system and
wait a long time for a reroute.

Train rides are like IP. 
You pay a flat rate to get to Maastricht. 
There are many valid ways to get there (via Utrecht, via Amsterdam
Centraal, or via Rotterdam), 
and which you take is nondeterministic, depending on when you start the
journey
and whether some lines are not running (due to weekends, work on the
lines, etc).
The processing required at each hop may seem complex 
(arrive at platform 13, take elevator up, and then down to platform 5a),
but your best strategy is just to take the first train in the right
direction that comes along 
(after all Dijkstra was Dutch). 
You can pay for a first-class DiffServ priority, 
but the difference is not very big and they don't reserve an assigned
seat for you. 
Even if you accidentally get on the wrong cabin and end up in Heerlan,
you just take the next train back.

Y(J)S

---

From: Byron Ellacott <[email-masked]>
Date: Wed, 28 Jul 2010 11:34:23 +0200

No-one wants to be a dropped packet :-)

No problems with trains from Frankfurt here, though.

  Byron

---

From: Basil Dolmatov <[email-masked]>
Date: Wed, 28 Jul 2010 14:16:14 +0400

> No-one wants to be a dropped packet :-)

Or clipped one (in ATM) ;)

> On 28/07/2010, at 11:15 AM, Yaakov Stein<[email-masked]>  wrote:
>
>

---

From: Scott Brim <[email-masked]>
Date: Wed, 28 Jul 2010 13:07:02 +0200

Excellent.  Only one difference: you can be very sure another train will 
arrive before you "time out" and die.

---

From: Bob Hinden <[email-masked]>
Date: Wed, 28 Jul 2010 13:28:46 +0200

Yaakov,

> Even if you accidentally get on the wrong cabin and end up in Heerlan, you just take the next train back.

I tend to disagree about the use of diffserv in your descriptions.  I learned a long time ago about diffserv while waiting for a delayed for a delayed flight.  The people in first class were going to get to our destination city at the same time as the economy passengers.  We were all delayed equally.  

Also, changes planes in an airport like Heathrow or Frankfurt is very similar (or even worse) to changing trains.

Bob

---

From: "J.D. Falk" <[email-masked]>
Date: Wed, 28 Jul 2010 13:36:05 +0200

On Jul 28, 2010, at 1:07 PM, Scott Brim wrote:

> Excellent.  Only one difference: you can be very sure another train will arrive before you "time out" and die.

Given my limited understanding of the local train networks and my extremely limited ability to read Flemish, I was not so sure while standing on the platform just a few days ago.

But perhaps that was user error.

---

From: Simon Perreault <[email-masked]>
Date: Wed, 28 Jul 2010 13:46:48 +0200

Bob Hinden wrote, on 07/28/2010 01:28 PM:
> I tend to disagree about the use of diffserv in your descriptions.  I learned
> a long time ago about diffserv while waiting for a delayed for a delayed
> flight.  The people in first class were going to get to our destination city
> at the same time as the economy passengers.  We were all delayed equally.

Ah yes but they were packets in transit. Serialization time is the same for all
packets. The difference happens at congestion points, i.e. at the airports when
a flight is missed, first-class and elite passengers get priority treatment for
rerouting and will arrive quicker.

I really like this analogy!

Simon
-- 
NAT64/DNS64 open-source --> http://ecdysis.viagenie.ca
STUN/TURN server        --> http://numb.viagenie.ca
vCard 4.0               --> http://www.vcarddav.org

---

From: Joel Jaeggli <[email-masked]>
Date: Wed, 28 Jul 2010 13:52:17 +0200

> rerouting and will arrive quicker.

You can use RED to decrease the pressure on the queue fairly.

---

From: Scott Brim <[email-masked]>
Date: Wed, 28 Jul 2010 13:57:39 +0200

> You can use RED to decrease the pressure on the queue fairly.

If only individual participants were packets in flows.

---

From: David R Oran <[email-masked]>
Date: Wed, 28 Jul 2010 13:58:19 +0200

> You can use RED to decrease the pressure on the queue fairly.
Ah, perhaps we could enhance RED to pay the discarded packets for accommodation later when the link becomes less loaded.

---

From: Randy Bush <[email-masked]>
Date: Wed, 28 Jul 2010 14:07:14 +0200

> If only individual participants were packets in flows.

with the new net infrastructure, we are only conducting human subject
research below the back stairs in the hotel lobby.

randy

---

From: Yaakov Stein <[email-masked]>
Date: Wed, 28 Jul 2010 15:59:07 +0300

> I tend to disagree about the use of diffserv in your descriptions.  
> I learned a long time ago about diffserv while waiting for a delayed for a delayed flight.  
> The people in first class were going to get to our destination city at the same time as the economy passengers.  
> We were all delayed equally.  

In my experience, packets (sorry, passengers) marked "gold" get the first places on the next flight out.
They are thus delayed less.

> Also, changes planes in an airport like Heathrow or Frankfurt is very similar (or even worse) to changing trains.

Perhaps they were designed by people who previously designed train stations.
Similar to early LSRs that were software upgrades of previous routers,
and actually forwarded MPLS slower than IP!

Y(J)S

---

From: Scott Brim <[email-masked]>
Date: Wed, 28 Jul 2010 15:02:21 +0200

On 07/28/2010 14:59 GMT+02:00, Yaakov Stein wrote:
>
>> Also, changes planes in an airport like Heathrow or Frankfurt is
>> very similar (or even worse) to changing trains.
>
> Perhaps they were designed by people who previously designed train

I heard that a railroad operator said that when it comes to congestion, 
air travel has it backwards.  Trains share very few tracks between 
stations, and lots of tracks when they arrive.  Planes do the opposite.

> stations. Similar to early LSRs that were software upgrades of
> previous routers, and actually forwarded MPLS slower than IP!

:-)

---

From: Dave Thaler <[email-masked]>
Date: Wed, 28 Jul 2010 14:39:23 +0000

> On Behalf Of Simon Perreault
> Sent: Wednesday, July 28, 2010 1:47 PM
> To: [email-masked]
> Subject: Re: [78attendees] Plane flights vs. train rides = MPLS vs. IP
> 
> > I tend to disagree about the use of diffserv in your descriptions.  I
> > learned a long time ago about diffserv while waiting for a delayed for
> > a delayed flight.  The people in first class were going to get to our
> > destination city at the same time as the economy passengers.  We were all
> delayed equally.
> 
> packets. The difference happens at congestion points, i.e. at the airports when a
> flight is missed, first-class and elite passengers get priority treatment for

Don't push the analogy too far...
Just try to encapsulate "IP" in "MPLS", or vice versa... :)

-Dave

---

From: Andrew McGregor <[email-masked]>
Date: Wed, 28 Jul 2010 16:46:05 +0200

> Just try to encapsulate "IP" in "MPLS", or vice versa... :)

http://www.historyofaircargo.com/i-Train-takes-the-plane-or-the-plane-takes.html

---

From: Dave Thaler <[email-masked]>
Date: Wed, 28 Jul 2010 15:04:00 +0000

> From: Andrew McGregor [mailto:[email-masked]]
> Sent: Wednesday, July 28, 2010 4:46 PM
> To: Dave Thaler
> Cc: Simon Perreault; [email-masked]

Ah but that doesn't seem to have carried any passengers.
So apparently you can only do IP-in-MPLS if your IP packet 
has No-Next-Header :)

-Dave