Subject: [78attendees] A few clarifications on the NH network

From: Jim Martin <[email-masked]>
Date: Wed, 28 Jul 2010 10:57:46 +0200

In an act of barely constrained insanity, last night the IETF NOC team took over the wireless network in the NH, with the consent of the NH Management, and astoundingly good support from Swisscom. There is a long saga, best told over beer, on how it all happened, but let it just be said that it included a "creative" run from the MECC, an emergency equipment delivery from Utrecht at 2am, learning a completely new wireless system, and a team that just wouldn't quit. They finished at about 7 this morning. 

	Our goal was to send out just an IETF ssid, with the wireless system acting as a simple bridge, so we could provide public v4 addressing and IPv6. Alas, their smart system was far too smart for that, and as the sun came up, the pragmatic decision was made to keep the NAT and the original "Swisscom" SSID, so long as we could substitute our uplink, get rid of the logon pages, and remove all the bandwidth restrictions. 

	So, as it stands, you'll see the same swisscom ssids as before, with RFC1918 IPv4 space only, but it'll go out over the IETF net at 100M using a new upgraded wireless controller. No charges are involved, and nothing other than DNS should be being proxied.  Those who bought a 7-day pass from Swisscom should talk to the front desk about the possibility of a refund. 

	The original controller and uplink will be put back in service mid-afernoon on Friday, as we need to tear out the IETF network. Hopefully it will hold up for the few of us remaining over the weekend. 

	Please join me in thanking everyone involved in this project. The NH staff who facilitated the change, the Swisscom NOC that not only helped, but rousted someone out of bed to bring us new hardware, and most importantly the IETF NOC engineers that worked all night, Chris Elliott,  Bill Jensen, and Geert Jan de Groot.

	Enjoy it, but treat it gently ... I'm not sure we have a plan C ;-)

	- Jim

---

From: Bob Hinden <[email-masked]>
Date: Wed, 28 Jul 2010 11:08:51 +0200

Jim,

Kudos to the NOC team for taking the initiative to make this happen!  It's very appreciated by everyone staying at the NH.

Bob

On Jul 28, 2010, at 10:57 AM, Jim Martin wrote:

> _______________________________________________
> 78attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/78attendees

---

From: "Joel M. Halpern" <[email-masked]>
Date: Wed, 28 Jul 2010 05:23:38 -0400

Thank you VERY much!
Joel

Jim Martin wrote:
> ------------------------------------------------------------------------
>

---

From: Ray Bellis <[email-masked]>
Date: Wed, 28 Jul 2010 09:46:55 +0000

> Kudos to the NOC team for taking the initiative to make this happen!  It's very appreciated by everyone staying at the NH.

+1 (at least!)

Ray

---

From: John C Klensin <[email-masked]>
Date: Wed, 28 Jul 2010 06:26:19 -0400

+++++ (large number)

--On Wednesday, 28 July, 2010 11:08 +0200 Bob Hinden
<[email-masked]> wrote:

> Jim,
> 
> Kudos to the NOC team for taking the initiative to make this
> happen!  It's very appreciated by everyone staying at the NH.
> 
> Bob
> 
>> 	In an act of barely constrained insanity, last night the
>> 	IETF NOC team took over the wireless network in the NH, with
>> 	the consent of the NH Management, and astoundingly good
>> 	support from Swisscom. There is a long saga, best told over
>> 	beer, on how it all happened, but let it just be said that
>> 	it included a "creative" run from the MECC, an emergency
>> 	equipment delivery from Utrecht at 2am, learning a
>> 	completely new wireless system, and a team that just
>> 	wouldn't quit. They finished at about 7 this morning. 
>> 
>> 	Our goal was to send out just an IETF ssid, with the
>> 	wireless system acting as a simple bridge, so we could
>> 	provide public v4 addressing and IPv6. Alas, their smart
>> 	system was far too smart for that, and as the sun came up,
>> 	the pragmatic decision was made to keep the NAT and the
>> 	original "Swisscom" SSID, so long as we could substitute our
>> 	uplink, get rid of the logon pages, and remove all the
>> 	bandwidth restrictions. 
>> 
>> 	So, as it stands, you'll see the same swisscom ssids as
>> 	before, with RFC1918 IPv4 space only, but it'll go out over
>> 	the IETF net at 100M using a new upgraded wireless
>> 	controller. No charges are involved, and nothing other than
>> 	DNS should be being proxied.  Those who bought a 7-day pass
>> 	from Swisscom should talk to the front desk about the
>> 	possibility of a refund. 
>> 
>> 	The original controller and uplink will be put back in
>> 	service mid-afernoon on Friday, as we need to tear out the
>> 	IETF network. Hopefully it will hold up for the few of us
>> 	remaining over the weekend. 
>> 
>> 	Please join me in thanking everyone involved in this
>> 	project. The NH staff who facilitated the change, the
>> 	Swisscom NOC that not only helped, but rousted someone out
>> 	of bed to bring us new hardware, and most importantly the
>> 	IETF NOC engineers that worked all night, Chris Elliott,
>> 	Bill Jensen, and Geert Jan de Groot.
>>

---

From: Wes Hardaker <[email-masked]>
Date: Wed, 28 Jul 2010 03:59:51 -0700

>>>>> On Wed, 28 Jul 2010 10:57:46 +0200, Jim Martin <[email-masked]> said:

JM> In an act of barely constrained insanity, last night the IETF NOC
JM> team took over the wireless network in the NH, with the consent of
JM> the NH Management, and astoundingly good support from
JM> Swisscom.

Sometimes I wonder what the conversations are like in the hotels and
venues after we leave.  The technical staff in the places we depart from
must just stand around afterward and say things like "Boy, I wish we
could be more like them" and "Boy, our infrastructure sucks" and "I sure
wish they could have stayed longer".

Kudos to everyone involved in making the rest of the week doable!  Maybe
I actually can get something accomplished in the hotel room this week.
And more importantly, it'll actually add more time-slots to my life for
talking with my family back home (over the net) which has been hard this
week so far because of the lack of a network in the hotel.  This last
item is, by far, the most important to me and the one I'm most
appreciative for!  Thank you!
-- 
Wes Hardaker
Cobham Analytic Solutions

---

From: Samuel Weiler <[email-masked]>
Date: Wed, 28 Jul 2010 07:05:24 -0400 (EDT)

I want to highlight a few things:

> ... with the consent of the NH Management, and astoundingly good 
> support from Swisscom. ... an emergency equipment
> delivery from Utrecht at 2am ...

> ... the Swisscom NOC that not only helped, but rousted someone out 
> of bed to bring us new hardware,

I'm astounded at the level of cooperation the NOC got in making this 
happen.  Kudos to the NH management and Swisscom.

And thanks to the NOC.

-- Sam

---

From: Randy Bush <[email-masked]>
Date: Wed, 28 Jul 2010 13:17:22 +0200

> wish they could have stayed longer".

more likely "normal conference attendees want alcohol, where the drugs
girls/boys, and rock and roll are, etc.  these idiots wanted internet.
sheesh!"

randy

---

From: Wes Hardaker <[email-masked]>
Date: Wed, 28 Jul 2010 04:41:29 -0700

>>>>> On Wed, 28 Jul 2010 13:17:22 +0200, Randy Bush <[email-masked]> said:

>> wish they could have stayed longer".

RB> more likely "normal conference attendees want alcohol, where the drugs
RB> girls/boys, and rock and roll are, etc.  these idiots wanted internet.
RB> sheesh!"

After I sent that I realized I should have added "What the heck is IPv6?"
-- 
Wes Hardaker
Cobham Analytic Solutions

---

From: Randall Gellens <[email-masked]>
Date: Wed, 28 Jul 2010 05:20:31 -0700

At 10:57 AM +0200 7/28/10, Jim Martin wrote:

>  	So, as it stands, you'll see the same swisscom ssids as before, 
> with RFC1918 IPv4 space only, but it'll go out over the IETF net at 
> 100M using a new upgraded wireless controller. No charges are 
> involved, and nothing other than DNS should be being proxied. 
> Those who bought a 7-day pass from Swisscom should talk to the 
> front desk about the possibility of a refund.

Wow!  This sounds amazing.

Oddly, I have not been able to complete VPN negotiations in the hotel 
network since early morning today (I was able to do so prior).  Also, 
I have still gotten the Swisscom authenticate page.  Previously, in 
response to my complaints about being dropped continuously, Swisscom 
did something to theoretically permanently authenticate my laptop by 
MAC address.  I wonder if this is overriding the use of the IETF 
network?

>  	Please join me in thanking everyone involved in this project. The 
> NH staff who facilitated the change, the Swisscom NOC that not only 
> helped, but rousted someone out of bed to bring us new hardware, 
> and most importantly the IETF NOC engineers that worked all night, 
> Chris Elliott,  Bill Jensen, and Geert Jan de Groot.

Thank you!  I'm sure everyone at the NG hotel is very grateful for so 
much hard work.

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly selected tag: ---------------
The forceps of our mind are clumsy things and crush the truth a little
in the course of taking hold of it.
    --H.G. Wells

---

From: Randall Gellens <[email-masked]>
Date: Wed, 28 Jul 2010 05:22:27 -0700

At 3:59 AM -0700 7/28/10, Wes Hardaker wrote:

>  appreciative for!

If you bought the Swisscom "business class" service, it includes free 
phone calls to anywhere in the world.  Unlike their IP network, this 
has worked fine.

-------------- Randomly selected tag: ---------------
!!!!!CP MBI na ni deppart m'I  !pleH

---

From: Jim Martin <[email-masked]>
Date: Wed, 28 Jul 2010 16:25:46 +0200

Just a quick update: It seems the storm going through right now and the ethernet run between the Hotel and the MECC don't seem to get along. The Hotel is currently down, and there a team working on restoring service. Sorry for the outage. More updates as I get them....

	So sit, enjoy the plenary ...

	- JIm

---

From: Jim Martin <[email-masked]>
Date: Wed, 28 Jul 2010 17:53:21 +0200

> 	Just a quick update: It seems the storm going through right now and the ethernet run between the Hotel and the MECC don't seem to get along. The Hotel is currently down, and there a team working o…

	Ok, we're back up and connected to the hotel. The root cause of the failure seems to be a bad port on one of our switches and a bit of physical damage to the ethernet cable between the buildings. The port failure may be due to a spill from the serving staff. We've reterminated the cable (the damage was close to the end) and moved to a clean port, and the link looks solid. We'll continue to monitor the connection.

	Sorry for the outage!

	-Jim

---

From: [email-masked]
Date: Wed, 28 Jul 2010 23:01:21 +0200 (CEST)

I relay this message from a Swisscom Employee who was involved in the NH
issue (he is not subscribed to the list, I just forwarded the mails
regarding the network problems as well as the reactions to the solution to
them)

-- begin relayed message ----

Thanks Jim for sharing - I am glad to know that the customer is happy.

The beginning of the story went a bit chaotic.
but after the understanding of what we needed... we unleashed our best
resources to meet the customer need ;-)
I am at your disposal, Matteo.

-- end relayed message ----

> 	In an act of barely constrained insanity, last night the IETF NOC team
> took over the wireless network in the NH, with the consent of the NH
> Management, and astoundingly good support from Swisscom. There is a long
> saga, best told over beer, on how it all happened, but let it just be
> said that it included a "creative" run from the MECC, an emergency
> equipment delivery from Utrecht at 2am, learning a completely new
> wireless system, and a team that just wouldn't quit. They finished at
> about 7 this morning.
>
> 	Our goal was to send out just an IETF ssid, with the wireless system
> acting as a simple bridge, so we could provide public v4 addressing and
> IPv6. Alas, their smart system was far too smart for that, and as the sun
> came up, the pragmatic decision was made to keep the NAT and the original
> "Swisscom" SSID, so long as we could substitute our uplink, get rid of
> the logon pages, and remove all the bandwidth restrictions.
>
> 	So, as it stands, you'll see the same swisscom ssids as before, with
> RFC1918 IPv4 space only, but it'll go out over the IETF net at 100M using
> a new upgraded wireless controller. No charges are involved, and nothing
> other than DNS should be being proxied.  Those who bought a 7-day pass
> from Swisscom should talk to the front desk about the possibility of a
> refund.
>
> 	The original controller and uplink will be put back in service
> mid-afernoon on Friday, as we need to tear out the IETF network.
> Hopefully it will hold up for the few of us remaining over the weekend.
>
> 	Please join me in thanking everyone involved in this project. The NH
> staff who facilitated the change, the Swisscom NOC that not only helped,
> but rousted someone out of bed to bring us new hardware, and most
> importantly the IETF NOC engineers that worked all night, Chris Elliott,

---

From: [email-masked]
Date: Wed, 28 Jul 2010 23:04:10 +0200 (CEST)

Matteo is the NOC Manager Europe. Forgot to mention that, sorry :-)

---

From: Geoff Mulligan <[email-masked]>
Date: Wed, 28 Jul 2010 15:05:19 -0600

This was a really nice offer.  I suppose that lots of people are using
        the service, 'cause now the service via the KPN Hotspot (van der
        valk) in my hotel is
        abysmally slow.  It wasn't before this.
        
                geoff
        
        On Tue, 2010-07-27 at 07:38 -0700, Alexa Morris wrote:
        > XS4ALL Internet BV and KPN Hotspots is generously offering
        free access  
        > to KPN hotspots throughout The Netherlands for the remainder
        of the  
        > week, until Saturday.
        > 
        > They want you to be aware that this is a best effort service,
        meaning:
        > 
        > - they have never tested to the number of attendees we've got
        (1200)  
        > so things might break
        > - most hotspots are connected via ADSL, bandwidth per node can
        vary  
        > and will not exceed 20 megabit/s
        > - this is a group account, in case of abuse or misbehavior
        they will  
        > have to pull access for all of you so please don't spoil the
        party and  
        > run proper anti-virus software and do anything bad.
        > 
        > To login:
        > 
        > 1) Find a KPN hotspot in Maastricht
        > Google map of Maastricht here:
        http://maps.google.com/maps/ms?ie=UTF&msa=0&msid=108447039853577572764.00048c5ecc989f167224a 
        > . And a list of individual hot spots is found at the bottom of
        the  
        > email.
        > 
        > 2) Join the wireless named 'KPN'
        > 
        > 3) Point your browser to any page, this will redirect to a
        portal
        > 
        > 4) On the portal page, login with the following credentials
        > 
        >       access number:   16740
        >       access code:         GHAEKB
        > 
        > And push the login button. [Note, these credentials are also
        posted on  
        > the Google map page]
        > 
        > This is a group account so you will now be redirected to a
        seond  
        > portal asking you for your name, this is an optional step so
        other  
        > people might be able to locate you. (It is recommended that
        you use  
        > this with care, as they are not sure how the portal will
        behave with  
        > such a large numbers of users.) As soon as you are asked for
        your  
        > name, you should be able to access the internet.
        > 
        > If you need any support assistance, please send email to
        Marco  
        > Hogewoning at [email-masked], or the 78 attendees list.
        Please do  
        > not bombard the XS4ALL support desk with calls, as they have
        never  
        > handled a group as big as the IETF.
        > 
        > Thank you very much to XS4ALL Internet and KPN for offering
        this free  
        > internet access to IETF 78 attendees!
        > 
        > -Alexa
        > 
        > -----------
        > Alexa Morris / Executive Director / IETF
        > 48377 Fremont Blvd., Suite 117, Fremont, CA  94538
        > Phone: +1.510.492.4089 / Fax: +1.510.492.4001
        > Email: [email-masked]
        > 
        > Managed by Association Management Solutions (AMS)
        > Forum Management, Meeting and Event Planning
        > www.amsl.com <http://www.amsl.com/>
        > 
        > 78all mailing list
        > [email-masked]
        > https://www.ietf.org/mailman/listinfo/78all

---

From: Chris Morrow <[email-masked]>
Date: Wed, 28 Jul 2010 17:19:07 -0400

> Matteo is the NOC Manager Europe. Forgot to mention that, sorry :-)

does knowing him, and informing him of future locations maybe mean we
can better plan the next EMEA hotel experience? :) can we get
locations/hotels (if they are swisscom serviced) to Matteo before we
get there, with enough time to plan proper connectivity or
collaboration with the IETF NOC folk?

(note that as the original poster of the 'swisscom fail' messages I do
owe the IETF + swisscom NOC  folks some kudos, I'll do that in a few
on the original thread)

-chris

---

From: Arnoud van Wijk <[email-masked]>
Date: Wed, 28 Jul 2010 23:48:10 +0200

Yes...the hotspot at van der valk is now at 23:43 abysmally slow still! 
It is clearly an ADSL connected hotspot.
I paid for 1 week though :-(..
Is there a procedure for us to get the hotspot fee (partly) refunded? 
Not that I am counting on it..we are Dutch after all :-)

And I still say that it is a very nice action from XS4All. The gesture 
is very much appreciated.

/Arnoud

On 28-7-2010 23:05, Geoff Mulligan wrote:
>          >  www.amsl.com<http://www.amsl.com/>
>          >

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Thu, 29 Jul 2010 00:28:47 -0700

> -----Original Message-----
> From: [email-masked] [mailto:78attendees-
> [email-masked]] On Behalf Of Jim Martin
> Sent: Wednesday, July 28, 2010 1:58 AM
> To: [email-masked]
> Subject: [78attendees] A few clarifications on the NH network
> 
> 100M using a new upgraded wireless controller. No charges are involved,
> and nothing other than DNS should be being proxied.  Those who bought a
> 7-day pass from Swisscom should talk to the front desk about the
> possibility of a refund.

Three cheers for the NOC team!  That's outstanding.  And I really do need to get a photo of the orange CAT-5 running to the hotel, reminiscent of a giant extension cord.

Has anyone had success getting that refund from the NH?  I think I paid Swisscom directly through the web site, not through the hotel, so that seems unlikely to work...

---

From: Randall Gellens <[email-masked]>
Date: Thu, 29 Jul 2010 05:32:21 -0700

At 12:28 AM -0700 7/29/10, Murray S. Kucherawy wrote:

>  Three cheers for the NOC team!  That's outstanding.

Indeed, they have the extreme gratitude of a huge number of 
Internet-starved geeks.

>    And I really do need to get a photo of the orange CAT-5 running 
> to the hotel, reminiscent of a giant extension cord.

Please send the photo to this list.

>  Has anyone had success getting that refund from the NH?  I think I 
> paid Swisscom directly through the web site, not through the hotel, 
> so that seems unlikely to work...

Several of us have had success calling the Swisscom helpline.

-------------- Randomly selected tag: ---------------
Computers are not intelligent.  They only think they are.