Subject: [79attendees] For Dutch colleagues : visa

From: Olaf Kolkman <[email-masked]>
Date: Thu, 14 Oct 2010 12:41:37 +0200

Relevant for Dutch only. 

The lines at the embassy are so long that the visaburos don't process Chinese visas and you have to go yourself. 

If you still need to get your visa: Make sure you are at the embassy early (around 7) the door closes at 12. I technically did not make it after a 4 hrs wait. 

(technically, because the guy in front of me who made it in kindly took a few passes in. I'll let you know whether I am going to regret that opportunism. )

Sent from my iPhone

---

From: Elisa Jasinska <[email-masked]>
Date: Thu, 14 Oct 2010 12:48:54 +0200

Hi Olaf,

> The lines at the embassy are so long that the visaburos don't process Chinese visas and you have to go yourself. 

I ran into one visa service in Amsterdam refusing to process it, but those guys still do: http://cibt.nl/ (probably too late for you now).

Cheers
Elisa