Subject: [79attendees] Visa handlers for the US

From: Paul Hoffman <[email-masked]>
Date: Sun, 3 Oct 2010 13:57:51 -0700

Greetings again. IETF 79 is the first time in a long time that US IETFers have had to get a visa for an IETF meeting. I just used A Briggs <http://www.abriggs.com/> successfully. They answered questions well (particularly about "tourist" vs. "business"), didn't seem expensive, and had lots of other positive reviews. Also, the instructions on their site for what they needed to process a Chinese visa application showed much more attention to detail than others I saw.

--Paul Hoffman, Director
--VPN Consortium

---

From: Ed Jankiewicz <[email-masked]>
Date: Wed, 06 Oct 2010 10:21:06 -0400

I've had a good experience so far (application and submission - still 
waiting for the actual return of the visa) with CIBT.  Personal 
attention and follow-up.  http://www.us.cibt.com/

they have offices in USA, Canada, Australia and several European locations.

On 10/3/2010 4:57 PM, Paul Hoffman wrote:
> Greetings again. IETF 79 is the first time in a long time that US IETFers have had to get a visa for an IETF meeting. I just used A Briggs<http://www.abriggs.com/>  successfully. They answered questions well (particularly about "tourist" vs. "business"), didn't seem expensive, and had lots of other positive reviews. Also, the instructions on their site for what they needed to process a Chinese visa application showed much more attention to detail than others I saw.
>
> --Paul Hoffman, Director
> --VPN Consortium
> _______________________________________________
> 79attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/79attendees

-- 
Ed Jankiewicz - SRI International
Fort Monmouth Branch Office - IPv6 Research
Supporting DISA Standards Engineering Branch
732-389-1003 or  [email-masked]

---

From: Shane Amante <[email-masked]>
Date: Wed, 6 Oct 2010 09:13:34 -0600

On Oct 6, 2010, at 08:21 MDT, Ed Jankiewicz wrote:
> I've had a good experience so far (application and submission - still waiting for the actual return of the visa) with CIBT.  Personal attention and follow-up.  http://www.us.cibt.com/
> 

FWIW, I've also had good experience with CIBT.  I submitted my application to them on 9/22/2010 and just received my visa + passport yesterday: ~2 week turnaround.

-shane

---

From: "Frankel, Sheila E." <[email-masked]>
Date: Wed, 6 Oct 2010 11:44:42 -0400

Has anyone tried applying for a visa yourself by visiting the embassy?

Sheila Frankel
________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Ed Jankiewicz [[email-masked]]
Sent: Wednesday, October 06, 2010 10:21 AM
To: [email-masked]
Subject: Re: [79attendees] Visa handlers for the US (and elsewhere)

---

From: Andrew Sullivan <[email-masked]>
Date: Wed, 6 Oct 2010 11:59:40 -0400

> Has anyone tried applying for a visa yourself by visiting the embassy?

I needed my passport back and couldn't wait for a service, so I went
directly to the Chinese Consulate in Toronto.  I don't know about
other places, but the processing went fairly smoothly there (but I
spent a lot of time in lines).  I applied on a Monday, and received my
passport on Wednesday (but I had to pay a fee for this).  If I could
have gone back on Thursday instead, I would not have needed to pay the
extra fee.

A
-- 
Andrew Sullivan
[email-masked]
Shinkuro, Inc.

---

From: Fred Baker <[email-masked]>
Date: Wed, 6 Oct 2010 12:04:44 -0400

> Has anyone tried applying for a visa yourself by visiting the embassy?

yes, if "consulate" is an acceptable alternative. It takes the same amount of time - about a week, and money makes it go faster. It does in fact work.

---

From: "George, Wes E IV [NTK]" <[email-masked]>
Date: Wed, 6 Oct 2010 12:55:15 -0500

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Frankel, Sheila E.
Sent: Wednesday, October 06, 2010 11:45 AM
To: [email-masked]
Subject: Re: [79attendees] Visa handlers for the US (and elsewhere)

[[WEG]] yes, thus far unsuccessfully, but this was because the embassy in DC posted (on 9/24!) that they would be closed on 9/30 and 10/1 in observance of China's national day (10/1), and that was the day I had planned to already be in downtown DC and go to the visa office. Fortunately I checked *before* I headed to the office, so there was no wasted trip.
Moral of the story, visit the website before going to make sure you know the hours.

I have colleagues that have had better luck, so if you're near an embassy, certainly it's an option, I'm mainly annoyed that this was posted so late - it's not like they didn't know when National Day would be more than 6 days in advance...

Wes George

This e-mail may contain Sprint Nextel proprietary information intended for the sole use of the recipient(s). Any use by others is prohibited. If you are not the intended recipient, please contact the sender and delete all copies of the message.

---

From: Olafur Gudmundsson <[email-masked]>
Date: Wed, 06 Oct 2010 13:59:30 -0400

> Has anyone tried applying for a visa yourself by visiting the embassy?

Dropped the passport off two weeks ago, was ready a week later.

Walked in at 11:50 was out the door at 12:10, that included 5 minutes of 
the whole staff ogling my new Icelandic passport as this was the first 
time they saw one :-)

A co-worker tried to submit a passport on Monday but faced with 2.5 hour 
wait he left.
Yesterday he arrived at 10:00 and waited about an hour to submit the 
passport (and picked up mine while waiting).

	Olafur

---

From: Warren Kumari <[email-masked]>
Date: Wed, 6 Oct 2010 12:02:12 -0700

Yes....

I went down to the DC embassy, arrived around 11:00am - Took a number, waited maybe 15 minutes to be called...
Went up to the window, had all of the paperwork ready, double-checked, in a sane order, etc.

Person at window said that visa would be ready next day -- I asked if it could be mailed back to me because getting into the city was tricky... She offered to expedite it, and that it would be ready by 2:30pm the same day.... 
Went across the road, grabbed some lunch, got back at 2:25pm, waited 5 minutes and walked out the door with a shiny new visa..

Everyone was helpful, efficient and polite -- one of the best embassy / consulate / visa experiences I've ever had...

A++, would buy from again, etc... 
W

---

From: Ed Jankiewicz <[email-masked]>
Date: Wed, 06 Oct 2010 15:19:46 -0400

YMMV.

It sounds like if you are close to a city center where there is an 
embassy or consulate office, you can save the fee from the visa agent.  
As it would take me at least 4 hours round trip into NYC, I'd rather 
write a check.  Definitely a time v. money trade-off.

Wherever you go, check your list of requirements twice and make sure you 
have everything you need.  I had to follow-up with something missing 
before CIBT could submit my package.  If I had trucked into NYC only to 
find I was missing something I would have wasted a day.

Good luck, and see you in Beijing!

---

From: Ole Jacobsen <[email-masked]>
Date: Wed, 6 Oct 2010 12:44:00 -0700 (PDT)

And in case you are wondering: There is only ONE embassy of <country 
X> in and <country Y>. It usually resides in <country Y>'s capital,
which for the US is Washington, DC. The other offices are called 
consulates. Many have their own websites, for example in San Francisco:

http://www.chinaconsulatesf.org/eng/

... which seems to be unreachable from where I am right now (Atlanta),
but it normally has lots of good info. Note in particular the hours
of operation. The place closes at 3pm, worth keeping in mind when you
are picking up your passport. They are also closed for lunch for a 
hour. Normal processing time 4 days.

Ole

Ole J. Jacobsen
Editor and Publisher,  The Internet Protocol Journal
Cisco Systems
Tel: +1 408-527-8972   Mobile: +1 415-370-4628
E-mail: [email-masked]  URL: http://www.cisco.com/ipj

On Wed, 6 Oct 2010, Ed Jankiewicz wrote:

>  YMMV.
> 
> It sounds like if you are close to a city center where there is an embassy or
> consulate office, you can save the fee from the visa agent.  As it would take
> me at least 4 hours round trip into NYC, I'd rather write a check.  Definitely
> a time v. money trade-off.
> 
> Wherever you go, check your list of requirements twice and make sure you have
> everything you need.  I had to follow-up with something missing before CIBT
> could submit my package.  If I had trucked into NYC only to find I was missing
> something I would have wasted a day.
> 
> > Person at window said that visa would be ready next day -- I asked if it
> > could be mailed back to me because getting into the city was tricky... She
> > offered to expedite it, and that it would be ready by 2:30pm the same
> > day....
> > Went across the road, grabbed some lunch, got back at 2:25pm, waited 5
> > minutes and walked out the door with a shiny new visa..
> >
> > Everyone was helpful, efficient and polite -- one of the best embassy /
> > consulate / visa experiences I've ever had...
> >
> > > From: [email-masked] [[email-masked]] On
> > > Behalf Of Ed Jankiewicz [[email-masked]]

---

From: Michael StJohns <[email-masked]>
Date: Wed, 06 Oct 2010 15:52:30 -0400

Dropped my package off at the Chinese Embassy Visa office on Wednesday, 
picked it up on the following Monday.  Surprisingly, ended up with a 
multiple entry 1 year business visa based on the IETF invitation letter. 
If you've got multiple people in the office going, only one needs to 
drop off/pick up - if you do all the packages at the same time.

Mike

---

From: Yi Zhao <[email-masked]>
Date: Wed, 06 Oct 2010 23:16:42 -0500

In US, you may go to the Chinese Embassy  in DC or consulates in New York,
San Francisco, LA, Chicago, or Houston in person for the visa application.
With extra $30 expedite fee, you can get the visa the same day (submit
before 12noon and receive the visa around 2pm).

Yi 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Fred Baker
Sent: Wednesday, October 06, 2010 11:05 AM
To: Frankel, Sheila E.
Cc: [email-masked]
Subject: Re: [79attendees] Visa handlers for the US (and elsewhere)

> Has anyone tried applying for a visa yourself by visiting the embassy?

yes, if "consulate" is an acceptable alternative. It takes the same amount
of time - about a week, and money makes it go faster. It does in fact work.

---

From: Ed Jankiewicz <[email-masked]>
Date: Fri, 15 Oct 2010 19:22:53 -0400

to close the loop, our passports with visas were returned today, 
promptly and all in order.  About 8 day turnaround with no special 
handling, so if you have procrastinated, time to get moving or pay the 
expedite fees.

see you in Beijing!

On 10/6/2010 10:21 AM, Ed Jankiewicz wrote:
>> Greetings again. IETF 79 is the first time in a long time that US 
>> IETFers have had to get a visa for an IETF meeting. I just used A 
>> Briggs<http://www.abriggs.com/>  successfully. They answered 
>> questions well (particularly about "tourist" vs. "business"), didn't 
>> seem expensive, and had lots of other positive reviews. Also, the 
>> instructions on their site for what they needed to process a Chinese 
>> visa application showed much more attention to detail than others I saw.
>>
>> --Paul Hoffman, Director
>> --VPN Consortium