Subject: [94attendees] multicast/broadcast experiment at IETF94

From: Jari Arkko <[email-masked]>
Date: Mon, 2 Nov 2015 16:09:48 +0900

In Prague we had one experiment that we wanted to run in the IETF
network but were unable to do so due to privacy concerns. The folks
behind the experiment have now redesigned their experiment to
reduce those concerns, and we plan to run it in the IETF network
from Wednesday to Thursday. The affected SSIDs are “ietf” and
“ietf-legacy”.

The experiment and background related to it described further in

http://net.hs-augsburg.de/projects/2015/10/21/ietf-broadcast-revisited.html
https://tools.ietf.org/html/draft-winfaa-broadcast-consider-01

The goal of the experiment is to see whether there is
personally identifiable information in various broadcast
and multicast packets in the IETF network. The general
arrangement is to collect broadcast and multicast traffic,
hash it in a way that allows (probabilistic) comparisons
to be made within the data. The original information
does not leave the IETF network NOC, and a salted
hashing process is setup in a manner that does not
allow tracking back to individuals. The process will
end up losing some information that humans would
be able to recognise as personally identifying
information, so the results of the experiment
will only be able to provide a lower bound on the
amount of information.

Rolf will have more detailed description of the process if
anyone is interested.

Jari Arkko

---

From: Joseph Lorenzo Hall <[email-masked]>
Date: Tue, 3 Nov 2015 09:24:03 +0900

Jari,

If we prefer to opt-out of these experiments it sounds like we should use
one of the other SSIDs?

best, Joe

-- 
Joseph Lorenzo Hall
Chief Technologist
Center for Democracy & Technology
1634 I ST NW STE 1100
Washington DC 20006-4011
(p) 202-407-8825
(f) 202-637-0968
[email-masked]
PGP: https://josephhall.org/gpg-key
fingerprint: 3CA2 8D7B 9F6D DBD3 4B10  1607 5F86 6987 40A9 A871

---

From: Jari Arkko <[email-masked]>
Date: Tue, 3 Nov 2015 09:47:04 +0900

Given the setup, do you feel there is a need to opt-out? Your data does not leave the NOC in a form where it could be reversed and traced back to you.

Jari

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 3 Nov 2015 00:59:10 +0000

Hi Joe,

> If we prefer to opt-out of these experiments it sounds like we should use

I believe that is the case, yes (hopefully someone will correct me
if that's wrong).

S

> _______________________________________________
> 94attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/94attendees
>

---

From: Benson Schliesser <[email-masked]>
Date: Tue, 3 Nov 2015 10:21:56 +0900

Hi, Joe.

I also believe that your understanding is correct - that only the broadcast
domains of those two SSIDs will be monitored - but I hope that somebody
from NOC and/or the experimenters can confirm.

In any case I'd also like to point out that:

1) The potentially sensitive (personally identifying) data gathered in this
experiment will be hashed with a salt that is discarded after collection,
effectively anonymizing it. The experiment methods have been reviewed in
the context of Germany and EU laws, where it is deemed adequately
protective of personal privacy. The laws of Japan are less stringent. But
in any case the experiment design seems to be respectful of meeting the
ethical expectations of the IETF a community.

2) The pre-processed (pre-anonymized) data being collected will merely
include the broadcast and multicast packets that all of our hosts (laptops,
phones, etc) are already seeing. The experimenters are not gathering data
from a "privileged" vantage point. One could see the same data themselves
by simply running a sniffer program... In case it's not clear, the
experiment will thus be able to point out where existing protocols and
implementations are "leaking" information.

-Benson

---

From: Joseph Lorenzo Hall <[email-masked]>
Date: Tue, 3 Nov 2015 10:44:23 +0900

Thanks very much, all.

I'm not planning to opt-out myself, but it's crucial when you notify
folks about the protections that have been built into the experiment
that you also let people know how they can decline to participate in
the experiment (without loosing all connectivity).

I think you've done a great job, and with the information about how
folks can decline to participate by joining other SSIDs the typical
research notice would be complete.

(Incidentally, if you had a way to notify people about the details of
the experiment that included opt-out instructions that was available
when they connected to the network -- e.g., something short in the
SSID itself like a URL, maybe not a freaking captive portal! -- I
don't think you'd need to do the hashing and anonymization (unless you
plan to keep the data for a very long time or share it more widely).
Research ethics is all about risk vs. reward and if the risks are
clearly explained and an opt-out available and the reward (potential
importance of the results) for the research is substantial, you can
assume more risk. The opt-out is key to this kind of balancing.)

Anyway, thanks very much for the care that you've taken and I
personally can't wait to see what you find!

best, Joe

PS: And thanks for putting up with those of us that have spent way way
way too much time in our lives thinking about ethical network research
design. These are not easy issues, but shouldn't stop us from learning
important things about our deployments!

On Tue, Nov 3, 2015 at 10:31 AM, Rolf Winter <[email-masked]> wrote:
> Hi,
>
> that is absolutely correct. Only those two SSIDs will be part of the
> experiment. So by connecting to another SSID you effectively opt out. While
> I hope most people will not opt out, I certainly understand there is no
> particular reason to trust us with this experiment. Please note however,
> that the NOC folks will connect the devices we brought to the network and
> they will remain with the NOC for the duration of the experiment and only
> connect to specially provisioned ports on a switch. Benson's description of
> our experiment is accurate and to the point, so I am not repeating the
> details of it but I am more than happy to answer further questions about the
> experiment.
>
> Best,
>
> Rolf
>
> Am 11/3/15 um 2:21 AM schrieb Benson Schliesser:
>>
>> Hi, Joe.
>>
>> I also believe that your understanding is correct - that only the
>> broadcast domains of those two SSIDs will be monitored - but I hope that
>> somebody from NOC and/or the experimenters can confirm.
>>
>> 1) The potentially sensitive (personally identifying) data gathered in
>> this experiment will be hashed with a salt that is discarded after
>> collection, effectively anonymizing it. The experiment methods have been
>> reviewed in the context of Germany and EU laws, where it is deemed
>> adequately protective of personal privacy. The laws of Japan are less
>> stringent. But in any case the experiment design seems to be respectful
>> of meeting the ethical expectations of the IETF a community.
>>
>> include the broadcast and multicast packets that all of our hosts
>> (laptops, phones, etc) are already seeing. The experimenters are not
>> gathering data from a "privileged" vantage point. One could see the same
>> data themselves by simply running a sniffer program... In case it's not
>> clear, the experiment will thus be able to point out where existing
>> protocols and implementations are "leaking" information.
>>
>> -Benson
>>
>>
>>
>>
>> On Tue, Nov 3, 2015 at 9:59 AM, Stephen Farrell
>> <[email-masked] <mailto:[email-masked]>> wrote:
>>
>>
>>     Hi Joe,
>>
>>      > On Monday, November 2, 2015, Jari Arkko <[email-masked]
>>     <mailto:[email-masked]>> wrote:
>>      >
>>      >>
>>      > [email-masked] <mailto:[email-masked]>
>>     [email-masked] <mailto:[email-masked]>

---

From: Rolf Winter <[email-masked]>
Date: Tue, 3 Nov 2015 02:03:30 +0100

Stephen, Joe,

That indeed is a way to opt out.

Best,

Rolf

---

From: Rolf Winter <[email-masked]>
Date: Tue, 3 Nov 2015 02:31:12 +0100

Hi,

that is absolutely correct. Only those two SSIDs will be part of the 
experiment. So by connecting to another SSID you effectively opt out. 
While I hope most people will not opt out, I certainly understand there 
is no particular reason to trust us with this experiment. Please note 
however, that the NOC folks will connect the devices we brought to the 
network and they will remain with the NOC for the duration of the 
experiment and only connect to specially provisioned ports on a switch. 
Benson's description of our experiment is accurate and to the point, so 
I am not repeating the details of it but I am more than happy to answer 
further questions about the experiment.

Best,

Rolf

---

From: Nat Sakimura <[email-masked]>
Date: Tue, 3 Nov 2015 12:22:39 +0900

An interesting experiment. It would surely have a positive impact to our
privacy going forward. I would have supported it if pre-announced. I have
some concerns to do it after the fact however.

Please note that I am not giving a legal advise but a general observation
here.

Saying the laws of Japan are less stringent is misleading for the following
reasons.

First, Japanese data protection law equivalent does not take a risk based
approach like EU. Whether you anonymize the data after the fact does not
matter. Whether the data collected can reasonably associated with the data
subject matters.

Second, it is not only the data protection law equivalent that you need to
be careful. The Telecommunications Business Law prohibits any person who is
in the position of providing the communication to read the message.

Third, you probably need to take the Consumer Contract Act and the Civil
Code into account. Note that there can be others as well.

Best,

Nat Sakimura

2015-11-03 10:21 GMT+09:00 Benson Schliesser <[email-masked]>:

> stringent. But in any case the experiment design seems to be respectful of
> meeting the ethical expectations of the IETF a community.
>
> On Tue, Nov 3, 2015 at 9:59 AM, Stephen Farrell <[email-masked]
> > wrote:
>
>>
>> Hi Joe,
>>

-- 
Nat Sakimura (=nat)
Chairman, OpenID Foundation
http://nat.sakimura.org/
@_nat_en

---

From: Kostas Pentikousis <[email-masked]>
Date: Tue, 3 Nov 2015 04:42:43 +0100

Hi,

Is there any particular reason why IETF 94 in Yokohama, Japan has been selected for this experiment? Is this going to be known as the Yokohama IETF privacy experiment?

Best regards,

Kostas

From: 94attendees [mailto:[email-masked]] On Behalf Of Nat Sakimura
Sent: Dienstag, 3. November 2015 04:23
To: Benson Schliesser
Cc: [email-masked]; Rolf Winter; Jari Arkko; Joseph Lorenzo Hall; Stephen Farrell
Subject: Re: [94attendees] multicast/broadcast experiment at IETF94

An interesting experiment. It would surely have a positive impact to our privacy going forward. I would have supported it if pre-announced. I have some concerns to do it after the fact however.

Please note that I am not giving a legal advise but a general observation here.

Saying the laws of Japan are less stringent is misleading for the following reasons.

First, Japanese data protection law equivalent does not take a risk based approach like EU. Whether you anonymize the data after the fact does not matter. Whether the data collected can reasonably associated with the data subject matters.

Second, it is not only the data protection law equivalent that you need to be careful. The Telecommunications Business Law prohibits any person who is in the position of providing the communication to read the message.

Third, you probably need to take the Consumer Contract Act and the Civil Code into account. Note that there can be others as well.

Best,

Nat Sakimura

2015-11-03 10:21 GMT+09:00 Benson Schliesser <[email-masked]<mailto:[email-masked]>>:
Hi, Joe.

I also believe that your understanding is correct - that only the broadcast domains of those two SSIDs will be monitored - but I hope that somebody from NOC and/or the experimenters can confirm.

1) The potentially sensitive (personally identifying) data gathered in this experiment will be hashed with a salt that is discarded after collection, effectively anonymizing it. The experiment methods have been reviewed in the context of Germany and EU laws, where it is deemed adequately protective of personal privacy. The laws of Japan are less stringent. But in any case the experiment design seems to be respectful of meeting the ethical expectations of the IETF a community.

2) The pre-processed (pre-anonymized) data being collected will merely include the broadcast and multicast packets that all of our hosts (laptops, phones, etc) are already seeing. The experimenters are not gathering data from a "privileged" vantage point. One could see the same data themselves by simply running a sniffer program... In case it's not clear, the experiment will thus be able to point out where existing protocols and implementations are "leaking" information.

-Benson

On Tue, Nov 3, 2015 at 9:59 AM, Stephen Farrell <[email-masked]<mailto:[email-masked]>> wrote:

Hi Joe,

S

>
> best, Joe
>
> On Monday, November 2, 2015, Jari Arkko <[email-masked]<mailto:[email-masked]>> wrote:
>
>>
> [email-masked]<mailto:[email-masked]>

_______________________________________________
94attendees mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/94attendees

_______________________________________________
94attendees mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/94attendees

---

From: Rolf Winter <[email-masked]>
Date: Tue, 3 Nov 2015 04:49:54 +0100

Hi,

We originally tried to do the experiment during the last meeting in 
Prague but we cancelled it (see here why: 
http://net.hs-augsburg.de/projects/2015/07/20/ietf-measurement-cancelled.html). 
We improved the data collection, made the analytics privacy-preserving 
and consulted with a number of lawyers. The reason we do it in Yokohama 
is basically because we got everything in place for this meeting. 
Nothing more, nothing less.

Best,

Rolf

Am 11/3/15 um 4:42 AM schrieb Kostas Pentikousis:
> Hi,
>
> Is there any particular reason why IETF 94 in Yokohama, Japan has been
> selected for this experiment? Is this going to be known as the Yokohama
> IETF privacy experiment?
>
> Best regards,
>
> Kostas
>
> *From:*94attendees [mailto:[email-masked]] *On Behalf Of
> *Nat Sakimura
> *Sent:* Dienstag, 3. November 2015 04:23
> *To:* Benson Schliesser
> *Cc:* [email-masked]; Rolf Winter; Jari Arkko; Joseph Lorenzo
> Hall; Stephen Farrell
> *Subject:* Re: [94attendees] multicast/broadcast experiment at IETF94
>
> privacy going forward. I would have supported it if pre-announced. I
> have some concerns to do it after the fact however.
>
> First, Japanese data protection law equivalent does not take a risk
> based approach like EU. Whether you anonymize the data after the fact
> does not matter. Whether the data collected can reasonably associated
> with the data subject matters.
>
> Second, it is not only the data protection law equivalent that you need
> to be careful. The Telecommunications Business Law prohibits any person
> who is in the position of providing the communication to read the message.
>

---

From: Michael Graff <[email-masked]>
Date: Tue, 3 Nov 2015 03:52:28 +0000

While I am a fan of privacy, how is this any different than someone running “tcpdump” and looking at the broadcast and multicast traffic?

I mean, while this is an experiment, your machine IS sending this out for all to see when it is connected to that SSID, or any SSID, or any wired network.  Why are people so worried about this, or does this experiment somehow surpass just capturing what is already trivially able to be captured from any client device?

—Michael

---

From: Hirotaka Nakajima <[email-masked]>
Date: Tue, 3 Nov 2015 12:53:03 +0900

Hi,

I'm not planning to opt-out myself as well but I would like to clarify that
avoiding two SSID(ietf and ietf-legacy) is a way to opt-out?

If it’s correct,
we only have 2.4GHz wifi ,IPv6 only and nat64 network which doesn’t include normal dual stack 2.4GHz/5GHz network.

It would be very helpful if we could get a general dual stack, 2.4GHz, 5GHz SSID but opted-out from this experiment?

Best,
Hiro

> On Nov 3, 2015, at 12:42 PM, Kostas Pentikousis <[email-masked]> wrote:
> 
> Hi,
> 
> On Tue, Nov 3, 2015 at 9:59 AM, Stephen Farrell <[email-masked]> wrote:
> 
> Hi Joe,
>

---

From: Nat Sakimura <[email-masked]>
Date: Tue, 3 Nov 2015 12:55:19 +0900

Hi

So did you consult a Japanese lawyer who is good in this area? I can name only a few and I would not advise going to anyone else. 

The previous statement like Japanese law are less stringent makes me worried. 

=nat via iPhone

2015/11/03 12:49、Rolf Winter <[email-masked]> のメッセージ:

> Hi,
> 
> We originally tried to do the experiment during the last meeting in Prague but we cancelled it (see here why: http://net.hs-augsburg.de/projects/2015/07/20/ietf-measurement-cancelled.html). We improved the data collection, made the analytics privacy-preserving and consulted with a number of lawyers. The reason we do it in Yokohama is basically because we got everything in place for this meeting. Nothing more, nothing less.
> 
> Best,
> 
> Rolf
> 
>

---

From: Rolf Winter <[email-masked]>
Date: Tue, 3 Nov 2015 05:22:08 +0100

Hi,

there is indeed an important legal aspect to consider here. Just because 
everybody can see this data, it is not necessarily OK to actually look 
at the data, store and process it if the data contains personally 
identifiable information. Since some messages potentially contain such 
information, we securely hash everything before processing. This makes a 
lot of legal questions go away. But you are absolutely right, anybody on 
the network has access to the data.

The things we worry about are documented here:

and the experiment is used as a data point.

Best,

Rolf

---

From: Rolf Winter <[email-masked]>
Date: Tue, 3 Nov 2015 05:30:09 +0100

Maybe this is not optimally phrased. Please do not understand this as an
excuse to be less careful on our side. There is no PII being stored or
analyzed in the clear for this experiment.

---

From: Michael Graff <[email-masked]>
Date: Tue, 3 Nov 2015 04:46:24 +0000

On Nov 3, 2015, at 1:22 PM, Rolf Winter <[email-masked]<mailto:[email-masked]>> wrote:

there is indeed an important legal aspect to consider here. Just because everybody can see this data, it is not necessarily OK to actually look at the data, store and process it if the data contains personally identifiable information

I have to admit this is one of the stupidest things I’ve heard all day.  If your machine is broadcasting it, it’s freely given.  If you don’t want it to be seen, unicast it.

I see this as little different than putting ones political affiliation on their car as a bumper sticker.  If you don’t want people to know it, don’t advertise it.

Regardless, you’re welcome to whatever my machine advertises.  I’d like to know if it leaks data, even though I often check myself already.

—Michael

---

From: Rolf Winter <[email-masked]>
Date: Tue, 3 Nov 2015 05:53:24 +0100

You should have seen my face when a lawyer explained this to me and I am 
not sure this statement is true in every country... in mine it is though.

Am 11/3/15 um 5:46 AM schrieb Michael Graff:
>
>> On Nov 3, 2015, at 1:22 PM, Rolf Winter <[email-masked]
>> <mailto:[email-masked]>> wrote:
>>
>> there is indeed an important legal aspect to consider here. Just
>> because everybody can see this data, it is not necessarily OK to
>> actually look at the data, store and process it if the data contains
>> personally identifiable information
>
> I have to admit this is one of the stupidest things I’ve heard all day.
>   If your machine is broadcasting it, it’s freely given.  If you don’t
> want it to be seen, unicast it.
>
> I see this as little different than putting ones political affiliation
> on their car as a bumper sticker.  If you don’t want people to know it,
> don’t advertise it.
>
> Regardless, you’re welcome to whatever my machine advertises.  I’d like
> to know if it leaks data, even though I often check myself already.
>
> —Michael
>

---

From: Keith Mitchell <[email-masked]>
Date: Tue, 03 Nov 2015 00:10:07 -0500

> want it to be seen, unicast it.

+1

---

From: Nat Sakimura <[email-masked]>
Date: Tue, 3 Nov 2015 14:10:52 +0900

And in Japanese law, it is. It does not matter whether it is publicly done
or not, which I think is stupid and we wanted to amend at this round (Sept.
2015 change) but could not.

Nat

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Tue, 3 Nov 2015 14:25:35 +0900

On Tue, Nov 03, 2015 at 04:46:24AM +0000,
 Michael Graff <[email-masked]> wrote
 a message of 81 lines which said:

> I have to admit this is one of the stupidest things I’ve heard all
> day.  If your machine is broadcasting it, it’s freely given.  If you
> don’t want it to be seen, unicast it.

It is *not* stupid, it is the law in European Union and for good
reasons. When you walk in the street, meet people and buy a hot dog,
all these activities are public. Does it mean you would be fine if
your spouse / your boss / someone hired a private detective to follow
you all day and report it at the end?

--
Stéphane
Opting-out because my old Wifi chipset can only connect to ietf-2.4.

---

From: "Somers-Harris, David | David | OPS" <[email-masked]>
Date: Tue, 3 Nov 2015 05:29:12 +0000

Private detectives are illegal in Europe? Interesting!

-----Original Message-----
From: 94attendees [mailto:[email-masked]] On Behalf Of Stephane Bortzmeyer
Sent: Tuesday, November 03, 2015 2:26 PM
To: Michael Graff <[email-masked]>
Cc: [email-masked]; Rolf Winter <[email-masked]>
Subject: Re: [94attendees] multicast/broadcast experiment at IETF94

> don’t want it to be seen, unicast it.

It is *not* stupid, it is the law in European Union and for good reasons. When you walk in the street, meet people and buy a hot dog, all these activities are public. Does it mean you would be fine if your spouse / your boss / someone hired a private detective to follow you all day and report it at the end?

---

From: Василий Долматов <[email-masked]>
Date: Tue, 3 Nov 2015 08:33:19 +0300

вторник, 3 ноября 2015 г. пользователь Somers-Harris, David | David | OPS

> Private detectives are illegal in Europe? Interesting!

Moreover, "following people in the street is illegal in Europe??
Interesting!"

One can go any direction he wants and look at any person he wants, unless
it is proven to be done as a part of crime or preparation to committing
crime.

> From: 94attendees [mailto:[email-masked] <javascript:;>] On
> Behalf Of Stephane Bortzmeyer
> To: Michael Graff <[email-masked] <javascript:;>>
> Cc: [email-masked] <javascript:;>; Rolf Winter <
> [email-masked] <javascript:;>>
> On Tue, Nov 03, 2015 at 04:46:24AM +0000,  Michael Graff <
> [email-masked] <javascript:;>> wrote  a message of 81 lines
> which said:
>
> It is *not* stupid, it is the law in European Union and for good reasons.
> When you walk in the street, meet people and buy a hot dog, all these
> activities are public. Does it mean you would be fine if your spouse / your
> boss / someone hired a private detective to follow you all day and report
> it at the end?
>
> --
> Stéphane
> [email-masked] <javascript:;>
> [email-masked] <javascript:;>

---

From: Yoav Nir <[email-masked]>
Date: Tue, 3 Nov 2015 14:35:47 +0900

> On 3 Nov 2015, at 2:25 PM, Stephane Bortzmeyer <[email-masked]> wrote:
> 

As far as I know, London is in the European Union, and there were cameras all over the place.

Is this OK just because they were put there by (local) government?

I also note that people are taking pictures with their phones all over the place with little regard to who they capture.

Yoav

---

From: Peter Koch <[email-masked]>
Date: Tue, 3 Nov 2015 06:36:57 +0100

On Tue, Nov 03, 2015 at 04:46:24AM +0000, Michael Graff wrote:

> I have to admit this is one of the stupidest things I???ve heard all day.  If your machine is broadcasting it, it???s freely given.  If you don???t want it to be seen, unicast it.

interesting incompatibility of sense of privacy.

There are legislations where (luckily) automated surveillance of
public places is illegal. (That such legislation might essentially lack
consistent positions re: illegal evidence is a different story).

-Peter

---

From: Manner Jukka <[email-masked]>
Date: Tue, 3 Nov 2015 05:40:01 +0000

It doesn’t really matter what everybody’s own country allows or doesn’t. This experiment is done in Japan, and you need to play by local rules.

On the “stupidest" comment below, the point of the whole experiment is to understand what gets broadcast. Most of us probably don’t know all the things these devices broadcast, what they did in the past and what they do today. You need to know first what you need to manage and block. All my broadcast traffic probably does not have my consent, my OS vendor or apps do not always tell me what they really do in the background...

Jukka

> On 03 Nov 2015, at 13:53, Rolf Winter <[email-masked]> wrote:
> 
> You should have seen my face when a lawyer explained this to me and I am not sure this statement is true in every country... in mine it is though.
>

---

From: Keiji Takeda <[email-masked]>
Date: Tue, 3 Nov 2015 00:42:13 -0500

It this legal discussion is about "Act on the Protection of Personal 
Information" in Japan I think it may be still controversial.

1 broadcast/multicast packets may not be recognized as "personal 
information" unless they are linked to individual users.

http://www.japaneselawtranslation.go.jp/law/detail_main?id=130&

The term "personal information" as used in this Act shall mean 
information about a living individual which can identify the specific 
individual by name, date of birth or other description contained in such 
information (including such information as will allow easy reference to 
other information and will thereby enable the identification of the 
specific individual).

2 If it is purpose for academic studies it can be excluded from 
restriction/duties.

Article 50　(1)　With respect to entities handling personal information, 
being the entities enumerated in each of the items below, if all or part 
of the purpose of handling personal information is a purpose 
respectively prescribed in each of the items, the provisions of the 
preceding chapter shall not be applied.

(iii)　Colleges, universities, other institutions or organizations 
engaged in academic studies, or entities belonging to them:　The purpose 
for academic studies

Keiji Takeda

---

From: Joseph Lorenzo Hall <[email-masked]>
Date: Tue, 3 Nov 2015 14:55:41 +0900

> Is this OK just because they were put there by (local) government?

This is a public safety or national security use, so very much
exempted from laws that might restrict private citizens. best, Joe

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Tue, 3 Nov 2015 14:56:31 +0900

On Tue, Nov 03, 2015 at 05:29:12AM +0000,
 Somers-Harris, David | David | OPS <[email-masked]> wrote 

> Private detectives are illegal in Europe? Interesting!

I was talking about digital collect and processing of information. The
private detective story was an "meat space" analogy to make people
understand the difference between "public data" and "collect and
processing of this data".

I find also interesting that nobody replied that he was fine with
being followed by a private detective.

---

From: "Somers-Harris, David | David | OPS" <[email-masked]>
Date: Tue, 3 Nov 2015 06:02:22 +0000

Oh ok.
Thanks for the clarification.

-----Original Message-----
From: Stephane Bortzmeyer [mailto:[email-masked]] 
Sent: Tuesday, November 03, 2015 2:57 PM
To: Somers-Harris, David | David | OPS <[email-masked]>
Cc: Stephane Bortzmeyer <[email-masked]>; Michael Graff <[email-masked]>; [email-masked]; Rolf Winter <[email-masked]>
Subject: Re: [94attendees] multicast/broadcast experiment at IETF94

> Private detectives are illegal in Europe? Interesting!

I was talking about digital collect and processing of information. The private detective story was an "meat space" analogy to make people understand the difference between "public data" and "collect and processing of this data".

I find also interesting that nobody replied that he was fine with being followed by a private detective.

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Tue, 3 Nov 2015 14:19:23 +0900