Subject: [94attendees] Shopping for traditional Japanese things around here

From: Darshak Thakore <[email-masked]>
Date: Wed, 4 Nov 2015 08:03:32 +0000

Hi,
I was hoping to buy some traditional Japanese souvenirs on Friday. I’m looking for things on this website

http://injapan.gaijinpot.com/play/travel/2012/06/04/30-must-have-souvenirs-from-japan-some-travel-tips/

More specifically the Tenugui, Wagasu, good quality chopsticks, Kumade and the Kokeshi dolls, matcha tea sets and other stoneware. I figured I may not get all of these in one place but is there a market/place around here where these things would be available ?

I walked around the Queen’s square Plaza but most stuff there is “modern”

Thanks

Darshak Thakore

---

From: joel jaeggli <[email-masked]>
Date: Wed, 4 Nov 2015 17:14:24 +0900

On 11/4/15 5:03 PM, Darshak Thakore wrote:
> Hi, I was hoping to buy some traditional Japanese souvenirs on
> Friday. I’m looking for things on this website
> 
>  More specifically the Tenugui, Wagasu, good quality chopsticks,
> Kumade and the Kokeshi dolls, matcha tea sets and other stoneware.
> I figured I may not get all of these in one place but is there a
> market/place around here where these things would be available ?
> 

Upper floors of yokohama world-porters have quite a lot of housewares
and regional tchotchkes

Across from  Yokohama station is a branch of Takashimaya which is one
of the larger and more famous department store chains, apart from a
great deal of entertainment value, there are many aesthetically
pleasing things to be found there albeit not cheaply.

> Thanks
> 
> Darshak Thakore
> 
> 
> 
> 
> _______________________________________________ 94attendees mailing
> list [email-masked] 
> https://www.ietf.org/mailman/listinfo/94attendees
>

---

From: David C Lawrence <[email-masked]>
Date: Wed, 4 Nov 2015 03:57:55 -0500

Darshak Thakore writes:
> I was hoping to buy some traditional Japanese souvenirs on Friday. 

There's a fair bit in Sogo, a department store just across from
Yokohama station.  It was recommended to me by Yoneya-san.  That place
is pretty huge though, and the Japanese stuff is scattered throughout,
among more modern stuff.  I finally found some Japanese art prints
that I was looking for up on the 7th floor (one floor ABOVE the one
that has an art museum).

It might not be the best spot, but if you're already in the area of
Yokohama Station it's probably worth a browse.