Subject: [97attendees] Steak House discount

From: "Eggert, Lars" <[email-masked]>
Date: Sat, 12 Nov 2016 11:47:46 +0000

"The Steak House"'on the bottom of the IFC mall has a 10% discount on the entire bill for folks who are staying at the Conrad (need to show room key).

-- 
Sent from a mobile device; please excuse typos.
+49 151 120 55791

---

From: "Eggert, Lars" <[email-masked]>
Date: Sat, 12 Nov 2016 19:06:19 +0000

> "The Steak House"'on the bottom of the IFC mall has a 10% discount on the entire bill for folks who are staying at the Conrad (need to show room key).

Since multiple people asked: Food was pretty good, style is western. Our split check came to about 62K each (after discount), but we stayed away from the ridiculously overpriced wine (wine selection is decent though).

They had to refire two plates, because the waiters had mixed up "rare" and "well" (oops) but turnaround was very good.

Lars