Subject: [abnf-discuss] Wherefore no HTAB in literal text strings in ABNF

From: Sean Leonard <[email-masked]>
Date: Sun, 14 Aug 2016 18:34:56 -0700

Hello Knowledgeable ABNF Folks:

I have been working with RFC 5234 lately. What is the rationale (or what are the rationales) for including SP %d32 but excluding HTAB %d9 in char-val, aka the literal text string? I am sure that this decision was not an oversight.

It may be appreciated that the comment production is defined as WSP, which includes HTAB.

Regards,

Sean

---

From: Dave Crocker <[email-masked]>
Date: Sun, 14 Aug 2016 18:37:11 -0700

> I have been working with RFC 5234 lately. What is the rationale (or what are the rationales) for including SP %d32 but excluding HTAB %d9 in char-val, aka the literal text string? I am sure that th…

I don't recall.  Sorry.  I could generate guesses, but that's all they'd be.

d/

-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 15 Aug 2016 07:52:22 +0200

I wasn't there when the decision was made, but clearly bare HTs don't
belong in specification texts, so leaving them out was a rather obvious
decision.
(But maybe I don't understand the question.)
HTs in comments cause ugliness, but are not as devastating as HTs in
semantically relevant parts of the specification.

Grüße, Carsten

Sean Leonard wrote:
> _______________________________________________
> abnf-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/abnf-discuss
>

---

From: Paul Overell <[email-masked]>
Date: Mon, 15 Aug 2016 10:02:20 +0100

> It may be appreciated that the comment production is defined as WSP, which includes HTAB.

   char-val       =  DQUOTE *(%x20-21 / %x23-7E) DQUOTE
                                ; quoted string of SP and VCHAR
                                ;  without DQUOTE

So that the contents of a string literal are visible and unambiguous to
a human reader - spaces and tabs look alike.  For comments is doesn't
matter if the white space comprises of spaces or tabs, it doesn't change
the meaning of a comment.  But for strings it's important for a human
reader to know exactly what's in them.

Regards

-- 
Paul Overell

---

From: Sean Leonard <[email-masked]>
Date: Thu, 18 Aug 2016 19:47:03 -0700

> On Aug 15, 2016, at 2:02 AM, Paul Overell <[email-masked]> wrote:
> 
> 
> 
> So that the contents of a string literal are visible and unambiguous to a human reader - spaces and tabs look alike.  For comments is doesn't matter if the white space comprises of spaces or tabs, it doesn't change the meaning of a comment.  But for strings it's important for a human reader to know exactly what's in them. 
> 
> 
> Regards
> -- 
> Paul Overell

Thank you. That was one of the justifications that I was thinking, and what I was looking for.

Best regards,

Sean

---

From: Dave Crocker <[email-masked]>
Date: Thu, 18 Aug 2016 19:52:01 -0700

> Thank you. That was one of the justifications that I was thinking, and

FWIW, I don't recall any logic being asserted, of the types that Paul 
provided, but it resonates with me as a good excuse now.

d/

-- 

   Dave Crocker