Subject: Re: [Ace] AD review of draft-ietf-ace-usecases-05

From: Stefanie Gerdes <[email-masked]>
Date: Mon, 28 Sep 2015 14:57:34 +0200

Hi Kathleen,

Maybe you can help me with your comment concerning the problems summary sections (see below).

Am 25.09.2015 15:05 schrieb Kathleen Moriarty <[email-masked]>:

> On Thu, Sep 24, 2015 at 3:42 AM, Ludwig Seitz <[email-masked]> wrote: 

> > 
> > On 2015-09-24 03:04, Kathleen Moriarty wrote:

> >> ACE Use Case Draft review: 
> >> 
> >> It seems the "Authorization problem summary" lists contain a mix of 
> >> desired capabilities/requirements and problems.  Is this the right 
> >> heading for this section? 
> > 
> > 
> > We have tried to steer away from specific requirements in order to reduce 
> > the tendency towards requirements engineering. 
> > It is clear that many of the problems could be easily reinterpreted as 
> > generic desired capabilities and generic requirements. 
> > 
> > The point we are trying to make is this: 
> > 
> > Various entities have requirements and desired capabilities in the different 
> > use cases, some of these lead to authorization problems involving 
> > constrained devices, which ACE has the ambition to solve. We tried to 
> > capture the latter in the sections called "Authorization problems summary". 
> > 
> > I've no problem changing the section headers, as long as the indention of 
> > the document remains clear. I'm grateful for suggestions on how to proceed 
> > here. 
>
> Hmm, maybe if you read through them again with this comment in mind, 
> some editing that makes the purpose clear might be good. 
>

The purpose of the problems summary sections is to list what pricipals need from an authorization solution and which special characteristics of the application scenario need to be considered. I read through the problem summary sections again and find the items listed therein quite useful. Is there something that you especially dislike about the sections or would it help if we would rename them, maybe to something like "authorization characteristics summary"?

Thanks,
Steffi

---

From: Kathleen Moriarty <[email-masked]>
Date: Mon, 28 Sep 2015 09:08:50 -0400

Hi Steffi,

> The purpose of the problems summary sections is to list what pricipals need from an authorization solution and which special characteristics of the application scenario need to be considered. I rea…

I do agree that the items are all useful,  WHat I was referring to was
how they read, not necessarily as problems, but in some cases a list
of requirements.  If the problem was pointed out, then the section
heading would make more sense.

Thanks!

-- 

Best regards,
Kathleen

---

From: Stefanie Gerdes <[email-masked]>
Date: Mon, 28 Sep 2015 17:36:56 +0200

Hi Kathleen,

Thank you for the clarification. I think I understand now what you are
aiming at.

Thanks,
Steffi

-- 
Stefanie Gerdes			Tel: +49 421 218 63906
TZI Universität Bremen		E-Mail: [email-masked]
Bibliothekstr. 1, MZH 5150
28359 Bremen, Germany