Subject: [Ace] Fwd: Condensed task list

From: Ludwig Seitz <[email-masked]>
Date: Wed, 30 Sep 2015 16:28:41 +0200

Hello,

Here is what I made at IETF 93. I think it covers everything from the
task list in actors-03, I also found it relatively self-explanatory but
YMMV.

/Ludwig

-- 
Ludwig Seitz, PhD
SICS Swedish ICT AB
Ideon Science Park
Building Beta 2
Scheelevägen 17
SE-223 70 Lund

Phone +46(0)70-349 92 51
http://www.sics.se

---

From: Stefanie Gerdes <[email-masked]>
Date: Wed, 30 Sep 2015 16:36:54 +0200

Hi Ludwig,

I guess you missed some of the tasks when copying them from the draft:

* Configure for C authorization information for sources for R
* Configure for S authorization information for accessing R
* Validate on the client side that an entity has certain attributes
* Validate on the server side that an entity has certain attributes
* Obtain authorization information about an entity from S' principal

Moreover, these tasks are more useful if it is clear which device must
perform them.

Steffi

On 09/30/2015 04:28 PM, Ludwig Seitz wrote:
> _______________________________________________
> Ace mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ace
> 

-- 
Stefanie Gerdes			Tel: +49 421 218 63906
TZI Universität Bremen		E-Mail: [email-masked]
Bibliothekstr. 1, MZH 5150
28359 Bremen, Germany

---

From: Göran Selander <[email-masked]>
Date: Wed, 30 Sep 2015 15:16:43 +0000

Two comments:

1. As I noted in my review of Steffi's draft, these actions are not
necessary to perform in all cases. Therefore this list could be viewed as
a list of *examples* and as such does not require much explanation.

2. Before discussion this any further, I think we should go back to the
review comment and ask if this at all would adress the comment or not.

Göran

---

From: Stefanie Gerdes <[email-masked]>
Date: Wed, 30 Sep 2015 17:53:37 +0200

Hi Göran,

> a list of *examples* and as such does not require much explanation.

I don't think "examples" is a very good expression. To achieve the
integrity and confidentiality of data certain tasks must be performed.
Otherwise the security objectives of the principals cannot be achieved.
The required tasks may differ depending on the principals' needs, but we
need to look at the tasks very carefully to determine that.

Steffi

---

From: Göran Selander <[email-masked]>
Date: Wed, 30 Sep 2015 17:52:36 +0000

>need to look at the tasks very carefully to determine that.

Considering the many different possible deployment options, I think that
is out of scope. But let’s first see if this is anything like what is
requested.

Göran