Subject: [Ace] Fwd: New Version Notification for draft-ietf-ace-usecases-06.txt

From: Ludwig Seitz <[email-masked]>
Date: Wed, 23 Sep 2015 13:12:16 +0200

Hello ACE,

we have submitted a new version of the usecases draft addressing the 
comments of the second WGLC, especially those made by:

Kepeng Li
Prashant Jhingran
Jim Schaad

Regards,

Ludwig

-------- Forwarded Message --------
Subject: New Version Notification for draft-ietf-ace-usecases-06.txt

A new version of I-D, draft-ietf-ace-usecases-06.txt
has been successfully submitted by Ludwig Seitz and posted to the
IETF repository.

Name:		draft-ietf-ace-usecases
Revision:	06
Title:		ACE use cases
Document date:	2015-09-23
Group:		ace
Pages:		26
URL: 
https://www.ietf.org/internet-drafts/draft-ietf-ace-usecases-06.txt
Status:         https://datatracker.ietf.org/doc/draft-ietf-ace-usecases/
Htmlized:       https://tools.ietf.org/html/draft-ietf-ace-usecases-06
Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-ace-usecases-06

Abstract:
    Constrained devices are nodes with limited processing power, storage
    space and transmission capacities.  These devices in many cases do
    not provide user interfaces and are often intended to interact
    without human intervention.

    This document comprises a collection of representative use cases for
    the application of authentication and authorization in constrained
    environments.  These use cases aim at identifying authorization
    problems that arise during the lifecycle of a constrained device and
    are intended to provide a guideline for developing a comprehensive
    authentication and authorization solution for this class of
    scenarios.

    Where specific details are relevant, it is assumed that the devices
    use the Constrained Application Protocol (CoAP) as communication
    protocol, however most conclusions apply generally.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: <[email-masked]>
Date: Sun, 27 Sep 2015 17:22:37 +0000

Dell - Internal Use - Confidential
Hi Ludwig,

Thanks for incorporating my comments, the document diff looks good to me.

-
Regards,
Prashant Jhingran
Product Marketing Consultant

"Smile at everything & smile through everything" - http://www.artofliving.org/

-----Original Message-----
From: Ace [mailto:[email-masked]] On Behalf Of Ludwig Seitz
Sent: Wednesday, September 23, 2015 4:42 PM
To: [email-masked]
Subject: [Ace] Fwd: New Version Notification for draft-ietf-ace-usecases-06.txt

Hello ACE,

we have submitted a new version of the usecases draft addressing the comments of the second WGLC, especially those made by:

Kepeng Li
Prashant Jhingran
Jim Schaad

Regards,

Ludwig

-------- Forwarded Message --------

A new version of I-D, draft-ietf-ace-usecases-06.txt has been successfully submitted by Ludwig Seitz and posted to the IETF repository.

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: <[email-masked]>
Date: Sun, 27 Sep 2015 17:50:36 +0000

Hi Ludwig,

Could not capture the below mentioned point earlier, besides this the document looks very comprehensive to me.

Section 3.1 talks about the DoS attacks.

An attacker can potentially cause a DoS attack by various means, the easiest attack can be caused by forcing the device to send continuous or abnormally higher number of monitoring, troubleshooting or heartbeat messages to the GW or somewhere, thus forcing more number of transactions than expected, this may eventually lead to faster exhaustion of device resources like battery etc.

Hence we should also add "Number of message exchanges required during monitoring or troubleshooting" besides the existing limitations, like "Number of message exchanges required by security measures".

-
Regards,
Prashant Jhingran

From: Ace [mailto:[email-masked]] On Behalf Of Jhingran, Prashant
Sent: Sunday, September 27, 2015 10:53 PM
To: [email-masked]; [email-masked]
Subject: Re: [Ace] Fwd: New Version Notification for draft-ietf-ace-usecases-06.txt

-
Regards,
Prashant Jhingran

-----Original Message-----
From: Ace [mailto:[email-masked]] On Behalf Of Ludwig Seitz
Sent: Wednesday, September 23, 2015 4:42 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [Ace] Fwd: New Version Notification for draft-ietf-ace-usecases-06.txt

Hello ACE,

Kepeng Li
Prashant Jhingran
Jim Schaad

Regards,

Ludwig

-------- Forwarded Message --------

Abstract:

The IETF Secretariat