Subject: [Ace] Syntax check of examples in draft-ietf-ace-cwt-proof-of-possession-05

From: Roman Danyliw <[email-masked]>
Date: Fri, 30 Nov 2018 19:10:07 +0000

Hello!

As part of my shepherd review, I ran all of the examples in draft-ietf-ace-cwt-proof-of-possession-05 through a CBOR diagnostic-to-CBOR validator (thanks Carsten for cbor.me).  All of the examples were fine but the first one in Section 3.3:

--[current text]--
     {
      /kty/ 1 : /Symmetric/ 4,
      /alg/ 3 : /HMAC256/ 5,
      /k/ -1 : h'6684523ab17337f173500e5728c628547cb37df
                 e68449c65f885d1b73b49eae1A0B0C0D0E0F10'
     }
--[end]--

The error was:

Expected one of [ \t\n\r], "/", [0-9a-fA-F] at line 5, column 56 (byte 184) after { /kty/ 1 : /Symmetric/ 4, /alg/ 3 : /HMAC256/ 5, /k/ -1 : h'6684523ab17337f173500e5728c628547cb37df e68449c65f885d1b73b49eae1A0B0C0D0E0F10

It appears that the string of hex encoded octets in /k/ is short one character.

Roman

---

From: Mike Jones <[email-masked]>
Date: Fri, 30 Nov 2018 19:45:49 +0000

Thanks - we'll address that as well.

				-- Mike

-----Original Message-----
From: Ace <[email-masked]> On Behalf Of Roman Danyliw
Sent: Friday, November 30, 2018 11:10 AM
To: [email-masked]
Subject: [Ace] Syntax check of examples in draft-ietf-ace-cwt-proof-of-possession-05

Hello!

--[current text]--
     {
      /kty/ 1 : /Symmetric/ 4,
      /alg/ 3 : /HMAC256/ 5,

The error was:

Roman 

_______________________________________________
Ace mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ace