Subject: Re: [Ace] FW: [IANA #1157486] Last Call: <draft-ietf-ace-oauth-authz-27.txt> (Authentication and Authorization for Constrained Environments (ACE) using the OAuth 2.0 Framework (ACE-OAuth)) to Proposed Standard

From: Ludwig Seitz <[email-masked]>
Date: Sat, 21 Dec 2019 12:25:42 +0100

> From: Sabrina Tanamal via RT <[email-masked]>
> Subject: [IANA #1157486] Last Call: <draft-ietf-ace-oauth-authz-27.txt> (Authentication and Authorization for Constrained Environments (ACE) using the OAuth 2.0 Framework (ACE-OAuth)) to Proposed Standard
>
> (BEGIN IANA COMMENTS)
>
> IESG/Authors/WG Chairs:
>
> The IANA Functions Operator has completed its review of draft-ietf-ace-oauth-authz-27. If any part of this review is inaccurate, please let us know.
>
> The IANA Functions Operator has a question about one of the actions requested in the IANA Considerations section of this document.
>
> The IANA Functions Operator understands that, upon approval of this document, there are fifteen actions which we must complete.
>
> NOTE: We’re asking the ADs how to handle the registrations for which Hannes is the only reviewer.
>
> IANA Question --> Several sections of the current draft propose to create new registries (Sections 8.1, 8.3, 8.4, 8.6, 8.7, 8.9, and 8.11). For each of these requests, IANA asks the authors where the new registries are to be located. Should they be added to an existing registry page? If not, do they belong in an existing category at http://www.iana.org/protocols? For each of the new registries, it is not clear from the context of the request where the new registries should be established.
>
Hello WG chairs (WG and ADs in cc),

I am in need of some guidance here due to my lack of experience in IANA
matters.

Do we want to establish a new protocol page for ACE in the IANA registries?

Alternatively we could add them to the OAuth pages under a specific ACE
section.

Regards,
Ludwig

---

From: Jim Schaad <[email-masked]>
Date: Sat, 21 Dec 2019 11:07:34 -0800

Personal opinion,

I think that we should be requesting a separate page.  I think we are going to have enough different registries that keeping them separate from OAuth is going to be useful in preventing confusion.  For the mapping registries, it might be useful to see if IANA can give us a link from the mapping registry to the OAuth registry.

Jim

-----Original Message-----
From: Ludwig Seitz <[email-masked]> 
Sent: Saturday, December 21, 2019 3:26 AM
To: Jim Schaad <[email-masked]>; 'Daniel Migault' <[email-masked]>
Cc: [email-masked]; Benjamin Kaduk <[email-masked]>; 'Roman Danyliw' <[email-masked]>
Subject: Re: FW: [IANA #1157486] Last Call: <draft-ietf-ace-oauth-authz-27.txt> (Authentication and Authorization for Constrained Environments (ACE) using the OAuth 2.0 Framework (ACE-OAuth)) to Proposed Standard

> Subject: [IANA #1157486] Last Call: 
> <draft-ietf-ace-oauth-authz-27.txt> (Authentication and Authorization 
> for Constrained Environments (ACE) using the OAuth 2.0 Framework 
> (ACE-OAuth)) to Proposed Standard
>
> (BEGIN IANA COMMENTS)
>
> IESG/Authors/WG Chairs:
>

I am in need of some guidance here due to my lack of experience in IANA matters.

Alternatively we could add them to the OAuth pages under a specific ACE section.

Regards,
Ludwig

---

From: Benjamin Kaduk <[email-masked]>
Date: Tue, 24 Dec 2019 12:15:10 -0800

> I think that we should be requesting a separate page.  I think we are going to have enough different registries that keeping them separate from OAuth is going to be useful in preventing confusion.…

I think IANA can do that sort of link, and am inclined to agree about
having a separate page.

-Ben