Subject: [Ace] I-D Action: draft-ietf-ace-cmpv2-coap-transport-03.txt

From: [email-masked]
Date: Fri, 01 Oct 2021 14:12:46 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Authentication and Authorization for Constrained Environments WG of the IETF.

        Title           : CoAP Transfer for the Certificate Management Protocol
        Authors         : Mohit Sahni
                          Saurabh Tripathi
	Filename        : draft-ietf-ace-cmpv2-coap-transport-03.txt
	Pages           : 9
	Date            : 2021-10-01

Abstract:
   This document specifies the use of Constrained Application Protocol
   (CoAP) as a transfer mechanism for the Certificate Management
   Protocol (CMP).  purpose of certificate creation and management.
   CoAP is an HTTP like client-server protocol used by various
   constrained devices in the IoT space.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ace-cmpv2-coap-transport/

There is also an htmlized version available at:
https://datatracker.ietf.org/doc/html/draft-ietf-ace-cmpv2-coap-transport-03

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-ace-cmpv2-coap-transport-03

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Mohit Sahni <[email-masked]>
Date: Fri, 1 Oct 2021 14:27:48 -0700

Hello Ace WG,
This draft incorporates the comments that I got in WG last call. Here is
summary of main changes:
- Change Transport to Transfer Mechanism
- Use CMP instead of CMPv2/v3 and Light weight CMP
- Clarifications about URI format examples
- 'ct' attribute in RA/CA discovery section
- More clarification around handling of requests that may take additional
time to be processed using the "Separate response"
- Using Observe option for announcement message (Thanks Daniel for
suggesting that)
- Update references for the drafts and some minor text and format changes.

Please let me know if any of the comments are unresolved.

Thanks
Mohit

On Fri, Oct 1, 2021 at 2:14 PM <[email-masked]> wrote:

> _______________________________________________
> Ace mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ace
>

---

From: "Brockhaus, Hendrik" <[email-masked]>
Date: Mon, 4 Oct 2021 06:03:37 +0000

Hello Mohit

Many thanks for this update.
I especially like the addressing of delayed delivery of responses and the registration for announcement messages.

Hendrik

Von: Ace <[email-masked]> Im Auftrag von Mohit Sahni
Gesendet: Freitag, 1. Oktober 2021 23:28
An: Ace Wg <[email-masked]>
Cc: [email-masked]
Betreff: Re: [Ace] I-D Action: draft-ietf-ace-cmpv2-coap-transport-03.txt

Hello Ace WG,
This draft incorporates the comments that I got in WG last call. Here is summary of main changes:
- Change Transport to Transfer Mechanism
- Use CMP instead of CMPv2/v3 and Light weight CMP
- Clarifications about URI format examples
- 'ct' attribute in RA/CA discovery section
- More clarification around handling of requests that may take additional time to be processed using the "Separate response"
- Using Observe option for announcement message (Thanks Daniel for suggesting that)
- Update references for the drafts and some minor text and format changes.

Thanks
Mohit

On Fri, Oct 1, 2021 at 2:14 PM <[email-masked]<mailto:[email-masked]>> wrote:

Abstract:

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ace-cmpv2-coap-transport/<https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-ace-cmpv2-coap-transport%2F&data=04%7C01%7Chendrik.brockhaus%40siemens.com%7C6e1bcc8dd5c44dc4c15a08d98522666f%7C38ae3bcd95794fd4addab42e1495d55a%7C1%7C0%7C637687205071342200%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=MUSSk8r3CYXrJdRn9fz8YBHYbzzRiH1pTjEB3sRhCVY%3D&reserved=0>

There is also an htmlized version available at:
https://datatracker.ietf.org/doc/html/draft-ietf-ace-cmpv2-coap-transport-03<https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-ace-cmpv2-coap-transport-03&data=04%7C01%7Chendrik.brockhaus%40siemens.com%7C6e1bcc8dd5c44dc4c15a08d98522666f%7C38ae3bcd95794fd4addab42e1495d55a%7C1%7C0%7C637687205071342200%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=n76kkuqWG3btz2T0ErGMPbeS%2Fh1y%2B92A5YKcvk1KQwo%3D&reserved=0>

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-ace-cmpv2-coap-transport-03<https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Frfcdiff%3Furl2%3Ddraft-ietf-ace-cmpv2-coap-transport-03&data=04%7C01%7Chendrik.brockhaus%40siemens.com%7C6e1bcc8dd5c44dc4c15a08d98522666f%7C38ae3bcd95794fd4addab42e1495d55a%7C1%7C0%7C637687205071352191%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=wvTIynT%2B5nfzNmJmEIWfrfM4SWGR8VzcFHUwHpnOk0o%3D&reserved=0>

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/<https://eur01.safelinks.protection.outlook.com/?url=ftp%3A%2F%2Fftp.ietf.org%2Finternet-drafts%2F&data=04%7C01%7Chendrik.brockhaus%40siemens.com%7C6e1bcc8dd5c44dc4c15a08d98522666f%7C38ae3bcd95794fd4addab42e1495d55a%7C1%7C0%7C637687205071352191%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=b0JtuiWULBp6zK2XNwJicUkvuFV0Y59jF0SWXGCfJEM%3D&reserved=0>

_______________________________________________
Ace mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ace<https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Face&data=04%7C01%7Chendrik.brockhaus%40siemens.com%7C6e1bcc8dd5c44dc4c15a08d98522666f%7C38ae3bcd95794fd4addab42e1495d55a%7C1%7C0%7C637687205071362184%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdata=UHelzT%2F8TH2U%2FUaSzRxd0eT55XV%2B6I9VCQEDhRzEMwc%3D&reserved=0>

---

From: Daniel Migault <[email-masked]>
Date: Mon, 25 Oct 2021 15:37:07 -0400

Hi,

Here are some information I need to complete the shepherd:

A.  Do we have existing implementation or intention to implement it.

B. Can both co-authors confirm they are not aware of any IPR.

C. The document seems to lack the recommended RFC 2119 boilerplate, even if

     it appears to use RFC 2119 keywords -- however, there's a paragraph with
     a matching beginning. Boilerplate error?

D.  .The draft uses .well-known/cmp. .well-known/cmp is indicated as
temporary [iana] and cmp-updates is still a draft. I am not sure we need to
wait for cmp-updates to be published, but if the draft is abandoned we may
need to indicate IANA that the cmp needs to be moved to permanent after
2022-05-20  - or may be at the publication of this draft. I suggest we add
a note in the IANA section which could be removed by IANA or the RFC
editor.

E. I am not sure the registration of pkiccmp does not need more
information. More especially, I see
https://www.iana.org/assignments/core-parameters/core-parameters.xhtml#content-formats
https://www.rfc-editor.org/rfc/rfc7252.html#section-12.3

Please check what is needed and make sure the IANA is correct.

Yours,
Daniel

---

From: Mohit Sahni <[email-masked]>
Date: Mon, 25 Oct 2021 14:18:43 -0700

Hi Daniel,

Please find answers to your questions:
A) Currently there is an open source implementation to support CMP over
CoAP maintained by @David von Oheimb <[email-masked]>. I
believe these do not follow the draft exactly but are based on this draft.
Here are github links:

   - https://github.com/siemens/LightweightCmpRa
   - https://github.com/siemens/embeddedCMP

B) I can confirm that I am not aware of any IPR. Adding @Saurabh Tripathi
<[email-masked]> to confirm on this side also.

C) I generated the document using the xml2rfc v3 tool. The boilerplate is
generated by the xml2rfc tool based on xml tags. It could be an issue with
the NITS tool or XML2RFC tool, I will try to generate another txt version
based on latest version of the tool or fix the issue manually.

D) I will add a note for IANA mentioning this. Can you please review if
this note looks good?

This Internet draft references the .well-known/cmp temporary IANA registry
[Link to:
https://www.iana.org/assignments/well-known-uris/well-known-uris.xhtml].
Please add a reference of this draft to the .well-known/cmp registry and if
this draft is published before [I-D.ietf-lamps-cmp-updates] please make the
.well-known/cmp registry permanent based on this draft's publication.

E) Can you confirm if this change looks good to you?
OLD:
   This document requires a new entry to the CoAP Content-Formats
   Registry code for the content-type "application/pkixcmp" for
   transfering CMP transactions over CoAP.

   Type name: application

   Subtype name: pkixcmp

NEW:
   This document requires a new entry to the CoAP Content-Formats
   Registry code for the content-type "application/pkixcmp" for
   transfering CMP transactions over CoAP from the identifier
   range 256-9999 reserved for IETF specifications.

   Type name: application

   Subtype name: pkixcmp

   Encoding: Content may contain arbitrary octet
   values. The octet values are the ASN.1 DER
   encoding of a PKI message, as defined in the
   [RFC4210] specifications.

   Reference: This internet draft and RFC4210

Thanks a lot for your help moving this forward.

Regards
Mohit

---

From: Daniel Migault <[email-masked]>
Date: Mon, 25 Oct 2021 20:22:06 -0400

On Mon, Oct 25, 2021 at 5:18 PM Mohit Sahni <[email-masked]> wrote:

> great. That is helpful for the shepherd

>    -
> thanks.

> you did good. I was looking at the wrong place. The nits was misleading to
me.

> That seems fine to me. They will probably ask for something else or remove
the text, but we have avoided running through the cracks.

> Looks good!

-- 
Daniel Migault
Ericsson

---

From: Daniel Migault <[email-masked]>
Date: Mon, 25 Oct 2021 20:26:59 -0400

Thanks. I am ready to push the next version to the IESG.

Thank you all for moving this document.

Yours
Daniel

On Mon, Oct 25, 2021 at 5:30 PM Saurabh Tripathi <
[email-masked]> wrote:

> Hi Mohit,
>
> I am not aware of any IPR.
>
> --Saurabh
>
> On Mon, Oct 25, 2021 at 2:18 PM Mohit Sahni <[email-masked]> wrote:
>
>> Hi Daniel,
>>
>>    <https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_siemens_LightweightCmpRa&d=DwMFaQ&c=V9IgWpI5PvzTw83UyHGVSoW3Uc1MFWe5J8PTfkrzVSo&r=ZOdGf2OQ8EYofyZRMf0bHltv3S89_8OfM7ykqC8-cvA&m=HYATU_g3NfOO8cMsDWF7hUXVleiwuE4kv8hH17Mzk5c&s=Ck7iZwTTMXwZp5qhZJ5UPta4b3n6MeQg97vmgl0nVnE&e=>
>>    <https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_siemens_embeddedCMP&d=DwMFaQ&c=V9IgWpI5PvzTw83UyHGVSoW3Uc1MFWe5J8PTfkrzVSo&r=ZOdGf2OQ8EYofyZRMf0bHltv3S89_8OfM7ykqC8-cvA&m=HYATU_g3NfOO8cMsDWF7hUXVleiwuE4kv8hH17Mzk5c&s=T4mI0MvZMWr3puXUJ9sEy2izdpL1g1cGFeBx5GYJyB4&e=>
>>
>> This Internet draft references the .well-known/cmp temporary IANA
>> registry [Link to:
>> https://www.iana.org/assignments/well-known-uris/well-known-uris.xhtml
>> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.iana.org_assignments_well-2Dknown-2Duris_well-2Dknown-2Duris.xhtml&d=DwMFaQ&c=V9IgWpI5PvzTw83UyHGVSoW3Uc1MFWe5J8PTfkrzVSo&r=ZOdGf2OQ8EYofyZRMf0bHltv3S89_8OfM7ykqC8-cvA&m=HYATU_g3NfOO8cMsDWF7hUXVleiwuE4kv8hH17Mzk5c&s=a2BlPpzMwKPT5yrPzFc731SADo9AVmndkKmo_sIKas4&e=>].
>>> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.iana.org_assignments_core-2Dparameters_core-2Dparameters.xhtml-23content-2Dformats&d=DwMFaQ&c=V9IgWpI5PvzTw83UyHGVSoW3Uc1MFWe5J8PTfkrzVSo&r=ZOdGf2OQ8EYofyZRMf0bHltv3S89_8OfM7ykqC8-cvA&m=HYATU_g3NfOO8cMsDWF7hUXVleiwuE4kv8hH17Mzk5c&s=FEM3wm5EidYOaq1P8f_ttf01fuCvqRwdvyLYGWQpelM&e=>
>>> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.rfc-2Deditor.org_rfc_rfc7252.html-23section-2D12.3&d=DwMFaQ&c=V9IgWpI5PvzTw83UyHGVSoW3Uc1MFWe5J8PTfkrzVSo&r=ZOdGf2OQ8EYofyZRMf0bHltv3S89_8OfM7ykqC8-cvA&m=HYATU_g3NfOO8cMsDWF7hUXVleiwuE4kv8hH17Mzk5c&s=nqyc0oepdjMtut1f6ksijcbyRAExj6jBgREVcQcDq6Q&e=>
>>>

-- 
Daniel Migault
Ericsson

---

From: "Brockhaus, Hendrik" <[email-masked]>
Date: Tue, 26 Oct 2021 06:15:16 +0000

Von: Daniel Migault <[email-masked]>
Gesendet: Dienstag, 26. Oktober 2021 02:22

On Mon, Oct 25, 2021 at 5:18 PM Mohit Sahni <[email-masked]<mailto:[email-masked]>> wrote:

D) I will add a note for IANA mentioning this. Can you please review if this note looks good?

This Internet draft references the .well-known/cmp temporary IANA registry [Link to: https://www.iana.org/assignments/well-known-uris/well-known-uris.xhtml<https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.iana.org%2Fassignments%2Fwell-known-uris%2Fwell-known-uris.xhtml&data=04%7C01%7Chendrik.brockhaus%40siemens.com%7C2bbd6c1b1f314c91356608d99816ab79%7C38ae3bcd95794fd4addab42e1495d55a%7C1%7C0%7C637708046625686656%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=EE1ke%2FeqXN5RpTikRqMsgMz%2BPv8w0sgOxPiqN5JywTY%3D&reserved=0>]. Please add a reference of this draft to the .well-known/cmp registry and if this draft is published before [I-D.ietf-lamps-cmp-updates] please make the .well-known/cmp registry permanent based on this draft's publication.

That seems fine to me. They will probably ask for something else or remove the text, but we have avoided running through the cracks.

[Bro] I updated the CMP Updates and the Lightweight CMP Profile drafts yesterday and asked the LAMPS chairs for WGLC. The CMP Algorithms draft already passed WGLC.
BTW, I discussed with Russ, that we would like to publish the three CMP related drafts with consecutive RFC numbers.

Hendrik

---

From: Daniel Migault <[email-masked]>
Date: Tue, 26 Oct 2021 10:29:06 -0400

Thanks for the follow-up Handrik. I will put that into the shepherd. Given
that draft submission is closed, the drafts will be roughly sent at the
same time to our ADs, so the timing looks fine.

Then, I am wondering what we should put into the IANA section. I am tempted
to put instead the text below. I am happy with any other alternatives.

This Internet draft references the .well-known/cmp temporary IANA registry
[Link to:
https://www.iana.org/assignments/well-known-uris/well-known-uris.xhtml
<https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.iana.org%2Fassignments%2Fwell-known-uris%2Fwell-known-uris.xhtml&data=04%7C01%7Chendrik.brockhaus%40siemens.com%7C2bbd6c1b1f314c91356608d99816ab79%7C38ae3bcd95794fd4addab42e1495d55a%7C1%7C0%7C637708046625686656%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=EE1ke%2FeqXN5RpTikRqMsgMz%2BPv8w0sgOxPiqN5JywTY%3D&reserved=0>].
This document is expected to be published together with
[I-D.ietf-lamps-cmp-updates]
that makes .well-known/cmp registry permanent.

Yours,
Daniel

On Tue, Oct 26, 2021 at 2:15 AM Brockhaus, Hendrik <
[email-masked]> wrote:

>
>
>
>
> *Von:* Daniel Migault <[email-masked]>
> *Gesendet:* Dienstag, 26. Oktober 2021 02:22
>
>
>
> <https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.iana.org%2Fassignments%2Fwell-known-uris%2Fwell-known-uris.xhtml&data=04%7C01%7Chendrik.brockhaus%40siemens.com%7C2bbd6c1b1f314c91356608d99816ab79%7C38ae3bcd95794fd4addab42e1495d55a%7C1%7C0%7C637708046625686656%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=EE1ke%2FeqXN5RpTikRqMsgMz%2BPv8w0sgOxPiqN5JywTY%3D&reserved=0>].
> [Bro] I updated the CMP Updates and the Lightweight CMP Profile drafts
> yesterday and asked the LAMPS chairs for WGLC. The CMP Algorithms draft
> already passed WGLC.
>
> BTW, I discussed with Russ, that we would like to publish the three CMP
> related drafts with consecutive RFC numbers.
>
>
>
> Hendrik
>

-- 
Daniel Migault
Ericsson

---

From: "Brockhaus, Hendrik" <[email-masked]>
Date: Tue, 26 Oct 2021 14:51:15 +0000

Thank you for the suggestion. I am fine with it.
Hendrik

Von: Daniel Migault <[email-masked]>
Gesendet: Dienstag, 26. Oktober 2021 16:29

Thanks for the follow-up Handrik. I will put that into the shepherd. Given that draft submission is closed, the drafts will be roughly sent at the same time to our ADs, so the timing looks fine.

Then, I am wondering what we should put into the IANA section. I am tempted to put instead the text below. I am happy with any other alternatives.

This Internet draft references the .well-known/cmp temporary IANA registry [Link to: https://www.iana.org/assignments/well-known-uris/well-known-uris.xhtml<https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.iana.org%2Fassignments%2Fwell-known-uris%2Fwell-known-uris.xhtml&data=04%7C01%7Chendrik.brockhaus%40siemens.com%7C36a90282ef44486bac4708d9988cfe0c%7C38ae3bcd95794fd4addab42e1495d55a%7C1%7C0%7C637708554252515691%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=O%2Fd1DH4xsH5%2F%2FkzqUmFzhTjOK92PqSoMNBVsjyixOJE%3D&reserved=0>]. This document is expected to be published together with [I-D.ietf-lamps-cmp-updates] that makes .well-known/cmp registry permanent.

Yours,
Daniel

On Tue, Oct 26, 2021 at 2:15 AM Brockhaus, Hendrik <[email-masked]<mailto:[email-masked]>> wrote:

Von: Daniel Migault <[email-masked]<mailto:[email-masked]>>
Gesendet: Dienstag, 26. Oktober 2021 02:22

This Internet draft references the .well-known/cmp temporary IANA registry [Link to: https://www.iana.org/assignments/well-known-uris/well-known-uris.xhtml<https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.iana.org%2Fassignments%2Fwell-known-uris%2Fwell-known-uris.xhtml&data=04%7C01%7Chendrik.brockhaus%40siemens.com%7C36a90282ef44486bac4708d9988cfe0c%7C38ae3bcd95794fd4addab42e1495d55a%7C1%7C0%7C637708554252525686%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=NgaodceiFq5QSaEz%2B%2FydswbVU7kuWtt7rIVlYAtAzfs%3D&reserved=0>]. Please add a reference of this draft to the .well-known/cmp registry and if this draft is published before [I-D.ietf-lamps-cmp-updates] please make the .well-known/cmp registry permanent based on this draft's publication.

Hendrik

--
Daniel Migault
Ericsson

---

From: Mohit Sahni <[email-masked]>
Date: Tue, 26 Oct 2021 07:57:26 -0700

Hi Daniel,
Does this text look good to you?

   This document references the cmp, a temporary entry, in the Well-
   Known URIs [1] IANA registry.  This document is expected to be
   published together with [I-D.ietf-lamps-cmp-updates] that makes
   the cmp registry entry permanent. Please add a reference of this
   document to the Well-Known URIs [1] IANA registry for that entry.

8.3.  URIs

   [1] https://www.iana.org/assignments/well-known-uris/well-known-
       uris.xhtml

Thanks
Mohit

On Tue, Oct 26, 2021 at 7:51 AM Brockhaus, Hendrik <
[email-masked]> wrote:

> *Gesendet:* Dienstag, 26. Oktober 2021 16:29
>
> Then, I am wondering what we should put into the IANA section. I am
> tempted to put instead the text below. I am happy with any other
> alternatives.
>
>
>
> <https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.iana.org%2Fassignments%2Fwell-known-uris%2Fwell-known-uris.xhtml&data=04%7C01%7Chendrik.brockhaus%40siemens.com%7C36a90282ef44486bac4708d9988cfe0c%7C38ae3bcd95794fd4addab42e1495d55a%7C1%7C0%7C637708554252515691%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=O%2Fd1DH4xsH5%2F%2FkzqUmFzhTjOK92PqSoMNBVsjyixOJE%3D&reserved=0>].
> [I-D.ietf-lamps-cmp-updates] that makes .well-known/cmp registry permanent.
>
>
>
> Yours,
> Daniel
>
>
>
> <https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.iana.org%2Fassignments%2Fwell-known-uris%2Fwell-known-uris.xhtml&data=04%7C01%7Chendrik.brockhaus%40siemens.com%7C36a90282ef44486bac4708d9988cfe0c%7C38ae3bcd95794fd4addab42e1495d55a%7C1%7C0%7C637708554252525686%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=NgaodceiFq5QSaEz%2B%2FydswbVU7kuWtt7rIVlYAtAzfs%3D&reserved=0>].

---

From: Daniel Migault <[email-masked]>
Date: Tue, 26 Oct 2021 14:59:50 +0000

looks good to me.
Yours,
Daniel
________________________________
From: Ace <[email-masked]> on behalf of Mohit Sahni <[email-masked]>
Sent: Tuesday, October 26, 2021 10:57 AM
To: Brockhaus, Hendrik <[email-masked]>
Cc: Saurabh Tripathi <[email-masked]>; Russ Housley <[email-masked]>; [email-masked] <[email-masked]>; Daniel Migault <[email-masked]>; Ace Wg <[email-masked]>
Subject: Re: [Ace] I-D Action: draft-ietf-ace-cmpv2-coap-transport-03.txt

Hi Daniel,

8.3.  URIs

Thanks
Mohit

On Tue, Oct 26, 2021 at 7:51 AM Brockhaus, Hendrik <[email-masked]<mailto:[email-masked]>> wrote:

Hendrik

This Internet draft references the .well-known/cmp temporary IANA registry [Link to: https://www.iana.org/assignments/well-known-uris/well-known-uris.xhtml<https://protect2.fireeye.com/v1/url?k=fe0a6103-a1915805-fe0a2198-86ee86bd5107-981714ff6a88f6b0&q=1&e=085826df-8b5b-4acc-9251-32e8a7cc6efe&u=https%3A%2F%2Feur01.safelinks.protection.outlook.com%2F%3Furl%3Dhttps%253A%252F%252Fwww.iana.org%252Fassignments%252Fwell-known-uris%252Fwell-known-uris.xhtml%26data%3D04%257C01%257Chendrik.brockhaus%2540siemens.com%257C36a90282ef44486bac4708d9988cfe0c%257C38ae3bcd95794fd4addab42e1495d55a%257C1%257C0%257C637708554252515691%257CUnknown%257CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%253D%257C3000%26sdata%3DO%252Fd1DH4xsH5%252F%252FkzqUmFzhTjOK92PqSoMNBVsjyixOJE%253D%26reserved%3D0>]. This document is expected to be published together with [I-D.ietf-lamps-cmp-updates] that makes .well-known/cmp registry permanent.

Yours,
Daniel

This Internet draft references the .well-known/cmp temporary IANA registry [Link to: https://www.iana.org/assignments/well-known-uris/well-known-uris.xhtml<https://protect2.fireeye.com/v1/url?k=2af65ff7-756d66f1-2af61f6c-86ee86bd5107-4da7b38d59847a6c&q=1&e=085826df-8b5b-4acc-9251-32e8a7cc6efe&u=https%3A%2F%2Feur01.safelinks.protection.outlook.com%2F%3Furl%3Dhttps%253A%252F%252Fwww.iana.org%252Fassignments%252Fwell-known-uris%252Fwell-known-uris.xhtml%26data%3D04%257C01%257Chendrik.brockhaus%2540siemens.com%257C36a90282ef44486bac4708d9988cfe0c%257C38ae3bcd95794fd4addab42e1495d55a%257C1%257C0%257C637708554252525686%257CUnknown%257CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%253D%257C3000%26sdata%3DNgaodceiFq5QSaEz%252B%252FydswbVU7kuWtt7rIVlYAtAzfs%253D%26reserved%3D0>]. Please add a reference of this draft to the .well-known/cmp registry and if this draft is published before [I-D.ietf-lamps-cmp-updates] please make the .well-known/cmp registry permanent based on this draft's publication.

Hendrik

--

Daniel Migault

Ericsson

---

From: Mohit Sahni <[email-masked]>
Date: Tue, 26 Oct 2021 11:39:26 -0700

Hi Daniel,
I have the changes ready, but I cannot publish the new draft because draft
submission is blocked currently till 11/06. Here is the message that I see
on the submission page.

"The I-D submission tool will be reopened after 2021-11-06 23:59 UTC
(IETF-meeting local time)."

Thanks
Mohit

On Tue, Oct 26, 2021 at 7:59 AM Daniel Migault <[email-masked]>
wrote:

> looks good to me.
> Yours,
> Daniel
> ------------------------------
> *From:* Ace <[email-masked]> on behalf of Mohit Sahni <
> [email-masked]>
> *Sent:* Tuesday, October 26, 2021 10:57 AM
> *To:* Brockhaus, Hendrik <[email-masked]>
> *Cc:* Saurabh Tripathi <[email-masked]>; Russ Housley <
> [email-masked]>; [email-masked] <
> [email-masked]>; Daniel Migault <[email-masked]>; Ace
> Wg <[email-masked]>
> *Subject:* Re: [Ace] I-D Action:
> draft-ietf-ace-cmpv2-coap-transport-03.txt
>
> Hi Daniel,
> <https://protect2.fireeye.com/v1/url?k=fe0a6103-a1915805-fe0a2198-86ee86bd5107-981714ff6a88f6b0&q=1&e=085826df-8b5b-4acc-9251-32e8a7cc6efe&u=https%3A%2F%2Feur01.safelinks.protection.outlook.com%2F%3Furl%3Dhttps%253A%252F%252Fwww.iana.org%252Fassignments%252Fwell-known-uris%252Fwell-known-uris.xhtml%26data%3D04%257C01%257Chendrik.brockhaus%2540siemens.com%257C36a90282ef44486bac4708d9988cfe0c%257C38ae3bcd95794fd4addab42e1495d55a%257C1%257C0%257C637708554252515691%257CUnknown%257CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%253D%257C3000%26sdata%3DO%252Fd1DH4xsH5%252F%252FkzqUmFzhTjOK92PqSoMNBVsjyixOJE%253D%26reserved%3D0>].
> <https://protect2.fireeye.com/v1/url?k=2af65ff7-756d66f1-2af61f6c-86ee86bd5107-4da7b38d59847a6c&q=1&e=085826df-8b5b-4acc-9251-32e8a7cc6efe&u=https%3A%2F%2Feur01.safelinks.protection.outlook.com%2F%3Furl%3Dhttps%253A%252F%252Fwww.iana.org%252Fassignments%252Fwell-known-uris%252Fwell-known-uris.xhtml%26data%3D04%257C01%257Chendrik.brockhaus%2540siemens.com%257C36a90282ef44486bac4708d9988cfe0c%257C38ae3bcd95794fd4addab42e1495d55a%257C1%257C0%257C637708554252525686%257CUnknown%257CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%253D%257C3000%26sdata%3DNgaodceiFq5QSaEz%252B%252FydswbVU7kuWtt7rIVlYAtAzfs%253D%26reserved%3D0>].

---

From: Daniel Migault <[email-masked]>
Date: Wed, 27 Oct 2021 00:02:24 +0000

sure. Just submit when the submission re-opens.

Yours,
Daniel
________________________________
From: Mohit Sahni <[email-masked]>
Sent: Tuesday, October 26, 2021 2:39 PM
To: Daniel Migault <[email-masked]>
Cc: Brockhaus, Hendrik <[email-masked]>; Saurabh Tripathi <[email-masked]>; Russ Housley <[email-masked]>; [email-masked] <[email-masked]>; Daniel Migault <[email-masked]>; Ace Wg <[email-masked]>
Subject: Re: [Ace] I-D Action: draft-ietf-ace-cmpv2-coap-transport-03.txt

Hi Daniel,
I have the changes ready, but I cannot publish the new draft because draft submission is blocked currently till 11/06. Here is the message that I see on the submission page.

"The I-D submission tool will be reopened after 2021-11-06 23:59 UTC (IETF-meeting local time)."

Thanks
Mohit

On Tue, Oct 26, 2021 at 7:59 AM Daniel Migault <[email-masked]<mailto:[email-masked]>> wrote:
looks good to me.
Yours,
Daniel
________________________________
From: Ace <[email-masked]<mailto:[email-masked]>> on behalf of Mohit Sahni <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, October 26, 2021 10:57 AM
To: Brockhaus, Hendrik <[email-masked]<mailto:[email-masked]>>
Cc: Saurabh Tripathi <[email-masked]<mailto:[email-masked]>>; Russ Housley <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>; Daniel Migault <[email-masked]<mailto:[email-masked]>>; Ace Wg <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Ace] I-D Action: draft-ietf-ace-cmpv2-coap-transport-03.txt

Hi Daniel,

8.3.  URIs

Thanks
Mohit

Hendrik

Yours,
Daniel

Hendrik

--

Daniel Migault

Ericsson