Subject: [Acme] IDN encoding

From: Roland Bracewell Shoemaker <[email-masked]>
Date: Mon, 29 Aug 2016 15:51:56 -0700

I'd be interested in hearing peoples thoughts about this PR which adds
language about how IDNs should be encoded by clients who wish to use
them as identifier values.

https://github.com/ietf-wg-acme/acme/pull/184

---

From: Philipp Junghannß <[email-masked]>
Date: Tue, 30 Aug 2016 01:21:06 +0200

shouldnt IDNs just get Punycoded? at least that's the common standard for
IDN stuff iirc.

2016-08-30 0:51 GMT+02:00 Roland Bracewell Shoemaker <[email-masked]
>:

> _______________________________________________
> Acme mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/acme
>

---

From: Richard Barnes <[email-masked]>
Date: Mon, 29 Aug 2016 19:36:07 -0400

Yeah, there's no reason to use U-labels here.  Let's just require that the
names be in ASCII.  I don't think there's really a need to require anything
further than that (servers can do case folding).

Note that this only affects Authorization.identifier.value for
Authorization.identifier.type == "dns".  The names in the CSR can still
have all the delightful variation that X.509 allows.

On Mon, Aug 29, 2016 at 7:21 PM, Philipp Junghannß <[email-masked]
> wrote:

> 2016-08-30 0:51 GMT+02:00 Roland Bracewell Shoemaker <
> [email-masked]>:
>

---

From: Roland Bracewell Shoemaker <[email-masked]>
Date: Mon, 29 Aug 2016 16:39:03 -0700

The referenced RFCs describe punycode encoding using the 'xn--' ACE prefix.

On 08/29/2016 04:21 PM, Philipp Junghannß wrote:
> shouldnt IDNs just get Punycoded? at least that's the common standard
> for IDN stuff iirc.
> 
> 2016-08-30 0:51 GMT+02:00 Roland Bracewell Shoemaker
> <[email-masked] <mailto:[email-masked]>>:
> 
>     <https://github.com/ietf-wg-acme/acme/pull/184>
> 
>     [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/acme>
> 
>

---

From: Roland Bracewell Shoemaker <[email-masked]>
Date: Mon, 29 Aug 2016 16:42:01 -0700

On 08/29/2016 04:36 PM, Richard Barnes wrote:
> Yeah, there's no reason to use U-labels here.  Let's just require that
> the names be in ASCII.  I don't think there's really a need to require
> anything further than that (servers can do case folding).
> 

That is what this patch does, but actually describes how the
ASCII-ification should be done instead of leaving it up to the reader to
figure out.

> On Mon, Aug 29, 2016 at 7:21 PM, Philipp Junghannß
> <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     shouldnt IDNs just get Punycoded? at least that's the common
>     standard for IDN stuff iirc.
> 
>