Subject: [Acme] I-D Action: draft-ietf-acme-acme-09.txt

From: [email-masked]
Date: Thu, 14 Dec 2017 06:14:02 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Automated Certificate Management Environment WG of the IETF.

        Title           : Automatic Certificate Management Environment (ACME)
        Authors         : Richard Barnes
                          Jacob Hoffman-Andrews
                          Daniel McCarney
                          James Kasten
	Filename        : draft-ietf-acme-acme-09.txt
	Pages           : 80
	Date            : 2017-12-14

Abstract:
   Certificates in PKI using X.509 (PKIX) are used for a number of
   purposes, the most significant of which is the authentication of
   domain names.  Thus, certificate authorities in the Web PKI are
   trusted to verify that an applicant for a certificate legitimately
   represents the domain name(s) in the certificate.  Today, this
   verification is done through a collection of ad hoc mechanisms.  This
   document describes a protocol that a certification authority (CA) and
   an applicant can use to automate the process of verification and
   certificate issuance.  The protocol also provides facilities for
   other certificate management functions, such as certificate
   revocation.

   RFC EDITOR: PLEASE REMOVE THE FOLLOWING PARAGRAPH: The source for
   this draft is maintained in GitHub.  Suggested changes should be
   submitted as pull requests at https://github.com/ietf-wg-acme/acme
   [1].  Instructions are on that page as well.  Editorial changes can
   be managed in GitHub, but any substantive change should be discussed
   on the ACME mailing list ([email-masked]).

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-acme-acme/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-acme-acme-09
https://datatracker.ietf.org/doc/html/draft-ietf-acme-acme-09

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-acme-acme-09

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Richard Barnes <[email-masked]>
Date: Thu, 14 Dec 2017 09:16:48 -0500

For reference, this version incorporates several PRs that we got finished
since the last IETF meeting, listed below.  One I would like to note in
particular is that we added Daniel McCarney as a co-author in recognition
of the role he's already been playing, contributing a lot of text and
reviews.  Thanks, Daniel!  Now you're signed up to help address IESG review
comments :)

Chairs: I think this version is ready to go back into WGLC / IESG
processing.

--Richard

WIP: Further AD review responses (#348)
Removed "tel" URIs from the examples (#353)
Remove proactive issuance & csr-first new-order. (#342)
Remove optional "scope" field from authorization objects. (#349)
Define sub-problems. (#354)
Use consistent example URLs. (#352)
Remove incorrect "instance" usage. (#355)
List feedback (#357)
Responses to Gen-ART review (#358)
Fix detail key in sub-problems (#361)
Remove obsolete mention of authz reuse in pre-auth flow. (#365)
Ignore `.targets.mk`. (#366)
Remove the Out-of-Band (OOB) Challenge type. (#360)
Add order finalization examples, fix new-order examples. (#367)
Clarify external-account requirements (#359)
Add a registry to track 'meta' fields (#369)
Unifies to all object keys in camelCase (#362)
Add Daniel McCarney as co-author (#370)

On Thu, Dec 14, 2017 at 9:14 AM, <[email-masked]> wrote:

> _______________________________________________
> Acme mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/acme
>

---

From: Yoav Nir <[email-masked]>
Date: Thu, 14 Dec 2017 19:28:59 +0200

Hi

Draft-09 is now available and has (IMO) addressed all or the outstanding issues.

This starts an abbreviated WGLC for this draft. Please review the draft and send in your comments by EOD Monday the 25th. Please note that Monday the 25th is Christmas day, so don’t delay - send in your comments sooner rather than later.

If all goes well, we can go to IETF LC in early January and have this in the RFC Editor queue before the London meeting.

Yoav

> Begin forwarded message:
> 
> From: [email-masked]
> Subject: [Acme] I-D Action: draft-ietf-acme-acme-09.txt
> Date: 14 December 2017 at 16:14:02 GMT+2
> To: <[email-masked]>
> Cc: [email-masked]
> 
>

---

From: Yoav Nir <[email-masked]>
Date: Wed, 27 Dec 2017 06:46:04 +0200

Thank you for all who participated.

There have been two editorial changes suggested and accepted in the GitHub repository. As soon as a new draft is published, I think we can progress this.

Thanks again.

Yoav

> On 14 Dec 2017, at 19:28, Yoav Nir <[email-masked]> wrote:
> 
> Hi
> 
>> From: [email-masked] <mailto:[email-masked]>
>> To: <[email-masked] <mailto:[email-masked]>>
>> Cc: [email-masked] <mailto:[email-masked]>
>> 
>> 
>>   submitted as pull requests at https://github.com/ietf-wg-acme/acme <https://github.com/ietf-wg-acme/acme>
>>   on the ACME mailing list ([email-masked] <mailto:[email-masked]>).
>> 
>> 
>> https://datatracker.ietf.org/doc/draft-ietf-acme-acme/ <https://datatracker.ietf.org/doc/draft-ietf-acme-acme/>
>>

---

From: Yoav Nir <[email-masked]>
Date: Wed, 27 Dec 2017 21:15:58 +0200

I take that back.  Solve Sophie’s issue (from the other thread) first, and then publish a new draft.

> On 27 Dec 2017, at 6:46, Yoav Nir <[email-masked]> wrote:
> 
>> On 14 Dec 2017, at 19:28, Yoav Nir <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Hi
>> 
>>> https://tools.ietf.org/html/draft-ietf-acme-acme-09 <https://tools.ietf.org/html/draft-ietf-acme-acme-09>