Subject: Re: [Acme] YA WGLC for draft-ietf-acme-acme

From: Daniel McCarney <[email-masked]>
Date: Tue, 2 Jan 2018 14:52:40 -0500

Hi Yoav,

There are a few threads on the go from Sophie. Is there one in particular
you mean to reference here? Both?

Thanks!

On Wed, Dec 27, 2017 at 2:15 PM, Yoav Nir <[email-masked]> wrote:

> I take that back.  Solve Sophie’s issue (from the other thread) first, and
> then publish a new draft.
>
>
> On 27 Dec 2017, at 6:46, Yoav Nir <[email-masked]> wrote:
>
> Thank you for all who participated.
>
> There have been two editorial changes suggested and accepted in the GitHub
> repository. As soon as a new draft is published, I think we can progress
> this.
>
> Thanks again.
>
> Yoav
>
> On 14 Dec 2017, at 19:28, Yoav Nir <[email-masked]> wrote:
>
> Hi
>
> Draft-09 is now available and has (IMO) addressed all or the outstanding
> issues.
>
> This starts an abbreviated WGLC for this draft. Please review the draft
> and send in your comments by EOD Monday the 25th. Please note that Monday
> the 25th is Christmas day, so don’t delay - send in your comments sooner
> rather than later.
>
> If all goes well, we can go to IETF LC in early January and have this in
> the RFC Editor queue before the London meeting.
>
> Yoav
>
> Begin forwarded message:
>
> *From: [email-masked]
> *Subject: **[Acme] I-D Action: draft-ietf-acme-acme-09.txt*
> *Date: *14 December 2017 at 16:14:02 GMT+2
> *To: *<[email-masked]>
> *Cc: [email-masked]
>
>
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> This draft is a work item of the Automated Certificate Management
> Environment WG of the IETF.
>
>        Title           : Automatic Certificate Management Environment
> (ACME)
>        Authors         : Richard Barnes
>                          Jacob Hoffman-Andrews
>                          Daniel McCarney
>                          James Kasten
> Filename        : draft-ietf-acme-acme-09.txt
> Pages           : 80
> Date            : 2017-12-14
>
> Abstract:
>   Certificates in PKI using X.509 (PKIX) are used for a number of
>   purposes, the most significant of which is the authentication of
>   domain names.  Thus, certificate authorities in the Web PKI are
>   trusted to verify that an applicant for a certificate legitimately
>   represents the domain name(s) in the certificate.  Today, this
>   verification is done through a collection of ad hoc mechanisms.  This
>   document describes a protocol that a certification authority (CA) and
>   an applicant can use to automate the process of verification and
>   certificate issuance.  The protocol also provides facilities for
>   other certificate management functions, such as certificate
>   revocation.
>
>   RFC EDITOR: PLEASE REMOVE THE FOLLOWING PARAGRAPH: The source for
>   this draft is maintained in GitHub.  Suggested changes should be
>   submitted as pull requests at https://github.com/ietf-wg-acme/acme
>   [1].  Instructions are on that page as well.  Editorial changes can
>   be managed in GitHub, but any substantive change should be discussed
>   on the ACME mailing list ([email-masked]).
>
>
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-acme-acme/
>
> There are also htmlized versions available at:
> https://tools.ietf.org/html/draft-ietf-acme-acme-09
> https://datatracker.ietf.org/doc/html/draft-ietf-acme-acme-09
>
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-ietf-acme-acme-09
>
>
> Please note that it may take a couple of minutes from the time of
> submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
> _______________________________________________
> Acme mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/acme
>
>
>
>
>
> _______________________________________________
> Acme mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/acme
>
>

---

From: Yoav Nir <[email-masked]>
Date: Tue, 2 Jan 2018 22:15:16 +0200

I meant the one titled “Challenge objects are provoking implementation mistakes”

If there are other threads that are still open, then obviously let’s get them closed before submitting the next draft. 

> On 2 Jan 2018, at 21:52, Daniel McCarney <[email-masked]> wrote:
> 
> Hi Yoav,
> 
> There are a few threads on the go from Sophie. Is there one in particular you mean to reference here? Both?
> 
> Thanks!
> 
> 
> On Wed, Dec 27, 2017 at 2:15 PM, Yoav Nir <[email-masked] <mailto:[email-masked]>> wrote:
> I take that back.  Solve Sophie’s issue (from the other thread) first, and then publish a new draft.
> 
> 
>> On 27 Dec 2017, at 6:46, Yoav Nir <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> There have been two editorial changes suggested and accepted in the GitHub repository. As soon as a new draft is published, I think we can progress this.
>> 
>> Thanks again.
>> 
>> Yoav
>> 
>>> On 14 Dec 2017, at 19:28, Yoav Nir <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
>>> Hi
>>> 
>>> Draft-09 is now available and has (IMO) addressed all or the outstanding issues.
>>> 
>>> This starts an abbreviated WGLC for this draft. Please review the draft and send in your comments by EOD Monday the 25th. Please note that Monday the 25th is Christmas day, so don’t delay - send in your comments sooner rather than later.
>>> 
>>> If all goes well, we can go to IETF LC in early January and have this in the RFC Editor queue before the London meeting.
>>> 
>>> Yoav
>>> 
>>>> Begin forwarded message:
>>>> 
>>>> From: [email-masked] <mailto:[email-masked]>
>>>> Subject: [Acme] I-D Action: draft-ietf-acme-acme-09.txt
>>>> Date: 14 December 2017 at 16:14:02 GMT+2
>>>> To: <[email-masked] <mailto:[email-masked]>>
>>>> Cc: [email-masked] <mailto:[email-masked]>
>>>> 
>>>> 
>>>> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>>>> This draft is a work item of the Automated Certificate Management Environment WG of the IETF.
>>>> 
>>>>        Title           : Automatic Certificate Management Environment (ACME)
>>>>        Authors         : Richard Barnes
>>>>                          Jacob Hoffman-Andrews
>>>>                          Daniel McCarney
>>>>                          James Kasten
>>>>   submitted as pull requests at https://github.com/ietf-wg-acme/acme <https://github.com/ietf-wg-acme/acme>
>>>>   on the ACME mailing list ([email-masked] <mailto:[email-masked]>).
>>>> 
>>>> 
>>>> https://datatracker.ietf.org/doc/draft-ietf-acme-acme/ <https://datatracker.ietf.org/doc/draft-ietf-acme-acme/>
>>>> 
>>>> https://tools.ietf.org/html/draft-ietf-acme-acme-09 <https://tools.ietf.org/html/draft-ietf-acme-acme-09>
>>>> https://datatracker.ietf.org/doc/html/draft-ietf-acme-acme-09 <https://datatracker.ietf.org/doc/html/draft-ietf-acme-acme-09>
>>>> 
>>>> https://www.ietf.org/rfcdiff?url2=draft-ietf-acme-acme-09 <https://www.ietf.org/rfcdiff?url2=draft-ietf-acme-acme-09>
>>>> 
>>>> 
>>>> Please note that it may take a couple of minutes from the time of submission
>>>> until the htmlized version and diff are available at tools.ietf.org <http://tools.ietf.org/>.
>>>> 
>>>> ftp://ftp.ietf.org/internet-drafts/ <ftp://ftp.ietf.org/internet-drafts/>
>>>> 
>>>> [email-masked] <mailto:[email-masked]>
>>>> https://www.ietf.org/mailman/listinfo/acme <https://www.ietf.org/mailman/listinfo/acme>
>>> 
>> 
> 
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/acme <https://www.ietf.org/mailman/listinfo/acme>
> 
>

---

From: Daniel McCarney <[email-masked]>
Date: Tue, 2 Jan 2018 15:19:35 -0500

Sounds good.

I think in addition to the "Challenge objects are provoking implementation
mistakes" thread the other thread to address is "Challenge url -> finalize
flow and status definitions".

On Tue, Jan 2, 2018 at 3:15 PM, Yoav Nir <[email-masked]> wrote:

> If there are other threads that are still open, then obviously let’s get
> them closed before submitting the next draft.
>
>
>> There have been two editorial changes suggested and accepted in the
>> GitHub repository. As soon as a new draft is published, I think we can
>> progress this.
>>
>> Thanks again.
>>
>> Yoav
>>