Subject: [Acme] IETF 107; agenda

From: "Salz, Rich" <[email-masked]>
Date: Mon, 9 Mar 2020 15:11:08 +0000

Yaron and I cannot attend and will be remote.  We have volunteers to act as chairs for us (on CC).  Looking at the list below, it seems reasonable to cancel our session.  PLEASE POST IF YOU DISAGREE.  Of course "they" may decide to cancel anyway, but please post your opinion here.

Let’s look at the documents in our queue and see which need time at IETF 107.  See https://datatracker.ietf.org/wg/acme/documents/ to link to the document.

draft-ietf-acme-authority-token-04, ACME Challenges Using an Authority Token -and-
draft-ietf-acme-authority-token-tnauthlist-05,  TNAuthList profile of ACME Authority Token
	Any update from the authors?  Is this ready for WGLC?
	This has never had much in-person discussion, and the domain expertise is in STIR

draft-ietf-acme-client-00, ACME End User Client and Code Signing Certificates
	Any updates?  This was recently adopted by the WG.

draft-ietf-acme-integrations-00, ACME Integrations
	Michael Richardson can present.

draft-friel-acme-subdomains-02
	Michael Richardson can present; this is a topic for WG adoption

draft-ietf-acme-email-smime-06, Extensions to Automatic Certificate Management Environment for end user S/MIME certificates
	Any updates?  Ready for WGLC?

draft-ietf-acme-star-delegation-03, An ACME Profile for Generating Delegated STAR Certificates
	Yaron just pushed a new update.  Does this need F2F time?  The main document (draft-ietf-acme-star-11,  Support for Short-Term, Automatically-Renewed (STAR) Certificates in Automated Certificate Management Environment (ACME) is already in IESG review and probably wants this one to be in the same bundle.)

---

From: Yoav Nir <[email-masked]>
Date: Mon, 9 Mar 2020 19:34:23 +0200

…and Yoav won’t be there either. No idea about Yaron.

> On 9 Mar 2020, at 17:11, Salz, Rich <rsalz=[email-masked]> wrote:
> 
> _______________________________________________
> Acme mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/acme

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 9 Mar 2020 17:42:50 +0000

That is what I get for looking at the "new draft" email from Yaron while writing mail to ACME.  Ooops.

On 3/9/20, 1:34 PM, "Yoav Nir" <[email-masked]> wrote:

---

From: Yaron Sheffer <[email-masked]>
Date: Mon, 09 Mar 2020 22:55:23 +0200

It would not be the first time people confused Yoav and myself. I am honored...

Yaron (me) is not planning to be there, I am banned by both my company and my government.

Re: STAR, Rich didn't get it completely right: the base STAR is in AUTH48 and might actually get published in the next day or two. STAR Delegation has made lots of progress since the last meeting, but personally (I have not consulted with my coauthors) I think is not ready for LC yet. I'll be happy to present the progress remotely, if the meeting does happen.

Thanks,
	Yaron

On 3/9/20, 19:42, "Salz, Rich" <[email-masked]> wrote:

---

From: Michael Richardson <[email-masked]>
Date: Mon, 09 Mar 2020 17:46:32 -0400

Salz, Rich <rsalz=[email-masked]> wrote:
      > Yaron and I cannot attend and will be remote.  We have volunteers to
      > act as chairs for us (on CC).  Looking at the list below, it seems
      > reasonable to cancel our session.  PLEASE POST IF YOU DISAGREE.  Of
      > course "they" may decide to cancel anyway, but please post your
      > opinion here.

Hi, if you are going to cancel (I would prefer NOT to), then please schedule
    a virtual interim for early April to replace it.

    > This has never had much in-person discussion, and the domain expertise is in STIR

I have read this document when it came up in STIR, and I don't think that
here is much to say about this.  Is there feedback from implementers? I don't
think that this needs face time to advance.

    > Any updates?  This was recently adopted by the WG.

no idea.

    > Michael Richardson can present.

I was given some slides (wasn't I Owen? Or did you just say that you'd send
some), and the major item was to clarify the changes that were made based
comments.   I think that there isn't much to say.   I have running code that
integrates ACME with a BRSKI Registrar.

    > Michael Richardson can present; this is a topic for WG adoption

At first, I think that we thought that this work required no standard action,
because it was within the server's policy to do this or not.
However, the client may not know the server's policy, and so section 5 adds
the basedomain and implicitSubdomainAuthorization boolean.  If it comes back
false (or missing), then the client knows it has to perform authorizations for
every request (which is what my code above does).

I think that the WG previously expressed interest in adopting it, pending
some changes, and those changes are made.  It may not need actual WG time,
except that having it on a schedule sometimes gets a document read :-)

    > draft-ietf-acme-email-smime-06, Extensions to Automatic Certificate
    > Management Environment for end user S/MIME certificates

    > Yaron just pushed a new update.  Does this need F2F time?  The main
    > document (draft-ietf-acme-star-11,  Support for Short-Term,
    > Automatically-Renewed (STAR) Certificates in Automated Certificate
    > Management Environment (ACME) is already in IESG review and probably
    > wants this one to be in the same bundle.)

I think both are ready to be adopted.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: "Owen Friel (ofriel)" <[email-masked]>
Date: Tue, 10 Mar 2020 07:36:33 +0000

-----Original Message-----
From: Acme <[email-masked]> On Behalf Of Michael Richardson
Sent: 10 March 2020 05:47
To: Salz, Rich <rsalz=[email-masked]>
Cc: Alexey Melnikov <[email-masked]>; [email-masked]; Mary Barnes <[email-masked]>
Subject: Re: [Acme] IETF 107; agenda

    > Michael Richardson can present.

I was given some slides (wasn't I Owen? Or did you just say that you'd send some), and the major item was to clarify the changes that were made based
comments.   I think that there isn't much to say.   I have running code that
integrates ACME with a BRSKI Registrar.

[ofriel] you *will be* given some slides :)

    > Michael Richardson can present; this is a topic for WG adoption

At first, I think that we thought that this work required no standard action, because it was within the server's policy to do this or not.
However, the client may not know the server's policy, and so section 5 adds the basedomain and implicitSubdomainAuthorization boolean.  If it comes back false (or missing), then the client knows it has to perform authorizations for every request (which is what my code above does).

I think that the WG previously expressed interest in adopting it, pending some changes, and those changes are made.  It may not need actual WG time, except that having it on a schedule sometimes gets a document read :-)

 [ofriel] Similarly, you *will be* given some slides :)

---

From: Yoav Nir <[email-masked]>
Date: Tue, 10 Mar 2020 22:07:18 +0200

> Yaron and I cannot attend and will be remote.  We have volunteers to act as chairs for us (on CC).  Looking at the list below, it seems reasonable to cancel our session.  PLEASE POST IF YOU DISAGRE…

As it turns out, this decision has been made for us, as the entire meeting has been cancelled.

We will discuss on this list whether, when, and in what format we are planning on having a virtual meeting to replace the physical one.

See you all around, physically or virtually

Rich and Yoav

---

From: Mary Barnes <[email-masked]>
Date: Tue, 10 Mar 2020 15:21:04 -0500

So, I thought it was a possibility to have the week consist of all virtual
meetings.  Or has that been totally removed from the table?  Some of us
like that option as we've already blocked that week in our calendars.

On Tue, Mar 10, 2020 at 3:07 PM Yoav Nir <[email-masked]> wrote:

> > Yaron and I cannot attend and will be remote.  We have volunteers to act
> as chairs for us (on CC).  Looking at the list below, it seems reasonable
> to cancel our session.  PLEASE POST IF YOU DISAGREE.  Of course "they" may
> decide to cancel anyway, but please post your opinion here.
>
> We will discuss on this list whether, when, and in what format we are
> planning on having a virtual meeting to replace the physical one.
>

---

From: Yoav Nir <[email-masked]>
Date: Tue, 10 Mar 2020 22:24:48 +0200

The IESG are considering the options and will let us know. The intent is still to have a week of virtual meetings.

After that ACME can decide if we’re participating in that, or making our own virtual interim a few weeks later.

> On 10 Mar 2020, at 22:21, Mary Barnes <[email-masked]> wrote:
> 
> So, I thought it was a possibility to have the week consist of all virtual meetings.  Or has that been totally removed from the table?  Some of us like that option as we've already blocked that week in our calendars.  
> 
> On Tue, Mar 10, 2020 at 3:07 PM Yoav Nir <[email-masked] <mailto:[email-masked]>> wrote:
> 
> 
> > On 9 Mar 2020, at 17:11, Salz, Rich <rsalz=[email-masked] <mailto:[email-masked]>> wrote:
> >

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 12 Mar 2020 18:49:55 +0000

The IESG has posted a a virtual-107 schedule, it's available at https://mailarchive.ietf.org/arch/msg/ietf/i-tbl-a8fSzqT6sl92xXdfRPDAY/
It's only a subset of the original face-to-face schedule, and their rationale is included in the message.

ACME is not on the list.  So let's proceed with the usual process of email.  If the WG wants a virtual interim, we can do that.  So far only one person has requested it. If anyone else is interested, please post.

	/r$