Subject: [Acme] I-D Action: draft-ietf-acme-dtnnodeid-09.txt

From: [email-masked]
Date: Wed, 02 Mar 2022 16:34:56 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Automated Certificate Management Environment WG of the IETF.

        Title           : Automated Certificate Management Environment (ACME) Delay-Tolerant Networking (DTN) Node ID Validation Extension
        Author          : Brian Sipos
	Filename        : draft-ietf-acme-dtnnodeid-09.txt
	Pages           : 31
	Date            : 2022-03-02

Abstract:
   This document specifies an extension to the Automated Certificate
   Management Environment (ACME) protocol which allows an ACME server to
   validate the Delay-Tolerant Networking (DTN) Node ID for an ACME
   client.  The DTN Node ID is encoded as a certificate Subject
   Alternative Name (SAN) of type otherName with a name form of
   BundleEID and as an ACME Identifier type "bundleEID".

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-acme-dtnnodeid/

There is also an HTML version available at:
https://www.ietf.org/archive/id/draft-ietf-acme-dtnnodeid-09.html

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-acme-dtnnodeid-09

Internet-Drafts are also available by rsync at rsync.ietf.org::internet-drafts

---

From: Brian Sipos <[email-masked]>
Date: Wed, 2 Mar 2022 23:26:52 -0500

All,
I have posted an update to the Node ID Validation document which updates
references to now-published DTN RFCs (yay!) and adds algorithm agility for
the Key Authorization Digest to avoid the validation method being stuck on
SHA-256. It does add a publication dependency on the COSE hash document,
but that is in AUTH48 (though it's been stuck in that state for some time
now).
Comments are welcome and can be discussed at the next IETF.
Brian S.

On Wed, Mar 2, 2022 at 7:35 PM <[email-masked]> wrote:

>         Title           : Automated Certificate Management Environment
> (ACME) Delay-Tolerant Networking (DTN) Node ID Validation Extension
>         Author          : Brian Sipos
> _______________________________________________
> Acme mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/acme
>

---

From: Roman Danyliw <[email-masked]>
Date: Sun, 20 Mar 2022 21:28:55 +0000

Hi!

We’re past IETF LC in terms of document processing and -08 and -09 appear to have changed protocol behavior.  Since there hasn’t been any discussion about this on the mailing list yet, I’d like to ask the WG to review these changes (https://www.ietf.org/rfcdiff?url1=draft-ietf-acme-dtnnodeid-07&url2=draft-ietf-acme-dtnnodeid-09).  Please raise any objections by Friday April 1.

Helpfully, this document is on the ACME meeting agenda tomorrow at IETF 113.

Regards,
Roman

From: Acme <[email-masked]> On Behalf Of Brian Sipos
Sent: Wednesday, March 2, 2022 11:27 PM
To: IETF ACME <[email-masked]>
Subject: Re: [Acme] I-D Action: draft-ietf-acme-dtnnodeid-09.txt

All,
I have posted an update to the Node ID Validation document which updates references to now-published DTN RFCs (yay!) and adds algorithm agility for the Key Authorization Digest to avoid the validation method being stuck on SHA-256. It does add a publication dependency on the COSE hash document, but that is in AUTH48 (though it's been stuck in that state for some time now).
Comments are welcome and can be discussed at the next IETF.
Brian S.

On Wed, Mar 2, 2022 at 7:35 PM <[email-masked]<mailto:[email-masked]>> wrote:

Abstract:

_______________________________________________
Acme mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/acme

---

From: Deb Cooley <[email-masked]>
Date: Mon, 21 Mar 2022 07:12:32 -0400

It is on the agenda.  We will ask for volunteers to review.

Deb

On Sun, Mar 20, 2022 at 5:29 PM Roman Danyliw <[email-masked]> wrote:

> Hi!
>
>
>
> We’re past IETF LC in terms of document processing and -08 and -09 appear
> to have changed protocol behavior.  Since there hasn’t been any discussion
> about this on the mailing list yet, I’d like to ask the WG to review these
> changes (
> https://www.ietf.org/rfcdiff?url1=draft-ietf-acme-dtnnodeid-07&url2=draft-ietf-acme-dtnnodeid-09).
> Please raise any objections by Friday April 1.
>
>
>
> *From:* Acme <[email-masked]> *On Behalf Of * Brian Sipos
> *Sent:* Wednesday, March 2, 2022 11:27 PM
> *To:* IETF ACME <[email-masked]>
> *Subject:* Re: [Acme] I-D Action: draft-ietf-acme-dtnnodeid-09.txt
>
>
>
> All,
>