Subject: [Actn] ACTN framework draft

From: Daniele Ceccarelli <[email-masked]>
Date: Fri, 14 Feb 2014 17:45:39 +0000

Hi all,

A new version of the framework drafts has been published. Please find the link below.

http://tools.ietf.org/html/draft-ceccarelli-actn-framework-01

BR
Daniele and co-authors

---

From: [email-masked]
Date: Wed, 26 Feb 2014 08:17:46 -0800 (PST)

ACTN Framework co-authors,

First of all, this is a very good draft, well written and on the mark.  Unfortunately I have not been able to contribute much to this mailing list due to my internal commitment to a major product launch and customer trial.  I am still very much interested in the activities of ACTN.  Here are a couple of my input after reviewing the Framework draft.

Security:  The draft mentioned some security requirements, such as secure programming models, secure tunnels, encryption, privacy and isolation, however, not much detail were given in the draft.   In addition, some additional security requirements are missing.  For example, any security dealing with the data stored in the controller for decision making, location related security requirements, and so on. 

From a carrier's perspective (as I am actively preparing for the ACTN lab trial), my biggest concerns are: security #1, scalability #2.  Feature, functionality, and performance are important, but not nearly as critical in making the go-no-go decision with the adoption of the technology.  Perhaps the Framework is not the right place.  We will likely need a Requirement draft that covers some of the security concerns.

Scalability: The scalability has to be viewed horizontally (geographical coverage and its impact on protocol responsiveness and the total system performance) and vertically (request/response capacity and time, and rejection/retry/wait/drop).  

Programmability: this draft focused much of its attention to the networks, which is good.  But I feel it should also have more discussion on the Interfaces between the Application (Provisioning Systems, Billing Systems, DC Manager/orchestrator) and the controller.  The non-protocol related solutions are beyond IETF scope, however, its existence and interaction should be described in the Framework draft. 

Ning So
972-955-0914

On Friday, February 14, 2014 11:45 AM, Daniele Ceccarelli <[email-masked]> wrote:

Hi all, 

  
BR
Daniele and co-authors   
_______________________________________________
ACTN mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/actn

---

From: Leeyoung <[email-masked]>
Date: Thu, 27 Feb 2014 22:48:23 +0000

Hi Ning,

Thanks for providing your support of ACTN work and great comments. Here's my initial comment to yours; please see in-line.

Cheers,
Young

From: ACTN [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, February 26, 2014 10:18 AM
To: Daniele Ceccarelli; [email-masked]
Subject: Re: [Actn] ACTN framework draft

YOUNG>> Definitely, security is one of the most important requirements for ACTN work. We will try to address more detailed description of security requirements in the updated version. By the way, what do you mean "Location related Security"?

>From a carrier's perspective (as I am actively preparing for the ACTN lab trial), my biggest concerns are: security #1, scalability #2.  Feature, functionality, and performance are important, but no…

YOUNG>> Can you share some more info as to your ACTN lab trial? It is really great to hear that carriers like Tata are endorsing the ACTN ideas into lab trials. This will certainly boost up more industry interest especially from carriers.

YOUNG>> Good point. We will include these details on our scalability requirements.

YOUNG>> We have actually addressed network-side programmability between the Virtual Network Controller (VNC) and the Physical Network Controller (PNC) as well as customer control interface between Customer Controller and V/P Network Controllers. We will include operations/management aspect in the next revision to show how OSS/BSS can interact with Customer Controllers, etc.

Ning So
972-955-0914

On Friday, February 14, 2014 11:45 AM, Daniele Ceccarelli <[email-masked]<mailto:[email-masked]>> wrote:
Hi all,

BR
Daniele and co-authors

_______________________________________________
ACTN mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/actn

---

From: [email-masked]
Date: Thu, 27 Feb 2014 14:57:16 -0800 (PST)

Young,

Please see my comments inline.

Ning So
972-955-0914

On Thursday, February 27, 2014 4:48 PM, Leeyoung <[email-masked]> wrote:
  
Hi Ning, 
  
Thanks for providing your support of ACTN work and great comments. Here’s my initial comment to yours; please see in-line. 
  
Cheers, 
Young 
  
From:ACTN [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, February 26, 2014 10:18 AM
To: Daniele Ceccarelli; [email-masked]
Subject: Re: [Actn] ACTN framework draft   

   
  
YOUNG>> Definitely, security is one of the most important requirements for ACTN work. We will try to address more detailed description of security requirements in the updated version. By the way, what do you mean “Location related Security”? 

Ning: There can be a lot of information, some are network related, while others are application/customer related, carried in a global carrier's network.  Those information is critical for making optimal decision by the ACTN controller.  However, some information are geographic location bound by the law.  That is the most basic form of location-related security for the data/information.  We can discuss some more advanced security requirements privately.  

Ning: This is not yet a public information.  We are in the process of RFI/RFP.  Please do not consider this mentioning of lab trial as a public disclosure of the information.    

   

Ning: great.  It is much needed.

Ning So  
972-955-0914  

   
   
BR
Daniele and co-authors