Subject: [Actn] Draft Slides have been uploaded for ACTN BOF

From: Leeyoung <[email-masked]>
Date: Mon, 3 Nov 2014 18:18:44 +0000

Hi,

Please check the following link to take a look at draft slides uploaded.

https://datatracker.ietf.org/meeting/91/materials.html#rtg

We are still missing a couple of slide decks for problem statement and architecture option 2. They should be uploaded soon.

I think we can begin some discussion around these slides. One question I'd like to begin is on Slide 5 (Protocol Work), page 8 it talks about the need for Yang DM for topology. And this slides talks about different kinds of topology: path vector and abstract/physical topology as forms of TED and LSP DB, etc. One question I have is Are we assuming these Yang DM's be transport using Netconf? Or are we seeing the need for decoupling of YANG from Netconf? If we think the decoupling of YANG from Netconf, then would this be in scope? I believe this applies to all WG's that have some work on YANG. I have seen PCE WG in which YANG model is proposed to enhance PCEP. Would this be analogous to ACTN?

Thanks,
Young

---

From: Dhruv Dhody <[email-masked]>
Date: Tue, 4 Nov 2014 16:02:42 +0000

Hi Young, All,

[Dhruv]: Yang models are used by NetConf/RestConf only (so far).
I2RS is further using the same for its requirements.

Above work is focus primarily in communication to the device, in case of ACTN , the big difference is, that we are using the model for the communication between controllers.
But taking a cue from opendaylight - yang models with RestConf works well as north bound API at the controller. So perhaps Yang/Restconf should be explored first.

If there are any gaps in RestConf/Yang as far as ACTN requirements are concerned, then better approach would be to enhance them rather than reinventing new protocols for controllers.

Dhruv

---

From: Leeyoung <[email-masked]>
Date: Tue, 4 Nov 2014 16:09:42 +0000

Hi Dhruv,

Thanks for giving us further information. If such topology transport has a need for dynamic synchronization after changes of physical network resources that affect virtual networks (for customer) and the e2e abstract topology (that multi-domain coordination function keeps at VNC), would NetConf be a good protocol for that?

Regards,
Young

From: Dhruv Dhody
Sent: Tuesday, November 04, 2014 10:03 AM
To: Leeyoung; [email-masked]
Cc: Adrian Farrel; Daniele Ceccarelli; Dan King ([email-masked])
Subject: RE: Draft Slides have been uploaded for ACTN BOF

Hi Young, All,

Dhruv

---

From: Dhruv Dhody <[email-masked]>
Date: Tue, 4 Nov 2014 16:21:04 +0000

Hi Young,

NetConf/RestConf have mechanism to generate notifications, perhaps these notifications can be modeled to -

-          notify the exact change in the notification itself

-          notify that a change has taken place and one must get renewed data.

Dhruv

From: Leeyoung
Sent: 04 November 2014 21:40
To: Dhruv Dhody; [email-masked]
Cc: Adrian Farrel; Daniele Ceccarelli; Dan King ([email-masked])
Subject: RE: Draft Slides have been uploaded for ACTN BOF

Hi Dhruv,

Regards,
Young

From: Dhruv Dhody
Sent: Tuesday, November 04, 2014 10:03 AM
To: Leeyoung; [email-masked]<mailto:[email-masked]>
Cc: Adrian Farrel; Daniele Ceccarelli; Dan King ([email-masked]<mailto:[email-masked]>)
Subject: RE: Draft Slides have been uploaded for ACTN BOF

Hi Young, All,

Dhruv