Subject: Re: [Add] [Ext] Adam Roach's No Objection on charter-ietf-add-00-00: (with COMMENT)

From: "Deen, Glenn (NBCUniversal)" <[email-masked]>
Date: Tue, 4 Feb 2020 15:01:03 +0000

On 2/4/20, 4:46 AM, "Add on behalf of Eric Rescorla" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

On Tue, Feb 4, 2020 at 4:37 AM Paul Hoffman <[email-masked]<mailto:[email-masked]>> wrote:

>> - develop an informational document that describes how client
>>  applications and systems can manage selection of DNS resolvers
>>  in various network environments and use cases.
>
> Here I agree with both EKR and Éric that the described work is open-ended
> enough to result in unproductive and likely toxic interactions. It would
> be my strong recommendation to strike it from the charter at this time,
> with an intention of re-visiting it if the working group is able to
> productively make headway on the less-contentious issues called for by
> the other deliverables. It may well be that this community finds a
> positive way of interacting by solving the concrete discovery
> mechanisms described above, and can then leverage the relationships
> and trust they build during that exercise to succeed where conversations
> have so far been fruitless. But I fear that putting this on the plate
> as part of the first tranche of work is likely to lead to the same
> acrimony that has dogged this endeavor in the past.

However, taking it fully off the plate will lead to the same discussions happening repeatedly due to current deployment strategies of major vendors.

Well, perhaps, but we don't need an IETF WG for those discussions and the evidence is that that's not a productive venue for them.

While the ADD list and BoFs have certainly not been productive venues for discussions that’s largely attributable to a variety of factors which likely won’t be present in actual WG.   The ADD list and BoFs have been very broad and wide open, and lacked the focus of a charter, which resulted in unproductive discussions that didn’t progress.  The WG conversely will have a specific charter to focus it and chairs to help manage the activity.     That will let the IETF process of drafts, discussions, revisions, and more discussions to move things forward productively.

The general topic has also evolved considerably since 2019 which should help.  Now that there are deployment efforts going on, there is a growing amount of experience being gained that is helping people understand what’s actually needed as opposed to open speculation, assertion and opinion.  That should help move things from unproductive open ended abstract discussion toward productive focused activity.

-Glenn

---

From: Adam Roach <[email-masked]>
Date: Tue, 4 Feb 2020 10:12:00 -0600

On 2/4/20 09:01, Deen, Glenn (NBCUniversal) wrote:
>
> On 2/4/20, 4:46 AM, "Add on behalf of Eric Rescorla" 
> <[email-masked] <mailto:[email-masked]> on behalf of 
> [email-masked] <mailto:[email-masked]>> wrote:
>
>     However, taking it fully off the plate will lead to the same
>     discussions happening repeatedly due to current deployment
>     strategies of major vendors.
>
> Well, perhaps, but we don't need an IETF WG for those discussions and 
> the evidence is that that's not a productive venue for them.
>
>
> While the ADD list and BoFs have certainly not been productive venues 
> for discussions that’s largely attributable to a variety of factors 
> which likely won’t be present in actual WG.   The ADD list and BoFs 
> have been very broad and wide open, and lacked the focus of a charter, 
> which resulted in unproductive discussions that didn’t progress.  The 
> WG conversely will have a specific charter to focus it and chairs to 
> help manage the activity.
>

Thanks. I completely agree that there is useful work that a 
tightly-scoped charter can foster. I also agree with the implied 
converse, which is that an insufficiently-tightly-scoped charter will 
make useful work difficult or impossible.

/a

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 4 Feb 2020 08:37:29 -0800

In the interest of trying to move forward....

I agree that there are a bunch of tricky network scenarios that
need to be handled (captive portals, VPNs, split DNS, etc.) and
that providing some guidance here would be useful. What I'm trying
to avoid is that bleeding into a lot of debating about policy and
how particular clients ought to behave. With that in mind,
here is what I suggest:

1. Revise that bullet to be more clearly technical:

   - develop an informational document that describes mechanisms for
   clients to detect specific network environments (captive portal,
   split horizon, etc.) and use that to inform their DNS
   configuration.

2. Add a sentence to the charter after the work items that says:

   "This working group is chartered solely to develop technical
   mechanisms. Making any recommendations about specific policies
   for clients and servers is out of scope."

I think this would go a long way towards continuing the forms
of productive engagement we have been seeing (which I agree
there have been) while scoping out contentious and unproductive
policy debates.

-Ekr

On Tue, Feb 4, 2020 at 8:12 AM Adam Roach <[email-masked]> wrote:

> On 2/4/20, 4:46 AM, "Add on behalf of Eric Rescorla" <[email-masked]
> on behalf of [email-masked]> wrote:
>
>
>
> On Tue, Feb 4, 2020 at 4:37 AM Paul Hoffman <[email-masked]>
> wrote:
>
>
> However, taking it fully off the plate will lead to the same discussions
> happening repeatedly due to current deployment strategies of major vendors.
>
>
>
> Well, perhaps, but we don't need an IETF WG for those discussions and the
> evidence is that that's not a productive venue for them.
>
>
> While the ADD list and BoFs have certainly not been productive venues for
> discussions that’s largely attributable to a variety of factors which
> likely won’t be present in actual WG.   The ADD list and BoFs have been
> very broad and wide open, and lacked the focus of a charter, which resulted
> in unproductive discussions that didn’t progress.  The WG conversely will
> have a specific charter to focus it and chairs to help manage the activity.
>
>
> Thanks. I completely agree that there is useful work that a tightly-scoped
> charter can foster. I also agree with the implied converse, which is that
> an insufficiently-tightly-scoped charter will make useful work difficult or
> impossible.
>
> /a
>

---

From: Adam Roach <[email-masked]>
Date: Tue, 4 Feb 2020 10:41:47 -0600

> there have been) while scoping out contentious and unproductive

Thanks. This crossed on the wire with my previous message, and I think 
it's a good example of the kinds of guiderails I was calling for.

/a

---

From: Brian Dickson <[email-masked]>
Date: Tue, 4 Feb 2020 09:43:25 -0800

>    for clients and servers is out of scope."
I'm fine if the wording on this can be adequately tuned, to match the goal.
There are enough people in the world who can't distinguish these two kinds
of things:
"If X then Y"
"X"

I.e. What I am looking for, semantically, is that it is okay to have
technical work for addressing
policy goals, without that running afoul of the policy advocacy rule.
That leaves any policy decisions to the developer/operator/user, but allows
standardization
(or informational documents or experimental work) on how to
implement/operate/select
the mechanism(s) that correspond to a particular policy.)

The specifics of which work items within this area get worked on would be
based on interest, etc.,
with adoption by the WG after initial work would be subject to WG adoption
rules (consensus).

Is this what you meant by, or is this consistent with,  #1 and #2 above?

Brian

>> On 2/4/20, 4:46 AM, "Add on behalf of Eric Rescorla" <
>> [email-masked] on behalf of [email-masked]> wrote:
>>
>>
>>
>> tightly-scoped charter can foster. I also agree with the implied converse,
>> which is that an insufficiently-tightly-scoped charter will make useful
>> work difficult or impossible.
>>
>> /a
>>
> --
> Add mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/add
>

---

From: Tommy Pauly <[email-masked]>
Date: Tue, 04 Feb 2020 09:56:01 -0800

> On Feb 4, 2020, at 8:41 AM, Adam Roach <[email-masked]> wrote:
> 
> Thanks. This crossed on the wire with my previous message, and I think it's a good example of the kinds of guiderails I was calling for.

+1

I think both of these textual changes are appropriate, and clarify the intent of the charter, without unduly constraining the technical work of a group. I support performing both of these changes!

Thanks ekr for the suggestions.

Best,
Tommy

---

From: "Deen, Glenn (NBCUniversal)" <[email-masked]>
Date: Tue, 4 Feb 2020 18:04:31 +0000

On 2/4/20, 9:56 AM, "Add on behalf of Tommy Pauly" <[email-masked] on behalf of tpauly=[email-masked]> wrote:

    
    +1

    
    Best,
    Tommy

+1

I also don't have any heartburn with either of the suggested changes. They clarify the mission while keeping the charter clean enough that it's simple to read and understand.

-glenn

    -- 
    Add mailing list
    [email-masked]
    https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/add__;!!PIZeeW5wscynRQ!5OGEBWi5Dzvjs47pyHKrG_y_kSDWz6cwx4Y5yoU3HL263unJxStT7LZA0RJJpz2W$

---

From: Tommy Jensen <[email-masked]>
Date: Tue, 4 Feb 2020 18:20:45 +0000

+1, the spirit of what I want from the charter is preserved.

________________________________
From: Add <[email-masked]> on behalf of Deen, Glenn (NBCUniversal) <[email-masked]>
Sent: Tuesday, February 4, 2020 10:04 AM
To: Tommy Pauly <tpauly=[email-masked]>; Adam Roach <[email-masked]>
Cc: Eric Rescorla <[email-masked]>; Deen, Glenn (NBCUniversal) <[email-masked]>; [email-masked] <[email-masked]>; Paul Hoffman <[email-masked]>; ADD Mailing list <[email-masked]>; The IESG <[email-masked]>
Subject: Re: [Add] [EXTERNAL] Re: [Ext] Adam Roach's No Objection on charter-ietf-add-00-00: (with COMMENT)

    +1

    Best,
    Tommy

+1

-glenn

    --
    Add mailing list
    [email-masked]
    https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fadd&amp;data=02%7C01%7CJensen.Thomas%40microsoft.com%7C4423ed5ebe574671818608d7a99cb682%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637164362894043788&amp;sdata=0DsLiK%2FgODuVBOBMv195hFlGzl1AOkawvQk3eRL%2FSB0%3D&amp;reserved=0

--
Add mailing list
[email-masked]
https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fadd&amp;data=02%7C01%7CJensen.Thomas%40microsoft.com%7C4423ed5ebe574671818608d7a99cb682%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637164362894043788&amp;sdata=0DsLiK%2FgODuVBOBMv195hFlGzl1AOkawvQk3eRL%2FSB0%3D&amp;reserved=0

---

From: Andrew Campling <[email-masked]>
Date: Tue, 4 Feb 2020 18:24:58 +0000

Another +1 – a helpful change if this provides reassurance that there is no intended mission creep and provides the basis for the working group chartering process to move forward.

Andrew

From: Tommy Jensen <[email-masked]>
Sent: 04 February 2020 18:21
To: Deen, Glenn (NBCUniversal) <[email-masked]>; Tommy Pauly <tpauly=[email-masked]>; Adam Roach <[email-masked]>
Cc: Eric Rescorla <[email-masked]>; [email-masked]; Paul Hoffman <[email-masked]>; ADD Mailing list <[email-masked]>; The IESG <[email-masked]>
Subject: Re: [Add] [EXTERNAL] Re: [Ext] Adam Roach's No Objection on charter-ietf-add-00-00: (with COMMENT)

________________________________
From: Add <[email-masked]<mailto:[email-masked]>> on behalf of Deen, Glenn (NBCUniversal) <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, February 4, 2020 10:04 AM
To: Tommy Pauly <tpauly=[email-masked]<mailto:tpauly=[email-masked]>>; Adam Roach <[email-masked]<mailto:[email-masked]>>
Cc: Eric Rescorla <[email-masked]<mailto:[email-masked]>>; Deen, Glenn (NBCUniversal) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>; Paul Hoffman <[email-masked]<mailto:[email-masked]>>; ADD Mailing list <[email-masked]<mailto:[email-masked]>>; The IESG <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Add] [EXTERNAL] Re: [Ext] Adam Roach's No Objection on charter-ietf-add-00-00: (with COMMENT)

On 2/4/20, 9:56 AM, "Add on behalf of Tommy Pauly" <[email-masked] on behalf of tpauly=[email-masked]<mailto:[email-masked]%20on%20behalf%20of%20tpauly=[email-masked]>> wrote:

    > On Feb 4, 2020, at 8:41 AM, Adam Roach <[email-masked]<mailto:[email-masked]>> wrote:
    >

    +1

    Best,
    Tommy

+1

-glenn

    --
    Add mailing list
    [email-masked]<mailto:[email-masked]>
    https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fadd&amp;data=02%7C01%7CJensen.Thomas%40microsoft.com%7C4423ed5ebe574671818608d7a99cb682%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637164362894043788&amp;sdata=0DsLiK%2FgODuVBOBMv195hFlGzl1AOkawvQk3eRL%2FSB0%3D&amp;reserved=0

--
Add mailing list
[email-masked]<mailto:[email-masked]>
https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fadd&amp;data=02%7C01%7CJensen.Thomas%40microsoft.com%7C4423ed5ebe574671818608d7a99cb682%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637164362894043788&amp;sdata=0DsLiK%2FgODuVBOBMv195hFlGzl1AOkawvQk3eRL%2FSB0%3D&amp;reserved=0

---

From: "Diego R. Lopez" <[email-masked]>
Date: Tue, 4 Feb 2020 18:53:21 +0000

And yet another +1, in the same spirit as Andrew…

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
https://www.linkedin.com/in/dr2lopez/

e-mail: [email-masked]<mailto:[email-masked]>
Tel:         +34 913 129 041
Mobile:  +34 682 051 091
----------------------------------

On 04/02/2020, 19:25, "Add on behalf of Andrew Campling" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Andrew

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Tue, 4 Feb 2020 19:45:32 +0000

+1
And special thx to Tommy P for getting us to this point.
Barbara

From: Add <[email-masked]> On Behalf Of Diego R. Lopez
Sent: Tuesday, February 04, 2020 1:53 PM
To: ADD Mailing list <[email-masked]>; [email-masked]
Cc: The IESG <[email-masked]>
Subject: Re: [Add] [EXTERNAL] Re: [Ext] Adam Roach's No Objection on charter-ietf-add-00-00: (with COMMENT)

Dr Diego R. Lopez
Telefonica I+D
https://www.linkedin.com/in/dr2lopez/<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.linkedin.com_in_dr2lopez_&d=DwMGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=LoGzhC-8sc8SY8Tq4vrfog&m=O6BSKwaxOqYNuRvTknchnPqxYvW5ve_dY8EbB3OEfgk&s=2COvgsRjRNwMPORTTr0BYFEZKbg_jH73lF7WNIo2dow&e=>

Andrew

---

From: Barry Leiba <[email-masked]>
Date: Tue, 4 Feb 2020 14:59:06 -0500

Given the significant support for EKR's suggestion, I'm incorporating
it into the charter proposal now.

Barry

On Tue, Feb 4, 2020 at 11:38 AM Eric Rescorla <[email-masked]> wrote:
>> On 2/4/20, 4:46 AM, "Add on behalf of Eric Rescorla" <[email-masked] on behalf of [email-masked]> wrote:
>>
>>
>>
>> On Tue, Feb 4, 2020 at 4:37 AM Paul Hoffman <[email-masked]> wrote:
>>
>>
>> While the ADD list and BoFs have certainly not been productive venues for discussions that’s largely attributable to a variety of factors which likely won’t be present in actual WG.   The ADD list and BoFs have been very broad and wide open, and lacked the focus of a charter, which resulted in unproductive discussions that didn’t progress.  The WG conversely will have a specific charter to focus it and chairs to help manage the activity.
>>
>>
>> Thanks. I completely agree that there is useful work that a tightly-scoped charter can foster. I also agree with the implied converse, which is that an insufficiently-tightly-scoped charter will make useful work difficult or impossible.
>>
>> /a

---

From: Daniel Migault <[email-masked]>
Date: Tue, 4 Feb 2020 16:59:57 -0500

> there have been) while scoping out contentious and unproductive
It is good to explicitly roll out policies. I would like to clarify whether
informational document such as requirements or analysis could fit into the
scope of technical mechanisms - as long as they remain out of the policy
spectrum of course. I do not have a specific document in mind.

as we have informational documents in the goals we may specify the the
mechanism to be standard.

-- 
Daniel Migault
Ericsson

---

From: <[email-masked]>
Date: Wed, 5 Feb 2020 08:58:30 +0000

+1 on the proposed amendment below

I also feel Jim Reid’s suggestion of making the first paragraph read “develop a set of informational documents..” adds value too

Regards

Bob

From: Add <[email-masked]> On Behalf Of Andrew Campling
Sent: 04 February 2020 18:25
To: Tommy Jensen <[email-masked]>; Deen, Glenn (NBCUniversal) <[email-masked]>; Tommy Pauly <tpauly=[email-masked]>; Adam Roach <[email-masked]>
Cc: The IESG <[email-masked]>; Eric Rescorla <[email-masked]>; ADD Mailing list <[email-masked]>; Paul Hoffman <[email-masked]>; [email-masked]
Subject: Re: [Add] [EXTERNAL] Re: [Ext] Adam Roach's No Objection on charter-ietf-add-00-00: (with COMMENT)

Andrew

From: Tommy Jensen <[email-masked]<mailto:[email-masked]>>
Sent: 04 February 2020 18:21
To: Deen, Glenn (NBCUniversal) <[email-masked]<mailto:[email-masked]>>; Tommy Pauly <tpauly=[email-masked]<mailto:tpauly=[email-masked]>>; Adam Roach <[email-masked]<mailto:[email-masked]>>
Cc: Eric Rescorla <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Paul Hoffman <[email-masked]<mailto:[email-masked]>>; ADD Mailing list <[email-masked]<mailto:[email-masked]>>; The IESG <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Add] [EXTERNAL] Re: [Ext] Adam Roach's No Objection on charter-ietf-add-00-00: (with COMMENT)

    +1

    Best,
    Tommy

+1

-glenn

---

From: Rob Sayre <[email-masked]>
Date: Wed, 5 Feb 2020 23:23:04 -0800

> it into the charter proposal now.

This new charter sounds reasonable. But anything can be forked and/or
ignored.

thanks,
Rob