Subject: Re: [Add] [Ext] antitrust implications of IETF resolver discovery protocol work

From: Tony Rutkowski <[email-masked]>
Date: Mon, 23 Mar 2020 21:21:34 -0400

Hi Paul,

Indeed they have.  That's the point, they are similar.  Bob can speak as 
to the similarities and why The Handle System might be better here, or a 
competitive alternative.

This kind of work in the past has usually had some kind of 
governmental/intergovernmental aegis for antitrust protection. Here, it 
appears there is arguably significant potential exposure.  Just 
suggesting an antitrust analysis is appropriate, as well as some care as 
to the anti competitive effects.

--tony

>
>       Re: [Add] [Ext] antitrust implications of IETF resolver
>       discovery protocol work
>
> Paul Hoffman <[email-masked]>Tue, 24 March 2020 00:22 UTCShow 
> header <https://mailarchive.ietf.org/arch/browse/add/?#>
>
> On Mar 23, 2020, at 5:17 PM, Tony Rutkowski<[email-masked]>  <mailto:&lt;[email-masked]&gt;>  wrote:
> > 
> > Has anyone done an analysis of the antitrust implications of this work under an IETF aegis?  Has the IETF Trust bought off on this?
>
> Not that has reported to this group.
>
> > The work here is similar that undertaken for The Handle System, and the CNRI work in ITU to develop X.1255 and related treaty instrument resolutions.
>
> In what way is it "similar"? Various ways of doing discovery have been done for over 30 years.
>
> --Paul Hoffman

---

From: "Deen, Glenn (NBCUniversal)" <[email-masked]>
Date: Tue, 24 Mar 2020 02:44:00 +0000

What anti trust aspects are being suggested for discovery of dns resolvers and mechanisms to convey resolver information ?

I don’t see what the possible concerns are.

Glenn

On Mar 23, 2020, at 6:22 PM, Tony Rutkowski <[email-masked]> wrote:

Hi Paul,

Indeed they have.  That's the point, they are similar.  Bob can speak as to the similarities and why The Handle System might be better here, or a competitive alternative.

This kind of work in the past has usually had some kind of governmental/intergovernmental aegis for antitrust protection.  Here, it appears there is arguably significant potential exposure.  Just suggesting an antitrust analysis is appropriate, as well as some care as to the anti competitive effects.

--tony

Re: [Add] [Ext] antitrust implications of IETF resolver discovery protocol work

Paul Hoffman <[email-masked]><mailto:[email-masked]> Tue, 24 March 2020 00:22 UTCShow header<https://urldefense.com/v3/__https://mailarchive.ietf.org/arch/browse/add/?*__;Iw!!PIZeeW5wscynRQ!_HUNDgFB3bmkeXmbENuu3y4At1eJFinGmXaQq9D2UCwPZ5qaAzd2j8cGJ1Hw2HGK$>

--Paul Hoffman

--
Add mailing list
[email-masked]
https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/add__;!!PIZeeW5wscynRQ!_HUNDgFB3bmkeXmbENuu3y4At1eJFinGmXaQq9D2UCwPZ5qaAzd2j8cGJzy8cE6v$

---

From: Vittorio Bertola <[email-masked]>
Date: Tue, 24 Mar 2020 12:33:40 +0100 (CET)

>     Il 24/03/2020 03:44 Deen, Glenn (NBCUniversal) <[email-masked]> ha scritto:
> 
> 
Actually, antitrust concerns have been raised about deployment models in which discovery is *not* being done, as they attribute to whoever controls the client the ability to also determine or constrain the resolver that is being used, thus giving people with a strong position in the former market also a strong influence on the latter one. Having a discovery mechanism could provide a way to alleviate those concerns, for those that find them reasonable.

--

Vittorio Bertola | Head of Policy & Innovation, Open-Xchange
[email-masked] mailto:[email-masked] 
Office @ Via Treviso 12, 10144 Torino, Italy

---

From: Jim Reid <[email-masked]>
Date: Tue, 24 Mar 2020 12:09:41 +0000

On 24 Mar 2020, at 01:21, Tony Rutkowski <[email-masked]> wrote:
> 
> Bob can speak as to the similarities and why The Handle System might be better here, or a competitive alternative.

IMO it’s incumbent on you to do this since you raised this issue. Please explain. Though that’s probably off-topic for this list and WG.

The ADD WG is looking at discovery for services using DNS-based lookup technologies, not those using The Handle System (tm). Those two lookup mechanisms are orthogonal to each other and may well be mutually exclusive.

The WG’s charter -- ADD is an acronym for Adaptive DNS Discovery BTW -- actually says "This working group will focus on discovery and selection of DNS resolvers by DNS clients in a variety of networking environments”. There’s no mention of X.1255 or The Handle System at all.

I’m puzzled why you have raised what seems to be a couple of non-sequiturs.

---

From: Tony Rutkowski <[email-masked]>
Date: Tue, 24 Mar 2020 08:34:34 -0400

Hi Jim,

This is a subject of active discussion among parties analyzing the 
resolver system marketplace - which will scale significantly in a 5G 
environment.  The arena is in the process of becoming much more 
competitive and diverse.  Your note itself raises some flags about it 
being focused on only DNS-based lookup technologies.  Why not a broader 
array of resolver technologies - especially when the ADD remit is "in a 
variety of networking environments, including public networks, private 
networks, and VPNs."  It also seems like somebody was concerned about 
the anti-competitive implications with the addition of a subsequent 
caveat "making any recommendations about specific policies for clients 
or servers is out of scope."  The concern is also amplified by IETF 
proclivities to claim dominion over all implementations of TCP/IP and 
DNS protocols and the utter lack of any anti-trust policies or review 
processes.

It seems past due to get something published and vetted on a significant 
scale.  5G implementations will open up a new universe of virtualised 
architectures, services, and protocols; as the world moves to 
alternative IP and layer 2 protocols, end point identifiers, and 
discovery/resolver services.

--tony

---

From: Jim Reid <[email-masked]>
Date: Tue, 24 Mar 2020 13:55:12 +0000

> On 24 Mar 2020, at 12:34, Tony Rutkowski <[email-masked]> wrote:
> 
> This is a subject of active discussion among parties analyzing the resolver system marketplace - which will scale significantly in a 5G environment.

Who are these parties and where are those discussions taking place?

> The arena is in the process of becoming much more competitive and diverse.

Is it? Where? How?

> Your note itself raises some flags about it being focused on only DNS-based lookup technologies.  Why not a broader array of resolver technologies - especially when the ADD remit is "in a variety of networking environments, including public networks, private networks, and VPNs." 

Have you followed the long and tortuous process which lead to the formation of the ADD WG? The charter’s scope had to be carefully focused because (a) something diffuse was never going to result in useful output in a reasonable time-frame; (b) the IETF wouldn’t have been able to reach consensus on the creation of the new WG.

Asking for the WG to assimilate every flavour-of-the-month alternative to DNS at this stage is ill-judged and *very* premature. The WG hasn’t even met yet and you seem to want it rechartered. Hmmm.

---

From: "Deen, Glenn (NBCUniversal)" <[email-masked]>
Date: Tue, 24 Mar 2020 14:10:01 +0000

Hi everyone,

This discussion has been moved off list as this is not in scope for the WG - please focus on list  discussion to ADD technical matters on discovery and resolver info conveyance.  

Thanks
Glenn