Subject: [Add] Requirements for "encrypted forwarders"

From: "Martin Thomson" <[email-masked]>
Date: Wed, 09 Sep 2020 12:38:55 +1000

https://github.com/ietf-wg-add/draft-add-requirements/issues/22

Section 3.1.2 of the requirements draft has some text, but the thrust of that text is completely lost on me.  I've attempted an analysis in the issue.  I conclude that this section be removed.

---

From: Rob Sayre <[email-masked]>
Date: Tue, 8 Sep 2020 21:57:47 -0700

Hi,

Martin left a number of comments on the requirements draft.

I think they were all substantive, and may indicate the draft is misguided.

thanks,
Rob

On Tue, Sep 8, 2020 at 7:39 PM Martin Thomson <[email-masked]> wrote:

> Section 3.1.2 of the requirements draft has some text, but the thrust of
> that text is completely lost on me.  I've attempted an analysis in the
> issue.  I conclude that this section be removed.
>
> --
> Add mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/add
>

---

From: "Martin Thomson" <[email-masked]>
Date: Wed, 09 Sep 2020 15:05:01 +1000

> I think they were all substantive, and may indicate the draft is misguided.

I'm not going to go that far.  There are some significant issues to work through (I think that the issues Ekr raised are perhaps even more substantive; he just beat me to it), but that doesn't mean that there isn't something of value here.

I appreciate that the authors of this proposal have attempted to gather a broad set of possible requirements.  Our task in discussing these requirements should be to identify those requirements we share.  And to identify whether there is a common model upon which these are based (to Ekr's points about threat modeling and target deployments).  There might be a lot that ultimately gets cut based on that, but that doesn't mean the exercise had no value.

---

From: Rob Sayre <[email-masked]>
Date: Tue, 8 Sep 2020 22:10:20 -0700

On Tue, Sep 8, 2020 at 10:05 PM Martin Thomson <[email-masked]> wrote:

> I'm not going to go that far.

If you won't say it "may indicate the draft is misguided", I am not sure
what you are aiming to communicate. :)

There are some significant issues to work through (I think that the issues
> Ekr raised are perhaps even more substantive; he just beat me to it), but
> that doesn't mean that there isn't something of value here.
>
> I appreciate that the authors of this proposal have attempted to gather a
> broad set of possible requirements.
>

Oh, I don't appreciate it.

thanks,
Rob