Subject: Re: [Add] discussion on draft-btw-add-home

From: <[email-masked]>
Date: Wed, 9 Dec 2020 12:57:51 +0000

Hi Daniel,

Not sure to get your point, but the options can return an ADN, a list of IP addresses, an alternate port number, type(s) of the encrypted DNS, and  URI Templates for DoH. That’s already a good set of information to be learned.

Do you have in mind other information that is worth to be discovered?

Cheers,
Med

De : Add [mailto:[email-masked]] De la part de Daniel Migault
Envoyé : mercredi 25 novembre 2020 23:02
À : ADD Mailing list <[email-masked]>
Objet : [Add] discussion on draft-btw-add-home

Hi,

I understand the ADN designating the FQDN of the DNS server. I am wondering if the Encr DNS Types field may not be a bit limited, and if it might not be preferred to request a request of type SVCB.

Additionally, though it may depend on the size of the SVCB response, I am also wondering if sending the raw SVCB response could be possible.

Yours,
Daniel

--
Daniel Migault
Ericsson

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Daniel Migault <[email-masked]>
Date: Wed, 9 Dec 2020 08:46:24 -0500

Hi,

It seems sufficient to upgrade a designated resolver from Do53 interface to
DoT or DoH. However, when a DNS client needs to select among different
resolvers the selection may be based on other parameters. Exemples I can
think of [1] are, the ability to filter, to perform DNSSEC validation, the
name that the resolver claims being authoritative for, acceptable IP
addresses....

Yours,
Daniel

[1] https://tools.ietf.org/html/draft-mglt-add-rdp-03#section-8

On Wed, Dec 9, 2020 at 7:57 AM <[email-masked]> wrote:

> Hi Daniel,
>
>
>
> Not sure to get your point, but the options can return an ADN, a list of
> IP addresses, an alternate port number, type(s) of the encrypted DNS, and
>  URI Templates for DoH. That’s already a good set of information to be
> learned.
>
>
>
> *De :* Add [mailto:[email-masked]] *De la part de* Daniel Migault
> *Envoyé :* mercredi 25 novembre 2020 23:02
> *À :* ADD Mailing list <[email-masked]>
> *Objet :* [Add] discussion on draft-btw-add-home
>
>
>
> Hi,
>
>
>
> I understand the ADN designating the FQDN of the DNS server. I am
> wondering if the Encr DNS Types field may not be a bit limited, and if it
> might not be preferred to request a request of type SVCB.
>
>
>
> Additionally, though it may depend on the size of the SVCB response, I am
> also wondering if sending the raw SVCB response could be possible.
>
>
>
> Yours,
> Daniel
>
>
>
> --
>
> Daniel Migault
>
> Ericsson
>

-- 
Daniel Migault
Ericsson

---

From: <[email-masked]>
Date: Wed, 9 Dec 2020 14:54:25 +0000

Re-,

I see.

Such information can be retrieved:
* directly from the server at the cost of establishing a connection with a discovered server.

or

* use the ADN to query whatever favourite-RR would provide those.

Cheers,
Med

De : Daniel Migault [mailto:[email-masked]]
Envoyé : mercredi 9 décembre 2020 14:46
À : BOUCADAIR Mohamed TGI/OLN <[email-masked]>
Cc : ADD Mailing list <[email-masked]>; [email-masked]
Objet : Re: [Add] discussion on draft-btw-add-home

Hi,

It seems sufficient to upgrade a designated resolver from Do53 interface to DoT or DoH. However, when a DNS client needs to select among different resolvers the selection may be based on other parameters. Exemples I can think of [1] are, the ability to filter, to perform DNSSEC validation, the name that the resolver claims being authoritative for, acceptable IP addresses....

Yours,
Daniel

On Wed, Dec 9, 2020 at 7:57 AM <[email-masked]<mailto:[email-masked]>> wrote:
Hi Daniel,

Cheers,
Med

De : Add [mailto:[email-masked]<mailto:[email-masked]>] De la part de Daniel Migault
Envoyé : mercredi 25 novembre 2020 23:02
À : ADD Mailing list <[email-masked]<mailto:[email-masked]>>
Objet : [Add] discussion on draft-btw-add-home

Hi,

Yours,
Daniel

--
Daniel Migault
Ericsson

Thank you.

--
Daniel Migault
Ericsson

---

From: Daniel Migault <[email-masked]>
Date: Wed, 9 Dec 2020 12:26:13 -0500

Thanks for the response. I agree and support your approach. I prefer the
second option for the purpose of discovery as it enables the selection
prior the connection of the resolver.

Yours,
Daniel

On Wed, Dec 9, 2020 at 9:54 AM <[email-masked]> wrote:

> *De :* Daniel Migault [mailto:[email-masked]]
> *Envoyé :* mercredi 9 décembre 2020 14:46
> *À :* BOUCADAIR Mohamed TGI/OLN <[email-masked]>
> *Cc :* ADD Mailing list <[email-masked]>; [email-masked]
> *Objet :* Re: [Add] discussion on draft-btw-add-home
>
>
>
> Hi,
>
>
>
> It seems sufficient to upgrade a designated resolver from Do53 interface
> to DoT or DoH. However, when a DNS client needs to select among different

-- 
Daniel Migault
Ericsson