Subject: [addr-select-dt] next step

From: Arifumi Matsumoto <[email-masked]>
Date: Thu, 9 Sep 2010 19:30:07 +0900

DT members,

the Beijing meeting is approaching now. We have to think about
the next step for us.

As we have reached consensus within this design team, I think
the next step should be going out to 6man wg. If so, it may be
better to declare the conclusion of this design team.

What do you think about this ?
Do you have in mind any other item to be discussed here in this
design team ?

--
Arifumi Matsumoto
  NGN System Architecture Project
  NTT Service Integration Laboratories
  E-mail: [email-masked]
  TEL +81-422-59-3334 FAX +81-422-59-6364

---

From: Suresh Krishnan <[email-masked]>
Date: Thu, 9 Sep 2010 15:23:03 -0400

Hi Arifumi,
   Thanks for the timely reminder. I think it is time to revise/write 
drafts and handle any issues as they come up.

Cheers
Suresh

On 10-09-09 06:30 AM, Arifumi Matsumoto wrote:
> _______________________________________________
> addr-select-dt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/addr-select-dt

---

From: Brian Haberman <[email-masked]>
Date: Tue, 14 Sep 2010 14:48:19 -0400

Arifumi & DT,

> Do you have in mind any other item to be discussed here in this

I believe we have reached a point of completion for the design team with
the publication of the address selection considerations draft.  What Bob
& I would like to see now is a draft proposing the actual changes to RFC
3484.  This should be driven by the issues raised in
draft-ietf-6man-rfc3484-revise.  It would be encouraging to see such a
draft published soon so that it can be discussed on the mailing list and
possibly revised prior to the Beijing meeting.

Regards,
Brian

---

From: Bob Hinden <[email-masked]>
Date: Tue, 14 Sep 2010 13:00:44 -0700

Hi,

> possibly revised prior to the Beijing meeting.

I would like to second what Brian said.  This work has been going on for a long time (two years?) and it needs to get to completion.  

I think the DT is completed now that <draft-ietf-6man-rfc3484-revise-00.txt> was published.  As Brian said, now we need an actual specification that proposes specific changes to RFC3484.  I would like to see the first draft at least a month before the Beijing meeting to allow for a discussion and an update prior to the cutoff for drafts.

If you do not think you can make this schedule, please let us know.

Thanks,
Bob

---

From: Arifumi Matsumoto <[email-masked]>
Date: Thu, 16 Sep 2010 18:28:17 +0900

Brian,

> possibly revised prior to the Beijing meeting.

as you know, the current some parts of draft-ietf-6man-rfc3484-revise are actual changes, and also other parts are possible choices for updates.

One choice has to be picked for each undetermined issue before publication of an RFC that revise RFC 3484.

I hope this document of draft-ietf-6man-rfc3484-revise should be re-written to propose the actual changes, in the course of discussion at 6man.

Or, do you prefer a brand new proposal draft that contains the actual changes to RFC 3484 ?

Regards,

---

From: Brian Haberman <[email-masked]>
Date: Thu, 16 Sep 2010 09:30:12 -0400

On 9/16/10 5:28 AM, Arifumi Matsumoto wrote:
>>> As we have reached consensus within this design team, I think the
>>> next step should be going out to 6man wg. If so, it may be better
>>> to declare the conclusion of this design team.
>>> 
>>> What do you think about this ? Do you have in mind any other item
>>> to be discussed here in this design team ?
>> 
>> I believe we have reached a point of completion for the design team
>> with the publication of the address selection considerations draft.
>> What Bob & I would like to see now is a draft proposing the actual
>> changes to RFC 3484.  This should be driven by the issues raised
>> in draft-ietf-6man-rfc3484-revise.  It would be encouraging to see
>> such a draft published soon so that it can be discussed on the
>> mailing list and possibly revised prior to the Beijing meeting.
> 
> as you know, the current some parts of draft-ietf-6man-rfc3484-revise
> are actual changes, and also other parts are possible choices for
> updates.

Right.  My preference would be a draft that has the same title as RFC
3484 and only contains the necessary changes from 3484.  I view the
current draft as a "requirements" draft that identifies the issues that
need resolving.

> 
> One choice has to be picked for each undetermined issue before
> publication of an RFC that revise RFC 3484.
> 
> I hope this document of draft-ietf-6man-rfc3484-revise should be
> re-written to propose the actual changes, in the course of discussion
> at 6man.

If so, then the title should reflect that and it should take on a
structure similar to 3484.

> Or, do you prefer a brand new proposal draft that contains the actual

How about moving the requirements/considerations discussion to an
appendix, change the title, and have the body reflect the revised
address selection policies?  This would eliminate the need to ask the WG
to adopt another draft.

Regards,
Brian

---

From: Bob Hinden <[email-masked]>
Date: Thu, 16 Sep 2010 11:24:32 -0700

Brian, Arifumi,

> address selection policies?  This would eliminate the need to ask the WG

I agree that the draft name can stay the same

However, the title, that is currently:

  Things To Be Included in RFC 3484 Revision

needs to be changed to something like:

  Update to RFC 3484 Default Address Selection for IPv6

The document itself should include that it is updating RFC 3484.  Unless, the plan is to replace it completely, where it should say obsoleting RFC 3484.

Bob

---

From: Arifumi Matsumoto <[email-masked]>
Date: Mon, 27 Sep 2010 11:26:37 +0900

Bob, Brian,

I'm sorry for replying late.
I'm back after one week off.

Thank you for your suggestion.
I'll soon restructure and change the title so that it 
proposes the updates to the RFC 3484.