Subject: [admin-discuss] IETF LLC 2020 End Of Year Survey - Results and analysis

From: IETF Executive Director <[email-masked]>
Date: Sun, 21 Feb 2021 12:12:10 -0800

The IETF Administration LLC ran a survey over December 2020 - January 2021 to assess community satisfaction with the LLC’s performance in 2020 and community views on our proposed activities for 2021.  We have now published a blog post analysing the results and with details of how to see the full results:

    https://www.ietf.org/blog/ietf-llc-2020-end-year-survey/

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 22 Feb 2021 09:54:01 +1300

Thanks for posting this.

"Only 29 responses were received"

I realise that those people are probably all on this list. But it would be really desirable to get a much larger number of responses next time. I have no idea how to achieve that.

Regards
   Brian