Subject: [Adslmib] Comments on draft-ietf-adslmib-vdsl-ext-scm-06

From: "Randy Presuhn" <[email-masked]>
Date: Wed, 27 Oct 2004 18:10:24 -0700

Hi -

Here are a few things that jumped out at me from
draft-ietf-adslmiv-vdsl-ext-scm-06.txt.

1) Throughout: some section headings are
" N.<space><space>title", while others only have one space.
Pick one.

2) Page 2:
|   The MIB module is located in the MIB tree under  MIB-2 transmission.
delete extra space.  Note comment below on content.

3) page 2: "[DSLFTR057] and [DSLFWT096]."
These tags don't appear in the references section.
Are [DSLFTR57] and [DSLFWT96] intended?

4) page 3: "montioring" -> "monitoring"

5) This reference is never cited.  Either cite it, or remove the reference.
|   [DSLFTR57] DSL Forum TR-057, "VDSL Network Element Management",
|              February 2003.

6) This reference is never cited.  Either cite it, or remove the reference.
|   [DSLFWT96] DSL Forum WT-096, "SCM Specific Managed Objects In
|              VDSL Network Elements".

7) This reference is never cited.  Either cite it, or remove the reference.
|   [RFC2856]  Bierman, A., McCloghrie, K., and R. Presuhn, "Textual
|              Conventions for Additional High Capacity Data Types",
              RFC 2856, June 2000.

8) Page 5:
|        the VDSL line. The VDSL-LINE-MIB configures and monitors the
Need another space after "."

9) Page 6:
|    ::= { transmission XX }   -- To be assigned by IANA
|-- RFC Ed.: we suggest to put it under { transmission 98 } because
|--          transmission 97 is the VDSL-LINE-MIB, transmission 98
|--          would be this SCM MIB and transmission 99 the MCM MIB.
and Page 15:
|7. IANA Considerations
|   The IANA is kindly requested to assign the value of the
|   MODULE-IDENTITY. The authors suggest transmission 98, see section 4.
This won't work, and MUST be fixed.  IfType (which
is corresponds to the numbers under "transmission")
already has an assignment for 98.  For details see
http://www.iana.org/assignments/inana-iftype-mib

10) page 7:
|            is in use or not. The two possible values are:
Need another space after "."

11) page 12:
The vdslLineSCMPhysBandCurrSnrMgn OBJECT-TYPE's UNITS are
"dBm", but the DESCRIPTION says "dB".  Which is it?

12) page 12:
The vdslLineSCMPhysBandCurrAtn OBJECT-TYPE's UNITS are
"dBm", but the DESCRIPTION says "dB".  Which is it?

13) page 13:
|5. Acknowledgments
|
|   This document contains many definitions taken from
|   draft-ietf-adslmib-vdsl-07.txt.  As such any credit for the text
|   found within should be full attributed to the authors of that
|   document.
The i-d reference is missing from the references section.
Suggest simply giving their names.  "full" -> "fully".

14) page 14: check against current boilerplate at
http://www.ops.ietf.org/mib-security.html  In particular,
the vulnerable objects need to be explicitly listed.
I would also suggest that the material about persistence
of VACM entries belongs or should at least be repeated
here.

15) page 15:
|   MODULE-IDENTITY. The authors suggest transmission 98, see section 4.
Need another space after "."  See above for comment on content.

Randy

_______________________________________________
Adslmib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/adslmib

---

From: "Randy Presuhn" <[email-masked]>
Date: Wed, 27 Oct 2004 19:02:36 -0700

Hi -

> http://www.iana.org/assignments/inana-iftype-mib

Sorry, make that http://www.iana.org/assignments/ianaiftype-mib

Randy