Subject: [Adslmib] Influence of BBF TR-165 on the draft-ietf-adslmib-vdsl2

From: <[email-masked]>
Date: Wed, 22 Apr 2009 09:49:15 +0200

All,

The TR-165 "Vector of Profiles (VoP)" was recently published by the
Broadband Forum (BBF). It defines an optimized object model for
configuring DSL lines.
http://www.broadband-forum.org/technical/download/TR-165.pdf

It states in chapter 1.1:
...
The Vector of Profiles specified in this Technical Report obsoletes the
object model for
DSL line configuration defined in the Broadband Forum's TR-129. Legacy
systems may
still use that object model for configuration management. All other
object models of TR-
129 remain valid.
...

As TR-129 is is used as a reference in the draft-ietf-adslmib-vdsl2-06,
the influence of TR-165 has to be considered by the group and a decision
has to be made asap how to further proceed.
A stated in chapter 1.1 of TR-165, it obsoletes the object model for DSL
line configuration in TR-129 and this influences directy the
Configuration Template and Profile part of the MIB Draft.

I think of the following options for the working group to proceed:

1) Finish the work on the actual draft and define a new "VoP MIB" in the
next step. Once, the "VoP MIB" is ready, the Configuration Template and
Profile part in the existing MIB is marked as obsolete with reference to
the new "VoP MIB".

2) Finish the work on the actual draft and define a new "VoP MIB" in the
next step as an altenative MIB module for DSL line configuration and
leave the choice, which MIB to use to the users.

3) Define the object structure based on TR-165 and put it into the
existing MIB Draft before publication as a mandatory part and mark the
Configuration Template and Profile part as optional.

4) Leave everything as it is.

I prefer option 1).

Any comments?

Best Regards
Markus Freudenberger

T-Systems Enterprise Services GmbH

---

From: Menachem Dodge <[email-masked]>
Date: Wed, 22 Apr 2009 11:28:14 +0300

Hello Markus,

As you know the current vdsl2 draft was forwarded several months ago for publication following WG last call and is currently being revised following comments by the MIB Doctors.

I am expecting an updated version to be posted by the editors shortly and then the document can be forwarded for publication.

Therefore either option #1 or option #2 should be considered.

The Working Group received a Liaison from the DSL Forum on 14th March 2008 informing us that work had begun on a new project entitled "Vector of Profiles". No further word has been received on that subject from the Broadband Forum (DSL Forum).

If there is support for option #1 and option #2 the Working Group would need to request a Change of Charter in order to take on the new work item.

Best Regards,
Menachem Dodge

From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, April 22, 2009 10:49 AM
To: [email-masked]
Subject: [Adslmib] Influence of BBF TR-165 on the draft-ietf-adslmib-vdsl2

All,

The TR-165 "Vector of Profiles (VoP)" was recently published by the Broadband Forum (BBF). It defines an optimized object model for configuring DSL lines.

It states in chapter 1.1:
...
The Vector of Profiles specified in this Technical Report obsoletes the object model for
DSL line configuration defined in the Broadband Forum's TR-129. Legacy systems may
still use that object model for configuration management. All other object models of TR-
129 remain valid.
...

As TR-129 is is used as a reference in the draft-ietf-adslmib-vdsl2-06, the influence of TR-165 has to be considered by the group and a decision has to be made asap how to further proceed.

A stated in chapter 1.1 of TR-165, it obsoletes the object model for DSL line configuration in TR-129 and this influences directy the Configuration Template and Profile part of the MIB Draft.

1) Finish the work on the actual draft and define a new "VoP MIB" in the next step. Once, the "VoP MIB" is ready, the Configuration Template and Profile part in the existing MIB is marked as obsolete with reference to the new "VoP MIB".

2) Finish the work on the actual draft and define a new "VoP MIB" in the next step as an altenative MIB module for DSL line configuration and leave the choice, which MIB to use to the users.

3) Define the object structure based on TR-165 and put it into the existing MIB Draft before publication as a mandatory part and mark the Configuration Template and Profile part as optional.

I prefer option 1).

Any comments?

Best Regards
Markus Freudenberger

---

From: Scott Baillie <[email-masked]>
Date: Wed, 22 Apr 2009 17:56:25 +1000

Hi Markus,

I only had a quick look at the document TR-165 so I
would need to spend some more before I can say that
I understand the model being proposed.

What we can say though is that the current VDSL2 draft
MIB will be published pretty much "as is" with the exception
that we are adding in a number of modifications that have
been proposed by the MIB doctors review team.

We can discuss the management model defined in TR-165 after
the current draft goes RFC.

Regards,

Scott.

On Wed, 2009-04-22 at 09:49 +0200, [email-masked]
wrote:
> DSL line configuration defined in the Broadband Forum’s TR-129. Legacy
> systems may 
> As TR-129 is is used as a reference in the
> draft-ietf-adslmib-vdsl2-06, the influence of TR-165 has to be
> considered by the group and a decision has to be made asap how to
> further proceed.
> 
> A stated in chapter 1.1 of TR-165, it obsoletes the object model for
> DSL line configuration in TR-129 and this influences directy the
> 1) Finish the work on the actual draft and define a new "VoP MIB" in
> the next step. Once, the "VoP MIB" is ready, the Configuration
> Template and Profile part in the existing MIB is marked as obsolete
> with reference to the new "VoP MIB".
> 
> 2) Finish the work on the actual draft and define a new "VoP MIB" in
> the next step as an altenative MIB module for DSL line configuration
> and leave the choice, which MIB to use to the users.
> 
> _______________________________________________
> Adslmib mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/adslmib

---

From: <[email-masked]>
Date: Thu, 23 Apr 2009 17:30:18 +0200

Hello Scott,

I can help you if you have specific questions regarding TR-165 as I was one of the contributors to the document at the Broadband Forum.
I would appreciate if the working group can decide to spend the effort in defining the MIB based for TR-165.

I am available to help, if needed.

By the way: When do you expect publication of the current VDSL2 draft MIB?

Regards
Markus

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Scott Baillie
Gesendet: Mittwoch, 22. April 2009 09:56
An: Freudenberger, Markus
Cc: [email-masked]
Betreff: Re: [Adslmib] Influence of BBF TR-165 onthe draft-ietf-adslmib-vdsl2

Hi Markus,

I only had a quick look at the document TR-165 so I would need to spend some more before I can say that I understand the model being proposed.

What we can say though is that the current VDSL2 draft MIB will be published pretty much "as is" with the exception that we are adding in a number of modifications that have been proposed by the MIB doctors review team.

We can discuss the management model defined in TR-165 after the current draft goes RFC.

Regards,

Scott.

On Wed, 2009-04-22 at 09:49 +0200, [email-masked]
wrote:
> The Vector of Profiles specified in this Technical Report obsoletes 
> the object model for DSL line configuration defined in the Broadband 
> Forum's TR-129. Legacy systems may still use that object model for 
> configuration management. All other object models of TR-
> 129 remain valid. 
> ...
>

---

From: Scott Baillie <[email-masked]>
Date: Fri, 24 Apr 2009 16:38:40 +1000

Hi Markus,

Thanks,
I appreciate your offer and we will take you up on that !!

As for when the RFC will be published, as soon as possible
but check with Menachem for details.

Regards,

Scott.

---

From: Menachem Dodge <[email-masked]>
Date: Mon, 27 Apr 2009 16:14:54 +0300

Hi Markus, Scott,

The draft was forwarded for publication but following MIB Doctor review, an updated draft is required.
As soon as the draft is available and assuming that all the issues raised have been addressed, the publication 
process will then continue.

Best Regards,
Menachem

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Scott Baillie
Sent: Friday, April 24, 2009 9:39 AM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [Adslmib] Influence of BBF TR-165 on the draft-ietf-adslmib-vdsl2

Hi Markus,

Thanks,

Regards,

Scott.