Subject: Re: [Adslmib] Vector of Profiles MIB

From: "[email-masked]" <[email-masked]>
Date: Mon, 9 Nov 2009 19:52:24 +1100

Hi Menachem and Markus,

I think we should have a discussion first about the
scope and purpose of the "Vector of Profiles MIB" proposal.

Can we please address some of the following issues :

1. Would the new MIB cover all xDSL technologies like the
    VDSL2 MIB does ?
2. Would the new MIB cover all the parameters defined in G.997.1 ?
3. Would the only difference between the VDSL2 MIB and the new
    MIB be the way templates are represented ?
4. Can you state the things that the new MIB will have that the VDSL2
    MIB does not have.
5. Can you state the things that the VDSL2 MIB has that the new
    MIB does not have.
6. Is the new MIB intended for embedded use such as in DSLAMs
    and xDSL line cards ?
7. Can you justify having two MIBs that do basically the same thing
    but do it in a slightly different way ?
8. If you are a developer of xDSL equipment, what criterion would you
    use to select one MIB or the other ?

Regards,

Scott.

---- [email-masked] wrote: 
> on behalf of Deutsche Telekom, I am interested on that item.
>  
> Thanks
> Markus
>  
> ________________________________
> 
> Von: [email-masked] [mailto:[email-masked]] Im
> Auftrag von Menachem Dodge
> Gesendet: Montag, 9. November 2009 09:22
> An: Menachem Dodge; [email-masked]'
> Betreff: Re: [Adslmib] Vector of Profiles MIB
> 
> 
> 
> Hello,
> 
>  
> 
> I haven't received any response to my email of last Monday. 
> 
>  
> 
> If anyone at all, has an interest in this item of work, please speak up
> now.
> 
>  
> 
> Best Regards,
> 
> Menachem Dodge
> 
>  
> 
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Menachem Dodge
> Sent: Monday, November 02, 2009 7:07 PM
> To: [email-masked]'
> Subject: Re: [Adslmib] Vector of Profiles MIB
> 
>  
> 
> Hello All,
> 
>  
> 
> In April this year, several emails were exchanged regarding development
> of a "Vector of Profile" MIB in accordance with the Broadband Forum
> TR-165 Vector of Profiles document.
> 
> See the attached thread.
> 
>  
> 
> As this issue has been raised again, I would like to see if there is an
> interest amongst the members of the Working Group in this work.
> 
>  
> 
> Please share your thoughts on this issue.
> 
>  
> 
> Best Regards,
> 
> Menachem
>

---

From: <[email-masked]>
Date: Mon, 9 Nov 2009 11:27:23 +0100

Hello Scott,

First of all, I recommend to have a look at this paper: http://www.broadband-forum.org/technical/download/TR-165.pdf. It should answer a lot of your questions. 

Regarding your question 1)
Yes because Broadband Forum's TR-165 requires this. It obsoletes the object model for DSL line configuration defined in the TR-129.

Regarding your question 2)
Yes.

Regarding your question 3)
I am not sure if I got your question. TR-165 structures the xDSL configuration parameters into profiles in a different way. A vector is defined which must not necessarily represent a template.
It can be a template which summarizes a certain set of different profiles but it can also be a single DSL line with single profiles attached.
It might be useful, if you read Appendex I in TR-165. There, the implementation of "direct attached profiles" vs. "indirect attached profiles" (which is similar to the templates in the VDSL2-LINE-MIB) is described. At the end, a potintial VoP MIB should contain the option to switch between both methods.

Regarding your question 4) and 5) and 7)
I recommend to read the "Purpose ans Scope" Section of TR-165 on page 7.

Regarding your question 6)
Yes

Regarding your question 8)
The criteron should be that the VDSL2-LINE-MIB is based on the object model of TR-129, which now is obsoleted with TR-165.
But please be aware that it is not a decision of using one MIB versus another. The new "VoP MIB" deals only with configuration parameters resp. profiles and must be linked together with the VDSL2-LINE-MIB. Most Parts of RFC 5650 like notifications, line status, inventory or PM are not touched by Vector of Profiles anyway.

Hope this helps.

Regards
Markus

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] 
Gesendet: Montag, 9. November 2009 09:52
An: Freudenberger, Markus
Cc: [email-masked]; [email-masked]
Betreff: Re: [Adslmib] Vector of Profiles MIB

Hi Menachem and Markus,

I think we should have a discussion first about the scope and purpose of the "Vector of Profiles MIB" proposal.

Regards,

Scott.

---- [email-masked] wrote: 
> If anyone at all, has an interest in this item of work, please speak 
> up now.
> 
>  
> 
> Best Regards,
> 
> Menachem Dodge
> 
>  
> 
> In April this year, several emails were exchanged regarding 
> development of a "Vector of Profile" MIB in accordance with the 
> Broadband Forum
> As this issue has been raised again, I would like to see if there is 
> an interest amongst the members of the Working Group in this work.
> 
>  
>

---

From: Moti Morgenstern <[email-masked]>
Date: Mon, 9 Nov 2009 16:34:03 +0200

Hi Scott,

How are you?
See my embedded answers

Moti M

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, November 09, 2009 10:52 AM
To: [email-masked]
Cc: [email-masked]; Menachem Dodge
Subject: Re: [Adslmib] Vector of Profiles MIB

Hi Menachem and Markus,

1. Would the new MIB cover all xDSL technologies like the
    VDSL2 MIB does ?
[MM] Yes. It refers to the same TR-129 and G.997.1 documents

2. Would the new MIB cover all the parameters defined in G.997.1 ?
[MM] No. It more-or-less arranges the configuration parameters in a different way.
However, it does not address the status parameters, the PM parameters, alarm 
thresholds or notifications.

3. Would the only difference between the VDSL2 MIB and the new
    MIB be the way templates are represented ?
[MM] In addition to (2) above, the main issue is the way 'templates' are represented. 
The other issue is that the 'template', which is now called 'VoP', may belong to a 
single line. If that ('direct') mode is being utilized then the 'template' (VoP) is 
indexed by the line's ifIndex rather than by an ordered identifier/number.    

4. Can you state the things that the new MIB will have that the VDSL2
    MIB does not have.
[MM] In principle (ignoring few details) the configuration VoP is the same as what 
we call 'template'. The differences are: The 'direct' vs. 'indirect' VoP attachment 
methods, and better (with some compromises) division of the configuration parameters 
into smaller, focused, profiles. There are also few minor errors (in the vdsl2 MIB) that
are corrected in the new MIB.

5. Can you state the things that the VDSL2 MIB has that the new
    MIB does not have.
[MM] First of all, we're talking about the configuration part of the vdsl2 MIB. 
Other parts remain the same. I think the new MIB preserves the characteristics
of the vdsl2 MIB, except for the indexing. The VoP and related profiles indices are 
numeric rather than textual. 

[MM] yes.

7. Can you justify having two MIBs that do basically the same thing
    but do it in a slightly different way ?
[MM] There is no justification. The reason VoP was invented is because operators felt that
TR-129 model does not divide the configuration parameters in an optimal way and that may cause
waste of memory. The issue of 'direct' vs. 'indirect' attachment methods could also be solved 
with the TR-129 model. Was it pleasant for the BBF to publish two management models within 
a year or two? Certainly not.
   
8. If you are a developer of xDSL equipment, what criterion would you
    use to select one MIB or the other ?
[MM] A very good question. There's no natural mechanism to determine, such as different ifIndex values.

Regards,

Scott.

> on behalf of Deutsche Telekom, I am interested on that item.

_______________________________________________
Adslmib mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/adslmib