Subject: Re: [alto] Problems with the Alto problem statement

From: Laird Popkin <[email-masked]>
Date: Sat, 15 Nov 2008 13:42:57 -0500 (EST)

I think I see quite a few incorrect assumptions about ALTO that you're making in this discussion. I'll try to make a list so that we can address them:

1) You think that P2P companies won't use ALTO guidance because there is a 'tradeoff' between performance and resilience, where slower performance benefits the networks by forcing people to remain in the p2p swarm longer. I believe (based on discussions with numerous p2p companies) that they want to improve performance, and use other mechanisms to encourage contribution to the network. I'd suggest that the strong interest by p2p networks in P4P and now ALTO is evidence that they view this guidance as beneficial to their networks.

2) You believe that ALTO requires p2p networks to expose personally identifiable information of their users and their download activity to ISPs. This is not the case - ALTO specifically has a requirement that it not require P2P networks to expose any user or content identity to the ALTO server.

3) As a result of (2), you believe that neither ISPs not P2P networks will make use of ALTO, except for 'legit' downloads. Since (2) isn't the case, it shouldn't be a reason to prevent implementation of ALTO. ISPs may choose to provide ALTO guidance selectively, of course, but it seems premature to assume that they will all do so.

4) You assume that 'legit' p2p traffic is not worth optimizing. While a few years ago this was probably the case, there are many 'legit' p2p platforms distributing content (e.g. BBC iPlayer, Joost, NBC Direct, almost all large game downloads, e.g. World of Warcraft) that are moving significant volumes of traffic, which is certainly worth optimizing. And the projections are that 'legit' p2p data volumes will continue to grow. So while ALTO as a technology isn't limited to 'legit' content, even if it were only used that way the impact would be significant and growing. 

5) You assume that ALTO applies only to tracker-based p2p networks, and thus that ISPs would be required to approve specific Trackers (i.e. not where the pirated content is). This is not the case; as Richard emailed, ALTO is applicable to both tracker-based and trackerless p2p networks (as well as any other application where network locality is of value). So if p2p client X implements ALTO, it would benefit from ALTO for all of its downloads (if it was running at an ISP that provided ALTO guidance to it).

In addition, I'll point out that (if P4P is any guide) implementing ALTO should be extremely easy for ISPs to implement, so even if the benefit were small, it's almost certainly worth doing anyway.

- Laird Popkin, CTO, Pando Networks
  mobile: 646/465-0570

----- Original Message -----
From: "Y. Richard Yang" <[email-masked]>
To: "Paul Hoffman" <[email-masked]>
Cc: [email-masked]
Sent: Friday, November 14, 2008 10:26:12 PM (GMT-0500) America/New_York
Subject: Re: [alto] Problems with the Alto problem statement

Dear Paul,

>> The P4P WG participation includes many major p2p networks, including Pando, BitTorrent, Solid State, Grid Networks, LimeWire, Abacast, Azureus, Joost, etc.
>>     
>
> Just to be clear here, "BitTorrent" in your list is a single BitTorrent tracker which happens to be run by BitTorrent.com. It is not representative of the BitTorrent communities of which I spoke, namely the ones that are inundating ISPs.
>
>   
Just to add some information. Vuze (formerly called Azureus) is one of 
the most popular BT clients. I assume that users using Vuze is a part of 
the BT community that you are referring to. Please correct me if I 
misunderstand here. Vuze is also a member of P4P. They are working 
pretty actively lately to improve both network efficiency and 
application performance. For example, their most recent release adds 
features to try to use network information through a network coordinate 
system. We are also preparing to launch a client-based plugin for Vuze 
to utilize P4P information (one of the ALTO framework). The objective of 
the plugin is that, through this plugin, either tracker-based or 
trackerless swarms will be able to start to use network information. We 
hope that this will be a good starting point to start to have affects on 
the large amount of P2P traffic that you are referring to, if I 
understand you correctly. There are sure other BT clients/trackers that 
we need to work on to better move the tide, and to maximize effects, we 
need to enter through both trackers and clients. But I do believe that 
ALTO can make a difference here. Maybe I am too optimistic here...
 
Richard

>> The summary is that in exactly the scenario you assert that ALTO "does nothing" P4P (think of it as pre-ALTO) provide huge performance and efficiency benefits.
>>     
>
> That is quite possibly true; it is also not relevant to what I said. I was speaking about the BitTorrent communities that are currently the bandwidth problem for ISPs; you are speaking about other p2p communities whose current bandwidth usage is probably at least an order of magnitude less than the ones of which I am speaking.
>
> Of course, in the future, the bandwidth market may shift towards the kinds of systems you are talking about. If so, Alto could very well be helpful. People clearly want to work on that future problem, and Alto might be a good place to do it. My expressly-stated concern was that the problem statement document has wording that makes it sound like the Alto proposals might have an affect on the current large amount of traffic, which I believe it won't.
>
> <rest of information about Pando and P4P elided>
>
> --Paul Hoffman, Director
> --VPN Consortium
> _______________________________________________
> alto mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/alto
>   

_______________________________________________
alto mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/alto
_______________________________________________
alto mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/alto

---

From: Laird Popkin <[email-masked]>
Date: Sat, 15 Nov 2008 14:16:01 -0500 (EST)

I just spoke with Paul, and I'd like to apologize publicly if my email came across as insulting. I think that we're having a very productive and important discussion here, and I wouldn't want to derail that through clumsy wording.

----- Original Message -----
From: "Y. Richard Yang" <[email-masked]>
To: "Paul Hoffman" <[email-masked]>
Cc: [email-masked]
Sent: Friday, November 14, 2008 10:26:12 PM (GMT-0500) America/New_York
Subject: Re: [alto] Problems with the Alto problem statement

Dear Paul,

Richard

---

From: Paul Hoffman <[email-masked]>
Date: Sat, 15 Nov 2008 11:29:06 -0800

At 1:42 PM -0500 11/15/08, Laird Popkin wrote:
>I think I see quite a few incorrect assumptions about ALTO that you're making in this discussion.

Um, no. I didn't make any of those assumptions; if I had, I would have stated them. People who know me will tell you that I err on the side of verbosity, for better or (often) worse.

The assumption that I made, that I stated, is that the current large BitTorrent trackers would not want to use Alto information because they purposely do a bit of traffic management in order to spread the torrents out so that their communities are larger and more stable. I heard this directly from some folks who run trackers about two years ago.

After I started this thread, I have hear that, since then, the world has changed. Many BitTorrent clients in the past year have started to do what can be described as "discovery of additional peers". That is, if a tracker tells Client A that its peers are B, C, and D, A will ask each of them who they are peering with and, if (for example) C says it is also peering with E, A will add E to its lits of peers. I have also now been told that the largest trackers like this because it reduces their traffic because they have to update their peer lists less often.

Assuming that this new information is true (it is certainly plausible, given the scaling issues that the largest tracker is seeing), then my objection to the implications in the problem statement document is wrong. I'll do more research, but in the meantime, let's assume that the problem statement is correct and that Alto might have a positive effect on the current flood.

--Paul Hoffman, Director
--VPN Consortium

---

From: Robert Raszuk <[email-masked]>
Date: Sat, 15 Nov 2008 11:58:43 -0800

Hi Paul & all,

I kind of share your opinion here.

What I would like to better understand reg Alto what is the value add 
such ISP domain scoped device would provide ?

P2P clients by themselves can measure today bandwith, delay, latency 
between content peers and adjust their peer selection accordingly at the 
application layer.

Those peers may cross ISP domain boundaries or may not. I think that 
actually there may be a little conflict of interests ... ISPs would like 
to save some chunk of inter-as bandwith for the cost of keeping the p2p 
volumes local while p2p protocol designers have been quite intelligent 
of making the peer selection natively in the application.

Perhaps there is a clear prove that the above does not hold anymore but 
if so I would like to hear about them so don't hesitate to reply pls :).

Cheers,
R.

> Um, no. I didn't make any of those assumptions; if I had, I would
> have stated them. People who know me will tell you that I err on the
> side of verbosity, for better or (often) worse.
> 
> The assumption that I made, that I stated, is that the current large
> BitTorrent trackers would not want to use Alto information because
> they purposely do a bit of traffic management in order to spread the
> torrents out so that their communities are larger and more stable. I
> heard this directly from some folks who run trackers about two years
> ago.
> 
> After I started this thread, I have hear that, since then, the world
> has changed. Many BitTorrent clients in the past year have started to
> do what can be described as "discovery of additional peers". That is,
> if a tracker tells Client A that its peers are B, C, and D, A will
> ask each of them who they are peering with and, if (for example) C
> says it is also peering with E, A will add E to its lits of peers. I
> have also now been told that the largest trackers like this because
> it reduces their traffic because they have to update their peer lists
> less often.
> 
> Assuming that this new information is true (it is certainly
> plausible, given the scaling issues that the largest tracker is
> seeing), then my objection to the implications in the problem
> statement document is wrong. I'll do more research, but in the
> meantime, let's assume that the problem statement is correct and that
> Alto might have a positive effect on the current flood.
> 
> --Paul Hoffman, Director --VPN Consortium 
> _______________________________________________ alto mailing list 
> [email-masked] https://www.ietf.org/mailman/listinfo/alto
>

---

From: Paul Hoffman <[email-masked]>
Date: Sat, 15 Nov 2008 14:43:28 -0800

>I kind of share your opinion here.

Only kind of. I never said anything about Alto being harmful. I believe that it will be helpful, and cannot estimate to what extent it will be because we cannot estimate the adoption in clients, the adoption by ISPs, the privacy issues, and so on. My message was strictly about the breadth of the problem statement, not about the final result.

--Paul Hoffman, Director
--VPN Consortium