Subject: Re: [alto] Problems with the Alto problem statement

From: Laird Popkin <[email-masked]>
Date: Fri, 14 Nov 2008 18:56:08 -0500 (EST)

In talking with the major P2P networks, I haven't heard anyone express a serious desire to degrade performance to keep people in the network (though there was some cynical joking on the topic). To explain my perspective, I co-chair the P4P Working Group, which has been doing this sort of optimization for about a year (and which hopes to work within the ALTO framework). The P4P WG participation includes many major p2p networks, including Pando, BitTorrent, Solid State, Grid Networks, LimeWire, Abacast, Azureus, Joost, etc. There's more information about some recent work at http://www.ietf.org/internet-drafts/draft-livingood-woundy-p4p-experiences-02.txt. The summary is that in exactly the scenario you assert that ALTO "does nothing" P4P (think of it as pre-ALTO) provide huge performance and efficiency benefits.

In terms of p2p application motivations, faster download speeds not only make users happier (and are thus a competitive advantage to p2p networks), but also get data distributed out into the swarm more rapidly, producing more seeds and a more resilient data availability in the mesh. Admittedly, if users get their downloads faster they might drop out of the swarm sooner, but that's an issue that (IMO) is being addressed more effectively through other mechanisms, both social and technical, rather than than degrading performance.

In terms of preferring to move data long distances rather than short distances, this doesn't make the p2p networks more resilient, because resiliences comes from interconnections that provide many data sources, not data actually moving long distances rather than short distances. While the ALTO guidance allows the p2p network to try to exchange data with closest peers preferentially, it does not prevent the p2p network from interconnecting a full global mesh to provide resilience, and I would think that they would all do so for obvious reasons.

In terms of the privacy concern that you raise, I certainly agree - I wouldn't envision using ALTO to expose any specific content and user identity to the ALTO server, because it raises privacy issues for both the P2P network and the operator of the ALTO server. The data flow that I anticipate would be one-way, with the ISP providing guidance to applications, with no information flowing the other way.

Of course, ALTO will have many applications, in some of which additional information might be extremely valuable to exchange.

- Laird Popkin, CTO, Pando Networks
  mobile: 646/465-0570

----- Original Message -----
From: "Paul Hoffman" <[email-masked]>
To: [email-masked]
Sent: Friday, November 14, 2008 4:47:36 PM (GMT-0500) America/New_York
Subject: [alto] Problems with the Alto problem statement

Greetings. draft-marocco-alto-problem-statement-03 mixes two types of problem statements in a way that might confuse some readers. It covers both:

A: the problem of the large amount of P2P traffic seen on the current Internet

B: the problem of how to provide useful network information to applications

The proposed solution space for Alto will probably do nearly nothing for Problem A. Most BitTorrent traffic, which is often said to account for nearly 50% of all ISP traffic, comes from communities that would get no advantage from any of the proposed Alto solutions.

Most of the large BitTorrent communities *want* more users who are further away topologically from well-connected users, or have slower connectivity, so that the community grows. In exchange for slightly lower speed, those communities get much more stability by having torrents seeded for a longer time and more people who are willing to seed "long tail" material.

Further, any Alto solution that involves an application telling a server specific files that it is interested in, or even asking which of a list of other users would be best to communicate with, will only be useful if the user of that application is willing to directly reveal to his/her ISP what they are asking for or who they want to share with. For legitimate content, that is probably not so much of an issue. For content whose legality is questionable, it is a huge issue.

In short, an Alto might work for some scenarios, but it is pretty much irrelevant for the scenario that concerns many people now, which is the huge and growing amount of BitTorrent traffic on the net today. Therefore, any discussion of current problems with this BitTorrent traffic should be removed from the problem statements draft. Otherwise, someone reading it as part of the suite of Alto specification might think that Alto will be useful for this problem. The problems Alto might be useful for are quite different than what we have today.

--Paul Hoffman, Director
--VPN Consortium
_______________________________________________
alto mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/alto
_______________________________________________
alto mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/alto

---

From: Paul Hoffman <[email-masked]>
Date: Fri, 14 Nov 2008 17:25:31 -0800

At 6:56 PM -0500 11/14/08, Laird Popkin wrote:
>In talking with the major P2P networks, I haven't heard anyone express a serious desire to degrade performance to keep people in the network (though there was some cynical joking on the topic).

Nor have I. Note that I didn't say "degrade". I said live with "slightly lower speed". It's a tradeoff.

>The P4P WG participation includes many major p2p networks, including Pando, BitTorrent, Solid State, Grid Networks, LimeWire, Abacast, Azureus, Joost, etc.

Just to be clear here, "BitTorrent" in your list is a single BitTorrent tracker which happens to be run by BitTorrent.com. It is not representative of the BitTorrent communities of which I spoke, namely the ones that are inundating ISPs.

>The summary is that in exactly the scenario you assert that ALTO "does nothing" P4P (think of it as pre-ALTO) provide huge performance and efficiency benefits.

That is quite possibly true; it is also not relevant to what I said. I was speaking about the BitTorrent communities that are currently the bandwidth problem for ISPs; you are speaking about other p2p communities whose current bandwidth usage is probably at least an order of magnitude less than the ones of which I am speaking.

Of course, in the future, the bandwidth market may shift towards the kinds of systems you are talking about. If so, Alto could very well be helpful. People clearly want to work on that future problem, and Alto might be a good place to do it. My expressly-stated concern was that the problem statement document has wording that makes it sound like the Alto proposals might have an affect on the current large amount of traffic, which I believe it won't.

<rest of information about Pando and P4P elided>

--Paul Hoffman, Director
--VPN Consortium

---

From: "Y. Richard Yang" <[email-masked]>
Date: Fri, 14 Nov 2008 22:26:12 -0500

Dear Paul,

> Just to be clear here, "BitTorrent" in your list is a single BitTorrent tracker which happens to be run by BitTorrent.com. It is not representative of the BitTorrent communities of which I spoke, n…
Just to add some information. Vuze (formerly called Azureus) is one of 
the most popular BT clients. I assume that users using Vuze is a part of 
the BT community that you are referring to. Please correct me if I 
misunderstand here. Vuze is also a member of P4P. They are working 
pretty actively lately to improve both network efficiency and 
application performance. For example, their most recent release adds 
features to try to use network information through a network coordinate 
system. We are also preparing to launch a client-based plugin for Vuze 
to utilize P4P information (one of the ALTO framework). The objective of 
the plugin is that, through this plugin, either tracker-based or 
trackerless swarms will be able to start to use network information. We 
hope that this will be a good starting point to start to have affects on 
the large amount of P2P traffic that you are referring to, if I 
understand you correctly. There are sure other BT clients/trackers that 
we need to work on to better move the tide, and to maximize effects, we 
need to enter through both trackers and clients. But I do believe that 
ALTO can make a difference here. Maybe I am too optimistic here...
 
Richard