Subject: Re: [alto] New draft on relay usage for ALTO

From: "" <[email-masked]>
Date: Thu, 15 Oct 2009 17:55:31 +0800

Hi Yu Meng,

About your draft I have some questions,
In the "The model of combining ALTO service with relay service" part
|
|3.1 Integrating relay service into alto service
|
Are the relays provided by the application? So the ALTO sever should know the relay lists of every application ,in your model ?
In the model ,should the ALTO server need to know the topology information of other ISPs?
|
|3.2.  Cooperation between P2P application provider and ISP
|
|   We define another model which is compatible with the current ALTO 
|   architecture. The relay service is not integrated but considered as 
|   the ordinary peer selection process. The peer would provide the ALTO 
|   server with the relay candidate list, and the ALTO server would rank 
|   the list. 
|
Is there always only one relay between the endpoints?
if not ，how to guarant that the best relay in the first step is the best in all?
 
Thanks,
FanHua

FanHua
State Key Laboratory Of Networking And Switching Technology, Beijing University Of Posts And Telecommunications

---

From: Tao Ma <[email-masked]>
Date: Mon, 19 Oct 2009 11:26:47 +0800

Hi,
   For the first question, in my opinion, in the integration model,  ALTO
server should know and maintain the relay list of the applications. ALTO is
highly coupled with the applications. There might be two understanding ways.
1, ALTO server have become an entity of the applications. Maybe they are
provided by the same party.  2, ALTO server and relays jointly provide a
general relay service for all the users in the network. I am not very sure
whether they are feasible enough.
   For the second question, I think this model focuses on one relay case.
Tao Ma
Beijing University of Posts and Telecommunications, Mobile lIfe and New
mEdia(MINE) Lab

Hi Yu Meng,
About your draft I have some questions,
In the "The model of combining ALTO service with relay service" part
|
|3.1 Integrating relay service into alto service
|
Are the relays provided by the application? So the ALTO sever should know
the relay lists of every application ,in your model ?
In the model ,should the ALTO server need to know the topology information
of other ISPs?
 |
|3.2.  Cooperation between P2P application provider and ISP
|
|   We define another model which is compatible with the current ALTO
|   architecture. The relay service is not integrated but considered as
|   the ordinary peer selection process. The peer would provide the ALTO
|   server with the relay candidate list, and the ALTO server would rank
|   the list.
|
Is there always only one relay between the endpoints?
if not ，how to guarant that the best relay in the first step is the best in
all?

Thanks,
FanHua