Subject: [alto] Third-party ALTO server discovery

From: "Martin Stiemerling" <[email-masked]>
Date: Tue, 3 Nov 2009 13:36:06 +0100

Hi all,

I have read  just some drafts about the third-party ALTO server discovery (including draft-kiesel-alto-3pdisc-00) and I'm struggling to find the actual reasoning for the need of this discovery. 

Any hint to a draft with a technical reasoning or email thread I haven't found.

Thanks in advance

  Martin

[email-masked]

NEC Laboratories Europe - Network Research Division
NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014

---

From: Richard Alimi <[email-masked]>
Date: Tue, 3 Nov 2009 09:06:49 -0500

Hi Martin,

> I have read  just some drafts about the third-party ALTO server discovery
>  (including draft-kiesel-alto-3pdisc-00) and I'm struggling to find the
>  actual reasoning for the need of this discovery.
> 

A P2P tracker may wish to use ALTO information to bias the peer lists returned 
to P2P clients.  If P2P clients do not perform the discovery themselves (e.g., 
if the P2P clients are not modified), then the P2P tracker may need to do the 
discovery on behalf of the P2P client.

Does this clarify things?

-- 
Richard Alimi
Department of Computer Science
Yale University