Subject: [alto] cost symmetry/asymmetry

From: Picconi Fabio <[email-masked]>
Date: Tue, 23 Feb 2010 15:49:19 +0100

Hi,

Reading the ALTO protocol draft I noticed that there is no discussion about costs being symmetric or asymmetric. Does this mean that you assume symmetric path costs ?

Fabio

---

From: Richard Alimi <[email-masked]>
Date: Tue, 23 Feb 2010 10:10:04 -0500

Hi Fabio,

> Reading the ALTO protocol draft I noticed that there is no discussion about
> costs being symmetric or asymmetric. Does this mean that you assume
> symmetric path costs ?

Costs are not restricted nor assumed to be symmetric.  This can be made 
explicit in the document.

For some discussion and considerations about directionality and asymmetry in 
the context of P4P, see Section 9.1.2 of:
  http://tools.ietf.org/html/draft-p4p-framework-00

-- 
Richard Alimi
Department of Computer Science
Yale University

---

From: stefano previdi <[email-masked]>
Date: Tue, 23 Feb 2010 16:34:01 +0100

On Feb 23, 2010, at 3:49 PM, Picconi Fabio wrote:

> Hi,
>
> Reading the ALTO protocol draft I noticed that there is no  
> discussion about costs being symmetric or asymmetric. Does this mean  
> that you assume symmetric path costs ?

costs computation algorithms (for either maps or ranking services) is
assumed to be implementation specific.

Any smart implementation will figure out the cost taking into account
cost [a]symmetry and traffic direction.

s.

>
> Fabio
> _______________________________________________
> alto mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/alto