Subject: [alto] FW: I-D Action:draft-stiemerling-alto-dns-discovery-00.txt

From: Martin Stiemerling <[email-masked]>
Date: Tue, 27 Jul 2010 08:45:28 +0000

Hi,

Here is another way from Hannes and me of a DNS-based ALTO Server Discovery Procedure as input for our discussions.

  Martin

[email-masked]

NEC Laboratories Europe - Network Research Division
NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014 

> -----Original Message-----
> From: [email-masked] [mailto:i-d-announce-
> [email-masked]] On Behalf Of [email-masked]
> Sent: Tuesday, July 27, 2010 10:15 AM
> To: [email-masked]
> Subject: I-D Action:draft-stiemerling-alto-dns-discovery-00.txt
> 
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> 
> 	Title           : A DNS-based ALTO Server Discovery Procedure
> 	Author(s)       : M. Stiemerling, H. Tschofenig
> 	Filename        : draft-stiemerling-alto-dns-discovery-00.txt
> 	Pages           : 7
> 	Date            : 2010-07-27
> 
> The Application-Layer Traffic Optimization (ALTO) provides guidance
> to applications having to select one or several hosts from a set of
> candidates that are able to provide a desired resource.
> 
> This document specifies the U-NAPTR based resolution process.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-stiemerling-alto-dns-
> discovery-00.txt
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
W0ludGVybmV0U2hvcnRjdXRdDQpVUkw9ZnRwOi8vZnRwLmlldGYub3JnL2ludGVybmV0LWRyYWZ0
cy9kcmFmdC1zdGllbWVybGluZy1hbHRvLWRucy1kaXNjb3ZlcnktMDAudHh0DQo=

---

From: "Hannes Tschofenig" <[email-masked]>
Date: Tue, 27 Jul 2010 10:54:51 +0200

In addition to what Martin I would like to point out the design approach. 

This document builds on top of the work in the GEOPRIV group. It uses U-NAPTR. A domain name is in the starting point for the U-NAPTR resolution process. Obtaining such a domain name via DHCP is specified in draft-ietf-geopriv-lis-discovery-15. 

Ciao
Hannes

-------- Original-Nachricht --------
> Datum: Tue, 27 Jul 2010 08:45:28 +0000
> Von: Martin Stiemerling <[email-masked]>
> An: "[email-masked]" <[email-masked]>
> Betreff: [alto] FW: I-D Action:draft-stiemerling-alto-dns-discovery-00.txt

> Hi,
> 
> Here is another way from Hannes and me of a DNS-based ALTO Server
> Discovery Procedure as input for our discussions.
> 
>   Martin
>

---

From: "Thomson, Martin" <[email-masked]>
Date: Tue, 27 Jul 2010 18:49:17 +0800

This draft probably needs to be clearer on terminology.

For instance:

   ALTO servers are identified by U-NAPTR/DDDS (URI-Enabled NAPTR/
   Dynamic Delegation Discovery Service) [RFC4848] application unique
   strings, in the form of a DNS name.  An example is
   'altoserver.example.com'.

Use the terms from DDDS.  You are discovering an ALTO server.  The input to the DDDS process is a domain name.  That domain name comes from [I-D.lis-discovery].

The protocol and service tags are probably the same thing: ALTO.  The idea of HTTP as a protocol in this context doesn't make a great deal of sense.  Secondary question: Is there any need to provide both secured and unsecured resources for the same domain?

The security section is fair, but there is no reason to go for the exception that LoST got.  I predict that you will be unable to convince the SEC ADs that this is acceptable.

-- Martin (The other one)

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Hannes Tschofenig
> Sent: Tuesday, 27 July 2010 10:55 AM
> To: Martin Stiemerling; [email-masked]
> Subject: Re: [alto] FW: I-D Action:draft-stiemerling-alto-dns-
> discovery-00.txt
> 
> This document builds on top of the work in the GEOPRIV group. It uses
> U-NAPTR. A domain name is in the starting point for the U-NAPTR
> resolution process. Obtaining such a domain name via DHCP is specified
> in draft-ietf-geopriv-lis-discovery-15.
> 
> Ciao
> Hannes
> 
> > NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road,
> London
> > W3 6BL | Registered in England 2832014
> >
> >
> _______________________________________________
> alto mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/alto