Subject: Re: [alto] P2P CDN integrated in Wikipedia

From: "Rimac, Ivica (Ivica)" <[email-masked]>
Date: Thu, 30 Sep 2010 10:02:20 -0500

I agree with the huge number of Wikipedia users, but Victor's point makes sense. The demand for a service like alto depends on the pain the generated traffic causes to the ISPs-why bother if you can squeeze out an improvement of lower digit percent (the voice of devil's advocate in me ;) )?

A related question, does anybody know of Akamai's position for alto-like services for their NetSession solution? I am not aware of how prominent this is anyway though I read somewhere that it is being used for distribution of games.

Cheers,
 Ivica

From: [email-masked] [mailto:[email-masked]] On Behalf Of David A. Bryan
Sent: Thursday, September 30, 2010 8:41 AM
To: Victor Grishchenko
Cc: [email-masked]
Subject: Re: [alto] P2P CDN integrated in Wikipedia

Your statements are true from a bandwidth perspective, but that misses the point. From a total number of users perspective, I think that wikipedia has more users. My grandmother doesn't use bit torrent. As more mainstream apps (including you tube) -- regardless of total bandwith numbers today -- start to use p2p, the more you will need services like alto. It is a consequence of the shared access media.

On Sep 30, 2010 6:05 AM, "Victor Grishchenko" <[email-masked]<mailto:[email-masked]>> wrote:
> On 29 September 2010 21:16, David A. Bryan <[email-masked]<mailto:[email-masked]>> wrote:
>> Seems to me that the more that this kind of technology gets
>> incorporated into more "mainstream" applications (yeah, I know, more
>> people probably download video from BitTorrent than use Wikipedia,
>> but...), the higher the likelihood we will start seeing last mile
>> network issues, and the more motivation for things like ALTO and
>> DECADE.
>
> Sorry, that is laughable. Wikipedia's video is nothing compared to
> BitTorrent, YouTube, etc. Maybe, in some years it will catch up...
>
>> Does anyone know if any of the folks working on this (I know we have
>> some P2P-Next folks, or at least folks who are in touch with them) are
>> on the ALTO list? If this gets incorporated more widely into Wikipedia
>> in the future, this may be a very nice open, public source of data on
>> the problem, and possible test bed for the ALTO work as we move
>> forward.
>
> I'm in touch with them.
> I think, regarding the data you need, at this moment it is way more
> practical to measure existing BitTorrent networks. There are lots of
> publications and data on the subject, including those made by P2P-Next
> people.
> Video on Wikipedia is sorta starting to take off, but in most of the
> cases, those are 5-10MB short animated illustrations.
> Infrastructure-wise, that is negligible.
>
>> On Wed, Sep 29, 2010 at 8:07 AM, Enrico Marocco
>> <[email-masked]<mailto:[email-masked]>> wrote:
>>> Hi folks,
>>>
>>> in case someone has not noticed it yet, Wikimedia has just announced the
>>> adoption of a BitTorrent-based technology for distributing multimedia
>>> content in their websites, including Wikipedia:
>>>
>>> http://techblog.wikimedia.org/2010/09/video-labs-p2p-next-community-cdn-for-video-distribution/
>>>
>>> I thought this may be of some interest for people on this list, both for the
>>> wide diffusion of the free content available on such websites, and as food
>>> for thought regarding the CDN use-case that has recently received quite
>>> attention around here.
>>>
>>> --
>>> Ciao,
>>> Enrico
>>>
>>>
>>> _______________________________________________
>>> alto mailing list
>>> [email-masked]<mailto:[email-masked]>
>>> https://www.ietf.org/mailman/listinfo/alto
>>>
>>>
>> _______________________________________________
>> alto mailing list
>> [email-masked]<mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/alto
>>
>
>
>
> --
> Victor

---

From: Nicholas Weaver <[email-masked]>
Date: Fri, 1 Oct 2010 08:38:18 -0700

A fair number of online games that are big use P2P, notably the Blizzard games (Warcraft, Starcraft) to push out large updates.

This is mostly done not for performance reasons but for economic reasons: shifting the cost for delivering large (often VERY large) patches or even entire games (eg, Starcraft is several GB) from the content provider to the recipient's ISP.

And economic constraints are what makes P2P interesting.

Localization helps in such a framework, by deloading the access link network both up and down, but does nothing to deload the last mile network which for some networks (eg, DOCSIS) can be the big bottleneck/problem on P2P traffic, which means that although localization would improve the P2P traffic, the cost to the ISP might still be much greater than non-P2P if the local-access uplink costs more than the general access downlink.  

In fact, some ISPs would benefit from configuring the local Alto service to AVOID local seeds to save money, if Cost(local uplink) > (Cost(access uplink) + Cost(access downlink)).

On Sep 30, 2010, at 8:02 AM, Rimac, Ivica (Ivica) wrote:

> I agree with the huge number of Wikipedia users, but Victor’s point makes sense. The demand for a service like alto depends on the pain the generated traffic causes to the ISPs—why bother if you can squeeze out an improvement of lower digit percent (the voice of devil’s advocate in me ;) )?
>  
> A related question, does anybody know of Akamai’s position for alto-like services for their NetSession solution? I am not aware of how prominent this is anyway though I read somewhere that it is being used for distribution of games.