Subject: [alto] ALTO reqs: support of the target-independent and/or target-aware modes

From: Martin Stiemerling <[email-masked]>
Date: Tue, 5 Jul 2011 09:34:13 +0000

Dear all, 

Ben brought this point up about the support of the target-independent and/or target-aware modes in the ALTO protocol, as specified in the ALTO reqs draft. 

Here is the definition of the two modes (as a recap):

   o  In target-aware query mode, an ALTO client performs the ALTO query
      when the desired resource and a set of candidate resource
      providers are already known, i. e., after DHT lookups, queries to
      the resource directory, etc.

   o  In target-independent query mode, ALTO queries are performed in
      advance or periodically, in order to receive comprehensive,
      "target-independent" guidance, which will be cached locally and
      evaluated later, when a resource is to be accessed.

The requirements say that at least one of the two modes must be supported:

   REQ.  ARv10-24: An ALTO client protocol MUST support at least one of
   these two modes, either the target-aware or the target-independent
   query mode.

And that the protocol SHOULD support both. 

   REQ.  ARv10-25: An ALTO client protocol SHOULD support both the
   target-aware and the target-independent query mode.

We could also argue for replacing these 2 arguments with this new requirement:
   An ALTO client protocol MUST support both the
   target-aware and the target-independent query mode.

This will cut away a bit of freedom, but on the other hand ensure that the protocol itself is always capable of both modes. 

Please send your replies to this until July 7th COB. 

  Martin

[email-masked]

NEC Laboratories Europe - Network Research Division NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014

---

From: Sebastian Kiesel <[email-masked]>
Date: Tue, 5 Jul 2011 16:03:53 +0200

Dear all,

>    target-aware and the target-independent query mode.

<writing my personal opinion, without my reqs editor's hat>

I'm in favor of the old wording. Though it has been quiet for a while
about the map-vs-oracle discussion we had at the San Francisco meeting, 
I am not sure whether this discussion is really finished, or it's just
that some people keep quiet.

The protocol which this WG is about to finish soon DOES support both
modes (i.e., complies with all (old) reqs), and I see no reason to
restrict future protocols that might arise.

Thanks
Sebastian