Subject: [alto] Caching ALTO

From: "Thomson, Martin" <[email-masked]>
Date: Fri, 29 Jul 2011 01:35:15 +0800

One of the concerns that I had from my brief look at the server implementations on offer the other night was the lack of support for caching mechanisms.

Thinking about Robert's request for example scenarios, it seems sensible that EVERY alto flow starts with a request to the IRD.  That is, the application always retrieves it, but it is probably cached locally.

Caching is going to be key to the scalable performance of this protocol.  Implementing that caching in clients is a reasonable starting point, but what I'm seeing right now is that clients are caching on their own.  There is no guidance being given by servers.  

Doing this means that you can't take advantage of the existing caching infrastructure of the web.

It's really quite easy.  All you need to do is provide Cache-Control headers.

--Martin

---

From: Richard Alimi <[email-masked]>
Date: Thu, 28 Jul 2011 10:43:15 -0700

I agree that caching here is important, so thank you for bringing this
up.  In particular, beyond the directory, this is also the signal by
which a server indicates to clients when they should to check for
updated network maps and cost maps.  Servers get to suggest this
interval to clients.

Rich

On Thu, Jul 28, 2011 at 10:35 AM, Thomson, Martin
<[email-masked]> wrote:
> _______________________________________________
> alto mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/alto
>

---

From: Robert Varga <[email-masked]>
Date: Thu, 28 Jul 2011 10:56:32 -0700

Thanks for bringing this up, as it slipped my mind. Maybe we could 
design a few optional test cases to catch this at the next interop?

Bye,
Robert

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Thu, 28 Jul 2011 19:42:46 -0500

> design a few optional test cases to catch this at the next interop?

Yes, most definitely.

I had a brief chat with Enrico about this, and after the
IETF is over (and we have heaved a collective sigh of
relief), I will reach out to the folks who had contributed
to the test case document and we will turn it into an
Internet-Draft.

Enrico and I will like to maintain this I-D as a living
document to document the test cases etc. as the protocol
progresses, with the intention that the I-D will eventually
become an Informational RFC.

Thanks,

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60566 (USA)
Email: vkg@{bell-labs.com,acm.org} / [email-masked]
Web:   http://ect.bell-labs.com/who/vkg/