Subject: [alto] non-intercepting ALTO home proxy

From: Picconi Fabio <[email-masked]>
Date: Wed, 16 Nov 2011 08:27:50 +0100

Hi,

First of all, thanks for all the comments made during my presentation.

Regarding the non-intercepting variant (which people seem to prefer), one problem which I didn't mention is the following: how does the ALTO client specify to the local ALTO server which ALTO information (e.g., from which ALTO origin server) should be used to compute the result?

Imagine the local ALTO server is installed by the user (e.g., on its NAS) for performance purposes. The user might configure his applications to use multiple ALTO servers (e.g., the ISP's, plus a third-party server). How does the application instruct the local ALTO server to use this or that ALTO database?

One solution is to specify the remote ALTO server on the "Host:" header of the HTTP request, but that doesn't seem to be an elegant solution (you have an ALTO home proxy behaving as a local ALTO server, not a caching proxy, but it's receiving an HTTP request that looks like a request sent to a proxy).

What do you think?

The question is whether this case would require a modification of the ALTO protocol or not.

Comments are welcome!

Fabio

---

From: Songhaibin <[email-masked]>
Date: Thu, 17 Nov 2011 07:37:37 +0000

If there is only one ISP ALTO server to serve the particular home, then there is no such problem.

It's indeed a problem when there are multiple ALTO servers for a particular home. But the applications need to have the intelligence to tell the home proxy which ALTO server it wants to use. Although I still doubt why there are more than one ALTO servers for one home.

BR,

-Haibin

________________________________
From: [email-masked] [[email-masked]] on behalf of Picconi Fabio [[email-masked]]
Sent: Wednesday, November 16, 2011 3:27 PM
To: [email-masked]
Subject: [alto] non-intercepting ALTO home proxy

Hi,

Regarding the non-intercepting variant (which people seem to prefer), one problem which I didn’t mention is the following: how does the ALTO client specify to the local ALTO server which ALTO information (e.g., from which ALTO origin server) should be used to compute the result?

Imagine the local ALTO server is installed by the user (e.g., on its NAS) for performance purposes. The user might configure his applications to use multiple ALTO servers (e.g., the ISP’s, plus a third-party server). How does the application instruct the local ALTO server to use this or that ALTO database?

One solution is to specify the remote ALTO server on the “Host:” header of the HTTP request, but that doesn’t seem to be an elegant solution (you have an ALTO home proxy behaving as a local ALTO server, not a caching proxy, but it’s receiving an HTTP request that looks like a request sent to a proxy).

What do you think?

Comments are welcome!

Fabio