Subject: [alto] One small comment to ALTO protocol

From: Songhaibin <[email-masked]>
Date: Mon, 26 Dec 2011 09:42:49 +0000

Dear all,

Merry X'mas first!

Here is one small issue that concerns me in the ALTO protocol.

The current ALTO protocol document describes the dependency of the cost map and network map, and only network map version tag is used for consistence check. But the cost map might be changed without the change of network map, I think we should allow the ALTO client to only update its cost map if the network map has not been changed. Shall we add a version tag for the cost map?

BR,
-Haibin

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Mon, 26 Dec 2011 14:50:21 +0000

Haibin,

On 26 Dec 2011, at 09:42, Songhaibin wrote:

> The current ALTO protocol document describes the dependency of the cost map and network map, and only network map version tag is used for consistence check. But the cost map might be changed without the change of network map, I think we should allow the ALTO client to only update its cost map if the network map has not been changed.

This seems an unnecessary restriction as if the Network Map changes in many cases the resulting Cost Map will have to change and in addition there will be cases where the Cost map changes when the Network Map stays the same.

> Shall we add a version tag for the cost map?

My preference would be that ALTO Servers & Clients make use of HTTP Etags so that clients can do IfNoneMatch type operations to check if the Cost Map has changed without having to first obtain the entire unchanged map again and check for a costmap-version field embedded in the map itself.

Ben

---

From: Richard Alimi <[email-masked]>
Date: Mon, 26 Dec 2011 06:54:32 -0800

> My preference would be that ALTO Servers & Clients make use of HTTP Etags so that clients can do IfNoneMatch type operations to check if the Cost Map has changed without having to first obtain the…

Agreed. We only needed a version tag for consistency between network
map and cost map because they are two separate HTTP resources and we
need a way to cross-reference them.  Asking for updates to single
resource can be done using the standard tools in HTTP.

Rich

> Ben
>
> _______________________________________________
> alto mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/alto

---

From: Songhaibin <[email-masked]>
Date: Tue, 27 Dec 2011 05:53:51 +0000

Thanks to Ben and Rich for the respond. I agree with your answers.

BR,
-Haibin

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Richard Alimi
> Sent: Monday, December 26, 2011 10:55 PM
> To: Ben Niven-Jenkins
> Cc: Songhaibin; [email-masked]
> Subject: Re: [alto] One small comment to ALTO protocol
> 
> >> The current ALTO protocol document describes the dependency of the cost
> map and network map, and only network map version tag is used for consistence
> check. But the cost map might be changed without the change of network map, I
> think we should allow the ALTO client to only update its cost map if the network
> map has not been changed.
> >
> > This seems an unnecessary restriction as if the Network Map changes in many
> cases the resulting Cost Map will have to change and in addition there will be
> cases where the Cost map changes when the Network Map stays the same.
> >
> > My preference would be that ALTO Servers & Clients make use of HTTP Etags so
> that clients can do IfNoneMatch type operations to check if the Cost Map has
> changed without having to first obtain the entire unchanged map again and check
> for a costmap-version field embedded in the map itself.
> >
>