Subject: [alto] Section number references from draft-ietf-alto-protocol to draft-ietf-alto-deployments

From: "Scharf, Michael (Michael)" <[email-masked]>
Date: Fri, 1 Nov 2013 17:50:19 +0000

Hi all,

As I already mentioned in the last IETF meeting, I suggest that draft-ietf-alto-protocol does not refer to specific section numbers of draft-ietf-alto-deployments. The numbers referenced by draft-ietf-alto-protocol-20 are already outdated for draft-ietf-alto-deployments-08, and further updates of the deployment draft are likely (see below for one example).

Specifically, I suggest to remove this tight coupling by the following small changes:

OLD:
Section 10 of [I-D.ietf-alto-deployments] also discusses information leakage from ALTO.

NEW:
[I-D.ietf-alto-deployments] also discusses information leakage from ALTO.

OLD:
Note that ALTO-specific monitoring and metrics are discussed in 6.3 of [I-D.ietf-alto-deployments] and future versions of that document.

NEW:
Note that ALTO-specific monitoring and metrics are discussed in [I-D.ietf-alto-deployments].

OLD:
Both ALTO Service Providers and those using ALTO Clients should be aware of the impact of incorrect or faked guidance (see Section 10.3 of [I-D.ietf-alto-deployments] and future versions of that document).

NEW:
Both ALTO Service Providers and those using ALTO Clients should be aware of the impact of incorrect or faked guidance (see [I-D.ietf-alto-deployments]).

OLD:
Monitoring ALTO Servers and Clients is described in Section 6.3 of [I-D.ietf-alto-deployments] and future versions of that document.

NEW:
Monitoring ALTO Servers and Clients is described in [I-D.ietf-alto-deployments].

(The phrase "... and future versions of that document" could also stay.)

As discussed on the list, a performance directorate review asked for substantial changes of Section 6.3, which is explicitly references multiple times. According to this review, the content of Section 6.3 will have to change significantly before publication. 

Note that I moved the existing text from Section 6.3 in draft-ietf-alto-deployments-07 into an appendix in draft-ietf-alto-deployments-08, because I didn't have time to rewrite this part of the document (-08 contains numerous other improvements). Probably, -09 will have a reworded, dedicated section on monitoring in the main part again, but the section number is TBD.

Thanks

Michael

---

From: Sebastian Kiesel <[email-masked]>
Date: Fri, 1 Nov 2013 20:21:57 +0100

Michael,

thanks for pointing this out. I agree, this should be changed.

Sebastian

On Fri, Nov 01, 2013 at 05:50:19PM +0000, Scharf, Michael (Michael) wrote:
> _______________________________________________
> alto mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/alto

---

From: "Y. Richard Yang" <[email-masked]>
Date: Sat, 2 Nov 2013 19:38:24 -0400

Hi Michael, Sebastian,

Thanks a lot! We went ahead and made the changes. We will post these edits
right after IETF.

Richard
On Nov 1, 2013 3:22 PM, "Sebastian Kiesel" <[email-masked]> wrote:

> > As I already mentioned in the last IETF meeting, I suggest that
> draft-ietf-alto-protocol does not refer to specific section numbers of
> draft-ietf-alto-deployments. The numbers referenced by
> draft-ietf-alto-protocol-20 are already outdated for
> draft-ietf-alto-deployments-08, and further updates of the deployment draft
> are likely (see below for one example).
> >
> > Note that ALTO-specific monitoring and metrics are discussed in 6.3 of
> [I-D.ietf-alto-deployments] and future versions of that document.
> >
> > NEW:
> > Both ALTO Service Providers and those using ALTO Clients should be aware
> of the impact of incorrect or faked guidance (see Section 10.3 of
> [I-D.ietf-alto-deployments] and future versions of that document).
> >
> > NEW:
> > Both ALTO Service Providers and those using ALTO Clients should be aware
> of the impact of incorrect or faked guidance (see
> [I-D.ietf-alto-deployments]).
> >
> >
> > OLD:
> > Monitoring ALTO Servers and Clients is described in Section 6.3 of
> [I-D.ietf-alto-deployments] and future versions of that document.
> >
> > NEW:
> > As discussed on the list, a performance directorate review asked for
> substantial changes of Section 6.3, which is explicitly references multiple
> times. According to this review, the content of Section 6.3 will have to
> change significantly before publication.
> >
> > Note that I moved the existing text from Section 6.3 in
> draft-ietf-alto-deployments-07 into an appendix in
> draft-ietf-alto-deployments-08, because I didn't have time to rewrite this
> part of the document (-08 contains numerous other improvements). Probably,
> -09 will have a reworded, dedicated section on monitoring in the main part
> again, but the section number is TBD.
> >
> > Thanks
> >
> > Michael