Subject: [alto] ALTO agenda for London IETF

From: "Vijay K. Gurbani" <[email-masked]>
Date: Mon, 17 Feb 2014 14:06:26 -0600

Folks: The agenda for the London IETF has been posted.  Please see
http://www.ietf.org/proceedings/89/agenda/agenda-89-alto

The bulk of the time is allocated to the rechartering discussion.

Over the course of this week, Enrico and I will reach out to
a subset of the participants to prepare a short (3 minute*) per-topic
presentation kicking off the discussion on the work item under
consideration.

To keep the discussion focused, we will like exactly two slides
per topic.  The content of these two slides must contain examples
(preferably JSON representation) of the extensions being sought.

* The exception is the extensions to ALTO server discovery mechanism.
   Previous IETFs have demonstrated consensus for supporting this
   extension; unless something material has changed by the time we get
   to London, we will expect to spend the least amount of time on this
   work item.

The agenda is draft, of course, and not considered final until bashed
at the meeting.  But regardless, it should give you a reasonable feel
for where we are headed.

Thank you,

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60563 (USA)
Email: vkg@{bell-labs.com,acm.org} / [email-masked]
Web: http://ect.bell-labs.com/who/vkg/  | Calendar: http://goo.gl/x3Ogq

---

From: Leeyoung <[email-masked]>
Date: Mon, 17 Feb 2014 20:39:00 +0000

Hi Vijay,

I read your agenda page you just published. I read the following as one of the agenda:

(Informational) A survey of techniques to formalize the structure
   of a network graph (that can derived from a set of related ALTO
   network and cost maps) in a format that would facilitate advanced
   graph computation.  Such survey will cover both models used in
   popular open-source software (e.g. NetworkX, Blueprints) and models
   being considered in other working groups (e.g. netmod, i2rs). (18')

Have the WG already decided this item to be just informational not on standard track? 
I thought the mailing discussions in the last few weeks show that there are 
Sufficient interests and willingness to work on this item. 

Regards,
Young

-----Original Message-----
From: alto [mailto:[email-masked]] On Behalf Of Vijay K. Gurbani
Sent: Monday, February 17, 2014 2:06 PM
To: alto
Subject: [alto] ALTO agenda for London IETF

Folks: The agenda for the London IETF has been posted.  Please see http://www.ietf.org/proceedings/89/agenda/agenda-89-alto

Over the course of this week, Enrico and I will reach out to a subset of the participants to prepare a short (3 minute*) per-topic presentation kicking off the discussion on the work item under consideration.

To keep the discussion focused, we will like exactly two slides per topic.  The content of these two slides must contain examples (preferably JSON representation) of the extensions being sought.

The agenda is draft, of course, and not considered final until bashed at the meeting.  But regardless, it should give you a reasonable feel for where we are headed.

Thank you,

- vijay

_______________________________________________
alto mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/alto

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Mon, 17 Feb 2014 15:01:22 -0600

> Sufficient interests and willingness to work on this item.

Young: The interest and willingness to work is precisely why it is on
the list of work items!  Whether this turns out to be Informational,
Standards track or Experimental is yet to be determined; the track on
the agenda is merely where discussions start.

Clearly, the discussion we had on the list lead to an understanding
that this is a sufficiently complex topic that any pithy attempt to
characterize it merely for the sake of "doing something" will not be
valued as much as a reasoned attempt to catalogue what is missing from
the current models to represent graphs.  Once we have such a
distinction, it becomes relatively easy to figure out how to close
the gap.

Should we blithely put a deliverable of "Graph representation and
dynamic graph transformation techniques", I suspect that there will be
some push back from the IESG on exactly what this means, considering
that even among us there is some trepidation that we should do the
easy part (graph representation) first before tackling the hard
part (graph transformation).  Remember, the charter is produced by
the BoF/WG but has to be accepted by the IESG.  As such, taking a
nuanced approach by understanding the missing pieces first appears to
make sense, no?

We will discuss this some more during London, of course.

Cheers,

- vijay

---

From: "Y. Richard Yang" <[email-masked]>
Date: Mon, 17 Feb 2014 16:55:15 -0500

Hi Vijay,

Good agenda. Just to clarify: "per-topic" means that there are 4 topics as
listed in the agenda, correct?

Richard

-- 
-- 
 =====================================
| Y. Richard Yang <[email-masked]>   |
| Professor of Computer Science       |
| http://www.cs.yale.edu/~yry/        |
 =====================================

---

From: "Y. Richard Yang" <[email-masked]>
Date: Mon, 17 Feb 2014 17:00:12 -0500

As much as I would like to see the graph representation (using the new
terms that Greg, Wendy, and I are recently using, Path Vector and/or Graph
representation), starting with a survey is a quite reasonable idea. But I
hope that it is not limited to only an informational survey, and a couple
slides showing what the format might look like can be helpful.

Richard

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Mon, 17 Feb 2014 16:13:40 -0600

On 02/17/2014 03:55 PM, Y. Richard Yang wrote:
> Hi Vijay,
>
> Good agenda. Just to clarify: "per-topic" means that there are 4 topics
> as listed in the agenda, correct?

Richard: Sorry, I was not sufficiently clear.

Administrivia / Status is the chair's prerogative; Michael will present
deployment considerations and we all will chime in for the wrap-up.

The "per-topic" in my original email referred to the four work items
under consideration for rechartering portion of the agenda.

Hope that imposes some more clarity.

Cheers,

- vijay

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Mon, 17 Feb 2014 16:20:06 -0600

On 02/17/2014 04:00 PM, Y. Richard Yang wrote:
> terms that Greg, Wendy, and I are recently using, Path Vector and/or
> Graph representation), starting with a survey is a quite reasonable
> idea. But I hope that it is not limited to only an informational survey,
> and a couple slides showing what the format might look like can be helpful.

Richard: Absolutely.  The intent for those responsible for graph 
representation --- and I suspect you know who they are :-) --- is
not to present a couple of slides on a survey.  The survey will come
later, assuming the IESG recharters us.

Rather, the intent is exactly to show what the format will be like.  So,
yes, I would expect JSON code to adorn the viewgraph.

Cheers,

- vijay

---

From: "Songhaibin (A)" <[email-masked]>
Date: Tue, 18 Feb 2014 01:37:08 +0000

Hi Vijay,

> o (Standards Track) Protocol extensions to convey a richer set of
   attributes to allow applications to determine not only "where" 
   to connect but also "when" to connect.  Such additional information 
   will be related both to endpoints (e.g. conveying server load 
   and cache geolocation information for CDN use cases) and to 
   endpoint-to-endpoint costs (e.g. bandwidth calendaring to represent 
   time-averaged cost values in datacenter networks). (19')

This gives me a feeling that the protocol attributes extensions will only consider the time based attributes. But I think overlay layer path cost, i.e., you do not give only the source address and destination address, but also give the intermediate node address to retrieve the cost value for the overlay layer path, is also useful in some scenarios such like CDN network, and can be easily achieved by extending the protocol attributes.

Best Regards!
-Haibin

> Sent: Tuesday, February 18, 2014 4:06 AM
> To: alto
> Over the course of this week, Enrico and I will reach out to a subset of the
> participants to prepare a short (3 minute*) per-topic presentation kicking off
> the discussion on the work item under consideration.
> 
> To keep the discussion focused, we will like exactly two slides per topic.  The
> content of these two slides must contain examples (preferably JSON
> representation) of the extensions being sought.
> 
> The agenda is draft, of course, and not considered final until bashed at the
> meeting.  But regardless, it should give you a reasonable feel for where we
> are headed.
> 
> Thank you,
> 
> - vijay
> --

---

From: Qin Wu <[email-masked]>
Date: Tue, 18 Feb 2014 07:53:08 +0000

Hi,Vijay:
Question for clarification?
Four work item for rechartering or work items that are categorized into four classes for rechartering?
It looks 7 works items that were discussed and got supports on the list are now categorized into four 
classes you proposed, What am I missing?

Regards!
-Qin
-----Original Message-----
From: alto [mailto:[email-masked]] On Behalf Of Vijay K. Gurbani
Sent: Tuesday, February 18, 2014 6:14 AM
To: Y. Richard Yang
Cc: alto
Subject: Re: [alto] ALTO agenda for London IETF

Cheers,

- vijay

---

From: Enrico Marocco <[email-masked]>
Date: Tue, 18 Feb 2014 11:31:36 +0100

On 18/02/14 08:53, Qin Wu wrote:
> Question for clarification? Four work item for rechartering or work
> items that are categorized into four classes for rechartering? It
> looks 7 works items that were discussed and got supports on the list
> are now categorized into four classes you proposed, What am I
> missing?

That is exactly the case. The seven potential deliverables have been
clustered in 4 classes of WG items -- server notifications and partial
updates in #1, third-party discovery and anycast-based discovery in #2
and so on. Nothing from the initial list should be excluded. Do you read
it differently?

Enrico

---

From: Qin Wu <[email-masked]>
Date: Tue, 18 Feb 2014 10:35:35 +0000

No, just want to confirm this.
Thanks for your clarification.

Regards!
-Qin
-----Original Message-----
From: alto [mailto:[email-masked]] On Behalf Of Enrico Marocco
Sent: Tuesday, February 18, 2014 6:32 PM
To: [email-masked]
Subject: Re: [alto] ALTO agenda for London IETF

On 18/02/14 08:53, Qin Wu wrote:
> are now categorized into four classes you proposed, What am I missing?

That is exactly the case. The seven potential deliverables have been clustered in 4 classes of WG items -- server notifications and partial updates in #1, third-party discovery and anycast-based discovery in #2 and so on. Nothing from the initial list should be excluded. Do you read it differently?

Enrico

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Tue, 18 Feb 2014 08:26:20 -0600

On 02/17/2014 07:37 PM, Songhaibin (A) wrote:
>> attributes to allow applications to determine not only "where" to
>> connect but also "when" to connect.  Such additional information will
>> be related both to endpoints (e.g. conveying server load and cache
>> geolocation information for CDN use cases) and to
> This gives me a feeling that the protocol attributes extensions will
> only consider the time based attributes. But I think overlay layer
> path cost, i.e., you do not give only the source address and
> destination address, but also give the intermediate node address to
> retrieve the cost value for the overlay layer path, is also useful in
> some scenarios such like CDN network, and can be easily achieved by
> extending the protocol attributes.

Haibin: There is certainly nothing constraining the protocol attribute
extensions to temporal properties.  However, it seems to me that your
particular use case may be better approached through cost computations
over a graph representation.  But, as always is the case, the devil is
in the details.

Cheers,

- vijay

---

From: Leeyoung <[email-masked]>
Date: Tue, 18 Feb 2014 15:43:14 +0000

I fully support Richard's idea.

Young

From: [email-masked] [mailto:[email-masked]] On Behalf Of Y. Richard Yang
Sent: Monday, February 17, 2014 4:00 PM
To: Vijay K. Gurbani
Cc: Leeyoung; alto
Subject: Re: [alto] ALTO agenda for London IETF

As much as I would like to see the graph representation (using the new terms that Greg, Wendy, and I are recently using, Path Vector and/or Graph representation), starting with a survey is a quite reasonable idea. But I hope that it is not limited to only an informational survey, and a couple slides showing what the format might look like can be helpful.

Richard
On Mon, Feb 17, 2014 at 4:01 PM, Vijay K. Gurbani <[email-masked]<mailto:[email-masked]>> wrote:
On 02/17/2014 02:39 PM, Leeyoung wrote:
Hi Vijay,

Cheers,

- vijay
--
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60563 (USA)
Email: vkg@{bell-labs.com<http://bell-labs.com>,acm.org<http://acm.org>} / [email-masked]<mailto:[email-masked]>
Web: http://ect.bell-labs.com/who/vkg/  | Calendar: http://goo.gl/x3Ogq

_______________________________________________
alto mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/alto

--
--
 =====================================
| Y. Richard Yang <[email-masked]<mailto:[email-masked]>>   |
| Professor of Computer Science       |
| http://www.cs.yale.edu/~yry/        |
 =====================================

---

From: "RANDRIAMASY, SABINE (SABINE)" <[email-masked]>
Date: Tue, 18 Feb 2014 17:22:46 +0000

Hi all,

Given this discussion, should the slides assume that the extension proposals  related to work items already draw interest and thus mainly contain examples formats illustrating how --- simply --- these extensions can be expressed in the IRD capabilities, the ALTO request  and response, plus a list of possible format options?

Thanks,
Sabine

De : alto [mailto:[email-masked]] De la part de Leeyoung
Envoyé : mardi 18 février 2014 16:43
À : Y. Richard Yang; Gurbani, Vijay K (Vijay)
Cc : alto
Objet : Re: [alto] ALTO agenda for London IETF

Young

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Y. Richard Yang
Sent: Monday, February 17, 2014 4:00 PM
To: Vijay K. Gurbani
Cc: Leeyoung; alto
Subject: Re: [alto] ALTO agenda for London IETF

Richard

Cheers,

- vijay

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Tue, 18 Feb 2014 13:11:26 -0600

On 02/18/2014 11:22 AM, RANDRIAMASY, SABINE (SABINE) wrote:
> Hi all,
>
> Given this discussion, should the slides assume that the extension
> proposals  related to work items already draw interest and thus mainly
> contain examples formats illustrating how --- simply --- these
> extensions can be expressed in the IRD capabilities, the ALTO request
> and response, plus a list of possible format options?

Sabine: Indeed.  The intent is to show examples, not just bullet points
related to how the extension is to work.

Cheers,

- vijay

---

From: "Songhaibin (A)" <[email-masked]>
Date: Wed, 19 Feb 2014 07:33:56 +0000

Hi Vijay,

> From: Vijay K. Gurbani [mailto:[email-masked]]
> Sent: Tuesday, February 18, 2014 10:26 PM
> To: Songhaibin (A); alto
> Haibin: There is certainly nothing constraining the protocol attribute extensions
> to temporal properties.  However, it seems to me that your particular use
> case may be better approached through cost computations over a graph
> representation.  But, as always is the case, the devil is in the details.
> 

Cost computation over a graph representation does not work if the cost value is "ranking", and it does not work either if the cost value is numeric but cannot be computed over. Like you said, the devil is in the details. Giving the cost value over a path directly may be the easiest way to do it.

BR,
-Haibin

---

From: "Songhaibin (A)" <[email-masked]>
Date: Wed, 19 Feb 2014 08:06:14 +0000

>From the protocol point of view, I do not know if there is existing graph representation related standard that can be used, that has already provided functions like zoom out/zoom in, point search and marking, path search and marking, and etc.? Or a new mechanism is needed?

Best Regards!
-Haibin

From: alto [mailto:[email-masked]] On Behalf Of Leeyoung
Sent: Tuesday, February 18, 2014 11:43 PM
To: Y. Richard Yang; Vijay K. Gurbani
Cc: alto
Subject: Re: [alto] ALTO agenda for London IETF

Young

Richard

Cheers,

- vijay