Subject: [alto] Resource Attributes -- new draft

From: Wendy Roome <[email-masked]>
Date: Wed, 08 Oct 2014 15:32:05 -0400

I just submitted a draft proposal
(https://datatracker.ietf.org/doc/draft-roome-alto-resource-attr/) for
providing additional descriptive information for ALTO services. The draft
defines both the mechanism and an initial set of attributes. While
capabilities tell you want kind of resource this is, and what optional
features it supports, attributes tell you how this resource differs from
other resources of the same type.

Hopefully we can discuss this in November.

	- Wendy Roome

---

From: "RANDRIAMASY, SABINE (SABINE)" <[email-masked]>
Date: Fri, 10 Oct 2014 17:39:19 +0000

Hi Wendy,

I find this proposal very useful and agree with the simplicity of having attributes rather than capabilities. 

Here are some questions hoping they're clear:

- section 1.1: I didn't get the meaning of  "A client deduce attributes by using the resource. Capabilities cannot be deduced"

- In the example IRD and sections 3.3 there are 2 terms: "authoritative-prefixes" and "authoritative-exclusions" that are sets of prefixes.  In Section 3.4 they are characterized by 3 points (i.e. more detail). Section 3.4 then  "define the authoritative set with two sets of prefixes, one  inclusive, the other exclusive".  Does this mean that the "inclusive" set is the "authoritative-prefixes" set? 

- section 5: 
* I'm fine with using "attributes" as I understand this term expresses that there is additional information on the resource object  e.g. "xxx-map"
** w.r.t. the term authoritative, then how about integrating the term "provider" in the attribute to form something like "provider-prefixes-incl" or "provider-documented"?  

- in general: if we take the set of "authoritative-prefixes": is it possible one of these sets, say "1.2.0.0/16",  a specific level of detail is provided, that is not provided on another set of the "authoritative prefixes", say a particular endpoint cost on metric or property. If yes, can the IRD advertise a resource "numerical-metricX-cost-map" available on some custom sub-domain that would have an attribute like "authoritative prefixes" : "1.2.0.0/16". This would offer flexibility and scalability to the provider of the ALTO Server and allow the client to get directly to the focused information instead of having to download and cross-match large  cost-maps. 

Thanks,
Sabine

>>-----Message d'origine-----
>>De : alto [mailto:[email-masked]] De la part de Wendy Roome
>>Envoyé : mercredi 8 octobre 2014 21:32
>>À : IETF ALTO
>>Objet : [alto] Resource Attributes -- new draft
>>
>>providing additional descriptive information for ALTO services. The
>>draft defines both the mechanism and an initial set of attributes.
>>While capabilities tell you want kind of resource this is, and what
>>optional features it supports, attributes tell you how this resource
>>differs from other resources of the same type.
>>
>>_______________________________________________
>>alto mailing list
>>[email-masked]
>>https://www.ietf.org/mailman/listinfo/alto